Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] amarok-2.0.90 (2.1-beta): No collection plugin
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
euphi2
n00b
n00b


Joined: 25 Aug 2004
Posts: 59

PostPosted: Sun Apr 26, 2009 8:39 pm    Post subject: [kde-testing] amarok-2.0.90 (2.1-beta): No collection plugin Reply with quote

I had a lot of problems with amarok2 in the last weeks, but after the upgrade to 2.0.90 everything seemed to be fine. Startup was successful, Collection was found and also a rescan of it worked fine. And, of course, music was also playing fine.

After some more updates of other packages, amarok was broken again:

--> "Amarok could not find any collection plugins."

I tried to reemerge amarok and amarok-utils, did a python-upgrade, revdep-rebuild and reemerge amarok and amarok-utils again... All the time the same error.

I also tried to move the config files away...

How can I try to solve the problem? Where is the right place to start debugging?

Output of amarok --debug:

-------------------------------------------------------
ian@martok $ amarok --debug
amarok: ************************************************************************************************************
amarok: ** DEBUGGING OUTPUT IS NOW ENABLED. PLEASE NOTE THAT YOU WILL ONLY SEE THE FULL OUTPUT ON THE NEXT START. **
amarok: ************************************************************************************************************
amarok: END__: static void App::handleCliArgs() - Took 0.00049s
amarok: END__: virtual int App::newInstance() - Took 0.00063s
amarok: [PluginManager] Plugin trader constraint: "[X-KDE-Amarok-framework-version] == 40 and [X-KDE-Amarok-plugintype] == 'collection' and [X-KDE-Amarok-rank] > 0"
amarok: [CollectionManager] Second attempt: Received [ "0" ] collection plugin offers
-------------------------------------------------------
Back to top
View user's profile Send private message
euphi2
n00b
n00b


Joined: 25 Aug 2004
Posts: 59

PostPosted: Sun Apr 26, 2009 10:06 pm    Post subject: Update Reply with quote

After a look at my emerge-logs with genlop, I think that version amarok-2.0.90 was fine, while 2.0.90-r1 is not.

Changelog says:

21 Apr 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+media-sound/amarok/amarok-2.0.90-r1.ebuild:
Let's add --as-needed to the ldflags to get amarok to build.
Back to top
View user's profile Send private message
euphi2
n00b
n00b


Joined: 25 Aug 2004
Posts: 59

PostPosted: Wed Apr 29, 2009 8:02 pm    Post subject: Reply with quote

Additionally a windows appears with the following output:

Code:

Amarok could not find any collection plugins. it is possible that Amarok is installed under the wrong prefix, please fix your installation using:
$ cd /path/to/amarok/source-code/
$ su -c "make uninstall"
$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` && su -c "make install"
$ kbuildsycoca4 --noincremental
$ amarok
More information can be found in the README file. For further assistance join us at #amarok on irc.freenode.net.
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Thu Apr 30, 2009 5:42 pm    Post subject: Reply with quote

I'll tag along on this thread in case you or someone figures it out before next update, as I have the same problem. /jim
Back to top
View user's profile Send private message
surnu
n00b
n00b


Joined: 24 Jan 2007
Posts: 15

PostPosted: Mon May 04, 2009 7:51 pm    Post subject: Reply with quote

euphi2 wrote:
Additionally a windows appears with the following output:

Code:

Amarok could not find any collection plugins. it is possible that Amarok is installed under the wrong prefix, please fix your installation using:
$ cd /path/to/amarok/source-code/
$ su -c "make uninstall"
$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` && su -c "make install"
$ kbuildsycoca4 --noincremental
$ amarok
More information can be found in the README file. For further assistance join us at #amarok on irc.freenode.net.


Hi,

I got my amarok work.
I have same error at on of my computers and and only thing whats diffrent is in /etc/env.d/43kdepaths-4.2 file.
That machine were i got this error, there /etc/env.d/43kdepaths-4.2 is missing line KDEDIRS="/usr"
If someone have same problem try this,
if in file /etc/env.d/43kdepaths-4.2 there don't have line KDEDIRS="/usr", then add it.
then run env-update
logoff/logon your kde or do reboot.
and try again. Mayby you need to delete $HOME/.kde-4.2/apps/amarok directory
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Tue May 05, 2009 1:49 pm    Post subject: Reply with quote

You get that error if you have KDE in /use/kde/4.2 and Amarok in /usr. That would mean you're mixing Amarok from the Gentoo repository, which doesn't support installing in /use/kde/4.2 anymore as far as I can tell, and KDe from the kde-testing repository.

If you switch to Amarok from the kde-testing repository, which does install in the right prefix, you won't be able to hear any music anyway because your collection will be empty and stay empty no matter what you do and playing files directly won't work.

I don't know if you can fix both problems switching to regular Gentoo ebuilds or disabling the kdeprefix useflag and rebuilding everything, or both, but with kde-testing it's either one or the other.
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum