Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDE4] plasmoids set
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
theRealMorpheu5
l33t
l33t


Joined: 26 Feb 2004
Posts: 841
Location: Vicenza, IT

PostPosted: Thu Apr 30, 2009 5:15 pm    Post subject: [KDE4] plasmoids set Reply with quote

Hi. It seems that I cannot emerge @plasmoids due to this error:

Code:
porto mopdisk # emerge @plasmoids
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "kde-plasmoids/plasma-weather".


Apparently there's no kde-plasmoids at all in my portage tree. Ideas?
Back to top
View user's profile Send private message
Gambit89
n00b
n00b


Joined: 28 Jan 2009
Posts: 22

PostPosted: Thu Apr 30, 2009 7:20 pm    Post subject: Reply with quote

Are you using the kde-testing overlay? A few weeks ago, that kde-plasmoids category existed, but then was removed and now the plasmoids live in kde-misc. This is what I get with @plasmoids from kde-testing:
Code:
emerge -pv @plasmoids

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "<kde-misc/eyesaver-9999" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-misc/eyesaver-0.2a (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

which just means that I need to add eyesaver to packages.keywords (plus the rest of them). My guess (correct me if I'm wrong) is that you aren't using kde-testing but instead copied the set files to /etc/portage/sets . You'll probably need to add the kde-testing overlay so that you get an updated plasmoids set file AND all the plasmoid ebuilds.
Back to top
View user's profile Send private message
theRealMorpheu5
l33t
l33t


Joined: 26 Feb 2004
Posts: 841
Location: Vicenza, IT

PostPosted: Thu Apr 30, 2009 11:52 pm    Post subject: Reply with quote

Gambit89 wrote:
My guess (correct me if I'm wrong) is that you aren't using kde-testing but instead copied the set files to /etc/portage/sets


Exactly. So using that overlay should solve my problem. Too bad, since I wanted to live on-the-edge-but-not-too-much :)
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Fri May 01, 2009 1:14 am    Post subject: Reply with quote

Moved from Multimedia to Unsupported Software.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum