Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
! SOLVED ! net-wireless/bluez HELL !!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 461
Location: Earth

PostPosted: Tue May 05, 2009 11:38 pm    Post subject: ! SOLVED ! net-wireless/bluez HELL !!! Reply with quote

WTF with ' bluetooth ' :evil: and Gnome 8O :!:

Quote:
emerge -uvaDN --keep-going world
Unavailable repository 'gentoo' referenced by masters entry in '/usr/local/portage/layman/kde-testing/metadata/layout.conf'

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] net-wireless/bluez-libs-3.36 USE="-debug" 307 kB [0]
[ebuild R ] media-libs/libcddb-1.3.2 USE="-doc (-iconv%*)" 0 kB [0]
[ebuild U ] sys-power/acpid-1.0.10_p3 [1.0.10] 83 kB [0]
[ebuild U ] media-libs/freetype-2.3.9-r1 [2.3.9] USE="X -bindist -debug -doc -fontforge -utils" 0 kB [0]
[ebuild U ] media-sound/lame-3.98.2-r1 [3.98.2] USE="-debug mmx -mp3rtp -sndfile" 0 kB [0]
[ebuild U ] perl-core/Module-Build-0.33 [0.32] 246 kB [0]
[ebuild U ] virtual/perl-Module-Build-0.33 [0.32] 0 kB [0]
[ebuild U ] sys-apps/debianutils-3.1.1 [3.1] USE="-static" 121 kB [0]
[ebuild U ] dev-libs/glib-2.20.1-r1 [2.20.1] USE="-debug -doc -fam -hardened (-selinux) -xattr" 0 kB [1=>0]
[ebuild N ] dev-util/gob-2.0.15 USE="-debug" 204 kB [0]
[ebuild U ] sys-apps/file-5.02 [5.01] USE="python" 601 kB [0]
[ebuild R ] app-portage/gentoolkit-0.2.4.3 USERLAND="(-GNU%*)" 0 kB [0]
[ebuild U ] dev-dotnet/libgdiplus-2.4 [2.2] USE="(-pango)" 1,988 kB [0]
[ebuild U ] x11-apps/mesa-progs-7.4.1 [7.4] 1,336 kB [0]
[ebuild U ] media-libs/netpbm-10.46.00 [10.44.00-r1] USE="X%* -jbig jpeg jpeg2k png -rle -svga tiff xml zlib" 1,854 kB [0]
[ebuild N ] net-wireless/bluez-4.38 USE="alsa cups -debug -doc gstreamer -old-daemons -test-programs usb" 0 kB [0]
[ebuild N ] net-wireless/bluez-utils-3.36 USE="alsa cups -debug -examples gstreamer -old-daemons -test-programs usb" 932 kB [0]
[ebuild N ] dev-libs/openobex-1.5 USE="bluetooth -debug -irda -syslog usb" 0 kB [0]
[ebuild R ] x11-libs/gtksourceview-2.6.1 USE="(-debug%) -doc" 0 kB [1=>0]
[ebuild N ] net-wireless/libbtctl-0.10.0 USE="-debug -doc" 324 kB [0]
[ebuild U ] dev-lang/mono-2.4 [2.2-r5] USE="-minimal -moonlight -xen" 24,279 kB [0]
[ebuild UD] gnome-base/librsvg-2.26.0 [2.26.0-r1] USE="-debug -doc zlib" 0 kB [1=>0]
[ebuild N ] kde-base/libknotificationitem-9999 USE="-debug -kdeprefix" 0 kB [2]
[ebuild U ] kde-base/plasma-workspace-9999-r1 [9999] USE="-debug -doc -google-gadgets -kdeprefix -python -rss xcomposite xinerama" 0 kB [2]
[blocks b ] =kde-base/plasma-workspace-9999[-kdeprefix] ("=kde-base/plasma-workspace-9999[-kdeprefix]" is blocking kde-base/libknotificationitem-9999)
[ebuild R ] gnome-extra/gnome-media-2.26.0 USE="-canberra% -debug -esd -gnomecd ipv6 pulseaudio" 0 kB [1]
[ebuild R ] dev-libs/totem-pl-parser-2.26.1 USE="(-doc%) hal" 0 kB [1=>0]
[ebuild U ] net-libs/libsoup-2.26.1 [2.26.0] USE="-debug -doc gnome ssl" 0 kB [3=>0]
[ebuild N ] gnome-base/gvfs-1.2.2 USE="-archive -avahi -bash-completion bluetooth cdda -debug -doc -fuse gnome -gnome-keyring -gphoto2 hal -samba" 0 kB [1]
[ebuild R ] gnome-extra/gtkhtml-3.26.1.1 USE="-debug glade%*" 0 kB [1=>0]
[ebuild N ] net-libs/webkit-gtk-1.1.6 USE="-coverage -debug -doc -gnome-keyring gstreamer svg" 0 kB [1]
[ebuild R ] net-libs/libproxy-0.2.3 USE="gnome -kde networkmanager python webkit* -xulrunner" 0 kB [1=>0]
[ebuild R ] mail-client/evolution-2.26.1.1 USE="crypt dbus -debug -exchange% gstreamer%* hal -kerberos -krb4 -ldap -mono networkmanager -nntp -pda -profile -pst% python ssl" 0 kB [1]
[ebuild NS ] net-wireless/gnome-bluetooth-0.12.0 [2.27.4] USE="-debug" 538 kB [0]
[blocks B ] net-wireless/bluez ("net-wireless/bluez" is blocking net-wireless/bluez-utils-3.36, net-wireless/bluez-libs-3.36)
[blocks B ] net-wireless/bluez-utils ("net-wireless/bluez-utils" is blocking net-wireless/bluez-4.38)
[blocks B ] net-wireless/bluez-libs ("net-wireless/bluez-libs" is blocking net-wireless/bluez-4.38)

Total: 33 packages (14 upgrades, 1 downgrade, 9 new, 1 in new slot, 8 reinstalls), Size of downloads: 32,805 kB
Conflict: 4 blocks (3 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage/layman/gnome
[2] /usr/local/portage/layman/kde-testing
[3] /usr/local/portage/overlayees

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'net-wireless/bluez-4.38', 'merge') pulled in by
net-wireless/bluez required by ('ebuild', '/', 'dev-libs/openobex-1.5', 'merge')
net-wireless/bluez required by ('ebuild', '/', 'gnome-base/gvfs-1.2.2', 'merge')

('ebuild', '/', 'net-wireless/bluez-utils-3.36', 'merge') pulled in by
>=net-wireless/bluez-utils-2.25 required by ('ebuild', '/', 'net-wireless/libbtctl-0.10.0', 'merge')

('ebuild', '/', 'net-wireless/bluez-libs-3.36', 'merge') pulled in by
>=net-wireless/bluez-libs-2.25 required by ('ebuild', '/', 'net-wireless/libbtctl-0.10.0', 'merge')
>=net-wireless/bluez-libs-3.36 required by ('ebuild', '/', 'net-wireless/bluez-utils-3.36', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


need advice :roll:

THX

CooSee ' Ya
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - Sapphire Nitro+ Radeon RX590 8G - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Mouse G400


Last edited by CooSee on Wed May 06, 2009 9:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Wed May 06, 2009 12:48 am    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Wed May 06, 2009 2:14 am    Post subject: Reply with quote

autounmask =net-wireless/libbtctl-0.11.1
emerge -C bluez-utils
emerge -1 bluez
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
gruftie
Apprentice
Apprentice


Joined: 24 Sep 2002
Posts: 182

PostPosted: Wed May 06, 2009 5:23 am    Post subject: Reply with quote

you also want to have a look at net-wireless/blueman, believe me :)
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 461
Location: Earth

PostPosted: Wed May 06, 2009 9:38 pm    Post subject: Reply with quote

THX to all and sorry for my annoyance :roll:

CooSee ' Ya
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - Sapphire Nitro+ Radeon RX590 8G - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Mouse G400
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1423
Location: /uk/sheffield

PostPosted: Fri May 08, 2009 8:17 am    Post subject: Reply with quote

Just been trying to resolve similar issues (to get blueman-1.10 installed), and I'd unmasked libbtctl, but an old version of bluez was still being pulled in by libpcap. The solution was to set USE="-bluetooth" for libpcap.

Added for reference in case anyone else has the same problem :D

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
whams
n00b
n00b


Joined: 11 Aug 2006
Posts: 9
Location: amsterdam, netherlands

PostPosted: Sat May 16, 2009 3:17 pm    Post subject: Reply with quote

slack---line wrote:
Just been trying to resolve similar issues (to get blueman-1.10 installed), and I'd unmasked libbtctl, but an old version of bluez was still being pulled in by libpcap. The solution was to set USE="-bluetooth" for libpcap.

Added for reference in case anyone else has the same problem :D

slack


Apart from libpcap, there also seems to be a dependency with the old bluetooth libs in gnome-base/gvfs: I had to recompile gvfs with USE=-bluetooth in order as to get a clean revdep-rebuild after emerging bluez-4.39.
HTH
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2483
Location: Silver City, NM

PostPosted: Tue Jun 02, 2009 1:19 am    Post subject: Reply with quote

Thanks whams. Your solution worked for me too. You saved me some detective work.
Back to top
View user's profile Send private message
astaines
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2004
Posts: 92
Location: Ireland

PostPosted: Sun Jun 07, 2009 10:40 pm    Post subject: Reply with quote

Also dragged in by media-video /totem,
so I ended up with :-

Code:

gnome-base/gvfs -bluetooth
media-video/totem -bluetooth


in /etc/portage/package.use.
Thanks again, very helpful!

Anthony
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum