Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
google-chromium-bin SNAPSHOT ebuild
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue May 12, 2009 2:16 pm    Post subject: google-chromium-bin SNAPSHOT ebuild Reply with quote

this ebuild is taken from the shellex overlay, has to download the deb-file twice (if someone could provide a fix for not needing
Code:
   wget ${PACK_URL} -O ${DISTDIR}/${PACK}
it wouldn't do this again )

this should work on x86 (uses libs from mozilla-firefox-bin build) or even amd64 (x86 not tested)

depending on the arch you're installing you need to rename the instances of i386 to amd64



google-chromium-bin-15847.ebuild

Code:
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

DESCRIPTION="Chromium is the open-source project behind Google Chrome."
HOMEPAGE="http://code.google.com:80/chromium/"
SRC_URI="http://build.chromium.org/buildbot/snapshots/chromium-rel-linux/${PV}/chromium-browser_0.${PV}-r${PV}_i386.deb"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"

IUSE=""

DEPEND="
   >=dev-lang/python-2.4
   >=dev-libs/nss-3.12
   x11-libs/gtk+:2
   media-fonts/corefonts
   www-client/mozilla-firefox-bin
"
RDEPEND="${DEPEND}"

S="${WORKDIR}/chromium"






pkg_preinst() {
   declare CHROMIUM_HOME=/opt/chromium.org/
   # Remove entire installed instance
   rm -rf "${ROOT}"${CHROMIUM_HOME}
}


src_unpack() {
#get_latest_package
#   LV=`curl http://build.chromium.org/buildbot/snapshots/chromium-rel-linux/15847/${PACK}`   
   PACK="chromium-browser_0.${PV}-r${PV}_i386.deb"
#   echo "LATEST PACKAGE: ${PACK}"
   PACK_URL="http://build.chromium.org/buildbot/snapshots/chromium-rel-linux/${PV}/chromium-browser_0.${PV}-r${PV}_i386.deb"
   wget ${PACK_URL} -O ${DISTDIR}/${PACK}
#    cp -a {DISTDIR}/chromium-browser_0.${PV}-r${PV}_amd64.deb
#LV=`cat ${DISTDIR}/${A}`
#wget -c ${PACK_URL} -O ${DISTDIR}/${PACK}
   ar xv ${DISTDIR}/${PACK}
   tar xvzf data.tar.gz
}

src_compile() {
   # do nothing
   :
}


src_install() {
   declare CHROMIUM_HOME=/opt/chromium.org/

   # Install icon and .desktop for menu entry
   newicon /opt/chromium.org/chromium/chromium-browser.png ${PN}-icon.png
   domenu "${WORKDIR}"/opt/chromium.org/chromium/chromium-browser.desktop

   dodir ${CHROMIUM_HOME}
   mv ${WORKDIR}/opt/chromium.org/chromium/ "${D}"${CHROMIUM_HOME}
   
   # Create symbol links for necessary libraries
   dosym /opt/firefox/libnspr4.so ${CHROMIUM_HOME}/chromium/libnspr4.so.0d
   dosym /opt/firefox/libnss3.so ${CHROMIUM_HOME}/chromium/libnss3.so.1d
   dosym /opt/firefox/libnssutil3.so ${CHROMIUM_HOME}/chromium/libnssutil3.so.1d
   dosym /opt/firefox/libplc4.so ${CHROMIUM_HOME}/chromium/libplc4.so.0d
   dosym /opt/firefox/libplds4.so ${CHROMIUM_HOME}/chromium/libplds4.so.0d

   dosym /opt/firefox/libsmime3.so ${CHROMIUM_HOME}/chromium/libsmime3.so.1d
   dosym /opt/firefox/libssl3.so ${CHROMIUM_HOME}/chromium/libssl3.so.1d

   # Create /usr/bin/chromium-bin
   dodir /usr/bin/
   cat <<EOF >"${D}"/usr/bin/chromium-bin
#!/bin/sh
unset LD_PRELOAD
exec /opt/chromium.org/chromium/chromium-browser "\$@"
EOF
   fperms 0755 "/usr/bin/chromium-bin"
   
}


atm I'm still getting:

Quote:
linux32 ./chrome
./chrome: error while loading shared libraries: libnss3.so.1d: cannot open shared object file: No such file or directory


(seems like it's looking in /usr/lib/ for its libraries)

update:

after modifying chromium-browser in /opt/chromium.org/chromium/ it still won't run:

Code:
PROGDIR=$(dirname $(readlink -f $0))
#export LD_LIBRARY_PATH=$PROGDIR:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH=/opt/chromium.org/chromium/
exec "$PROGDIR/chrome" "$@"
exec "chrome" "$@"


Quote:
./chromium-browser
/opt/chromium.org/chromium/chrome: error while loading shared libraries: libgconf-2.so.4: wrong ELF class: ELFCLASS64


this file only exists in a 64bit version on amd64 / multilib-systems so it will be pretty hard to get the binaries to run on those ...
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
V-Li
Retired Dev
Retired Dev


Joined: 03 Jan 2006
Posts: 606

PostPosted: Thu May 28, 2009 7:04 am    Post subject: Reply with quote

It is in Portage now as www-client/chromium-bin.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu May 28, 2009 7:21 am    Post subject: Reply with quote

V-Li wrote:
It is in Portage now as www-client/chromium-bin.


thanks Christian ! :)

unfortunately I can't take benefit of it right now since it won't run on amd64, hopefully this will be fixed in the near future via updated emul-linux-x86 libs ...

update:

after emerging emul-linux-x86-nss and -nspr (from zen's THE overlay) most of the libs should be there but unfortunately the libaries aren't linked correctly


Quote:
ls -l
total 0
lrwxrwxrwx 1 root root 12 2009-05-28 10:06 libnspr4.so.0d -> /libnspr4.so
lrwxrwxrwx 1 root root 11 2009-05-28 10:06 libnss3.so.1d -> /libnss3.so
lrwxrwxrwx 1 root root 15 2009-05-28 10:06 libnssutil3.so.1d -> /libnssutil3.so
lrwxrwxrwx 1 root root 11 2009-05-28 10:06 libplc4.so.0d -> /libplc4.so
lrwxrwxrwx 1 root root 12 2009-05-28 10:06 libplds4.so.0d -> /libplds4.so
lrwxrwxrwx 1 root root 13 2009-05-28 10:06 libsmime3.so.1d -> /libsmime3.so
lrwxrwxrwx 1 root root 11 2009-05-28 10:06 libssl3.so.1d -> /libssl3.so



=>
Quote:
ls -l
total 0
lrwxrwxrwx 1 root root 27 2009-05-28 10:09 libnspr4.so.0d -> /usr/lib32/nspr/libnspr4.so
lrwxrwxrwx 1 root root 25 2009-05-28 10:09 libnss3.so.1d -> /usr/lib32/nss/libnss3.so
lrwxrwxrwx 1 root root 29 2009-05-28 10:10 libnssutil3.so.1d -> /usr/lib32/nss/libnssutil3.so
lrwxrwxrwx 1 root root 26 2009-05-28 10:11 libplc4.so.0d -> /usr/lib32/nspr/libplc4.so
lrwxrwxrwx 1 root root 27 2009-05-28 10:11 libplds4.so.0d -> /usr/lib32/nspr/libplds4.so
lrwxrwxrwx 1 root root 27 2009-05-28 10:12 libsmime3.so.1d -> /usr/lib32/nss/libsmime3.so
lrwxrwxrwx 1 root root 25 2009-05-28 10:12 libssl3.so.1d -> /usr/lib32/nss/libssl3.so


unfortunately it also needs gconf - WTF ?
Quote:
chromium-bin
./chrome: error while loading shared libraries: libgconf-2.so.4: cannot open shared object file: No such file or directory


update2:

there are a hell of a lot dependencies (especially ubuntu ;) ):
Quote:
Software Requirements

Building on Linux requires the following software. (TODO: make this Linux-distribution independent)

Python >= 2.4
Perl >= 5.x
gcc/g++ >= 4.2
g++-multilib >=4.2
bison >= 2.3
flex >= 2.5.34
gperf >= 3.0.3
pkg-config >= 0.20
libnss3-dev >= 3.12 (in THE overlay)
libasound2-dev
libgconf2-dev
libglib2.0-dev
libgtk2.0-dev
libnspr4-0d >= 4.7.1+1.9-0ubuntu0.8.04.5 (ubuntu0.8.04.1 causes duplicate dtoa references) (in THE overlay)
libnspr4-dev >= 4.7.1+1.9-0ubuntu0.8.04.5
(in THE overlay)
msttcorefonts (Microsoft fonts)
freetype-dev
libcairo2-dev
libdbus-1-dev

Optional (currently, all of these are only used by layout tests):

wdiff
lighttpd
php5-cgi
sun-java6-fonts (needed for Lucida)

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
V-Li
Retired Dev
Retired Dev


Joined: 03 Jan 2006
Posts: 606

PostPosted: Thu May 28, 2009 10:26 am    Post subject: Reply with quote

You should discuss your thoughts with voyageur (Bernard Cafarelli), who added the ebuild (I did not) to the tree.
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Thu May 28, 2009 12:18 pm    Post subject: Reply with quote

Someone called me? ;)

Yes, for amd64, we miss nss/nspr and gconf. For nss/nspr I was thinking about requiring one of firefox-bin, xulrunner-bin, adobe-flash[32bit] or maybe seamonkey-bin (not tested) and change the links in /opt/chromium.org/lib accordingly.

However as you saw, it does need gconf... And gconf (gnome part) is not in emul-linux-x86-gtklibs, nor in other binary packages (acroread, adobe-flash, ...)
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
Tito1337
n00b
n00b


Joined: 02 Jul 2007
Posts: 12
Location: Brussels, Belgium

PostPosted: Thu May 28, 2009 11:03 pm    Post subject: GLIBCXX_3.4.9 not found Reply with quote

I've Googled a bit but didn't found the solution to this error at chromium launch:
Code:
./chrome: /usr/lib/gcc/i686-pc-linux-gnu/4.1.2/libstdc++.so.6: version `LIBCXX_3.4.9' not found (required by ./chrome)


Help please :P
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Fri May 29, 2009 9:04 am    Post subject: Reply with quote

Ah looks like their buildbot uses a recent gcc (libstdc++.so.6). What's your gcc version? LIBCXX_3.4.9 means at least gcc 4.2 (so current gentoo stable 4.3 does the job)

edit: ok another user filled a bug on this one, and indeed he had gcc 4.1. I've added >=gcc4.2 as dependency
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
Tito1337
n00b
n00b


Joined: 02 Jul 2007
Posts: 12
Location: Brussels, Belgium

PostPosted: Sat May 30, 2009 7:58 pm    Post subject: Reply with quote

I already have sys-devel/gcc-4.3.2-r3 compiled and installed...

But here is something strange:
Code:
~ $ gcc --version
gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.0.2)


Code:
*  sys-devel/gcc
      Latest version available: 4.3.2-r3
      Latest version installed: 4.3.2-r3
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat May 30, 2009 8:22 pm    Post subject: Reply with quote

Code:
gcc-config -l


Code:
gcc-config 5



e.g. where <5> is gcc 4.3.3

then
Code:
env-update && source /etc/profile

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Tito1337
n00b
n00b


Joined: 02 Jul 2007
Posts: 12
Location: Brussels, Belgium

PostPosted: Sat May 30, 2009 8:47 pm    Post subject: Reply with quote

Thanks to both of you, it works well now :)
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Tue Jun 02, 2009 9:44 am    Post subject: Reply with quote

Recently it stopped showing anything for me if i try to open a web page it loads it, but the page stays blank
the only thing on the console is
Quote:
/opt/chromium.org/chrome-linux/chrome: Symbol `SSL_ImplementedCiphers' has different size in shared object, consider re-linking
/opt/chromium.org/chrome-linux/chrome: Symbol `SSL_ImplementedCiphers' has different size in shared object, consider re-linking


i've tried clearing settings, but it changed nothing.

what may be wrong with it?
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jun 02, 2009 12:52 pm    Post subject: Reply with quote

Voyageur wrote:
Someone called me? ;)

Yes, for amd64, we miss nss/nspr and gconf. For nss/nspr I was thinking about requiring one of firefox-bin, xulrunner-bin, adobe-flash[32bit] or maybe seamonkey-bin (not tested) and change the links in /opt/chromium.org/lib accordingly.

However as you saw, it does need gconf... And gconf (gnome part) is not in emul-linux-x86-gtklibs, nor in other binary packages (acroread, adobe-flash, ...)


i have created emul-linux-x86-nss and emul-linux-x86-nspr ebuilds which should provide you with those libs, they are in THE overlay

EDIT: sorry didnt see u already had those marked
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
hxpurnama
n00b
n00b


Joined: 15 Nov 2008
Posts: 7
Location: Indonesia

PostPosted: Thu Jun 04, 2009 3:53 am    Post subject: Reply with quote

Just emerged chromium-bin today, but when i run it in terminal, it reported this error:
Code:
0 hari@tsu: ~
Thu Jun 04, 10:25 $ chromium-bin
./chrome: Symbol `SSL_ImplementedCiphers' has different size in shared object, consider re-linking
Illegal instruction

Could anybody point me what am i missng?

I use openssl-0.9.8k-r1. Should I re-emerge this package too?
Code:
0 root@tsu: ~
Thu Jun 04, 10:49 # eix dev-libs/openssl
[I] dev-libs/openssl
     Available versions:  0.9.8j 0.9.8k (~)0.9.8k-r1 {bindist gmp kerberos sse2 test zlib}
     Installed versions:  0.9.8k-r1(11:27:17 06/01/09)(zlib -bindist -gmp -kerberos -sse2 -test)
     Homepage:            http://www.openssl.org/
     Description:         Toolkit for SSL v2/v3 and TLS v1

Fyi, this is my emerge --info output:
Code:
0 root@tsu: ~
Thu Jun 04, 10:42 # emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.28-gentoo-4 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-4-i686-AMD_Athlon-tm-_XP-M_-LV-_2000+-with-glibc2.0
Timestamp of tree: Thu, 04 Jun 2009 00:45:02 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=" --with-bdeps y"
FEATURES="ccache distcc distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://kambing.ui.edu/gentoo/ http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.mirrors.tds.net/gentoo http://gentoo.mirrors.pair.com/ http://mirror.usu.edu/mirrors/gentoo/ "
LANG="C"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/gentoo-china /usr/local/portage/layman/zugaina /usr/local/portage/layman/enlightenment /usr/local/portage/layman/sectools"
SYNC="rsync://rsync.asia.gentoo.org/gentoo-portage"
USE="X acl acpi alsa bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde ldap libnotify mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis win32codecs x86 xface xml xorg xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest" APACHE2_MPMS=" prefork" ELIBC="glibc" FOO2ZJS_DEVICES=" hp1020" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
regards,
hp
Back to top
View user's profile Send private message
Voyageur
Developer
Developer


Joined: 06 Mar 2005
Posts: 342
Location: Paris, France

PostPosted: Thu Jun 04, 2009 9:30 am    Post subject: Reply with quote

I have the SSL_ImplementedCiphers warnings too (disadvantage of a binary package), but they are harmless here.

It's possible this build uses processor extensions not available on your Athlon-XP (from your uname), which means you'll probably have to try chromium from source
_________________
Routinely breaking NX, GNUstep, net-ftp, miscellaneous (llvm, filezilla, rdesktop, chromium, ...) packages
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Jun 04, 2009 1:47 pm    Post subject: Reply with quote

Voyageur wrote:
I have the SSL_ImplementedCiphers warnings too (disadvantage of a binary package), but they are harmless here.

It's possible this build uses processor extensions not available on your Athlon-XP (from your uname), which means you'll probably have to try chromium from source


you know.... it would probably be easier for me to build chromium from source with generic i686 flags against gentoo's system and then we would create our own binary builds ;)
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
Timbers2k
Apprentice
Apprentice


Joined: 03 Oct 2003
Posts: 215

PostPosted: Fri Jun 05, 2009 7:17 pm    Post subject: Reply with quote

Google has released the developer version of Chrome for Linux and Mac. It's available for Ubuntu 32 and 64 bit systems. This would be nice to have an ebuild for!
Back to top
View user's profile Send private message
dioslaska
n00b
n00b


Joined: 14 Mar 2006
Posts: 34

PostPosted: Tue Jun 09, 2009 1:44 pm    Post subject: Reply with quote

rmh3093 wrote:
Voyageur wrote:
Someone called me? ;)

Yes, for amd64, we miss nss/nspr and gconf. For nss/nspr I was thinking about requiring one of firefox-bin, xulrunner-bin, adobe-flash[32bit] or maybe seamonkey-bin (not tested) and change the links in /opt/chromium.org/lib accordingly.

However as you saw, it does need gconf... And gconf (gnome part) is not in emul-linux-x86-gtklibs, nor in other binary packages (acroread, adobe-flash, ...)


i have created emul-linux-x86-nss and emul-linux-x86-nspr ebuilds which should provide you with those libs, they are in THE overlay

EDIT: sorry didnt see u already had those marked


I had the same issues on amd64, and i couldn't resolve. So finally I downloaded this: http://media.codeweavers.com/pub/crossover/chromium/install-cxchromium-0.9.0.sh. And it works. I only need it for testing purposes, not for regular use.
Back to top
View user's profile Send private message
taipan67
l33t
l33t


Joined: 04 Dec 2004
Posts: 866
Location: England (i'm told...)

PostPosted: Thu Jun 25, 2009 2:55 pm    Post subject: Reply with quote

Voyageur wrote:
I have the SSL_ImplementedCiphers warnings too (disadvantage of a binary package), but they are harmless here.

It's possible this build uses processor extensions not available on your Athlon-XP (from your uname), which means you'll probably have to try chromium from source

Ahhh! That might indeed be the cause of my woes - the binary won't run on my Athlon-XP, emitting the same warnings. I'm currently trying to get my head around a source-build (i know about this thread, but am exploring the ins and outs of differing manual builds anyway), and sure enough if you don't modify it's defaults, it uses...
Code:
'conditions': [
  ['branding=="Chromium"', {
    'cflags': [
      '-march=pentium4',
      '-msse2',
      '-mfpmath=sse',
    ],
  }]
]

...and the Athlon doesn't support 'sse2'. :evil:

My supposition, therefore, would be that their pre-compiled binaries have these defaults too... :?
_________________
"Anyone who goes to see a psychiatrist should have their head examined!"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum