Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KompoZer 0.8 and beyond
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rafo
Apprentice
Apprentice


Joined: 18 Nov 2003
Posts: 161
Location: Sollentuna, Sweden

PostPosted: Thu May 21, 2009 7:18 pm    Post subject: KompoZer 0.8 and beyond Reply with quote

Since a couple of months there is ongoing work towards KompoZer version 0.8 at http://kompozer.net.

I tried the binary tarball (http://sourceforge.net/project/downloading.php?group_id=170132&filename=kompozer-0.8a4-gcc4.2-i686.tar.gz) briefly today. Unpacking it and running the executable worked right away in my Gentoo environment. I don't dare to say anything about the stability though.

I did some searching for an ebuild but I didn't find any. So I downloaded the latest 0.7.10 ebuild from https://bugs.gentoo.org/show_bug.cgi?id=146761 and started tweaking it just to see how far I would get.

Not very far I am afraid .. fetching and unpacking is no problem, but the compile step ended after a number of minutes with the error that you can see below.

Anyway, I uploaded my ebuild file to https://bugs.gentoo.org/show_bug.cgi?id=146761. Feel free to take it closer to a working ebuild!

Code:

/usr/include/pango-1.0/pango/pangocairo.h:69: error: 'cairo_font_type_t' was not declared in this scope
/usr/include/pango-1.0/pango/pangocairo.h:72: error: 'cairo_font_type_t' does not name a type
nsCanvasRenderingContext2D.cpp:198: warning: 'PRBool FloatValidate(double, double, double)' defined but not used
gmake[5]: *** [nsCanvasRenderingContext2D.o] Error 1
gmake[5]: Leaving directory `/var/tmp/portage/app-editors/kompozer-0.8_alpha4/work/mozilla/content/canvas/src'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/var/tmp/portage/app-editors/kompozer-0.8_alpha4/work/mozilla/content/canvas'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/var/tmp/portage/app-editors/kompozer-0.8_alpha4/work/mozilla/content'
gmake[2]: *** [tier_9] Error 2
gmake[2]: Leaving directory `/var/tmp/portage/app-editors/kompozer-0.8_alpha4/work/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-editors/kompozer-0.8_alpha4/work/mozilla'
make: *** [build] Error 2
 *
 * ERROR: app-editors/kompozer-0.8_alpha4 failed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum