Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200905-04 ] GnuTLS: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message

Joined: 12 May 2004
Posts: 2235

PostPosted: Sun May 24, 2009 3:26 pm    Post subject: [ GLSA 200905-04 ] GnuTLS: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: GnuTLS: Multiple vulnerabilities (GLSA 200905-04)
Severity: normal
Exploitable: remote
Date: May 24, 2009
Bug(s): #267774
ID: 200905-04


Multiple vulnerabilities in GnuTLS might result in a Denial of Service,
spoofing or the generation of invalid keys.


GnuTLS is an Open Source implementation of the TLS 1.0 and SSL 3.0

Affected Packages

Package: net-libs/gnutls
Vulnerable: < 2.6.6
Unaffected: >= 2.6.6
Architectures: All supported architectures


The following vulnerabilities were found in GnuTLS:
  • Miroslav Kratochvil reported that lib/pk-libgcrypt.c does not
    properly handle corrupt DSA signatures, possibly leading to a
    double-free vulnerability (CVE-2009-1415).
  • Simon Josefsson
    reported that GnuTLS generates RSA keys stored in DSA structures when
    creating a DSA key (CVE-2009-1416).
  • Romain Francoise reported
    that the _gnutls_x509_verify_certificate() function in
    lib/x509/verify.c does not perform time checks, resulting in the
    "gnutls-cli" program accepting X.509 certificates with validity times
    in the past or future (CVE-2009-1417).


A remote attacker could entice a user or automated system to process a
specially crafted DSA certificate, possibly resulting in a Denial of
Service condition. NOTE: This issue might have other unspecified impact
including the execution of arbitrary code. Furthermore, a remote
attacker could spoof signatures on certificates and the "gnutls-cli"
application can be tricked into accepting an invalid certificate.


There is no known workaround at this time.


All GnuTLS users should upgrade to the latest version:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.6.6"



Last edited by GLSA on Tue Dec 01, 2009 4:28 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum