Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.30_rc7 kernel... amd64 not supported??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Mon May 25, 2009 8:06 pm    Post subject: 2.6.30_rc7 kernel... amd64 not supported?? Reply with quote

Two issues - one good, one bad.

good: it is 1/4 the size of other kernel versions... why?

EDIT: I understand - it's patching on 2.6.29, which I already had. Ignore this one, look at the next

bad: the vanilla-sources ebuild is not keyworded for ~amd64... why?

I added it with ** to package.keywords, but why don't the devs agree?
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5674
Location: Removed by Neddy

PostPosted: Mon May 25, 2009 8:17 pm    Post subject: Re: 2.6.30_rc7 kernel... amd64 not supported?? Reply with quote

poly_poly-man wrote:
Two issues - one good, one bad.

good: it is 1/4 the size of other kernel versions... why?

EDIT: I understand - it's patching on 2.6.29, which I already had. Ignore this one, look at the next

bad: the vanilla-sources ebuild is not keyworded for ~amd64... why?

I added it with ** to package.keywords, but why don't the devs agree?


either
1) a easy mistake
2) noone from teh amd64 herd has check it is actually ok

if it is ok open a bug and ask for the keyword
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Mon May 25, 2009 8:29 pm    Post subject: Re: 2.6.30_rc7 kernel... amd64 not supported?? Reply with quote

Naib wrote:
poly_poly-man wrote:
Two issues - one good, one bad.

good: it is 1/4 the size of other kernel versions... why?

EDIT: I understand - it's patching on 2.6.29, which I already had. Ignore this one, look at the next

bad: the vanilla-sources ebuild is not keyworded for ~amd64... why?

I added it with ** to package.keywords, but why don't the devs agree?


either
1) a easy mistake
2) noone from teh amd64 herd has check it is actually ok

if it is ok open a bug and ask for the keyword


compiling now... hopefully going to fix both the amd64 disk I/O-causes-latency issues and give me radeon drm ootb...
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Mon May 25, 2009 9:08 pm    Post subject: Reply with quote

I think that the vanilla-sources rc ebuild always had a ~* flag. I've been that adventurous only since 2.6.27 and I'm pretty sure that all .27 .28 29 and now .30 rcs where ~*. And I think it's good. An RC kernel is something that should demand more than a mere ~ keyword which is for stable releases that are not yet "gentoo stable".
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Mon May 25, 2009 9:55 pm    Post subject: Reply with quote

szczerb wrote:
I think that the vanilla-sources rc ebuild always had a ~* flag. I've been that adventurous only since 2.6.27 and I'm pretty sure that all .27 .28 29 and now .30 rcs where ~*. And I think it's good. An RC kernel is something that should demand more than a mere ~ keyword which is for stable releases that are not yet "gentoo stable".
exactly - I don't understand why ~amd64 is not on the list...

EDIT: wow, that took a while to reboot from.

Why did they change the default ext4 data mode? I left writeback in my fstab, and I consistently couldn't get it to boot with a rw root... had to download the latest sysresccd to fix another fstab error (apparently "extents" is no longer an option), then used grub to make writeback my default.

it also made my 2 speakers into 6ch somehow - maybe I'm just insane :?

oh yeah, and the radeon drm, which was the whole point of this, appears to not work - why is xvideo not working???
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Mon May 25, 2009 10:08 pm    Post subject: Reply with quote

If I remember correctly, then the first KMS intel stuff also didn't have textured video, just overlay (if you have no xv at all, then that's a bigger problem...) and I guess that you just should be patient ;]

About the keyword, read what I wrote again. An rc needs to be keyworded more that a normal release that's not yet Gentoo-stable :)
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Mon May 25, 2009 10:56 pm    Post subject: Reply with quote

well, I've gotten radeon to give me full xv accel in the past - I went through a nvidia->fglrx->radeon cycle again, and it wasn't working this time - so I figured I'd give the in-kernel stuff a try (they say it should work with the 2.6.30 drm...

what's kms?


and also, read what I wrote about the keyword - I expect the rc's to be masked. Once I unmasked it, I expected it to be ~arch keyworded - well, it was, but they forgot ~amd64.
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Mon May 25, 2009 11:00 pm    Post subject: Reply with quote

got my xvideo back - had to re-emerge xorg-server.
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Mon May 25, 2009 11:01 pm    Post subject: Reply with quote

KMS is kernel-mode-setting, as in, no more flicker during bootup or changing VT's. Mode setting code being ripped out of Xorg and put into the kernel drivers.

I'm used to rcs not being masked (which, I think, should be for broken stuff or stuff that breaks other stuff) but keyworded ~* instead :)
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 530
Location: Coruña (Spain)

PostPosted: Tue May 26, 2009 12:02 pm    Post subject: Reply with quote

Many vanilla rc versions don't have ~amd64 among the keywords, don't know why (when all the other arches were there). I remember having to add "<kernel-version> ~x86" to package.keywords several times in the past to get an rc version.

They merged drm-next in .30-rc, yay :). That's one less patch to apply to get nouveau with kms.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue May 26, 2009 3:10 pm    Post subject: Reply with quote

poly_poly-man wrote:


oh yeah, and the radeon drm, which was the whole point of this, appears to not work - why is xvideo not working???


poly, could you please post some lines with instructions how you got your 4830 (4850 ?) to work with this kernel and xf86-video-ati (what driver are you using radeonhd / radeon ? in-kernel drm, x11-drm ?)

is http://www.gentoo-wiki.info/Radeon still accurate ?

could you also please post your xorg.conf ?

many many thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Tue May 26, 2009 7:21 pm    Post subject: Reply with quote

kernelOfTruth wrote:
poly_poly-man wrote:


oh yeah, and the radeon drm, which was the whole point of this, appears to not work - why is xvideo not working???


poly, could you please post some lines with instructions how you got your 4830 (4850 ?) to work with this kernel and xf86-video-ati (what driver are you using radeonhd / radeon ? in-kernel drm, x11-drm ?)

is http://www.gentoo-wiki.info/Radeon still accurate ?

could you also please post your xorg.conf ?

many many thanks in advance


I have an hd4830, using the radeon driver, and a monitor with a correct EDID (my old monitor didn't have an EDID, so I used to have a full monitor section...

http://omploader.org/vMXFqbg - that's current - the keyboard and mouse stuff has to be there for some reason, and some of those options are probably unnecessary.

Beyond that, make sure that the radeon drm is enabled in-kernel or as a module (2.6.30 only), make sure that both the nvidia and fglrx modules are off your system (these like to load randomly), and that radeon is loaded.

If it says that something is "too old" in your logs, re-emerge xorg-server.

radeonhd does not support xvideo, so no good for me (at least, wiki.x.org said so).
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Jun 07, 2009 8:47 pm    Post subject: Reply with quote

thanks ! :)

update:

either I'm doing something wrong or my card (EAH4850 non-TOP) isn't supported:

emerging xf86-video-radeonhd or xf86-video-ati (latest from upstream 9999), mesa built with ati / radeon ... use-flag

Code:
modprobe drm radeon


fire up X

the only results so far were:

* ati / radeon-driver: black screen and immediately after that leading to monitor standby / turning off

* radeonhd: also black screen but not turning off


there's no way in gaining output again by switching through VTs only a magic sysrq key (haven't tried ctrl + alt + del) is able to bring the box back at a usable state ... :?

anyone is experiencing the same and has a fix for this ?

is there a known setting to cause this ?

I've also tried to launch X with plain xorg.conf and practically no settings but still the same ...

I'd really like to switch to 2.6.30* and opensource drivers (that would make my system entirely opensource-driver driven but it seemingly unforuntately won't happen so fast :( )

many thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 530
Location: Coruña (Spain)

PostPosted: Fri Jun 12, 2009 5:01 pm    Post subject: Reply with quote

kernelOfTruth wrote:
anyone is experiencing the same and has a fix for this ?

is there a known setting to cause this ?

Do you have the fglrx drivers installed?

https://forums.gentoo.org/viewtopic-t-768839-highlight-.html
https://bugs.gentoo.org/show_bug.cgi?id=258322
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jun 12, 2009 5:32 pm    Post subject: Reply with quote

Fran wrote:
kernelOfTruth wrote:
anyone is experiencing the same and has a fix for this ?

is there a known setting to cause this ?

Do you have the fglrx drivers installed?

https://forums.gentoo.org/viewtopic-t-768839-highlight-.html
https://bugs.gentoo.org/show_bug.cgi?id=258322


thanks Fran !

yes, I've got it installed,

but but but:

it's installed for 2.6.29-zen2 and the kernel I'm trying to get to run is/was 2.6.30-rc-zen* / 2.6.30-zen0 :(

so the best practice should be just to uninstall it (fglrx) after having compiled the kernel / installed all of the opensource-drivers & then reboot, I guess

I'll give that a try

only few steps away to the opensource'd desktop - yay ! :D
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Fran
Guru
Guru


Joined: 29 Feb 2004
Posts: 530
Location: Coruña (Spain)

PostPosted: Fri Jun 12, 2009 6:46 pm    Post subject: Reply with quote

kernelOfTruth wrote:
so the best practice should be just to uninstall it (fglrx) after having compiled the kernel / installed all of the opensource-drivers & then reboot, I guess

I'll give that a try

only few steps away to the opensource'd desktop - yay ! :D

Or patch the xorg-server ebuild with the patch in that bug report so that you can have both installed. I still don't understand WHY that bug is unsolved, when the solution seems so TRIVIAL.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jun 12, 2009 7:16 pm    Post subject: Reply with quote

Fran wrote:
kernelOfTruth wrote:
so the best practice should be just to uninstall it (fglrx) after having compiled the kernel / installed all of the opensource-drivers & then reboot, I guess

I'll give that a try

only few steps away to the opensource'd desktop - yay ! :D

Or patch the xorg-server ebuild with the patch in that bug report so that you can have both installed. I still don't understand WHY that bug is unsolved, when the solution seems so TRIVIAL.


I did the latter and will try later during free time to reboot and see whether it works,

even stranger is that both libdri.so and libglx.so where both missing in /usr/lib64/opengl/xorg-x11/extensions/ :roll:

after modifying the ebuild both are there - even libdri2.so
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jun 12, 2009 8:41 pm    Post subject: Reply with quote

excellent - it works ! :D

now I only need to get compiz(-fusion) to work:
Quote:
DISPLAY=:0 compiz --replace ccp --sm-disable
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0


Quote:
glxinfo | grep pixm
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap


the weird thing is:
Quote:
cat /var/log/Xorg.0.log | grep GL
(**) Option "AIGLX" "On"
(**) AIGLX enabled
(II) Loading extension GLX
ATI FireGL M24 GL 3154 (PCIE), ATI Radeon X600 (RV380) 3E50 (PCIE),
ATI FireGL V3200 (RV380) 3E54 (PCIE), ATI Radeon IGP320 (A3) 4136,
ATI FireGL Z1 AG (AGP), ATI Radeon 9800SE AH (AGP),
ATI FireGL X2 AK (AGP), ATI Radeon 9600 AP (AGP),
ATI Radeon 9600 AS (AGP), ATI FireGL T2 AT (AGP), ATI Radeon 9650,
ATI FireGL RV360 AV (AGP), ATI Radeon 7000 IGP (A4+) 4237,
ATI Radeon X800 (R420) JL (AGP), ATI FireGL X3 (R420) JM (AGP),
ATI Mobility FireGL 7800 M7 LX (AGP),
ATI FireGL Mobility 9000 (M9) Ld (AGP),
ATI FireGL X1 NG (AGP), ATI Radeon 9800PRO NH (AGP),
ATI Radeon 9800 NI (AGP), ATI FireGL X2 NK (AGP),
ATI FireGL Mobility T2 (M10) NT (AGP),
ATI FireGL Mobility T2e (M11) NV (AGP), ATI Radeon QD (AGP),
ATI FireGL 8700/8800 QH (AGP), ATI Radeon 8500 QL (AGP),
ATI FireGL M22 GL 5464 (PCIE), ATI Radeon X800 (R423) UH (PCIE),
ATI FireGL V7100 (R423) (PCIE), ATI FireGL V5100 (R423) UQ (PCIE),
ATI FireGL unknown (R423) UR (PCIE),
ATI FireGL unknown (R423) UT (PCIE),
ATI Mobility FireGL V5000 (M26) (PCIE),
ATI Mobility FireGL V5000 (M26) (PCIE),
ATI FireGL V3100 (RV370) 5B64 (PCIE),
ATI Mobility FireGL V5100 (M28) (PCIE),
ATI unknown Radeon / FireGL (R480) 5D50 (PCIE),
ATI FireGL V5000 (RV410) (PCIE), ATI Radeon X700 XT (RV410) (PCIE),
ATI Mobility FireGL V7200, ATI FireGL V7200, ATI FireGL V5300,
ATI Mobility FireGL V7100, ATI Radeon X1800, ATI Radeon X1800,
ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
ATI RV505, ATI RV505, ATI FireGL V3300, ATI FireGL V3350,
ATI Mobility FireGL V5200, ATI Mobility Radeon X1600,
ATI Radeon X1300 XT/X1600 Pro, ATI FireGL V3400,
ATI Mobility FireGL V5250, ATI Mobility Radeon X1700,
ATI Mobility Radeon X1700 XT, ATI FireGL V5200,
ATI Radeon X1950 GT, ATI RV570, ATI RV570, ATI FireGL V7400,
ATI FireGL V8650, ATI FireGL V8600, ATI FireGL V7600,
ATI FirePro V8750 (FireGL), ATI FirePro V7760 (FireGL),
AMD FireStream 9250, ATI FirePro V8700 (FireGL),
ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
ATI Radeon HD 2400 Pro, ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000,
ATI Radeon HD3870 X2, ATI FireGL V7700, ATI Radeon HD3850,
ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
ATI FireGL V3600, ATI Radeon HD 2600 LE,
ATI Mobility FireGL Graphics Processor, ATI Radeon RV710,
ATI Mobility Radeon HD 3670, ATI Mobility FireGL V5700,
ATI Mobility FireGL V5725, ATI Radeon HD 3200 Graphics,
(II) AIGLX: Screen 0 is not DRI2 capable
(EE) AIGLX error: dlopen of /usr/lib64/dri/r600_dri.so failed (/usr/lib64/dri/r600_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Loaded and initialized /usr/lib64/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0


Quote:
The following messages are absolutely normal in your Xorg.0.log (as we don't have 3D acceleration yet):

(EE) AIGLX error: dlopen of /usr/lib/dri/r600_dri.so failed
(EE) AIGLX: reverting to software rendering


but it nevertheless should provide working compiz or am I confusing something ?

update:

I found a temporary solution: kde 4 (currently 4.3 beta2) with compositing and XRender as the compositing type

this doesn't support the magic lamp, invert effect and some other but it's a start

hopefully fully functioning 3D-support for the R6XX and R7XX will be added soon :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum