Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gimp] Pas de support du jpeg (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Mon May 25, 2009 9:50 pm    Post subject: [gimp] Pas de support du jpeg (résolu) Reply with quote

Bonjour.

Bon, je suis un gros débutant, je voudrait bien le préciser.

j'ai installé gimp (emerge -va gimp)
en essayant d'ouvrir un fichier au format jpg, gimp me dit que "format de fichier inconnu".

du coup je cherche un peu, et j'essaie d'ajouter le cflag jpg, au cas où :

Code:
#> USE='jpg' sudo emerge -va gimp


Marche pas, même erreur.

j'arrive pas à trouver des infos là-dessus sur le net. Pouvez-vous m'aider ?

Edit : pas d'erreur apparente lors de la compilation.

Dernière modification par she0gorath (Aujourd'hui 23:45:48)


Last edited by she0gorath on Tue May 26, 2009 9:48 am; edited 2 times in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8128
Location: ~Brussels - Belgique

PostPosted: Mon May 25, 2009 10:00 pm    Post subject: Reply with quote

salut,

si tu fais un "emerge -pv gimp", tu verras que le USE à mettre est "jpeg" et pas "jpg".

Mets à jour /etc/make.conf et fais un "emerge -DuNav world" pour mettre à jour le nouveau USE globalement. Si tu le mets en ligne de commande, il disparaîtra lors de la prochaine mise à jour.

Quel est ton "profile" ? apparmment, c'est un "server", au lieu de "desktop".
(eselect profile list)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon May 25, 2009 11:29 pm    Post subject: Reply with quote

Salut et bienvenue ! Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)

Et +1 pour la réponse de XavierMiller.
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue May 26, 2009 9:48 am    Post subject: Reply with quote

Autant pour moi pour le titre... C'est vrai que j'ai survolé un peu vite le réglement, pensant qu'il ressemblerait à ceux des autres forums que je fréquente.

Sinon, ça marche bien. Merci.

Pour mon "profile",

Code:
> eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/2008.0 *
  [2]   default/linux/amd64/2008.0/desktop
  [3]   default/linux/amd64/2008.0/developer
  [4]   default/linux/amd64/2008.0/no-multilib
  [5]   default/linux/amd64/2008.0/server
  [6]   hardened/amd64
  [7]   hardened/amd64/multilib
  [8]   selinux/2007.0/amd64
  [9]   selinux/2007.0/amd64/hardened
  [10]  hardened/linux/amd64

Code:
> eselect profile show
Current make.profile symlink:
  default/linux/amd64/2008.0


Du coup , je le met sur desktop, comme vous me le conseillez.

Merci encore...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8128
Location: ~Brussels - Belgique

PostPosted: Tue May 26, 2009 10:19 am    Post subject: Reply with quote

et ensuite, tu fais un "emerge -DuNav world" (--deep --update --newuse --ask --verbose) pour tout mettre à jour (dont le changement des flags USE, ça fera un paquet de paquets à recompiler...)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue May 26, 2009 10:32 am    Post subject: Reply with quote

Euh... Encore une question de n00b : j'ai ça :
Code:
> sudo emerge -DuNav world
Mot de passe :

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/cairo-1.7.6[svg,X]".
!!! One of the following packages is required to complete your request:
- x11-libs/cairo-1.8.6-r1 (Change USE: +svg)
(dependency required by "x11-libs/pango-1.24.1" [installed])
(dependency required by "x11-libs/gtk+-2.16.1" [ebuild])
(dependency required by "x11-libs/qt-gui-4.5.1" [installed])
(dependency required by "kde-base/qimageblitz-0.0.4" [installed])
(dependency required by "kde-base/kdm-4.2.3" [installed])
(dependency required by "@world" [argument])


 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

C'est grave, docteur ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8128
Location: ~Brussels - Belgique

PostPosted: Tue May 26, 2009 12:32 pm    Post subject: Reply with quote

Oui et non : pas moyen de mettre à jour automatiquement.

essaie "emerge -1av cairo"
(le -1 est pour éviter que cette dépendance soit dans "world")
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum