Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amule-adu error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Mon Jun 01, 2009 8:24 am    Post subject: Amule-adu error Reply with quote

Hi all.
I have some troubles in emerging amule-adu from dottout overlay.

This the error I get:
Code:
Compiling UserEvents.cpp
Compiling OtherFunctions.cpp
Compiling NetworkFunctions.cpp
Linking amule
/usr/lib/libcryptopp.a(rng.o): In function `CryptoPP::X917RNG::X917RNG(CryptoPP::BlockTransformation*, unsigned char const*, unsigned char const*)':
(.text+0x977): warning: memset used with constant zero length parameter; this could be due to transposed parameters
amule-ThreadTasks.o: In function `CAllocateFileTask::Entry()':
ThreadTasks.cpp:(.text+0x483): undefined reference to `fallocate64'
collect2: ld returned 1 exit status
make[3]: *** [amule] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2


I have tried to emerge amule-2.2.5 and it works, I don't know why amule-adu doesn't emerge.
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Mon Jun 01, 2009 6:36 pm    Post subject: Reply with quote

same error on my 2 machines, dunno why. btw, its unsupported software, and you are spelling it wrong, its amuleadu! :D btw-2, in 2-3 weeks Ill change isp, probably I wont provide any more updates..
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2674
Location: here, there or in transit

PostPosted: Mon Jun 01, 2009 6:45 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
Ebuilds from overlays :arrow: Unsupported.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Tue Jun 02, 2009 6:44 am    Post subject: Reply with quote

I have the same idential problem with amuleadu-3.14-r222.
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Tue Jun 02, 2009 6:56 am    Post subject: Reply with quote

yellowhat wrote:
I have the same idential problem with amuleadu-3.14-r222.

r222 is an ancient version. I suggest you to move to -9999, since in the last months there were no official releases. 9999 is 2.2.5 based ;)
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Tue Jun 02, 2009 6:58 am    Post subject: Reply with quote

I tried both but nothing it doesn't works. Could you post how to install amuleadu-9999. If I wrong something.

Thanks
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Tue Jun 02, 2009 7:01 am    Post subject: Reply with quote

you need to emerge it ;) and if you dont want to lose your settings/credits move the old amuleadu's home to ~/.aMuleAdunanzA
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Tue Jun 02, 2009 7:13 am    Post subject: Reply with quote

Could you post dependences?
I am doing a new installation of Gentoo.

I think that it maybe a problem of dependences. Because in the old installation I have amuleadu, based on 2.2.4, installed, and it worked. But I could not emerge amuleadu based on 2.2.5.
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Tue Jun 02, 2009 7:20 am    Post subject: Reply with quote

sorry but im not at home. This evening I'll check if amule 2.2.5 ebuild has pulled in new deps. Btw, if you compiled succesfully the official ebuild you should already have the proper dependencies on your system
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Tue Jun 02, 2009 7:22 am    Post subject: Reply with quote

I am using ~x86, so the system change very quickly. Since I installed the 2.2.4 it was a long time.
Yesterday I emerged amule 2.2.5 and it worked, but amuleadu 2.2.5 doesn't emerge.
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Tue Jun 02, 2009 9:24 pm    Post subject: Reply with quote

https://bugzilla.redhat.com/show_bug.cgi?id=500487
http://repo.or.cz/w/glibc.git?a=commit;h=1f3615a1c97a030bca59f728f998947f852679b9
according to these posts, its a glibc bug. they've already fixed it but we have to wait for the next release
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Wed Jun 03, 2009 2:12 pm    Post subject: Reply with quote

Thank you very much.
So the problem is glibc, so I will wait new version.
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Tue Jun 09, 2009 8:41 am    Post subject: Reply with quote

Is there a way to have a later glibc version?
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Tue Jun 09, 2009 10:31 am    Post subject: Reply with quote

you are free to download a snapshot from glibc repo, but it's NOT safe.
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Tue Jun 09, 2009 3:01 pm    Post subject: Reply with quote

There isn't an overlay for glibc?
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Tue Jun 09, 2009 3:03 pm    Post subject: Reply with quote

I don't think so.. actually I dont know ;) btw, its a very unsafe solution
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Tue Jun 09, 2009 3:04 pm    Post subject: Reply with quote

What can be another possible solution?
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Tue Jun 09, 2009 3:06 pm    Post subject: Reply with quote

well.. I dont know :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum