Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox 3.5 and Thunderbird 3 - "Preferences" dialog broken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Wed Jun 10, 2009 4:59 am    Post subject: Firefox 3.5 and Thunderbird 3 - "Preferences" dial Reply with quote

I decided to check out mozilla-firefox-3.5_beta4-r1 and mozilla-thunderbird-3.0_beta2 in one of my machines (from the "mozilla" overlay). They both emerged fine without problems. They even run without problems except that I can't change their configuration. In both Firefox and Thunderbird, "Edit->Preferences" brings up a big but totally empty dialog:

http://i44.tinypic.com/2i70jer.png

I did "rm -rf ~/.mozilla ~/.thunderbird" so everything is clean, but still no go.

Anyone else encountered this? The machine in question is ACCEPT_KEYWORDS="~amd64" so everything is up to date.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jun 10, 2009 10:19 am    Post subject: Reply with quote

afaik it's some problem caused by qtcurve theme / libs

let me have a look at my docs and I'll post a solution to this problem (it was to delete a .css file inside /usr/* - dunno the exact location, if I recall correctly)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Wed Jun 10, 2009 11:31 am    Post subject: Reply with quote

Hmm, I do use QtCurve but now I tried Raleph and Oxygen-gtk too but still same problem.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jun 10, 2009 11:49 am    Post subject: Reply with quote

it's the file:

/usr/share/themes/QtCurve/mozilla/QtCurve.css

just delete it (before that make a backup, just in case ...) or follow further instructions in the below thread


the thread is:

https://forums.gentoo.org/viewtopic-t-717516-start-50-postdays-0-postorder-asc-highlight-.html (mozilla-firefox 3.1 beta2 ebuild?)

kudos to Rion and laplata !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Wed Jun 10, 2009 12:06 pm    Post subject: Reply with quote

kernelOfTruth wrote:
it's the file:

/usr/share/themes/QtCurve/mozilla/QtCurve.css

just delete it (before that make a backup, just in case ...) or follow further instructions in the below thread


Thanks. Though it's QtCurve-KDEButtonOrder.css that causes the problem, not QtCurve.css :) Works OK now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum