Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[mount] petit problème de lecteur de cdrom
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Fri Jun 12, 2009 1:40 pm    Post subject: [mount] petit problème de lecteur de cdrom Reply with quote

Bonjour. Un problème sûrement tout simple, mais qui me casse la tête depuis quelques temps :

Je n'arrive pas à monter mon lecteur de cd.
Code:
hache-paix ~ # ls -al /dev/cd*
lrwxrwxrwx 1 root root 3 juin  12 16:54 /dev/cdrom -> hda
lrwxrwxrwx 1 root root 3 juin  12 16:54 /dev/cdrw -> hda


Du coup, j'essaie
Code:
hache-paix ~ # mount /dev/hda /mnt/cdrom
mount: Aucun fichier ou dossier de ce type
hache-paix ~ # mkdir /mnt/cdrom
mkdir: ne peut créer le répertoire `/mnt/cdrom': Le fichier existe
hache-paix ~ # mount /dev/cdrom /mnt/cdrom
mount: Aucun fichier ou dossier de ce type


Une idée de ce qui se passe ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8131
Location: ~Brussels - Belgique

PostPosted: Fri Jun 12, 2009 2:05 pm    Post subject: Reply with quote

Un souci avec les persistent rules de udev ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Fri Jun 12, 2009 2:52 pm    Post subject: Reply with quote

Sans doute, mais je ne sais pas trop comment ça marche, et surtout comment configurer ces rules...
Vu que j'ai compilé le kernel avec genkernel, je croyais que c'était configuré correctement déjà par défaut.
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 461
Location: Martinique

PostPosted: Sat Jun 13, 2009 1:59 am    Post subject: Reply with quote

et ls -l /dev/hda ?
Back to top
View user's profile Send private message
salamandrix
Apprentice
Apprentice


Joined: 03 Aug 2006
Posts: 245

PostPosted: Sun Jun 14, 2009 6:58 am    Post subject: Reply with quote

Hm une question bête mais genkernel n'utilise pas libata ? Et en conséquence le lecteur ne devrait pas être plutôt en /dev/sr0 ?
Back to top
View user's profile Send private message
novazur
Guru
Guru


Joined: 19 Mar 2005
Posts: 461
Location: Martinique

PostPosted: Sun Jun 14, 2009 7:43 am    Post subject: Reply with quote

salamandrix wrote:
Hm une question bête mais genkernel n'utilise pas libata ? Et en conséquence le lecteur ne devrait pas être plutôt en /dev/sr0 ?

d'où ma question de savoir si ce /dev/hda est bien le lecteur cd en question (bon, certes, question pas exprimée comme ça).
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Mon Jun 15, 2009 4:01 pm    Post subject: Reply with quote

Juste comme ça en passant : à tout hasard, tu n'essaies pas de monter un CD audio ? Parce que ça n'est pas possible (par défaut).

Ensuite les lecteurs "amovibles" sont montés dans "/media" (sauf règle particulière). Mais il me semble qu'il est possible de monter un périphérique sur plusieurs points (à confirmer).

Enfin, tu pourrais nous donner le résultat d'un "ls -al /mnt/", d'un "mount" et d'un "uname -a" stp ?

Enjoy !
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue Jun 16, 2009 9:43 pm    Post subject: Reply with quote

yoyo wrote:
Juste comme ça en passant : à tout hasard, tu n'essaies pas de monter un CD audio ? Parce que ça n'est pas possible (par défaut).

Ah ben si, je savais pas, c'était la première fois que je le faisait, quant j'y pense...
Code:
> ls -al /mnt/
total 13
drwxr-xr-x  9 root root   240 juin  10 19:57 .
drwxr-xr-x 22 root root   536 juin  15 02:26 ..
drwxr-xr-x  2 root root    48 mai   11 11:28 arch
drwxr-xr-x  2 root root    48 mai   20 00:38 boot
drwx------  2 root root    72 juin  17  2008 cdrom
drwx------  2 root root    72 juin  17  2008 floppy
-rw-r--r--  1 root root     0 juin  17  2008 .keep
drwxr-xr-x  2 root root    48 mai   20 00:40 mp
drwxr-xr-x  2 root root    48 juin  10 19:57 server

mp/ je ne sais plus à quoi il me servait, mais pour l'instant, il est vide, et server/ est le point de montage de mon server en sshfs.
d'ailleurs, quant je le monte, ça me donne ça :
Code:
> ls -al /mnt/
ls: ne peut accéder /mnt/server: Permission non accordée
total 13
drwxr-xr-x  9 root root   240 juin  10 19:57 .
drwxr-xr-x 22 root root   536 juin  15 02:26 ..
drwxr-xr-x  2 root root    48 mai   11 11:28 arch
drwxr-xr-x  2 root root    48 mai   20 00:38 boot
drwx------  2 root root    72 juin  17  2008 cdrom
drwx------  2 root root    72 juin  17  2008 floppy
-rw-r--r--  1 root root     0 juin  17  2008 .keep
drwxr-xr-x  2 root root    48 mai   20 00:40 mp
??????????  ? ?    ?        ?              ? server
C'est normal ?
Code:
> mount
rootfs on / type rootfs (rw)
/dev/sda6 on / type reiserfs (rw,noatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
rc-svcdir on /lib64/rc/init.d type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
udev on /dev type tmpfs (rw,nosuid,relatime,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda3 on /home type ext3 (rw,noatime)
/dev/sda2 on /mnt/win7 type fuseblk (rw,allow_other,blksize=4096)
usbfs on /proc/bus/usb type usbfs (rw,noexec,nosuid,devmode=0664,devgid=85)

Code:
> uname -a
Linux hache-paix 2.6.30-gentoo-r1 #1 SMP Fri Jun 12 02:40:27 CEST 2009 x86_64 Intel(R) Pentium(R) Dual CPU T2370 @ 1.73GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Jun 17, 2009 8:14 am    Post subject: Reply with quote

pour ton sshfs c'est pas normal. Enfin moi j'ai pas ça. Tu le montes comment ? sshfs user@host:/path/ server/ ?

De plus ton mount ne le mentionne pas. T'as pas d'erreur au montage ? T'as bien FUSE_FS dans le kernel ?
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum