Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[java] Downgrade de gcc nécessaire ? (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Mon Jun 22, 2009 10:33 pm    Post subject: [java] Downgrade de gcc nécessaire ? (résolu) Reply with quote

Bonjour,

J'ai un petit problème avec java : quant j'essaie de lancer une application java, ça me donne un message d'erreur comme suit :
Quote:
$--> java -jar ./JDownloader.jar
23 juin 2009 02:19:12 - INFO [jd.Main(main)] -> Start JDownloader
JAR
23 juin 2009 02:19:12 - LE PLUS FIN [jd.utils.JDUtilities(getJDClassLoader)] -> Create Classloader: for: /home/ego/Desktop/JDownloader 0.6.193
23 juin 2009 02:19:12 - LE PLUS FIN [jd.JDClassLoader(<init>)] -> rootDir:/home/ego/Desktop/JDownloader 0.6.193
/home/ego/Desktop/JDownloader 0.6.193
file:/home/ego/Desktop/JDownloader%200.6.193/jd
23 juin 2009 02:19:12 - PLUS FIN [jd.JDClassLoader(<init>)] -> Jar file loaded: /home/ego/Desktop/JDownloader 0.6.193/plugins/JDShutdown.jar
23 juin 2009 02:19:12 - PLUS FIN [jd.JDClassLoader(<init>)] -> Jar file loaded: /home/ego/Desktop/JDownloader 0.6.193/plugins/JDUnrar.jar
23 juin 2009 02:19:12 - PLUS FIN [jd.JDClassLoader(<init>)] -> Jar file loaded: /home/ego/Desktop/JDownloader 0.6.193/plugins/JDChat.jar
23 juin 2009 02:19:12 - PLUS FIN [jd.JDClassLoader(<init>)] -> Jar file loaded: /home/ego/Desktop/JDownloader 0.6.193/plugins/JDHJMerge.jar
23 juin 2009 02:19:12 - PLUS FIN [jd.JDClassLoader(<init>)] -> Jar file loaded: /home/ego/Desktop/JDownloader 0.6.193/plugins/JDTray.jar
23 juin 2009 02:19:12 - PLUS FIN [jd.JDClassLoader(<init>)] -> Jar file loaded: /home/ego/Desktop/JDownloader 0.6.193/JDownloader.jar
23 juin 2009 02:19:12 - GRAVE [jd.Main(main)] -> Instance Handling not possible!
23 juin 2009 02:19:12 - PLUS FIN [jd.config.DatabaseConnector(<init>)] -> Loading database
23 juin 2009 02:19:13 - ATTENTION [jd.config.DatabaseConnector(getData)] -> Database not available. Create new one: simpleGUI
23 juin 2009 02:19:13 - LE PLUS FIN [jd.controlling.JDLogger(exception)] -> FINEST Exception occurred
java.sql.SQLException: Table not found in statement [SELECT * FROM config]
at org.hsqldb.jdbc.Util.sqlException(Unknown Source)
at org.hsqldb.jdbc.jdbcStatement.fetchResult(Unknown Source)
at org.hsqldb.jdbc.jdbcStatement.executeQuery(Unknown Source)
at jd.config.DatabaseConnector.getData(Unknown Source)
at jd.config.SubConfiguration.<init>(Unknown Source)
at jd.config.SubConfiguration.getConfig(Unknown Source)
at jd.Main.main(Unknown Source)
First save simpleGUI
23 juin 2009 02:19:13 - ATTENTION [jd.config.DatabaseConnector(saveConfiguration)] -> Database save error: simpleGUI
23 juin 2009 02:19:13 - LE PLUS FIN [jd.controlling.JDLogger(exception)] -> FINEST Exception occurred
java.sql.SQLException: Table not found in statement [INSERT INTO config VALUES (?,?)]
at org.hsqldb.jdbc.Util.throwError(Unknown Source)
at org.hsqldb.jdbc.jdbcPreparedStatement.<init>(Unknown Source)
at org.hsqldb.jdbc.jdbcConnection.prepareStatement(Unknown Source)
at jd.config.DatabaseConnector.saveConfiguration(Unknown Source)
at jd.config.SubConfiguration.save(Unknown Source)
at jd.config.SubConfiguration.getConfig(Unknown Source)
at jd.Main.main(Unknown Source)
23 juin 2009 02:19:13 - INFO [jd.Main(main)] -> init Splash
Exception in thread "main" java.lang.UnsatisfiedLinkError: /opt/icedtea6-bin-1.4.1/jre/lib/amd64/libfontmanager.so: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /opt/icedtea6-bin-1.4.1/jre/lib/amd64/libfontmanager.so)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1767)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1684)
at java.lang.Runtime.loadLibrary0(Runtime.java:840)
at java.lang.System.loadLibrary(System.java:1047)
at sun.font.FontManagerNativeLibrary$1.run(FontManagerNativeLibrary.java:61)
at java.security.AccessController.doPrivileged(Native Method)
at sun.font.FontManagerNativeLibrary.<clinit>(FontManagerNativeLibrary.java:32)
at sun.font.FontManager$1.run(FontManager.java:233)
at java.security.AccessController.doPrivileged(Native Method)
at sun.font.FontManager.<clinit>(FontManager.java:230)
at sun.java2d.SunGraphicsEnvironment$2.run(SunGraphicsEnvironment.java:178)
at java.security.AccessController.doPrivileged(Native Method)
at sun.java2d.SunGraphicsEnvironment.<init>(SunGraphicsEnvironment.java:162)
at sun.awt.X11GraphicsEnvironment.<init>(X11GraphicsEnvironment.java:213)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
[...]

Bon. J'essaie de comprendre ce message d'erreur, et je retiens ce qui est en rouge : ça a l'air d'un problème de version de gcc.
Qu'en pensez-vous ?
Que dois-je faire ?


Last edited by she0gorath on Tue Jun 23, 2009 5:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Jun 23, 2009 7:20 am    Post subject: Reply with quote

Pas forcément un downgrade, gcc peut être "slotté". Ça devrait suffire: démasque gcc 4.2 et installes le.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Tue Jun 23, 2009 7:27 am    Post subject: Reply with quote

je dirais plutot une mise à jour de gcc pas finie :)


Tente un "fix_libtool_files.sh"
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Delvin
Guru
Guru


Joined: 07 Jul 2004
Posts: 546

PostPosted: Tue Jun 23, 2009 10:01 am    Post subject: Reply with quote

fais voir le résultat d'un "eselect gcc list"

Je penche pour un démerge de gcc 4.2 sans avoir selectionné le nouveau avec eselect

J'ai eu ça récemment :)
_________________
Ne tirez pas sur les canards !!
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue Jun 23, 2009 1:10 pm    Post subject: Reply with quote

Anéfé :
Code:
--# eselect gcc list
!!! Error: Can't load module gcc
exiting
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8078
Location: ~Brussels - Belgique

PostPosted: Tue Jun 23, 2009 1:18 pm    Post subject: Reply with quote

gcc-config -l
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue Jun 23, 2009 2:27 pm    Post subject: Reply with quote

Je viens de re-emerger gcc. Même message d'erreur. (
Code:
--> gcc-config -l
 [1] x86_64-pc-linux-gnu-4.1.2 *
 [2] x86_64-pc-linux-gnu-4.3.3
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Tue Jun 23, 2009 2:58 pm    Post subject: Reply with quote

she0gorath wrote:
Je viens de re-emerger gcc. Même message d'erreur. (
Code:
--> gcc-config -l
 [1] x86_64-pc-linux-gnu-4.1.2 *
 [2] x86_64-pc-linux-gnu-4.3.3

Bah tu vois pas comme qui dirait un problème? Il manque gcc 4.2... installes le. Et fais aussi ce que proposes guilc
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue Jun 23, 2009 3:43 pm    Post subject: Reply with quote

Euh... Excusez mon ignorance, je suis nouveau sous gentoo...
Comment on fait pour installer une vielle version d'un logiciel (ici gcc) via emerge ? Là dans ma liste d'ebuilds, je n'ai que la version 3.3-r2
Suis-je obligé de compiler à la main ?
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Tue Jun 23, 2009 3:54 pm    Post subject: Reply with quote

l'arbre portage contient pas mal de version de gcc:
Code:

~ $ eix --exact gcc
[I] sys-devel/gcc
     Available versions: 
   (2.95)   2.95.3-r9 ~2.95.3-r10!s
   (3.1)   3.1.1-r2
   (3.2)   **3.2.2!s 3.2.3-r4
   (3.3)   ~3.3.6-r1!s
   (3.4)   3.4.6-r2!s
   (4.0)   ~*4.0.4!s
   (4.1)   4.1.2!s
   (4.2)   ~4.2.4-r1!s
   (4.3)   4.3.2-r3!s ~4.3.2-r4!s ~4.3.3-r2!s
   (4.4)   [M]~4.4.0!s


la version 4.2 est keywordée donc, rajoute
Code:
=sys-devel/gcc-4.2.4-r1

dans ton package.keywords

puis un
Code:
emerge -av =gcc-4.1.2

devrait faire l'affaire

Bruno
Back to top
View user's profile Send private message
Delvin
Guru
Guru


Joined: 07 Jul 2004
Posts: 546

PostPosted: Tue Jun 23, 2009 4:21 pm    Post subject: Reply with quote

euh gcc-config -f 2 résoudra plus que probablement le problème, pas besoin de réinstaller le 4.2 , le 4.3 fait l'affaire, enfin pour moi ça a marché nickel .
_________________
Ne tirez pas sur les canards !!
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue Jun 23, 2009 4:26 pm    Post subject: Reply with quote

Merci brubru, je ne connaissais pas eix. Très pratique...
Je compile, et je vous fait part ensuite des résultats...
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Tue Jun 23, 2009 4:37 pm    Post subject: Reply with quote

Delvin wrote:
euh gcc-config -f 2 résoudra plus que probablement le problème, pas besoin de réinstaller le 4.2 , le 4.3 fait l'affaire, enfin pour moi ça a marché nickel .


c'est sùr, surtout que la version 4.2 n'a jamais été stabilisée, je crois. Donc avant de perdre une heure de compilation...
Tu devrais aussi passer à gcc-4.3.3, car ton gcc-config indique que tu compile tous avec le 4.1.2
Back to top
View user's profile Send private message
she0gorath
n00b
n00b


Joined: 25 May 2009
Posts: 25

PostPosted: Tue Jun 23, 2009 5:46 pm    Post subject: Reply with quote

brubru wrote:
Delvin wrote:
euh gcc-config -f 2 résoudra plus que probablement le problème, pas besoin de réinstaller le 4.2 , le 4.3 fait l'affaire, enfin pour moi ça a marché nickel .


c'est sùr, surtout que la version 4.2 n'a jamais été stabilisée, je crois. Donc avant de perdre une heure de compilation...
Tu devrais aussi passer à gcc-4.3.3, car ton gcc-config indique que tu compile tous avec le 4.1.2


C'est fait ! Et ça marche avec la 4.3.3

résolu !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum