Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel mode PPPoE or Penguins DO NOT ROAR!!!
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
c0ma2k
n00b
n00b


Joined: 30 Sep 2002
Posts: 15
Location: Germany

PostPosted: Thu Jun 10, 2004 11:57 am    Post subject: Reply with quote

I have switched to using the net.ppp0 script instead of the rp-pppoe package quite a while ago. I was using sync ppp with rp-pppoe before, and now I'm wondering if this is still used with the "pure-pppd-way".
rp-pppoe needed the n_hdlc module which isn't loaded automatically now, and if I load it manually before connecting, lsmod says it's unused. Also there's the ppp_synctty module, which does not seem to be used either. My /etc/ppp/options includes the "sync" option.
Is there a way to find out if the DSL connection is sync or async? With rp-pppoe the syslog told me that pppd actually was switching to sync, which it doesn't do anymore.
I'm asking, because I read that synctty should solve a few problems I have.
Back to top
View user's profile Send private message
opo
n00b
n00b


Joined: 28 Jun 2004
Posts: 32
Location: Rome, Italy

PostPosted: Mon Jul 05, 2004 5:41 pm    Post subject: Reply with quote

You guys are great: if I am on the Internet right now for the first time is thanks to U.
This post is intended to be a thanksgiving to everyone who posted this topic and a hope for n00bies like me, on linux for the first time since two weeks......I am really happy.

I run gentoo 2.4.25-r1 and really I couldn't yet cope with ADSL connection by myself.
This is my very first post from the internet, and I hope not the last since I don't feel like shutting down my machine anymore.......but I should :(

Now I really feel encouraged to keep on with Gentoo and Linux. Thanks again.
Back to top
View user's profile Send private message
jpsmith
n00b
n00b


Joined: 25 Apr 2002
Posts: 7

PostPosted: Thu Jul 08, 2004 6:45 am    Post subject: rp-pppoe Reply with quote

I was using su - , then adsl-start to connect; however I have now found that kdsl works correctly, and provides a gui internet connection for non-root users

http://kdslbroadband.sourceforge.net/

I have kernel 2.6.7-r7, dev-sources, but I may have had some residual kernel 2.4 as i booted 2004 as gentoo-nofb noraid

I have only changed the kernel to 4k stacks and no spinlocsks, no regparms (however nvidia driver 6106 loaded with the previous settings of regparms, 4k or 8k stacks and spinlocks installed)

Anyway it looks like KDSL works ok
--I did use rp-pppoe as the initial setup and have since enabled pppoe in the kernel
[/quote]
Back to top
View user's profile Send private message
eyefloater
n00b
n00b


Joined: 27 Jun 2004
Posts: 13

PostPosted: Fri Jul 09, 2004 4:08 am    Post subject: Reply with quote

hoschi wrote:
yes,
it is a error in the howto!

edit the /etc/ppp/options, and add:
plugin pppoe.se
name "your user name"
lock


and so you don't need rp-pppoe, ok, it is now only comsetic, but a emerge less to do :-)

ps: ich wrote three bash-scipts, for start, stop and status and now ist really my "own" way for getting a internet-connection :D

thank you, bye


i hate to ask you to walk me through this, but i need you to walk me through this. ;)

okay, adsl-start is timing out. i don't have rp-pppoe. i went into /etc/ppp/options and put in exactly what you suggested (and that was JUST my adsl user name, right? not like "b1qv@sympatico.ca" or something?). then ... just save and try adsl-start again, or what am i missing.

i've been at this for far too long now and i can't even see straight, so i apologize if i'm glazing over something obvious.
ps. yes, pppoe is compiled into the kernel, along synch/asynch and the two compression methods.
Back to top
View user's profile Send private message
gour
Apprentice
Apprentice


Joined: 16 Apr 2003
Posts: 231
Location: Zagreb, Croatia

PostPosted: Fri Jul 09, 2004 7:26 am    Post subject: Re: rp-pppoe Reply with quote

jpsmith wrote:
I was using su - , then adsl-start to connect; however I have now found that kdsl works correctly, and provides a gui internet connection for non-root users

http://kdslbroadband.sourceforge.net/


Is there some ebuild for it?

I'm still waiting for adsl from my provider, but want to be ready :lol:

Sincerely,
Gour
Back to top
View user's profile Send private message
nielchiano
Veteran
Veteran


Joined: 11 Nov 2003
Posts: 1283
Location: 50N 3E

PostPosted: Sat Nov 06, 2004 10:28 am    Post subject: Reply with quote

I just upgraded tot 2.4.2 and got this:
Code:
/usr/sbin/pppd: /usr/lib/pppd/2.4.2/pppoe.so: cannot open shared object file: No such file or directory
/usr/sbin/pppd: Couldn't load plugin pppoe.so

I looked a bit and found another file, named rp-pppoe.so (in the directory that he was looking).

Is this just a rename? Or have I lost my kernel-PPPOE?
Back to top
View user's profile Send private message
rth
Apprentice
Apprentice


Joined: 23 Sep 2002
Posts: 157

PostPosted: Sat Nov 13, 2004 1:17 am    Post subject: Reply with quote

I have the same error. Not sure where pppoe.so is hiding...
Back to top
View user's profile Send private message
AndCycle
n00b
n00b


Joined: 05 Jun 2004
Posts: 16

PostPosted: Sat Nov 13, 2004 6:41 am    Post subject: Reply with quote

Quote:
* Note: the library name has changed from pppoe.so to rp-pppoe.so.

you can see this notice after emerge net-dialup/ppp
Back to top
View user's profile Send private message
rth
Apprentice
Apprentice


Joined: 23 Sep 2002
Posts: 157

PostPosted: Sat Nov 13, 2004 7:24 pm    Post subject: Reply with quote

That part is fixed... Now I get this:

Code:
 * Bringing ppp0 up...
SIOCDELRT: No such process
Plugin rp-pppoe.so loaded.
RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2                   [ ok ]


Note the 2nd line... I don't get connected.
Back to top
View user's profile Send private message
vario
n00b
n00b


Joined: 10 Jan 2004
Posts: 15

PostPosted: Sun Sep 18, 2005 1:03 pm    Post subject: Using kernel-mode ppp with current gentoo Reply with quote

Hi,

just to update this a bit I include my setup with a working adsl connection using the new baselayout.

First of all you need rp-pppoe and ppp. So emerge those two packages and then edit your configuration files:

In /etc/ppp/pppoe.conf change the following lines:
Code:

# Ethernet card connected to ADSL modem
ETH=<eth0,1,2...>

USER="<username for provider>"

# say yes here if you have the module "n_hdlc" loaded, otherwise no
SYNCHRONOUS=yes

LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so


In /etc/conf.d/net
Code:

# Configure the interface to use ADSL
config_<eth0,1,2...>=( "adsl" )

# You probably won't need to edit /etc/ppp/pppoe.conf if you set this
adsl_user_<eth0,1,2...>="<username for provider>"


If there is no link yet create a link for the device:
Code:

ln -s /etc/init.d/net.<eth0,1,2...> /etc/init.d/net.lo


and try to start the whole thing with
Code:

/etc/init.d/net.<eth0,1,2...> start


This should give you a working adsl setup with the kernel-mode plugin. If it works something like this should show up in your logfiles:

Code:

Sep 18 14:38:07 defiant pppd[14164]: Plugin /etc/ppp/plugins/rp-pppoe.so loaded.
Sep 18 14:38:07 defiant pppd[14164]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2
Sep 18 14:38:07 defiant pppd[14164]: pppd 2.4.2 started by root, uid 0
Sep 18 14:38:12 defiant pppd[14164]: PADS: Service-Name: ''
Sep 18 14:38:12 defiant pppd[14164]: PPP session is 1513
Sep 18 14:38:12 defiant pppd[14164]: using channel 56
Sep 18 14:38:12 defiant pppd[14164]: Using interface ppp0
Sep 18 14:38:12 defiant pppd[14164]: Connect: ppp0 <--> eth1


and then

Code:

Sep 18 14:38:12 defiant pppd[14164]: local  IP address 82.xx.xx.xx
Sep 18 14:38:12 defiant pppd[14164]: remote IP address 145.xx.xx.xx


:)
Back to top
View user's profile Send private message
Redeeman
l33t
l33t


Joined: 25 Sep 2003
Posts: 957
Location: Denmark

PostPosted: Sun Sep 18, 2005 3:42 pm    Post subject: Reply with quote

the rp-pppoe package used to provide a rp-pppoe init script.
_________________
Sandberg Enterprises
Back to top
View user's profile Send private message
papu2005
n00b
n00b


Joined: 19 Sep 2005
Posts: 1

PostPosted: Mon Sep 19, 2005 8:01 am    Post subject: WHere do I get this stuff? Reply with quote

Hey guys Iam lost and want to know where I can get a code developer?

Doug
_________________
I have had the best food in my life at la rustica italian restaurant in new westminister bc canada, If anyone wants to go with me pm r email me.
Back to top
View user's profile Send private message
volkmar
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2004
Posts: 122

PostPosted: Sat Sep 24, 2005 7:29 am    Post subject: Re: Using kernel-mode ppp with current gentoo Reply with quote

vario wrote:
First of all you need rp-pppoe and ppp.

Does this mean that penguins finally started roaring?
No way anymore to do it without rp-stuff?
Back to top
View user's profile Send private message
Abraxa
Apprentice
Apprentice


Joined: 14 Jun 2005
Posts: 172
Location: Germany

PostPosted: Fri Oct 28, 2005 10:27 pm    Post subject: Reply with quote

AndCycle wrote:
Quote:
* Note: the library name has changed from pppoe.so to rp-pppoe.so.

you can see this notice after emerge net-dialup/ppp

Would be really nice if that change could be updated in the how-to cause it still says pppoe.so and I've ran into this problem with a fresh install following the guide just now.

-Abraxa
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum