Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]ati-driver 9.5 and hd4770
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rogerdv
Apprentice
Apprentice


Joined: 01 Apr 2006
Posts: 185
Location: Santiago, Cuba

PostPosted: Fri Jun 19, 2009 3:08 pm    Post subject: [solved]ati-driver 9.5 and hd4770 Reply with quote

I asked in Desktop forum, but so,mebody said this is the right forum to ask. I installed ati-drivers 9.5 to get support for my HD4770, but it says it is not recognized. This is the log:
Code:

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.25-gentoo-r7 x86_64
Current Operating System: Linux serenity 2.6.25-gentoo-r7 #1 PREEMPT Sat Oct 4 05:02:49 CDT 2008 x86_64
Build Date: 29 March 2009  08:26:34PM
 
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 19 09:16:26 2009
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x3200
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 4.1
   X.Org XInput driver : 2.1
   X.Org Server Extension : 1.1
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0@4:0:0) ATI Technologies Inc unknown chipset (0x94b3) rev 0, Mem @ 0xd0000000/268435456, 0xcffe0000/65536, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
List of video drivers:
   fglrx
   radeon
   ati
(II) LoadModule: "fglrx"

(II) Loading /usr/lib64/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
   compiled for 1.4.99.906, module version = 8.61.2
   Module class: X.Org Video Driver
(II) LoadModule: "radeon"

(II) Loading /usr/lib64/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 6.12.1
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 4.1
(II) LoadModule: "ati"

(II) Loading /usr/lib64/xorg/modules/drivers//ati_drv.so
(II) Module ati: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 6.12.1
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 4.1
(II) System resource ranges:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(II) Primary Device is: PCI 04@00:00:0
(WW) Falling back to old probe method for fglrx
(II) ATI Proprietary Linux Driver Version Identifier:8.61.2
(II) ATI Proprietary Linux Driver Release Identifier: 8.612                               
(II) ATI Proprietary Linux Driver Build Date: Apr 28 2009 21:45:06
(II) Loading PCS database from /etc/ati/amdpcsdb
(WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
(WW) Video driver ABI version of the X server is 4.1
(II) AMD ASIC control file status: R312 S1 B129 N128 T128
(WW) fglrx: No matching Device section for instance (BusID PCI:0@4:0:1) found
(**) ChipID override: 0x94B3
(**) Chipset Supported AMD Graphics Processor (0x94B3) found

Backtrace:
0: Xorg(xorg_backtrace+0x26) [0x4d7f9e]
1: Xorg(xf86SigHandler+0x39) [0x470171]
2: /lib/libc.so.6 [0x7f1f867ce430]
3: /usr/lib64/xorg/modules/drivers//fglrx_drv.so(atiddxProbeMain+0x34b) [0x7f1f8622f26b]
4: Xorg(xf86CallDriverProbe+0x1cc) [0x4606a3]
5: Xorg(DoConfigure+0x1bd) [0x46ba0f]
6: Xorg(InitOutput+0x652) [0x460ef5]
7: Xorg(main+0x24e) [0x4304ca]
8: /lib/libc.so.6(__libc_start_main+0xf4) [0x7f1f867bbb74]
9: Xorg [0x42fb09]

Fatal server error:
Caught signal 11.  Server aborting


Do I have to try the 9.6?
_________________
Game programming news for newbies | The Ark, making an RPG the right way!


Last edited by rogerdv on Sun Jun 21, 2009 1:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
E001754
Guru
Guru


Joined: 01 Aug 2004
Posts: 442
Location: Paris, France

PostPosted: Fri Jun 19, 2009 3:28 pm    Post subject: Reply with quote

Try posting in the phoronix forums.

There is an AMD dev (bridgman) that is really active out there and he can possibly answer you.

However, when reading you're log :

Quote:

(WW) fglrx: No matching Device section for instance (BusID PCI:0@4:0:1) found
(**) ChipID override: 0x94B3
(**) Chipset Supported AMD Graphics Processor (0x94B3) found


Perhaps try some "lspci" to see what is the PCIID of your Radeon 4770 ?
You have nothing to lose trying 9.6 (except losing your time).

Hope this helps.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jun 19, 2009 5:59 pm    Post subject: Reply with quote

E001754 wrote:

However, when reading you're log :

Quote:

(WW) fglrx: No matching Device section for instance (BusID PCI:0@4:0:1) found
(**) ChipID override: 0x94B3
(**) Chipset Supported AMD Graphics Processor (0x94B3) found



it's only a warning (WW) I get a similar warning with me 4850 and it still works :P
Quote:
cat /var/log/Xorg.0.log | grep Device
(**) | |-->Device "aticonfig-Device[0]-0"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(II) Primary Device is: PCI 06@00:00:0
(WW) fglrx: No matching Device section for instance (BusID PCI:0@6:0:1) found
(--) fglrx(0): (PciSubVendor = 0x1043, PciSubDevice = 0x026a)



something looks fishy:
Quote:
(II) Loading /usr/lib64/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
   compiled for 1.4.99.906, module version = 8.61.2
   Module class: X.Org Video Driver
(II) LoadModule: "radeon"

(II) Loading /usr/lib64/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 6.12.1
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 4.1
(II) LoadModule: "ati"


try not mixing opensource with proprietary graphics driver stuff (removing those lines or commenting out) and explicitely selecting fglrx as the graphics driver

see:
Quote:
cat /var/log/Xorg.0.log | grep LoadModule
(II) LoadModule: "glx"
(II) LoadModule: "dri"
(II) LoadModule: "fglrxdrm"
(II) LoadModule: "dbe"
(II) LoadModule: "extmod"
(II) LoadModule: "freetype"
(II) LoadModule: "xtrap"
(II) LoadModule: "record"
(II) LoadModule: "dri2"
(II) LoadModule: "fglrx"
(II) LoadModule: "vgahw"
(II) LoadModule: "fglrxdrm"
(II) LoadModule: "int10"
(II) LoadModule: "vbe"
(II) LoadModule: "ddc"
(II) LoadModule: "fb"
(II) LoadModule: "ramdac"
(II) LoadModule: "xaa"
(II) LoadModule: "glesx"
(II) LoadModule: "amdxmm"
(II) LoadModule: "evdev"



Code:
eselect opengl list


says what ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
rogerdv
Apprentice
Apprentice


Joined: 01 Apr 2006
Posts: 185
Location: Santiago, Cuba

PostPosted: Fri Jun 19, 2009 10:19 pm    Post subject: Reply with quote

Well, I have tried setting xrog to use ati, before running Xorg -configure, and yes, it is set. In Phorinix forums the recommendation was to remove xorg.conf, create an empty one and run aticonf to create the initial configuration.
_________________
Game programming news for newbies | The Ark, making an RPG the right way!
Back to top
View user's profile Send private message
E001754
Guru
Guru


Joined: 01 Aug 2004
Posts: 442
Location: Paris, France

PostPosted: Sat Jun 20, 2009 7:43 pm    Post subject: Reply with quote

and so, does it run now ?
Back to top
View user's profile Send private message
rogerdv
Apprentice
Apprentice


Joined: 01 Apr 2006
Posts: 185
Location: Santiago, Cuba

PostPosted: Sat Jun 20, 2009 8:02 pm    Post subject: Reply with quote

No, it didnt. When i try to run X my whole system freezes, and no clue about why is left in the logs. Currently Im getting a lot of help from bridgman but I dont know if it will work. Im also downloading 9.6 and it ebuild to see what happens.
_________________
Game programming news for newbies | The Ark, making an RPG the right way!
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jun 20, 2009 8:08 pm    Post subject: Reply with quote

try out my xorg.conf:
Code:

Section "ServerLayout"

# The Identifier line must be present
# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens.  The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen.  In this example, screen 2 is located to the
# right of screen 1.
# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used.  Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".
   Identifier     "Simple Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
   InputDevice    "Mouse1" "CorePointer"
   InputDevice    "Keyboard1" "CoreKeyboard"
   Option          "AIGLX" "on"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
#
    FontPath   "built-ins"
#    FontPath   "/usr/lib/X11/fonts/local/"
#    FontPath   "/usr/lib/X11/fonts/misc/"
#    FontPath   "/usr/lib/X11/fonts/75dpi/:unscaled"
#    FontPath   "/usr/lib/X11/fonts/100dpi/:unscaled"
#    FontPath   "/usr/lib/X11/fonts/Type1/"
#    FontPath   "/usr/lib/X11/fonts/TrueType/"
#    FontPath   "/usr/lib/X11/fonts/freefont/"
#    FontPath   "/usr/lib/X11/fonts/75dpi/"
#    FontPath   "/usr/lib/X11/fonts/100dpi/"
# The module search path.  The default path is shown here.
    FontPath        "/usr/share/fonts/100dpi/"
    FontPath        "/usr/share/fonts/75dpi/"
    FontPath        "/usr/share/fonts/aquafont/"
    FontPath        "/usr/share/fonts/aquapfont/"
    FontPath        "/usr/share/fonts/arkpandora/"
    FontPath        "/usr/share/fonts/arphicfonts/"
    FontPath        "/usr/share/fonts/baekmuk-fonts/"
    FontPath        "/usr/share/fonts/corefonts/"
    FontPath        "/usr/share/fonts/cyrillic/"
    FontPath        "/usr/share/fonts/default/"
    FontPath        "/usr/share/fonts/dejavu/"
    FontPath        "/usr/share/fonts/encodings/"
    FontPath        "/usr/share/fonts/fireflysung/"
    FontPath        "/usr/share/fonts/freefonts/"
    FontPath        "/usr/share/fonts/hkscs-ming/"
    FontPath        "/usr/share/fonts/intlfonts/"
    FontPath        "/usr/share/fonts/ja-ipafonts/"
    FontPath        "/usr/share/fonts/jisx0213/"
    FontPath        "/usr/share/fonts/kochi-substitute/"
    FontPath        "/usr/share/fonts/liberation-fonts-ttf/"
    FontPath        "/usr/share/fonts/mathematica-fonts/"
    FontPath        "/usr/share/fonts/mikachan-font/"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/terminus/"
    FontPath        "/usr/share/fonts/texcm-ttf/"
    FontPath        "/usr/share/fonts/ttf-bitstream-vera/"
    FontPath        "/usr/share/fonts/ttf-gentium/"
    FontPath        "/usr/share/fonts/TTF/"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/lib/X11/fonts/unifont/"
    FontPath        "/usr/lib/X11/fonts/urwvn-fonts/"
    FontPath        "/usr/lib/X11/fonts/TrueType/"
    FontPath        "/usr/lib/X11/fonts/freefont/"
EndSection

Section "Module"

# This loads the DBE extension module.
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# This loads the font modules
#    Load        "type1"
# This loads the GLX module
    Load       "glx"
    Load       "GLcore"
# This loads the DRI module
    Load       "dri"
   Load  "dbe"     # Double buffer extension
   SubSection "extmod"
      Option       "omit xfree86-dga"   # don't initialise the DGA extension
   EndSubSection
   Load  "freetype"
#    Load        "xtt"
    Load           "xtrap"
    Load           "record"
EndSection

Section "ServerFlags"
#   Option       "Xinerama" "off"
   Option       "AIGLX" "On"

# Uncomment this to disable the <Ctrl><Alt><BS> server abort sequence
# This allows clients to receive this key event.

    Option "DontZap" "false"
EndSection

Section "InputDevice"

#    Option   "Xleds"      "1 2 3"
#    Option "LeftAlt"     "Meta"
#    Option "RightAlt"    "ModeShift"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"    "pc105"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"    "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"   "de"
# or:
#    Option "XkbLayout"   "de"
#    Option "XkbVariant"  "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions"  "ctrl:swapcaps"
# These are the default XKB settings for Xorg
#    Option "XkbRules"    "xorg"
#    Option "XkbModel"    "pc105"
#    Option "XkbLayout"   "us"
#    Option "XkbVariant"  ""
#    Option "XkbOptions"  ""
#    Option "XkbDisable"
   Identifier  "Keyboard1"
   Driver      "kbd"
   Option       "AutoRepeat" "500 30"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
   Option       "XkbRules" "xorg"
#   Option       "XkbRules" "xfree86"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "de"
#   Option       "XkbVariant" "deadkeys"
EndSection

Section "InputDevice"

# Identifier and driver
#    Option "Resolution"   "256"
# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.
#    Option "BaudRate"   "9600"
#    Option "SampleRate"   "150"
# Mouse wheel mapping.  Default is to map vertical wheel to buttons 4 & 5,
# horizontal wheel to buttons 6 & 7.   Change if your mouse has more than
# 3 buttons and you need to map the wheel to different button ids to avoid
# conflicts.
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"
# ChordMiddle is an option for some 3-button Logitech mice
#    Option "ChordMiddle"
   Identifier  "Mouse1"
   Driver      "mouse"
   Option       "Protocol" "ExplorerPS/2"   # Explorer PS/2
   Option       "Device" "/dev/psaux"
# Mouse-speed setting for PS/2 mouse.
   Option       "ZAxisMapping" "4 5 6 7"
# Emulate3Buttons is an option for 2-button mice
EndSection

Section "Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
#    HorizSync   30-64         # multisync
#    HorizSync   31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync   15-25, 30-50  # multiple ranges of sync frequencies
# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
   Identifier   "samsung SyncMaster 205BW"
   HorizSync    31.5 - 82.2
   VertRefresh  50.0 - 188.1
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
   Modeline "1680x1050"  119.12  1680 1728 1760 1840  1050 1052 1058 1080
EndSection

Section "Device"

# The chipset line is optional in most cases.  It can be used to override
# the driver's chipset detection, and should not normally be specified.
#    Chipset   "generic"
# The Driver line must be present.  When using run-time loadable driver
# modules, this line instructs the server to load the specified driver
# module.  Even when not using loadable driver modules, this line
# indicates which driver should interpret the information in this section.
# The BusID line is used to specify which of possibly multiple devices
# this section is intended for.  When this line isn't present, a device
# section can only match up with the primary video device.  For PCI
# devices a line like the following could be used.  This line should not
# normally be included unless there is more than one video device
# intalled.
#    BusID      "PCI:0:10:0"
#    VideoRam   256
#    Clocks   25.2 28.3
   Identifier  "Standard VGA"
#   Driver      "vga"
   VendorName  "Unknown"
   BoardName   "Unknown"
EndSection

Section "Device"

    #VideoRam    524288
    # Insert Clocks lines here if appropriate
   Identifier  "ASUS Radeon4850"
#   Driver      "radeon"
EndSection

Section "Device"

## ATI stuff
        Option      "XAANoOffscreenPixmaps" "true" ## off when Textured2D enabled
        Option      "UseFastTLS" "1"
#       ### Experimental
        Option      "BackingStore" "on"

      Option     "RenderAccel" "True" # new
##        ### forced turned off so TextureVideo is used
        Option      "VideoOverlay" "On" # was off
        Option      "OpenGLOverlay" "Off"
##        Option      "EnablePrivateBackZ" "on"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
##   Driver       "ati"
   Option       "TexturedVideo" "On"
#       ### Set to 1 - better , set to 2 for compability, and 0 for basic
   Option       "Textured2D" "on"
   Option       "IgnoreABI" "on"
#        Option      "TexturedXRender" "on" # <-- hardlock
   Option       "BlockSignalsOnLock" "on"
        Option     "AddARGBGLXVisuals" "True"
        Option     "DisableGLXRootClipping" "True"
   BusID       "PCI:6:0:0"
EndSection

Section "Screen"
   Option      "AddARGBGLXVisuals" "True"
   Option      "DisableGLXRootClipping" "True"
    Option      "RenderAccel" "True" # goes into "device"
   Identifier "Screen 1"
   Device     "ASUS Radeon4850"
   Monitor    "samsung SyncMaster 205BW"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     8
      Modes    "1680x1050"
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
      Modes    "1680x1050"
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
      Modes    "1680x1050"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
EndSection

Section "Extensions"
    Option         "RENDER" "Enable"
    Option         "Composite" "Enable"
    Option         "DAMAGE" "Enable"


## ati stuff
## Should be loaded automatically, but for good measure
    Option      "XVideo" "On"

EndSection



and change e.g. BusID "PCI:6:0:0" to BusID "PCI:4:0:1"
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
rogerdv
Apprentice
Apprentice


Joined: 01 Apr 2006
Posts: 185
Location: Santiago, Cuba

PostPosted: Sun Jun 21, 2009 1:37 pm    Post subject: Reply with quote

Found the problem, or more exactly, the solution. Run aticonfig but with the templae xorg.conf. That produces a config file which can be used.
_________________
Game programming news for newbies | The Ark, making an RPG the right way!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum