Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PS3 wpa_supplicant fails to associate; "skip- no WPA/RSN IE"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
cmtptr
n00b
n00b


Joined: 20 Jun 2009
Posts: 3

PostPosted: Sat Jun 20, 2009 4:11 am    Post subject: PS3 wpa_supplicant fails to associate; "skip- no WPA/RS Reply with quote

Hi,

I recently installed Gentoo on my PS3 and I'm having trouble with wpa_supplicant. Have any of you been able to connect to a WPA2-PSK protected wireless network? For some reason it skips my network with the message "no WPA/RSN IE." I'm using an identical wpa_supplicant.conf on my laptop (Arch Linux x86_64) and it works fine. I have also been able to connect from the PS3 using iwconfig with network security removed, so I know the interface works.

Any suggestions would be greatly appreciated.
Thanks

My wpa_supplicant.conf:
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

ap_scan=1

network={
        ssid="stuff"
        #scan_ssid=1
        #psk="things"
        psk=thingsandstuff
        proto=WPA2
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=CCMP
}


And the output generated...
Code:
cmt_ps3 ~ # wpa_supplicant -ieth0 -Dwext -c /etc/wpa_supplicant/wpa_supplicant.conf -dd
Initializing interface 'eth0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='0'
ap_scan=1
Line: 6 - start of a new network block
ssid - hexdump_ascii(len=8):
     63 6d 74 5f 77 6c 61 6e                           cmt_wlan       
BSSID - hexdump(len=6): 00 1d 7e 1e a5 8c
PSK - hexdump(len=32): [REMOVED]
proto: 0x2
key_mgmt: 0x2
pairwise: 0x10
group: 0x10
Priority group 0
   id=0 ssid='cmt_wlan'
Initializing interface (2) 'eth0'
Interface eth0 set UP - waiting a second for the driver to complete initialization
SIOCGIWRANGE: WE(compiled)=22 WE(source)=19 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf flags 0x0
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:1f:a7:7c:a6:34
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
ctrl_interface_group=0
Added interface eth0
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x11003 ([UP][LOWER_UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 4096 bytes of scan results (0 BSSes)
Cached scan results are empty - not posting
Selecting BSS from priority group 0
Try to find WPA-enabled AP
Try to find non-WPA AP
No suitable AP found.
Setting scan request: 0 sec 0 usec
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 5 seconds
EAPOL: disable timer tick
Scan timeout - try to get results
Received 2964 bytes of scan results (10 BSSes)
CTRL-EVENT-SCAN-RESULTS
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:1d:7e:1e:a5:8c ssid='cmt_wlan' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
1: 00:1a:70:fd:72:95 ssid='Get Some' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
2: 00:10:18:02:01:f4 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
3: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
4: 8b:96:24:30:48:6c ssid='___*_' wpa_ie_len=0 rsn_ie_len=0 caps=0x2
   skip - no WPA/RSN IE
5: 74:65:72:10:24:00 ssid='_DIR-615_B' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
6: 43:5e:00:62:32:2f ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
7: 06:00:64:00:31:04 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
8: 6e:73:01:08:82:84 ssid='_____$_____US ___ _' wpa_ie_len=0 rsn_ie_len=0 caps=0x0
   skip - no WPA/RSN IE
9: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
Try to find non-WPA AP
0: 00:1d:7e:1e:a5:8c ssid='cmt_wlan' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - non-WPA network not allowed
1: 00:1a:70:fd:72:95 ssid='Get Some' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
2: 00:10:18:02:01:f4 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
3: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
4: 8b:96:24:30:48:6c ssid='___*_' wpa_ie_len=0 rsn_ie_len=0 caps=0x2
   skip - SSID mismatch
5: 74:65:72:10:24:00 ssid='_DIR-615_B' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
6: 43:5e:00:62:32:2f ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
7: 06:00:64:00:31:04 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
8: 6e:73:01:08:82:84 ssid='_____$_____US ___ _' wpa_ie_len=0 rsn_ie_len=0 caps=0x0
   skip - SSID mismatch
9: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 5 seconds
Scan timeout - try to get results
Received 3569 bytes of scan results (12 BSSes)
CTRL-EVENT-SCAN-RESULTS
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:1d:7e:1e:a5:8c ssid='cmt_wlan' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
1: 00:1a:70:fd:72:95 ssid='Get Some' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
2: 00:10:18:02:01:f4 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
3: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - no WPA/RSN IE
4: 8b:96:24:30:48:6c ssid='___*_' wpa_ie_len=0 rsn_ie_len=0 caps=0x2
   skip - no WPA/RSN IE
5: 8b:96:24:30:48:6c ssid='___*__/__2____`__' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
6: 74:65:72:10:24:00 ssid='_DIR-615_B' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
7: 43:5e:00:62:32:2f ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
8: 06:00:64:00:31:04 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
9: 6e:73:01:08:82:84 ssid='_____$_____US ___ _' wpa_ie_len=0 rsn_ie_len=0 caps=0x0
   skip - no WPA/RSN IE
10: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - no WPA/RSN IE
11: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x0
   skip - no WPA/RSN IE
Try to find non-WPA AP
0: 00:1d:7e:1e:a5:8c ssid='cmt_wlan' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - non-WPA network not allowed
1: 00:1a:70:fd:72:95 ssid='Get Some' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
2: 00:10:18:02:01:f4 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
3: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x11
   skip - SSID mismatch
4: 8b:96:24:30:48:6c ssid='___*_' wpa_ie_len=0 rsn_ie_len=0 caps=0x2
   skip - SSID mismatch
5: 8b:96:24:30:48:6c ssid='___*__/__2____`__' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
6: 74:65:72:10:24:00 ssid='_DIR-615_B' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
7: 43:5e:00:62:32:2f ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
8: 06:00:64:00:31:04 ssid='_' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
9: 6e:73:01:08:82:84 ssid='_____$_____US ___ _' wpa_ie_len=0 rsn_ie_len=0 caps=0x0
   skip - SSID mismatch
10: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
   skip - SSID mismatch
11: 00:00:00:00:00:00 ssid='' wpa_ie_len=0 rsn_ie_len=0 caps=0x0
   skip - SSID mismatch
No suitable AP found.
Setting scan request: 5 sec 0 usec
Starting AP scan (broadcast SSID)
Scan requested (ret=0) - scan timeout 5 seconds
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface eth0
State: SCANNING -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
wpa_driver_wext_set_countermeasures
No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
WEXT: Operstate: linkmode=0, operstate=6
Back to top
View user's profile Send private message
Poedel
n00b
n00b


Joined: 25 Oct 2006
Posts: 62

PostPosted: Sat Jun 20, 2009 8:12 am    Post subject: Reply with quote

I never get managed to install wpa anyway *G*
Is wired no alternative?

Swank about crypted wireless networks:
Does someone who knows how to hack wep crypt or to clone MACs want to infiltrate YOUR system?
Definetly not. WEP did work on my ps3 fine. But it is positioned next to my router, so it´s wired.
Back to top
View user's profile Send private message
cmtptr
n00b
n00b


Joined: 20 Jun 2009
Posts: 3

PostPosted: Sat Jun 20, 2009 3:11 pm    Post subject: Reply with quote

I wasn't asking for alternatives; I already know about them. I'm asking because I want to get WPA2 working, or at least give it a decent effort before I change my entire network just for the PS3.
Back to top
View user's profile Send private message
Ato
n00b
n00b


Joined: 22 Dec 2007
Posts: 66
Location: Duisburg, Germany

PostPosted: Sat Jun 20, 2009 9:53 pm    Post subject: Reply with quote

Try to let wpa_supplicant figure out the dirty details, omit the "pairwise" and the "group". It works here on my Mac Mini PPC:
network={
ssid="Foo"
scan_ssid=1
psk="Bar"
key_mgmt=WPA-PSK
priority=15
}
Back to top
View user's profile Send private message
cmtptr
n00b
n00b


Joined: 20 Jun 2009
Posts: 3

PostPosted: Mon Jun 22, 2009 12:14 am    Post subject: Reply with quote

I tried your suggestion, Ato. It still doesn't work, with the same error. Even more bizarre, I've started noticing that on some of the scans it doesn't even see my network at all. It still picks up everybody else's around me, though.

Thanks for the responses.
Back to top
View user's profile Send private message
Poedel
n00b
n00b


Joined: 25 Oct 2006
Posts: 62

PostPosted: Mon Jun 22, 2009 11:33 am    Post subject: Reply with quote

there is a gui for installing wpa networx. Does this help you?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum