Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Linux Wacom for the Novice
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
redhubcap
n00b
n00b


Joined: 25 Jun 2009
Posts: 2

PostPosted: Thu Jun 25, 2009 7:06 pm    Post subject: Linux Wacom for the Novice Reply with quote

hello I have followed the steps on the linux wacom site
http://linuxwacom.sourceforge.net/

after running the commands on this page

http://linuxwacom.sourceforge.net/index.php/howto/testtablet

it tells me, hid-core.c needs to be updated.
I think that this page tells me how to update hid-core.c (not sure yet what that is)
http://linuxwacom.sourceforge.net/index.php/howto/buildhid6

so my question is what does this bit of code mean

[jej@ayukawa wacom]$./configure --enable-hid --with-kernel=your-kernel-src-dir
...
BUILD OPTIONS:
hid.o - yes


how would I translate that to my specific case?

this is the example code on the page, it is the exact place that I got stuck following the wacom porject.

Im trying to get a wacom cintiq12wx to work with sabayon 4.0 a breed of gentoo yes I have posted on the sabayon forums and I will probably post this exact thing on there as well.

thanks in advance to anyone who can help translate the code for me. :)
Back to top
View user's profile Send private message
eduardhc
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jan 2007
Posts: 97

PostPosted: Mon Jun 29, 2009 4:17 pm    Post subject: Reply with quote

Hi,
Do you really need to get the lastest source code from linuxwacom & manually compiling it for some reason? If not, then the easiest way to add Wacom tablet support in Gentoo is to simply emerge "linuxwacom" package.

Regards,
Eduard
Back to top
View user's profile Send private message
redhubcap
n00b
n00b


Joined: 25 Jun 2009
Posts: 2

PostPosted: Sun Jul 05, 2009 10:56 pm    Post subject: yes emerge wacom does not do what I need Reply with quote

I almost have this complete here is the problem explained below
I also posted this on the sabayon forum as well

I hope someone can help me with this I have gotten a lot of it done already thanks in advance
wow, I have followed along with all the code on the linux wacom page
got to this point

http://linuxwacom.sourceforge.net/index.php/howto/xset

at some point it talks about a usb mouse can cause problems so I switched my mouse to a non usb one, so we can eliminate any conflicts from that.
Just so you know the tablet is a Cintiq 12WX yes it is supported according to the documentation.

notice the code on the link above is different than mine below
for one, module versioning is set to no but it should be yes(or should it?) how can I change that?
--------------------------------------
BUILD ENVIRONMENT:
architecture - x86_64-pc-linux-gnu
linux kernel - yes 2.6.27
module versioning - no
kernel source - yes /lib/modules/2.6.29-sabayon/source
XFree86 source - no
Xorg SDK - yes /usr/include/xorg
XSERVER64 - yes
dlloader - yes
XLib - yes /usr/lib64
xf86config - yes
TCL - yes /usr/include
TK - yes /usr/include
ncurses - yes

BUILD OPTIONS:
wacom.o - no
wacdump - yes
xidump - yes
libwacomcfg - yes
libwacomxi - yes
xsetwacom - yes
hid.o - no
usbmouse.o - no
evdev.o - no
mousedev.o - no
input.o - no
wacom_drv.so - yes /usr/lib64/xorg/modules/input
wacom_drv.o - no
wacom*_drv quirks - Uninit-called IsXExtensionPointer key-events dixScreenOrigins

---------------------------------------------------------------------------------------------------------
below is the example code from the site, the below code is different than mine how can I make them more the same?

[jej@ayukawa linuxwacom]$./configure
...
----------------------------------------
BUILD ENVIRONMENT:
architecture - i686
linux kernel - yes 2.4
module versioning - yes -DONFIG_MODVERSIONS -DMODVERSIONS -include /usr/src/linux/include/linux/modversions.h
kernel source - yes /usr/src/linux
XFree86 - no
XSERVER64 - no
dlloader - no
XLib - yes /usr/X11R6
TCL - yes /usr
TK - yes /usr
ncurses - yes

BUILD OPTIONS:
wacom.o - no
wacdump - yes
xidump - yes
libwacomcfg - yes
libwacomxi - yes
xsetwacom - yes
hid.o - no
usbmouse.o - no
evdev.o - no
mousedev.o - no
input.o - no
tabletdev.o - no
wacom_drv.so - no
wacom_drv.o - no
----------------------------------------
Back to top
View user's profile Send private message
eduardhc
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jan 2007
Posts: 97

PostPosted: Mon Jul 06, 2009 6:16 am    Post subject: Reply with quote

Again, why do you are using linuxwacom code package directly? You don't need to manually download and compile it, you can add install lastest Wacom package through portage, with a very simple command:

Code:

emerge linuxwacom


This will do it for you, and configure the package appropiately with your USE flags. It will also install some FDI files needed so your Wacom tablet is properly recognized by HAL, so you don't need to manually configure it in /etc/X11/xorg.conf.

Regards
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9265

PostPosted: Tue Jul 07, 2009 1:32 am    Post subject: Reply with quote

redhubcap wrote:
Im trying to get a wacom cintiq12wx to work with sabayon 4.0 a breed of gentoo yes I have posted on the sabayon forums and I will probably post this exact thing on there as well.
Please use the Sabayon forums for Sabayon related problems, given the modification of base packages, among other things, it is unreasonable to assume that all Sabayon problems map well to a Gentoo system.

Moved from Kernel & Hardware to Unsupported Software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum