Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Aug 25, 2009 4:32 pm    Post subject: Reply with quote

4.3.0 here, randomly all file associations and K-menu items have disappeared. Trying to set a file association in system settings crashes system settings, and rm -rf ~/.kde* didn't help.
Any suggestions or insights?
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Tue Aug 25, 2009 6:37 pm    Post subject: Reply with quote

coolsnowmen wrote:
4.3.0 here, randomly all file associations and K-menu items have disappeared. Trying to set a file association in system settings crashes system settings, and rm -rf ~/.kde* didn't help.
Any suggestions or insights?


Upgrade to kdelibs-4.3.0-r1 fixed that for me. Broke with startkde-4.3.0-r1. (Both packages in overlay)
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1595
Location: Just over the horizon

PostPosted: Tue Aug 25, 2009 7:59 pm    Post subject: Reply with quote

rahulthewall wrote:
coolsnowmen wrote:
4.3.0 here, randomly all file associations and K-menu items have disappeared. Trying to set a file association in system settings crashes system settings, and rm -rf ~/.kde* didn't help.
Any suggestions or insights?


Upgrade to kdelibs-4.3.0-r1 fixed that for me. Broke with startkde-4.3.0-r1. (Both packages in overlay)


Had the same issue...I just re-emerged all of KDE again last night and it was fixed...upgraded to kdelibs-4.3.0-r1 this morning...so I think the something I upgraded earlier (probably the startkde upgrade) screwed it all up.
Back to top
View user's profile Send private message
laughinggnome
n00b
n00b


Joined: 07 Mar 2006
Posts: 45

PostPosted: Wed Aug 26, 2009 2:09 pm    Post subject: Reply with quote

I'm trying to build @kdebase-live but I'm having a few problems with autogenerated headers for some packages.

kde-base/kstyles-9999 fails with:

Code:
Scanning dependencies of target kstyle_oxygen_config                                                                                           
[ 75%] Building CXX object kstyles/oxygen/config/CMakeFiles/kstyle_oxygen_config.dir/kstyle_oxygen_config_automoc.o                           
[ 83%] Building CXX object kstyles/oxygen/config/CMakeFiles/kstyle_oxygen_config.dir/oxygenconf.o                                             
/var/tmp/portage/kde-base/kstyles-9999/work/kstyles-9999/kstyles/oxygen/config/oxygenconf.cpp:30:35: error: oxygenstyleconfigdata.h: No such file or directory


oxygenstyleconfigdata.h was generated at the start of the build, but it is in /var/tmp/portage/kde-base/kstyles-9999/work/kstyles-9999_build instead of /var/tmp/portage/kde-base/kstyles-9999/work/kstyles-9999

Dolphin and krunner fail as well with similar issues. Is this a KDE or a Gentoo problem?

Cheers.
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Thu Aug 27, 2009 8:56 pm    Post subject: Reply with quote

Digikam-1.0.0_beta3 is crashing on me now with a segfault. I've been using it fine for several weeks until a couple days ago when I updated some programs.
I've re-emerged digikam, kipi-plugins, qt-core, kdelibs4.3.0-r1, PyQt4. No revdep-rebuild packages. I'm running unstable.

Updated packages include
ntfsprogs, vlc konqueror, kdebase-startkde, kdelibs, qt-opengl, openssh, eselect, eselect-python, e2fsprogs, rar, net-tools, DBD-mysql, libconfig, IO-socket-SSL, fontconfig, libdc1394, libstdc++, pciutils, sandbox, jpeg-7

after that digikam was kaput. (I think).

Hoping someone might spot a solution. Here's when running from command line:
Code:
~ $ digikam                 
Starting to load Plugins.           
=== MarbleDirs: ===                 
Local Path: "/home/jim/.marble/data"
Plugin Local Path: "/home/jim/.marble/plugins"
                                               
Marble Data Path (Run Time) : ""               
Marble Data Path (Compile Time): "/usr/share/apps/marble/data"
                                                               
Marble Plugin Path (Run Time) : ""                             
Marble Plugin Path (Compile Time): "/usr/lib/kde4/plugins/marble"
                                                                 
System Path: "/usr/share/apps/marble/data"                       
Plugin System Path: "/usr/lib/kde4/plugins/marble"               
===================                                               
render plugin found "/usr/lib/kde4/plugins/marble/CompassFloatItem.so"
render plugin found "/usr/lib/kde4/plugins/marble/CrosshairsPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/GeoRendererPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/GraticulePlugin.so"   
render plugin found "/usr/lib/kde4/plugins/marble/MapScaleFloatItem.so"
render plugin found "/usr/lib/kde4/plugins/marble/NavigationFloatItem.so"
render plugin found "/usr/lib/kde4/plugins/marble/OverviewMap.so"         
render plugin found "/usr/lib/kde4/plugins/marble/Photo.so"
network plugin found "/usr/lib/kde4/plugins/marble/QNamNetworkPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/StarsPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/Wikipedia.so"
Time elapsed: 65 ms
PhotoPlugin: Initialize
Use workaround:  0
Starting to load Plugins.
=== MarbleDirs: ===
Local Path: "/home/jim/.marble/data"
Plugin Local Path: "/home/jim/.marble/plugins"

Marble Data Path (Run Time) : ""
Marble Data Path (Compile Time): "/usr/share/apps/marble/data"

Marble Plugin Path (Run Time) : ""
Marble Plugin Path (Compile Time): "/usr/lib/kde4/plugins/marble"

System Path: "/usr/share/apps/marble/data"
Plugin System Path: "/usr/lib/kde4/plugins/marble"
===================
render plugin found "/usr/lib/kde4/plugins/marble/CompassFloatItem.so"
render plugin found "/usr/lib/kde4/plugins/marble/CrosshairsPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/GeoRendererPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/GraticulePlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/MapScaleFloatItem.so"
render plugin found "/usr/lib/kde4/plugins/marble/NavigationFloatItem.so"
render plugin found "/usr/lib/kde4/plugins/marble/OverviewMap.so"
render plugin found "/usr/lib/kde4/plugins/marble/Photo.so"
network plugin found "/usr/lib/kde4/plugins/marble/QNamNetworkPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/StarsPlugin.so"
render plugin found "/usr/lib/kde4/plugins/marble/Wikipedia.so"
Time elapsed: 57 ms
Model: Time elapsed: 240 ms
loadMapTheme "earth/srtm/srtm.dgml"
DGML2 Name       :  "Atlas"
KCrash: Application 'digikam' crashing...
sock_file=/home/jim/.kde4/socket-jad/kdeinit4__0
[2]   Exit 253                digikam
[3]   Exit 253                digikam

[4]+  Stopped                 digikam


And here's some of the debug:
Code:

Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 0 (LWP 13139)]

Thread 12 (Thread 0xb2c6fb70 (LWP 13140)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb640f135 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb648eeff in QWaitCondition::wait () from /usr/lib/qt4/libQtCore.so.4
#<snip>

Thread 11 (Thread 0xb2246b70 (LWP 13142)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb59bb927 in poll () from /lib/libc.so.6
#2  0xb54779cc in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0x00000001 in ?? ()
#4  0xffffffff in ?? ()
#5  0xb5500ff4 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0xb5501398 in ?? () from /usr/lib/libglib-2.0.so.0
#7  0x00000001 in ?? ()
#8  0xb5500ff4 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb546af7b in ?? () from /usr/lib/libglib-2.0.so.0
<snip>
#41 0xb65646ec in QEventLoop::processEvents () from /usr/lib/qt4/libQtCore.so.4
#42 0xb6452e40 in ?? () from /usr/lib/qt4/libQtCore.so.4
#43 0xb22462c0 in ?? ()
#44 0x00000024 in ?? ()
#45 0xb660cff4 in ?? () from /usr/lib/qt4/libQtCore.so.4
#46 0xb22462c8 in ?? ()
#47 0x08570d08 in ?? ()
#48 0xbf9a9094 in ?? ()
#49 0xb65648b9 in QEventLoop::exec () from /usr/lib/qt4/libQtCore.so.4
#50 0xb6452e40 in ?? () from /usr/lib/qt4/libQtCore.so.4

Thread 10 (Thread 0xb15ffb70 (LWP 13143)):
#0  0xb55063da in clock_gettime () from /lib/librt.so.1
#1  0xb658c8be in ?? () from /usr/lib/qt4/libQtCore.so.4
#2  0x00000001 in ?? ()
#3  0xb15ff0dc in ?? ()
#4  0x087030b0 in ?? ()
#5  0xb656640b in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/qt4/libQtCore.so.4
#6  0x18abbcc4 in ?? ()
#7  0xb660cff4 in ?? () from /usr/lib/qt4/libQtCore.so.4
#8  0x08570eb4 in ?? ()
#9  0xb658caa0 in ?? () from /usr/lib/qt4/libQtCore.so.4
#10 0x08570eb4 in ?? ()
#11 0x08570ed8 in ?? ()
#12 0x00000000 in ?? ()

Thread 9 (Thread 0xb0dfeb70 (LWP 13144)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb640f135 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb648eeff in QWaitCondition::wait () from /usr/lib/qt4/libQtCore.so.4
#3  0xb0dfe2a4 in ?? ()
#4  0x00048058 in ?? ()
#5  0x08550330 in ?? ()
#6  0xb0dfe330 in ?? ()
#7  0x085525f4 in ?? ()
#8  0xb80af5e0 in ?? () from /lib/ld-linux.so.2
#9  0xb7393cdb in Digikam::LoadSaveThread::run () from /usr/lib/libdigikamcore.so.1
#10 0xb648e176 in ?? () from /usr/lib/qt4/libQtCore.so.4
#11 0x085525e0 in ?? ()
#12 0x00000000 in ?? ()

Thread 8 (Thread 0xb05fdb70 (LWP 13145)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb59bb927 in poll () from /lib/libc.so.6
#2  0xb54779cc in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0x00000001 in ?? ()
#4  0xffffffff in ?? ()
#5  0xb5500ff4 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0xb5501398 in ?? () from /usr/lib/libglib-2.0.so.0
#7  0x00000001 in ?? ()
#8  0xb5500ff4 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb546af7b in ?? () from /usr/lib/libglib-2.0.so.0
<snip>
#23 0xffffffff in ?? ()
#24 0x08725f60 in ?? ()
#25 0xb54779a0 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0xb640e510 in ?? () from /lib/libpthread.so.0
#27 0xb640ce70 in ?? () from /lib/libpthread.so.0
#28 0x087aec8c in ?? ()
#29 0xb548ee52 in g_thread_self () from /usr/lib/libglib-2.0.so.0
#30 0x087aec88 in ?? ()
#31 0xb640ce70 in ?? () from /lib/libpthread.so.0
#32 0xb5501768 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb546b1a3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0x087aeb78 in ?? ()
#35 0x00000001 in ?? ()
#36 0x00000001 in ?? ()
#37 0xb658b11a in QEventDispatcherGlib::processEvents () from /usr/lib/qt4/libQtCore.so.4
#38 0x08725fa8 in ?? ()
#39 0x087aebd8 in ?? ()
#40 0xb05fd2d8 in ?? ()
#41 0xb65646ec in QEventLoop::processEvents () from /usr/lib/qt4/libQtCore.so.4
#42 0x087aebd8 in ?? ()
#43 0x00000000 in ?? ()

Thread 7 (Thread 0xafdfcb70 (LWP 13146)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb59bb927 in poll () from /lib/libc.so.6
#2  0xb54779cc in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0x00000001 in ?? ()
#4  0xffffffff in ?? ()
#5  0xb5500ff4 in ?? () from /usr/lib/libglib-2.0.so.0
#6  0xb5501398 in ?? () from /usr/lib/libglib-2.0.so.0
#7  0x00000001 in ?? ()
#8  0xb5500ff4 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb546af7b in ?? () from /usr/lib/libglib-2.0.so.0
#10 0x087a9ac8 in ?? ()
#11 0x00000001 in ?? ()
#12 0xffffffff in ?? ()
#13 0x087a9ac8 in ?? ()
#14 0x00000001 in ?? ()
#15 0x00000024 in ?? ()
<snip>
#25 0xb54779a0 in ?? () from /usr/lib/libglib-2.0.so.0
#26 0xb640e510 in ?? () from /lib/libpthread.so.0
#27 0xb640ce70 in ?? () from /lib/libpthread.so.0
#28 0x087aeeb4 in ?? ()
#29 0xb548ee52 in g_thread_self () from /usr/lib/libglib-2.0.so.0
#30 0x087aeeb0 in ?? ()
#31 0xb640ce70 in ?? () from /lib/libpthread.so.0
#32 0xb5501768 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb546b1a3 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#34 0x087aee50 in ?? ()
#35 0x00000001 in ?? ()
#36 0x00000001 in ?? ()
#37 0xb658b11a in QEventDispatcherGlib::processEvents () from /usr/lib/qt4/libQtCore.so.4
#38 0x087ae280 in ?? ()
#39 0x087b2460 in ?? ()
#40 0xafdfc2d8 in ?? ()
#41 0xb65646ec in QEventLoop::processEvents () from /usr/lib/qt4/libQtCore.so.4
#42 0x087b2460 in ?? ()
#43 0x00000000 in ?? ()

Thread 6 (Thread 0xaf5fbb70 (LWP 13147)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb640f135 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb648eeff in QWaitCondition::wait () from /usr/lib/qt4/libQtCore.so.4
#3  0xaf5fb2a4 in ?? ()
#4  0x00048058 in ?? ()
#5  0x08746ef8 in ?? ()
#6  0xb655b401 in QAbstractEventDispatcherPrivate::init () from /usr/lib/qt4/libQtCore.so.4
#7  0x08746fe8 in ?? ()
#8  0xb660cff4 in ?? () from /usr/lib/qt4/libQtCore.so.4
#9  0xb755dff4 in ?? () from /usr/lib/libdigikamcore.so.1
#10 0x08746450 in ?? ()
#11 0xaf5fb330 in ?? ()
#12 0x08746464 in ?? ()
#13 0xb7393cdb in Digikam::LoadSaveThread::run () from /usr/lib/libdigikamcore.so.1
#14 0xb648e176 in ?? () from /usr/lib/qt4/libQtCore.so.4
#15 0x08746450 in ?? ()
#16 0x00000000 in ?? ()

Thread 5 (Thread 0xaca7db70 (LWP 13148)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb640f462 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xad7f4d50 in ?? () from /usr/lib/libxine.so.1
<snip>
#14 0xb641aff4 in ?? () from /lib/libpthread.so.0
#15 0x00000000 in ?? ()

Thread 4 (Thread 0xabe44b70 (LWP 13149)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb59beae1 in select () from /lib/libc.so.6
#2  0xad81be5f in xine_usec_sleep () from /usr/lib/libxine.so.1

Thread 3 (Thread 0xab643b70 (LWP 13150)):
#0  0xb55063da in clock_gettime () from /lib/librt.so.1
#1  0xb658c8be in ?? () from /usr/lib/qt4/libQtCore.so.4
<snip>
#28 0xab643128 in ?? ()
#29 0xb640e42b in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xaae42b70 (LWP 13153)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb640f135 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xad8031d4 in ?? () from /usr/lib/libxine.so.1
#3  0x08c45080 in ?? ()
#4  0x08c45068 in ?? ()
#5  0x00000000 in ?? ()

Thread 1 (Thread 0xb4269700 (LWP 13139)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb598e916 in nanosleep () from /lib/libc.so.6
#2  0xb598e72f in sleep () from /lib/libc.so.6
#3  0xb6afd525 in ?? () from /usr/lib/libkdeui.so.5
#4  0x00000000 in ?? ()
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Sat Aug 29, 2009 8:24 am    Post subject: where is akonadi-server-1.2.60 Reply with quote

I was trying to update to 4.3.65. failed due to dependency on >=akonadi-server-1.2.60.
But there is no such a version:
Code:

* app-office/akonadi-server
     Available versions:  (~)1.0.0 (~)1.1.1 (~)1.1.2 (~)1.2.0 [M](**)9999[1] {mysql sqlite}
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[1] "kde" /usr/local/portage/layman/kde-testing


Is there something wrong with my overlay?
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Aug 29, 2009 8:55 am    Post subject: Re: where is akonadi-server-1.2.60 Reply with quote

z_sfeng wrote:
I was trying to update to 4.3.65. failed due to dependency on >=akonadi-server-1.2.60.
But there is no such a version:
Code:

* app-office/akonadi-server
     Available versions:  (~)1.0.0 (~)1.1.1 (~)1.1.2 (~)1.2.0 [M](**)9999[1] {mysql sqlite}
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[1] "kde" /usr/local/portage/layman/kde-testing


Is there something wrong with my overlay?


I think you should install 9999 version.
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Sat Aug 29, 2009 8:57 am    Post subject: Re: where is akonadi-server-1.2.60 Reply with quote

marcus84 wrote:
z_sfeng wrote:
I was trying to update to 4.3.65. failed due to dependency on >=akonadi-server-1.2.60.
But there is no such a version:
Code:

* app-office/akonadi-server
     Available versions:  (~)1.0.0 (~)1.1.1 (~)1.1.2 (~)1.2.0 [M](**)9999[1] {mysql sqlite}
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[1] "kde" /usr/local/portage/layman/kde-testing


Is there something wrong with my overlay?


I think you should install 9999 version.


unmask 9999, but kdepimlibs failed to compile. I think 9999 is not the correct version.
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Aug 29, 2009 9:39 am    Post subject: Re: where is akonadi-server-1.2.60 Reply with quote

z_sfeng wrote:
marcus84 wrote:
z_sfeng wrote:
I was trying to update to 4.3.65. failed due to dependency on >=akonadi-server-1.2.60.
But there is no such a version:
Code:

* app-office/akonadi-server
     Available versions:  (~)1.0.0 (~)1.1.1 (~)1.1.2 (~)1.2.0 [M](**)9999[1] {mysql sqlite}
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[1] "kde" /usr/local/portage/layman/kde-testing


Is there something wrong with my overlay?


I think you should install 9999 version.


unmask 9999, but kdepimlibs failed to compile. I think 9999 is not the correct version.


kdepimlibs-4.3.65 is failing for me either... you should wait for the next snapshot
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Tue Sep 01, 2009 12:15 pm    Post subject: Reply with quote

For those of you that also have problems emerging digikam-1.0.0_beta4 because of an error right at the beginning of the compile phase:

There was an error in the original tarballs, which is now fixed. See http://www.digikam.org/drupal/node/477

Of course the manifest is broken because of this, so you need to manually fix that until the devs come around to update this in the overlay.
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Thu Sep 03, 2009 5:14 pm    Post subject: Reply with quote

This is probably a silly question, but is networkmanager-applet the only way to handle network connections?
By the way, today it doesn't even compile.
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Thu Sep 03, 2009 8:25 pm    Post subject: Reply with quote

try wicd
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Thu Sep 03, 2009 8:44 pm    Post subject: Reply with quote

I'm already using nm-applet, I was thinking of something KDE-specific.
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri Sep 04, 2009 6:56 am    Post subject: Reply with quote

Dancingfire wrote:
try wicd


+1 for wicd - not kde specific but does not pull in unwanted dependencies.
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
lukipuki
n00b
n00b


Joined: 02 Nov 2004
Posts: 22
Location: Zürich, Switzerland

PostPosted: Fri Sep 04, 2009 2:23 pm    Post subject: Reply with quote

I don't know where to post bugs: liblastfm-0.3.0 from fails to compile without qt-sql and qt-gui.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Fri Sep 04, 2009 2:55 pm    Post subject: Reply with quote

Is it just me? I'm using paludis and the newly renamed sets in the overlay (the Documentation/sets/paludis ones) are breaking paludis. How do I get them renamed back to the old names?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Wed Sep 09, 2009 5:32 pm    Post subject: Reply with quote

Hey Guys,

4.6.67 landed. waiting for a bump :lol:
_________________
knowledge is power
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Wed Sep 09, 2009 6:45 pm    Post subject: Reply with quote

You surely must speak of 4.3.67 ;)

Is it usable yet? I'm getting tired of my oh-so-perfect 4.3.1 :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Wed Sep 09, 2009 8:05 pm    Post subject: Reply with quote

sure it's 4.3.67

i'm using 4.3.65 at the moment. pretty stable, no really bad bugs. (logout for example is not working)
_________________
knowledge is power
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Thu Sep 10, 2009 10:30 am    Post subject: Re: where is akonadi-server-1.2.60 Reply with quote

So now I need >=akonadi-server-1.2.61 to update to 4.3.67. Is this package missed from Gentoo?
here is some info about 1.2.61 from
http://www.mail-archive.com/pld-cvs-commit@lists.pld-linux.org/msg192601.html

z_sfeng wrote:
I was trying to update to 4.3.65. failed due to dependency on >=akonadi-server-1.2.60.
But there is no such a version:
Code:

* app-office/akonadi-server
     Available versions:  (~)1.0.0 (~)1.1.1 (~)1.1.2 (~)1.2.0 [M](**)9999[1] {mysql sqlite}
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[1] "kde" /usr/local/portage/layman/kde-testing


Is there something wrong with my overlay?
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Thu Sep 10, 2009 1:09 pm    Post subject: Re: where is akonadi-server-1.2.60 Reply with quote

z_sfeng wrote:
So now I need >=akonadi-server-1.2.61 to update to 4.3.67. Is this package missed from Gentoo?
here is some info about 1.2.61 from
http://www.mail-archive.com/pld-cvs-commit@lists.pld-linux.org/msg192601.html

z_sfeng wrote:
I was trying to update to 4.3.65. failed due to dependency on >=akonadi-server-1.2.60.
But there is no such a version:
Code:

* app-office/akonadi-server
     Available versions:  (~)1.0.0 (~)1.1.1 (~)1.1.2 (~)1.2.0 [M](**)9999[1] {mysql sqlite}
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[1] "kde" /usr/local/portage/layman/kde-testing


Is there something wrong with my overlay?

you need akonadi-server-9999



P.S.
for me kaddressbook-4.3.65 and 4.3.67 fails with something about Akonadi.
dunno what to do, just updated akonadi to latest revision - still no win.
buildlog: http://pastebin.ca/1561106
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Thu Sep 10, 2009 6:03 pm    Post subject: Re: where is akonadi-server-1.2.60 Reply with quote

With 9999, there's always something wrong in kde pim components. So I don't think 9999 is the correct version.

Dancingfire wrote:
z_sfeng wrote:
So now I need >=akonadi-server-1.2.61 to update to 4.3.67. Is this package missed from Gentoo?
here is some info about 1.2.61 from
http://www.mail-archive.com/pld-cvs-commit@lists.pld-linux.org/msg192601.html

z_sfeng wrote:
I was trying to update to 4.3.65. failed due to dependency on >=akonadi-server-1.2.60.
But there is no such a version:
Code:

* app-office/akonadi-server
     Available versions:  (~)1.0.0 (~)1.1.1 (~)1.1.2 (~)1.2.0 [M](**)9999[1] {mysql sqlite}
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[1] "kde" /usr/local/portage/layman/kde-testing


Is there something wrong with my overlay?

you need akonadi-server-9999



P.S.
for me kaddressbook-4.3.65 and 4.3.67 fails with something about Akonadi.
dunno what to do, just updated akonadi to latest revision - still no win.
buildlog: http://pastebin.ca/1561106
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Thu Sep 17, 2009 10:02 am    Post subject: Reply with quote

For quite some time now, kdebluetooth4 fails emerging:

Code:
>>> Unpacking source...
 * subversion update start -->
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/playground/network/kbluetooth4
svn: Target path does not exist


Code:
 * The specific snippet of code:
 *                           ${ESVN_UPDATE_CMD} ${options} || die "${ESVN}: can't update ${wc_path} from ${repo_uri}.";
 *  The die message:
 *   subversion: can't update /usr/portage/distfiles/svn-src/kdebluetooth4/kbluetooth4 from svn://anonsvn.kde.org/home/kde/trunk/playground/network/kbluetooth4.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri Sep 18, 2009 12:27 pm    Post subject: Reply with quote

kde-misc/stasks-9999 fails to compile

Code:

>>> Emerging (1 of 1) kde-misc/stasks-9999 from kde
 * checking ebuild checksums ;-) ...                                                                [ ok ]
 * checking auxfile checksums ;-) ...                                                               [ ok ]
 * checking miscfile checksums ;-) ...                                                              [ ok ]
>>> Unpacking source...                                                                                   
 * Updating /usr/portage/distfiles/hg-src/stasks/smooth-tasks from http://bitbucket.org/panzi/smooth-tasks/
 * Creating working directory in /var/tmp/portage/kde-misc/stasks-9999/work/smooth-tasks (revision: tip)   
>>> Source unpacked in /var/tmp/portage/kde-misc/stasks-9999/work                                         
>>> Preparing source in /var/tmp/portage/kde-misc/stasks-9999/work ...                                     
/var/tmp/portage/kde-misc/stasks-9999/temp/environment: line 3896: cd: /var/tmp/portage/kde-misc/stasks-9999/work/stasks: No such file or directory                                                                   
/var/tmp/portage/kde-misc/stasks-9999/temp/environment: line 711: cd: /var/tmp/portage/kde-misc/stasks-9999/work/stasks: No such file or directory                                                                   
>>> Source prepared.                                                                                       
>>> Configuring source in /var/tmp/portage/kde-misc/stasks-9999/work ...                                   
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-misc/stasks-9999/work/stasks_build"                       
 * I was unable to locate CMakeLists.txt under:                                                           
 * "/var/tmp/portage/kde-misc/stasks-9999/work/stasks/CMakeLists.txt"                                     
 * You should consider not inheriting the cmake eclass.                                                   
 *                                                                                                         
 * ERROR: kde-misc/stasks-9999 failed.                                                                     
 * Call stack:                                                                                             
 *               ebuild.sh, line   49:  Called src_configure                                               
 *             environment, line 3712:  Called kde4-base_src_configure                                     
 *             environment, line 2845:  Called cmake-utils_src_configure                                   
 *             environment, line 1056:  Called die                                                         
 * The specific snippet of code:                                                                           
 *           die "FATAL: Unable to find CMakeLists.txt";                                                   
 *  The die message:                                                                                       
 *   FATAL: Unable to find CMakeLists.txt                                                                 
 *                                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.                     
 * A complete build log is located at '/var/tmp/portage/kde-misc/stasks-9999/temp/build.log'.             
 * The ebuild environment file is located at '/var/tmp/portage/kde-misc/stasks-9999/temp/environment'.     
 * This ebuild used the following eclasses from overlays:                                                 
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                         
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass                                   
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'                   
 *                                                                                         

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Fri Sep 18, 2009 4:17 pm    Post subject: Reply with quote

hmm. stasks looks pretty abandoned; take a look at smooth tasks: http://kde-look.org/content/show.php/Smooth+Tasks?content=101586&PHPSESSID=7f36f67e5f4bba12e13f6b379fe11b9a
it's a fork from stasks ...
_________________
knowledge is power
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 36, 37, 38  Next
Page 8 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum