Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri Sep 18, 2009 7:27 pm    Post subject: Reply with quote

gaelic_cargal wrote:
hmm. stasks looks pretty abandoned; take a look at smooth tasks: http://kde-look.org/content/show.php/Smooth+Tasks?content=101586&PHPSESSID=7f36f67e5f4bba12e13f6b379fe11b9a
it's a fork from stasks ...


The stasks-9999 package is smooth tasks. :)
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Sat Sep 19, 2009 12:36 pm    Post subject: Reply with quote

oh. thats nice
_________________
knowledge is power
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sun Sep 20, 2009 12:29 pm    Post subject: Reply with quote

genstorm wrote:
For quite some time now, kdebluetooth4 fails emerging:

Code:
>>> Unpacking source...
 * subversion update start -->
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/playground/network/kbluetooth4
svn: Target path does not exist

Works again. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Sun Sep 20, 2009 4:10 pm    Post subject: Reply with quote

rahulthewall wrote:
kde-misc/stasks-9999 fails to compile

Code:

>>> Emerging (1 of 1) kde-misc/stasks-9999 from kde
 * checking ebuild checksums ;-) ...                                                                [ ok ]
 * checking auxfile checksums ;-) ...                                                               [ ok ]
 * checking miscfile checksums ;-) ...                                                              [ ok ]
>>> Unpacking source...                                                                                   
 * Updating /usr/portage/distfiles/hg-src/stasks/smooth-tasks from http://bitbucket.org/panzi/smooth-tasks/
 * Creating working directory in /var/tmp/portage/kde-misc/stasks-9999/work/smooth-tasks (revision: tip)   
>>> Source unpacked in /var/tmp/portage/kde-misc/stasks-9999/work                                         
>>> Preparing source in /var/tmp/portage/kde-misc/stasks-9999/work ...                                     
/var/tmp/portage/kde-misc/stasks-9999/temp/environment: line 3896: cd: /var/tmp/portage/kde-misc/stasks-9999/work/stasks: No such file or directory                                                                   
/var/tmp/portage/kde-misc/stasks-9999/temp/environment: line 711: cd: /var/tmp/portage/kde-misc/stasks-9999/work/stasks: No such file or directory                                                                   
>>> Source prepared.                                                                                       
>>> Configuring source in /var/tmp/portage/kde-misc/stasks-9999/work ...                                   
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-misc/stasks-9999/work/stasks_build"                       
 * I was unable to locate CMakeLists.txt under:                                                           
 * "/var/tmp/portage/kde-misc/stasks-9999/work/stasks/CMakeLists.txt"                                     
 * You should consider not inheriting the cmake eclass.                                                   
 *                                                                                                         
 * ERROR: kde-misc/stasks-9999 failed.                                                                     
 * Call stack:                                                                                             
 *               ebuild.sh, line   49:  Called src_configure                                               
 *             environment, line 3712:  Called kde4-base_src_configure                                     
 *             environment, line 2845:  Called cmake-utils_src_configure                                   
 *             environment, line 1056:  Called die                                                         
 * The specific snippet of code:                                                                           
 *           die "FATAL: Unable to find CMakeLists.txt";                                                   
 *  The die message:                                                                                       
 *   FATAL: Unable to find CMakeLists.txt                                                                 
 *                                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.                     
 * A complete build log is located at '/var/tmp/portage/kde-misc/stasks-9999/temp/build.log'.             
 * The ebuild environment file is located at '/var/tmp/portage/kde-misc/stasks-9999/temp/environment'.     
 * This ebuild used the following eclasses from overlays:                                                 
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                         
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass                                   
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'                   
 *                                                                                         


Rename stasks-9999 to smooth-tasks-9999 (the ebuild) and it works.
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Tue Sep 22, 2009 3:40 pm    Post subject: Reply with quote

Kdelibs-4.3.68 doesn't compile :
Code:
In file included from /var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/katepart_automoc.cpp:7:                                                               
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp: In member function ‘virtual int KateScriptView::qt_metacall(QMetaObject::Call, int, void**)’:                                                                                                                                                                           
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp:109: erreur: variable ‘KTextEditor::Range _r’ has initializer but incomplete type   
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp:109: erreur: invalid use of incomplete type ‘struct KTextEditor::Range’             
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/interfaces/ktexteditor/cursor.h:32: erreur: forward declaration of ‘struct KTextEditor::Range’                         
make[2]: *** [kate/CMakeFiles/katepart.dir/katepart_automoc.o] Erreur 1                                                                                                             
make[1]: *** [kate/CMakeFiles/katepart.dir/all] Erreur 2                                                                                                                           
make[1]: *** Attente des tâches non terminées....                                                                                                                                   
[ 61%] Building CXX object kate/CMakeFiles/testkateregression.dir/completion/katecompletionwidget.o                                                                                 
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/kate/completion/katecompletionwidget.h: In constructor ‘KateCompletionWidget::KateCompletionWidget(KateView*)’:       
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/kate/completion/katecompletionwidget.h:224: attention : ‘KateCompletionWidget::m_lastInvocationType’ will be initialized after                                                                                                                                                                             
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/kate/completion/katecompletionwidget.h:221: attention :   ‘bool KateCompletionWidget::m_noAutoHide’                   
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/kate/completion/katecompletionwidget.cpp:71: attention :   when initialized here                                       
[ 61%] Building CXX object kate/CMakeFiles/testkateregression.dir/completion/katecompletionmodel.o                                                                                 
In file included from /var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/testkateregression_automoc.cpp:7:                                                     
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp: In member function ‘virtual int KateScriptView::qt_metacall(QMetaObject::Call, int, void**)’:
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp:109: erreur: variable ‘KTextEditor::Range _r’ has initializer but incomplete type
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp:109: erreur: invalid use of incomplete type ‘struct KTextEditor::Range’
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/interfaces/ktexteditor/cursor.h:32: erreur: forward declaration of ‘struct KTextEditor::Range’
make[2]: *** [kate/CMakeFiles/testkateregression.dir/testkateregression_automoc.o] Erreur 1
make[2]: *** Attente des tâches non terminées....
make[1]: *** [kate/CMakeFiles/testkateregression.dir/all] Erreur 2
make: *** [all] Erreur 2


Is that related to Qt-4.6.999?

Thank you in advance!! ;)
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Tue Sep 22, 2009 7:38 pm    Post subject: Reply with quote

same thing with qt 4.5.x:

Code:

[ 78%] Built target katepart_automoc                                                               
[ 78%] Generating ui_spellcheckconfigwidget.h                                                       
[ 78%] Generating ui_appearanceconfigwidget.h                                                       
[ 78%] Generating ui_commandmenuconfigwidget.h                                                     
[ 78%] Generating ui_commandmenueditwidget.h                                                       
[ 78%] Generating ui_completionconfigtab.h                                                         
[ 78%] Generating ui_cursorconfigwidget.h                                                           
[ 78%] Generating ui_editconfigwidget.h                                                             
[ 78%] Generating ui_filetypeconfigwidget.h                                                         
[ 78%] Generating ui_indentationconfigwidget.h                                                     
[ 78%] Generating ui_opensaveconfigwidget.h                                                         
[ 78%] Generating ui_opensaveconfigadvwidget.h                                                     
[ 78%] Generating ui_modonhdwidget.h                                                               
[ 78%] Generating ui_schemaconfigcolortab.h                                                         
Warning: name gridLayout is already used                                                           
[ 78%] Generating ui_completionconfigwidget.h                                                       
[ 78%] Generating ui_searchbarincremental.h                                                         
[ 78%] Generating ui_searchbarpower.h                                                               
[ 79%] Generating ui_viinputmodeconfigwidget.h                                                     
Scanning dependencies of target katepart                                                           
[ 79%] Building CXX object kate/CMakeFiles/katepart.dir/katepart_automoc.o                         
In file included from /var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/katepart_automoc.cpp:6:                                                                                   
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp: In member function 'virtual int KateScriptView::qt_metacall(QMetaObject::Call, int, void**)':           
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp:103: error: variable 'KTextEditor::Range _r' has initializer but incomplete type                         
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_katescriptview.cpp:103: error: invalid use of incomplete type 'struct KTextEditor::Range'                                   
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/interfaces/ktexteditor/cursor.h:32: error: forward declaration of 'struct KTextEditor::Range'                                             
make[2]: *** [kate/CMakeFiles/katepart.dir/katepart_automoc.o] Error 1                             
make[1]: *** [kate/CMakeFiles/katepart.dir/all] Error 2                                             
make: *** [all] Error 2                                                                             
 *                                                                                                 
 * ERROR: kde-base/kdelibs-4.3.68 failed.                                                           
 * Call stack:                                                                                     
 *               ebuild.sh, line   49:  Called src_compile                                         
 *             environment, line 3773:  Called kde4-base_src_compile                               
 *             environment, line 2894:  Called cmake-utils_src_compile                             
 *             environment, line 1070:  Called cmake-utils_src_make                                 
 *             environment, line 1150:  Called die                                                 
 * The specific snippet of code:                                                                   
 *           emake "$@" || die "Make failed!";                                                     
 *  The die message:                                                                               
 *   Make failed!                                                                                   
 *                                                                                                 
 * If you need support, post the topmost build error, and the call stack if relevant.               
 * A complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.3.68/temp/build.log'.   
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdelibs-4.3.68/temp/environment'.                                                                                               
 * This ebuild used the following eclasses from overlays:                                           
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                 
 *   /usr/local/portage/layman/kde-testing/eclass/cmake-utils.eclass                               
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass                             
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'             
 *

_________________
knowledge is power
Back to top
View user's profile Send private message
freezby
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2006
Posts: 103
Location: Angers, France

PostPosted: Tue Sep 22, 2009 10:45 pm    Post subject: Reply with quote

Hi,

I'm using the kde-testing overlay and i'm trying to install the live ebuilds.
But I have a problem with the semantic-desktop useflag. I explain :
When i emerge kdelibs with this useflag, dolphin is blocked because i turned on semantic-desktop and so i can't emerge @kdebase-live.
And when i emerge kdelibs without this flag, i can't emerge @kdebase-live.
Code:

emerge: there are no ebuilds built with USE flags to satisfy ">=kde-base/kdelibs-9999:live[-semantic-desktop,-kdeprefix]".
!!! One of the following packages is required to complete your request:
- kde-base/kdelibs-9999 (Change USE: -semantic-desktop)
(dependency required by "kde-base/dolphin-9999-r1" [ebuild])
(dependency required by "@kdebase-live" [argument])


So, if someone has a solution :).

PS : sorry for my bad english ;)
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Wed Sep 23, 2009 1:52 am    Post subject: Reply with quote

freezby,
I could be wrong, but I seem to recall reading somewhere along the line in the overlay docs that if you wanted to go to kde-live, and you had another kde-4.x.x version already installed, you should remove it (and all it's deps) first, and then do a "clean" install of kde-live.

Another thought- did you emerge @kdedeps-live first, before trying to emerge @kdelibs-live?

Are your /etc/portage/package.use flags set correctly, and up-to-date with what the overlay requires? With kde-live, I've found I sometimes need to make adjustments as they update the overlay. I assume you sync'd the overlay first.

Also, you might check your world file and see if anything is trying to pull in other kde versions.

I have been using emerge -pv1 @kdedeps-live @kdelibs-live etc. etc. etc., so as to avoid having emerge put any kde overlay stuff in my world file. That seems to just keep it simpler for me, and avoid problems.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed Sep 23, 2009 5:48 pm    Post subject: Reply with quote

Amarok 2.1.90 fails to compile.

Code:

[ebuild     U ] media-sound/amarok-2.1.90 [2.1.85] USE="cdda lastfm mtp opengl semantic-desktop (-aqua) -daap -debug -ipod -mp3tunes" LINGUAS="en_GB -bg -ca -cs -da -de -es -et -eu -fi% -fr -it -ja -km -nb -nds -nl -pa -pl -pt -pt_BR -ru -sl -sr% -sr@latin% -sv -th -tr -uk -wa -zh_TW (-el%) (-gl%) (-he%) (-is%) (-ku%) (-lt%) (-lv%) (-nn%) (-ro%) (-zh_CN%)" 0 kB [2]                                                             


Code:
>>> Emerging (1 of 2) media-sound/amarok-2.1.90 from kde
 * amarok-2.1.90.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                            [ ok ]
 * checking ebuild checksums ;-) ...                                                                [ ok ]
 * checking auxfile checksums ;-) ...                                                               [ ok ]
 * checking miscfile checksums ;-) ...                                                              [ ok ]
>>> Unpacking source...                                                                                   
/var/tmp/portage/media-sound/amarok-2.1.90/temp/environment: line 3679: git_src_unpack: command not found
>>> Source unpacked in /var/tmp/portage/media-sound/amarok-2.1.90/work                                   
>>> Preparing source in /var/tmp/portage/media-sound/amarok-2.1.90/work ...                               
 *                                                                                                       
 * ERROR: media-sound/amarok-2.1.90 failed.                                                               
 * Call stack:                                                                                           
 *               ebuild.sh, line   49:  Called src_prepare                                               
 *             environment, line 3674:  Called kde4-base_src_prepare                                     
 *             environment, line 2859:  Called enable_selected_linguas                                   
 *             environment, line 1508:  Called die                                                       
 * The specific snippet of code:                                                                         
 *       [[ -d "${KDE_LINGUAS_DIR}" ]] || die "wrong linguas dir specified";                             
 *  The die message:                                                                                     
 *   wrong linguas dir specified                                                                         
 *                                                                                                       
 * If you need support, post the topmost build error, and the call stack if relevant.                     
 * A complete build log is located at '/var/tmp/portage/media-sound/amarok-2.1.90/temp/build.log'.       
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/amarok-2.1.90/temp/environment'.
 * This ebuild used the following eclasses from overlays:                                                 
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                         
 *   /usr/local/portage/layman/kde-testing/eclass/cmake-utils.eclass                                       
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass                                   
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'                   

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
grolsch
n00b
n00b


Joined: 23 Jul 2008
Posts: 31
Location: Scotland

PostPosted: Thu Sep 24, 2009 9:13 am    Post subject: Reply with quote

Sync with kde-testing, the problem seems to be resolved.
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Thu Sep 24, 2009 12:09 pm    Post subject: Reply with quote

I get this compiling kdelibs

Code:

[ 70%] Building CXX object plasma/CMakeFiles/plasma.dir/glapplet.o                                                                                                                 
[ 70%] Building CXX object plasma/CMakeFiles/plasma.dir/widgets/videowidget.o                                                                                                       
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp: In member function ‘void Plasma::VideoWidgetPrivate::volumeChanged(qreal)’:   
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:147: avís: passing ‘qreal’ for argument 1 to ‘void Plasma::Slider::setValue(int)’                                                                                                                                                                                 
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp: In member function ‘void Plasma::VideoWidgetPrivate::animateControlWidget(bool)’:                                                                                                                                                                                 
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:184: avís: passing ‘qreal’ for argument 2 to ‘QPoint::QPoint(int, int)’       
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:186: avís: passing ‘qreal’ for argument 2 to ‘QPoint::QPoint(int, int)’       
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp: In member function ‘virtual void Plasma::VideoWidget::resizeEvent(QGraphicsSceneResizeEvent*)’:                                                                                                                                                                   
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:526: avís: passing ‘qreal’ for argument 1 to ‘QSize::QSize(int, int)’         
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:526: avís: passing ‘qreal’ for argument 2 to ‘QSize::QSize(int, int)’         
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:527: avís: converting to ‘int’ from ‘qreal’                                   
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:532: avís: passing ‘qreal’ for argument 1 to ‘void QSize::setHeight(int)’     
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:534: avís: passing ‘qreal’ for argument 1 to ‘void QSize::setHeight(int)’     
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:536: avís: passing ‘qreal’ for argument 1 to ‘void QSize::setHeight(int)’     
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:538: avís: passing ‘qreal’ for argument 1 to ‘void QSize::setHeight(int)’     
/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/plasma/widgets/videowidget.cpp:540: avís: passing ‘qreal’ for argument 1 to ‘void QSize::setHeight(int)’     
Linking CXX shared library ../lib/libplasma.so                                                                                                                                     
[ 70%] Built target plasma                                                                                                                                                         
make: *** [all] Error 2                                                                                                                                                             
 *                                                                                                                                                                                 
 * ERROR: kde-base/kdelibs-4.3.68 failed.                                                                                                                                           
 * Call stack:                                                                                                                                                                     
 *               ebuild.sh, line   49:  Called src_compile                                                                                                                         
 *             environment, line 3753:  Called kde4-base_src_compile                                                                                                               
 *             environment, line 2885:  Called cmake-utils_src_compile                                                                                                             
 *             environment, line 1065:  Called cmake-utils_src_make                                                                                                                 
 *             environment, line 1145:  Called die                                                                                                                                 
 * The specific snippet of code:                                                                                                                                                   
 *           emake "$@" || die "Make failed!";                                                                                                                                     
 *  The die message:                                                                                                                                                               
 *   Make failed!                                                                                                                                                                   
 *                                                                                                                                                                                 
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                                               
 * A complete build log is located at '/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/temp/build.log'.                                                                           
 * The ebuild environment file is located at '/home/tmp_portage/portage/kde-base/kdelibs-4.3.68/temp/environment'.                                                                 
 * This ebuild used the following eclasses from overlays:                                                                                                                           
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                                                                                                 
 *   /usr/local/portage/layman/kde-testing/eclass/cmake-utils.eclass                                                                                                               
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass                                                                                                             
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'

Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 458
Location: Earth

PostPosted: Thu Sep 24, 2009 12:14 pm    Post subject: Reply with quote

PyQt4 failed!

Code:
>>> Emerging (1 of 16) dev-python/PyQt4-4.6_pre20090811 from qting-edge
Unavailable repository 'gentoo' referenced by masters entry in '/usr/local/portage/layman/kde-testing/metadata/layout.conf'
 * PyQt-x11-gpl-4.6-snapshot-20090811.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking PyQt-x11-gpl-4.6-snapshot-20090811.tar.gz to /var/tmp/portage/dev-python/PyQt4-4.6_pre20090811/work
>>> Source unpacked in /var/tmp/portage/dev-python/PyQt4-4.6_pre20090811/work
>>> Preparing source in /var/tmp/portage/dev-python/PyQt4-4.6_pre20090811/work/PyQt-x11-gpl-4.6-snapshot-20090811 ...
 * Applying configure.py.patch ...                                                                                                                     [ ok ]
 * Preparation of dev-python/PyQt4-4.6_pre20090811 with Python 2.6...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/PyQt4-4.6_pre20090811/work/PyQt-x11-gpl-4.6-snapshot-20090811 ...
 * Configuration of dev-python/PyQt4-4.6_pre20090811 with Python 2.6...
python2.6 configure.py --confirm-license --bindir=/usr/bin --destdir=/usr/lib64/python2.6/site-packages --sipdir=/usr/share/sip --enable=QtCore --enable=QtNetwork --enable=QtScript --enable=QtTest --enable=QtXml --enable=QtGui --enable=QtDesigner --enable=QtScriptTools --enable=QtOpenGL --enable=phonon --enable=QtSql --enable=QtSvg --enable=QtWebKit CC=x86_64-pc-linux-gnu-gcc CXX=x86_64-pc-linux-gnu-g++ LINK=x86_64-pc-linux-gnu-g++ LINK_SHLIB=x86_64-pc-linux-gnu-g++ CFLAGS='-march=core2 -O2 -pipe' CXXFLAGS='-O2 -pipe' LFLAGS='-Wl,-O1 -Wl,--sort-common -Wl,--as-needed'
Determining the layout of your Qt installation...
This is the GPL version of PyQt 4.6-snapshot-20090811 (licensed under the GNU
General Public License) for Python 2.6.2 on linux2.
Checking to see if the QtGui module should be built...
Checking to see if the QtNetwork module should be built...
Checking to see if the QtOpenGL module should be built...
Checking to see if the QtScript module should be built...
Checking to see if the QtScriptTools module should be built...
Checking to see if the QtSql module should be built...
Checking to see if the QtSvg module should be built...
Checking to see if the QtTest module should be built...
Checking to see if the QtWebKit module should be built...
Checking to see if the QtXml module should be built...
Checking to see if the phonon module should be built...
Checking to see if the QtDesigner module should be built...
Checking to see if the dbus support module should be built...
Qt v4.6.0 free edition is being used.
SIP 4.9-snapshot-20090811 is being used.
The Qt header files are in /usr/include/qt4.
The shared Qt libraries are in /usr/lib64/qt4.
The Qt binaries are in /usr/bin.
The Qt mkspecs directory is in /usr/share/qt4.
These PyQt modules will be built: QtCore, QtGui, QtNetwork, QtOpenGL, QtScript,
QtScriptTools, QtSql, QtSvg, QtTest, QtWebKit, QtXml, phonon, QtDesigner.
The PyQt Python package will be installed in
/usr/lib64/python2.6/site-packages.
The Designer plugin will be installed in /usr/lib64/qt4/plugins/designer.
The dbus support module will be installed in
/usr/lib64/python2.6/site-packages/dbus/mainloop.
The PyQt .sip files will be installed in /usr/share/sip.
pyuic4, pyrcc4 and pylupdate4 will be installed in /usr/bin.
Generating the C++ source for the QtCore module...
Creating the Makefile for the QtCore module...
Generating the C++ source for the QtGui module...
Creating the Makefile for the QtGui module...
Generating the C++ source for the QtNetwork module...
Creating the Makefile for the QtNetwork module...
Generating the C++ source for the QtOpenGL module...
Creating the Makefile for the QtOpenGL module...
Generating the C++ source for the QtScript module...
Creating the Makefile for the QtScript module...
Generating the C++ source for the QtScriptTools module...
Creating the Makefile for the QtScriptTools module...
Generating the C++ source for the QtSql module...
Creating the Makefile for the QtSql module...
Generating the C++ source for the QtSvg module...
Creating the Makefile for the QtSvg module...
Generating the C++ source for the QtTest module...
Creating the Makefile for the QtTest module...
Generating the C++ source for the QtWebKit module...
Creating the Makefile for the QtWebKit module...
Generating the C++ source for the QtXml module...
Creating the Makefile for the QtXml module...
Generating the C++ source for the phonon module...
Creating the Makefile for the phonon module...
Generating the C++ source for the QtDesigner module...
Creating the Makefile for the QtDesigner module...
Generating the C++ source for the Qt module...
Creating the Makefile for the Qt module...
Creating QScintilla API file...
Creating top level Makefile...
Creating QPy support library for QtCore Makefile...
Creating QPy support library for QtGui Makefile...
Creating QPy support library for QtDesigner Makefile...
Creating QPy support libraries Makefile...
Creating dbus support module Makefile...
Creating pyuic4 wrapper...
Creating pyuic4 Makefile...
Creating pylupdate4 Makefile...
Creating pyrcc4 Makefile...
Creating Qt Designer plugin Makefile...
Creating pyqtconfig.py...
 * Running qmake on w_qpycore.pro ...                                                                                                                  [ ok ]
 * Running qmake on w_qpydesigner.pro ...                                                                                                              [ ok ]
 * Running qmake on w_qpygui.pro ...                                                                                                                   [ ok ]
 * Running qmake on python.pro ...                                                                                                                     [ ok ]
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-python/PyQt4-4.6_pre20090811/work/PyQt-x11-gpl-4.6-snapshot-20090811 ...
 * Building of dev-python/PyQt4-4.6_pre20090811 with Python 2.6...
make -j5 -s
sipQtCorecmodule.cpp: In function »PyObject* func_qFatal(PyObject*, PyObject*)«:
sipQtCorecmodule.cpp:6815: Warnung: Format ist kein Zeichenkettenliteral, und keine Formatargumente
sipQtCorecmodule.cpp: In function »PyObject* func_qCritical(PyObject*, PyObject*)«:
sipQtCorecmodule.cpp:6841: Warnung: Format ist kein Zeichenkettenliteral, und keine Formatargumente
sipQtCorecmodule.cpp: In function »PyObject* func_qWarning(PyObject*, PyObject*)«:
sipQtCorecmodule.cpp:6867: Warnung: Format ist kein Zeichenkettenliteral, und keine Formatargumente
sipQtCorecmodule.cpp: In function »PyObject* func_qDebug(PyObject*, PyObject*)«:
sipQtCorecmodule.cpp:6893: Warnung: Format ist kein Zeichenkettenliteral, und keine Formatargumente
/usr/include/qt4/QtCore/qscopedpointer.h: In copy constructor »QResource::QResource(const QResource&)«:
/usr/include/qt4/QtCore/qscopedpointer.h:180: Fehler: »QScopedPointer<T, Cleanup>::QScopedPointer(const QScopedPointer<T, Cleanup>&) [with T = QResourcePrivate, Cleanup = QScopedPointerDeleter<QResourcePrivate>]« ist privat
/usr/include/qt4/QtCore/qresource.h:59: Fehler: in diesem Zusammenhang
sipQtCoreQResource.cpp: In constructor »sipQResource::sipQResource(const QResource&)«:
sipQtCoreQResource.cpp:83: Anmerkung: künstlich erzeugte Methode »QResource::QResource(const QResource&)« zuerst hier erfordert
/usr/include/qt4/QtCore/qscopedpointer.h: In static member function »static void QScopedPointerDeleter<T>::cleanup(T*) [with T = QResourcePrivate]«:
/usr/include/qt4/QtCore/qscopedpointer.h:100:   instantiated from »QScopedPointer<T, Cleanup>::~QScopedPointer() [with T = QResourcePrivate, Cleanup = QScopedPointerDeleter<QResourcePrivate>]«
/usr/include/qt4/QtCore/qresource.h:59:   instantiated from here
/usr/include/qt4/QtCore/qscopedpointer.h:59: Fehler: Ungültige Anwendung von »sizeof« auf unvollständigen Typen »QResourcePrivate«
/usr/include/qt4/QtCore/qscopedpointer.h:59: Fehler: Feld negativer Größe (»-0x00000000000000001«) wird erzeugt
/usr/include/qt4/QtCore/qscopedpointer.h:62: Warnung: mögliches Problem bei Aufruf des »delete«-Operators erkannt
/usr/include/qt4/QtCore/qscopedpointer.h:54: Warnung: »pointer« has incomplete type
/usr/include/qt4/QtCore/qresource.h:56: Warnung: forward declaration of »struct QResourcePrivate«
/usr/include/qt4/QtCore/qscopedpointer.h:62: Anmerkung: weder der Destruktor noch der klassenspezifische Operator »delete« wird aufgerufen, auch wenn sie bei der Klassendefinition deklariert werden
make[1]: *** [sipQtCoreQResource.o] Fehler 1
make[1]: *** Warte auf noch nicht beendete Prozesse...
make: *** [all] Fehler 2
 *
 * ERROR: dev-python/PyQt4-4.6_pre20090811 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3611:  Called python_execute_function '-d' '-s'
 *             environment, line 3102:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *  The die message:
 *   Building failed with Python 2.6 in python_default_function() function
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/dev-python:PyQt4-4.6_pre20090811:20090924-111921.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/PyQt4-4.6_pre20090811/temp/environment'.
 * This ebuild is from an overlay named 'qting-edge': '/usr/local/portage/layman/qting-edge/'
 *

>>> Failed to emerge dev-python/PyQt4-4.6_pre20090811, Log file:

>>>  '/var/log/portage/dev-python:PyQt4-4.6_pre20090811:20090924-111921.log'


first time install kde4!

Code:
emerge --info
Unavailable repository 'gentoo' referenced by masters entry in '/usr/local/portage/layman/kde-testing/metadata/layout.conf'
Portage 2.2_rc41 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.31-gentoo-3 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-3-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.1.6
Timestamp of tree: Wed, 23 Sep 2009 05:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p33
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.2-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.1.6
sys-apps/openrc:     0.5.0-r2
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical --ask --keep-going"
FEATURES="assume-digests ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="de de_DE en en_US"
MAKEOPTS="-j5 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/gnome /usr/local/portage/layman/lordvan /usr/local/portage/layman/kde-testing /usr/local/portage/layman/qting-edge /usr/local/portage/overlayees"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alac alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cddax cddb cdio cdr chdir cli consolekit cracklib crypt cups cvs dbus divx dri dts dvb dvd dvdr dvdread encode extras fbcondecor fbsplash ffmpeg firefox flac fontconfig fortran gif git glitz gnome gpm gstreamer gtk hal iconv id3tag ipv6 isdnlog java java5 jpeg jpeg2k kde lame lzma mad md5sum mjpeg mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pango pcre pdf perl phonon plasma png pppd pulseaudio python qt3support qt4 quicktime rar readline reflection session skins spl sql sse sse2 sse3 ssl ssse3 stream subversion svg sysfs tcl tcpd thunderbird tiff truetype udev unicode usb vcd vcdinfo vcdx vnc vorbis wavpack webkit winpopup wma wma-fixed wmf wmp x264 xcb xcomposite xine xinerama xml xorg xosd xpm xrandr xscreensaver xulrunner xv xvid xvmc yv12 zip zlib zvbi" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de de_DE en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


THX

CooSee ' Ya
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - Sapphire Nitro+ Radeon RX590 8G - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Mouse G400
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Thu Sep 24, 2009 1:46 pm    Post subject: Reply with quote

grolsch wrote:
Sync with kde-testing, the problem seems to be resolved.


Yup (assuming you too were taking about amarok). :)
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Fri Sep 25, 2009 4:40 am    Post subject: Reply with quote

me three. emerge kdelibs failed at katepart:
Code:

Scanning dependencies of target ktexteditor_python-encoding
[ 62%] Building CXX object kate/CMakeFiles/katepart.dir/katepart_automoc.o
[ 62%] Building CXX object kate/plugins/pythonencoding/CMakeFiles/ktexteditor_py
thon-encoding.dir/ktexteditor_python-encoding_automoc.o
[ 62%] Building CXX object kate/plugins/pythonencoding/CMakeFiles/ktexteditor_py
thon-encoding.dir/python_encoding.o
In file included from /var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.
68_build/kate/katepart_automoc.cpp:7:
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_kate
scriptview.cpp: In member function 'virtual int KateScriptView::qt_metacall(QMet
aObject::Call, int, void**)':
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_kate
scriptview.cpp:103: error: variable 'KTextEditor::Range _r' has initializer but
incomplete type
scriptview.cpp:103: error: variable 'KTextEditor::Range _r' has initializer but
incomplete type
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68_build/kate/moc_kate
scriptview.cpp:103: error: invalid use of incomplete type 'struct KTextEditor::R
ange'
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/interfaces/ktextedi
tor/cursor.h:32: error: forward declaration of 'struct KTextEditor::Range'
make[2]: *** [kate/CMakeFiles/katepart.dir/katepart_automoc.o] Error 1
make[1]: *** [kate/CMakeFiles/katepart.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
In file included from /var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/kate/plugins/pythonencoding/python_encoding.cpp:28:
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/kate/plugins/pythonencoding/python_encoding.h:41: warning: unused parameter 'document'
/var/tmp/portage/kde-base/kdelibs-4.3.68/work/kdelibs-4.3.68/kate/plugins/pythonencoding/python_encoding.h:41: warning: unused parameter 'saveas'
Linking CXX shared module ../../../lib/ktexteditor_python-encoding.so
[ 62%] Built target ktexteditor_python-encoding

compiling with qt-4.5.2, gcc-4.4.1
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Fri Sep 25, 2009 6:41 am    Post subject: Reply with quote

4.3.68 should be masked. i don't think kdelibs ever gonna compile ... just wait for 4.3.69 or whatever.
_________________
knowledge is power
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Sun Sep 27, 2009 11:30 am    Post subject: Reply with quote

The kdelibs problem is fixed! Thank you guys! :)

But ... i can't compile kaddressbook. What about you ?
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Sun Sep 27, 2009 12:53 pm    Post subject: Reply with quote

confirmed, kdelibs compile.
_________________
knowledge is power
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 458
Location: Earth

PostPosted: Sun Sep 27, 2009 9:03 pm    Post subject: Reply with quote

KDE4 is unusable because of " pykde4 " ! ?

how to start kde4 without startkde, because i can't emerge ' pykde4 ' and some packages left, too ?

Code:
Calculating dependencies... done!
[ebuild  N    ] kde-base/pykde4-9999  USE="-akonadi (-aqua) -debug -examples (-kdeprefix) -policykit -semantic-desktop" 0 kB [1]
[ebuild  N    ] kde-base/plasma-workspace-9999  USE="(-aqua) -debug -google-gadgets handbook (-kdeprefix) python -rss xinerama" 0 kB [1]
[ebuild  N    ] kde-base/marble-9999  USE="(-aqua) -debug -designer-plugin -gps handbook (-kdeprefix) plasma python -test" 0 kB [1]
[ebuild  N    ] kde-base/superkaramba-9999  USE="(-aqua) -debug handbook (-kdeprefix) python" 0 kB [1]
[ebuild  N    ] kde-base/printer-applet-9999  USE="(-aqua) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/system-config-printer-kde-9999  USE="(-aqua) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kdebase-startkde-9999  USE="(-aqua) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kdeplasma-addons-9999  USE="(-aqua) -debug -desktopglobe -exif (-kdeprefix) opengl -semantic-desktop" 0 kB [1]

Total: 9 packages (8 new, 1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/kde-testing
 [2] /usr/local/portage/layman/gnome


this is really annoying :evil: :!:

so i can't try or use kde4 :idea: :!: :?:

CooSee ' Ya
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - Sapphire Nitro+ Radeon RX590 8G - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Mouse G400
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Sun Sep 27, 2009 9:05 pm    Post subject: Reply with quote

just put kde-base/pykde4 into /etc/portage/profile/package.provided
_________________
knowledge is power
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Mon Sep 28, 2009 11:15 am    Post subject: Reply with quote

For me too, most of the PIM stuff doesn't compile (maybe it's everything of it).
Also pykde4 won't compile :( I still have 4.3.61 installed.
Any help ?
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Mon Sep 28, 2009 11:35 am    Post subject: Reply with quote

how can i set/use +kdeprefix with paludis?
thanks!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Mon Sep 28, 2009 5:40 pm    Post subject: Reply with quote

I get a circular dependence:

Code:

 * Error: circular dependencies:

('ebuild', '/', 'sys-devel/libtool-2.2.6a', 'merge') depends on
  ('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') (buildtime)
('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') depends on
  ('ebuild', '/', 'sys-devel/libtool-2.2.6a', 'merge') (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.



Any idea?
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Mon Sep 28, 2009 6:45 pm    Post subject: Reply with quote

ftp://ftp.kde.org/pub/kde/unstable/4.3.69 is out in the wild.
_________________
knowledge is power
Back to top
View user's profile Send private message
goffrie
n00b
n00b


Joined: 14 Mar 2007
Posts: 67

PostPosted: Mon Sep 28, 2009 10:49 pm    Post subject: Reply with quote

marcus84 wrote:
I get a circular dependence:

Code:

 * Error: circular dependencies:

('ebuild', '/', 'sys-devel/libtool-2.2.6a', 'merge') depends on
  ('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') (buildtime)
('ebuild', '/', 'app-arch/xz-utils-9999', 'merge') depends on
  ('ebuild', '/', 'sys-devel/libtool-2.2.6a', 'merge') (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.



Any idea?


Mask the -9999 and emerge xz-utils-4.999.9_beta first, or emerge lzma-utils instead of xz.
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Tue Sep 29, 2009 6:46 am    Post subject: Reply with quote

again emerge error in pykde4-4.3.69
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10 ... 36, 37, 38  Next
Page 9 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum