Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 10, 11, 12 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Thu Oct 08, 2009 9:35 pm    Post subject: Reply with quote

kaddressbook-4.3.69 fails with:

Code:
[ 88%] [ 90%] Building CXX object kaddressbook/CMakeFiles/kaddressbookprivate.dir/printing/stylepage.o                                                         
Building CXX object kaddressbook/CMakeFiles/kaddressbookprivate.dir/settings.o                                                                                 
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.cpp:61:41: error: akonadi_next/entitytreeview.h: No such file or directory                                                                                                                                                     
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.cpp: In constructor 'MainWidget::MainWidget(KXMLGUIClient*, QWidget*)':                                                                                                                                                       
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.cpp:128: error: invalid use of incomplete type 'struct Akonadi::EntityTreeView'                                                                                                                                               
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.h:33: error: forward declaration of 'struct Akonadi::EntityTreeView'                 


Anyone else with this error?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 248

PostPosted: Fri Oct 09, 2009 8:34 am    Post subject: Reply with quote

Finswimmer wrote:
kaddressbook-4.3.69 fails with:

Code:
[ 88%] [ 90%] Building CXX object kaddressbook/CMakeFiles/kaddressbookprivate.dir/printing/stylepage.o                                                         
Building CXX object kaddressbook/CMakeFiles/kaddressbookprivate.dir/settings.o                                                                                 
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.cpp:61:41: error: akonadi_next/entitytreeview.h: No such file or directory                                                                                                                                                     
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.cpp: In constructor 'MainWidget::MainWidget(KXMLGUIClient*, QWidget*)':                                                                                                                                                       
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.cpp:128: error: invalid use of incomplete type 'struct Akonadi::EntityTreeView'                                                                                                                                               
/var/tmp/portage/kde-base/kaddressbook-4.3.69/work/kaddressbook-4.3.69/kaddressbook/mainwidget.h:33: error: forward declaration of 'struct Akonadi::EntityTreeView'                 


Anyone else with this error?


I have problem with this one too, but I don't remember the problem (and don't have the pc near)
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Fri Oct 09, 2009 10:56 am    Post subject: Reply with quote

a new digikam and a new koffice beta is out, maybe we get an update soon :lol:
_________________
knowledge is power
Back to top
View user's profile Send private message
Zoboulo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2007
Posts: 97

PostPosted: Fri Oct 09, 2009 2:02 pm    Post subject: Reply with quote

genstorm wrote:
It's in portage (masked).


Thanks for the information.
I succesfully updated, but I have a problem with okular-4.3.2 : it works fine with ps, but it can no longer read pdf (pdf USE flag is on).

Anybody else has this problem ?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Fri Oct 09, 2009 3:29 pm    Post subject: Reply with quote

hm, pdf function works for me...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pdw_hu
Apprentice
Apprentice


Joined: 02 Jun 2008
Posts: 200
Location: Budapest, Hungary

PostPosted: Fri Oct 09, 2009 5:48 pm    Post subject: Reply with quote

Zoboulo wrote:
genstorm wrote:
It's in portage (masked).


Thanks for the information.
I succesfully updated, but I have a problem with okular-4.3.2 : it works fine with ps, but it can no longer read pdf (pdf USE flag is on).

Anybody else has this problem ?


There's a bug for in bugzilla. It's been there since 4.3.1. Or rather: I had to emerge @preserved-rebuild with some poppler reference, and afterwards it stopped working. No fix there, just a few confirmations... :/
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 248

PostPosted: Sat Oct 10, 2009 9:59 am    Post subject: Reply with quote

Zoboulo wrote:
genstorm wrote:
It's in portage (masked).


Thanks for the information.
I succesfully updated, but I have a problem with okular-4.3.2 : it works fine with ps, but it can no longer read pdf (pdf USE flag is on).

Anybody else has this problem ?


Check if you have USE=+lcms in all poppler related ebuild
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Mon Oct 12, 2009 2:58 pm    Post subject: Reply with quote

gaelic_cargal wrote:
a new digikam and a new koffice beta is out, maybe we get an update soon :lol:


still waiting :oops:
_________________
knowledge is power
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Mon Oct 12, 2009 7:44 pm    Post subject: Reply with quote

I assume as of Oct. 10, everyone running kde-live (kde.4.4) MUST go to qt-4.6 in the qting-edge overlay.

Correct?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Mon Oct 12, 2009 7:51 pm    Post subject: Reply with quote

correct - I looked it up in the eclass because people had some 'issues' with that (you now need qting-edge overlay for kde snapshots). I actually wanted to switch to 4.4 as soon as 4.3.70 was out, but I'm not sure I want to switch to qt-alpha...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Tue Oct 13, 2009 5:34 am    Post subject: Reply with quote

Any advice on what would be the recommended choice to try with kde-live?
Quote:
3) qt-4.6.9999[qt-copy] -> Live ebuilds from kdesvn repository ( 4.6 branch )
4) qt-4.6.9999[-qt-copy] -> Live ebuilds from Nokias' 4.6 git branch
5) qt-4.9999 -> Live ebuilds from Nokia Qt Softwares' repository ( master/4.7 branch )
6) qt-4.6.0_alpha_pre1 -> First Tech Release for Qt-4.6

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Tue Oct 13, 2009 9:06 am    Post subject: Reply with quote

wrc1944 wrote:
Any advice on what would be the recommended choice to try with kde-live?
Quote:
3) qt-4.6.9999[qt-copy] -> Live ebuilds from kdesvn repository ( 4.6 branch )
4) qt-4.6.9999[-qt-copy] -> Live ebuilds from Nokias' 4.6 git branch
5) qt-4.9999 -> Live ebuilds from Nokia Qt Softwares' repository ( master/4.7 branch )
6) qt-4.6.0_alpha_pre1 -> First Tech Release for Qt-4.6


From the Mailing list:

The release team has decided that KDE 4.4.0 will depend on Qt 4.6. To give developers the time to work with Qt 4.6, we have decided that from Saturday October 10th* trunk will start depending on Qt 4.6. Everyone need to update the coming two weeks to that version of Qt. Thiago recommends to use the following git repository:

if you want to help Qt development and fix the issues found before the 4.6.0 release, the unpatched branch is recommended:
qt.gitorious.org/qt/qt branch 4.6-stable

if you want to do KDE development, the 4.6-stable-patched would be recommended, This contains the kde patches and will trail behind 4.6-stable, so you may need to merge 4.6-stable yourself if you need the latest fixes:
qt.gitorious.org/qt/kde-qt branch 4.6-stable-patched

**Release Schedule Change**
The expected release dates of Qt's RC and the final release currently clash with KDE's release schedule. Therefore we have decided to shift the KDE release by two weeks.

This will give us approx. 2 weeks between Qt's RC and KDE's beta 1 and 2 weeks between the expected Qt final release and the start of our release candidate cycle. Of course we are not sure that Qt will release at those times, but with the former schedule it was to close to eachother. Qt will let the release team know if the schedule changes and we'll decide what to do at that moment.

The complete release schedule for KDE 4.4.0 now looks like this:
* 1.0 October 10th, 2009: Trunk depends on Qt 4.6
* 1.1 November 4th, 2009: Soft Feature Freeze
* 1.2 November 25th, 2009: Hard Feature Freeze
* 1.3 November 25th, 2009: Message Freeze.
* 1.4 November 25th, 2009: Tag KDE 4.4 Beta 1
* 1.5 December 1st, 2009: Release KDE 4.4 Beta 1
* 1.6 December 1st, 2009: Documentation/Handbook Freeze
* 1.7 December 16nd, 2009: Tag KDE 4.4 Beta 2
* 1.8 December 22th, 2009: Release KDE 4.4 Beta 2
* 1.9 Januari 5th, 2010: Artwork and Bindings Freeze
* 1.10 January 5th, 2010: Tag KDE 4.4 RC 1
* 1.11 January 6th, 2010: Release KDE 4.4 RC 1
* 1.12 January 19th, 2010: Tag KDE 4.4 RC 2
* 1.13 January 20th, 2010: Release KDE 4.4 RC 2
* 1.14 February 3rd, 2010: Tag KDE 4.4
* 1.15 February 9th, 2010: Release KDE 4.4
_________________
knowledge is power
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Tue Oct 13, 2009 11:34 pm    Post subject: Reply with quote

Thanks gaelic_cargal,

So we cd to say, /usr/local ( or /opt? ), and do:
Code:
git clone qt.gitorious.org/qt/kde-qt branch 4.6-stable-patched

Or, use the qting-overlay from layman, and use a kdesvn qt-copy 9999 version?

EDIT: When i tried the git repo with the link above, I got this:
Code:
amd64 wrc # cd /opt
amd64 opt # git clone qt.gitorious.org/qt/kde-qt branch 4.6-stable-patched
fatal: Could not switch to 'qt.gitorious.org/qt': No such file or directory
amd64 opt #


EDIT 2: OK- Using the qting-edge overlay doing an emerge -v1 @qt-all-4.6-live-kde gets me this:
Code:
>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 12) x11-libs/qt-core-4.6.9999-r1 from qting-edge
 * checking ebuild checksums ;-) ...                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                [ ok ]
 *
 * Please file bugs on bugs.gentoo.org and prepend the summary with
 * [qting-edge]. Alternatively, contact   qt@gentoo.org.
 * Thank you for using qting-edge overlay.
 *

 * The 4.6.9999 version ebuilds with qt-copy USE flag install qt-copy from gitorious kde-qt repository.

>>> Unpacking source...
 * GIT NEW clone -->
 *    repository:       git://gitorious.org/+kde-developers/qt/kde-qt.git
Initialized empty Git repository in /usr/portage/distfiles/git-src/qt-4.6.9999/
remote: Counting objects: 213750, done.
remote: Compressing objects: 100% (68615/68615), done.
Receiving objects:   3% (7488/213750), 1.97 MiB | 135 KiB/s 

Looks pretty good, so I'll see what happens. :) If it finishes up the download, and compiles replacing my current qt-4.5.3, I'll try a kde-live update. Isn't this fun! :wink:

EDIT 3: Well, all 12 qt-4.6.9999 packages compiled OK, but all my app icons in the gnome toolbar turned to generic white pages with a little red "x" in the middle. :o Why would a qt change affect gnome icons? I always boot with gnome when I'm updating kde/qt stuff, and this never happened before.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
Dottout
l33t
l33t


Joined: 07 Mar 2006
Posts: 882

PostPosted: Wed Oct 14, 2009 6:38 am    Post subject: Reply with quote

Code:
EDIT 3: Well, all 12 qt-4.6.9999 packages compiled OK, but all my app icons in the gnome toolbar turned to generic white pages with a little red "x" in the middle. :o Why would a qt change affect gnome icons? I always boot with gnome when I'm updating kde/qt stuff, and this never happened before.

did you update also shared-mime-info? look at this tread
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Wed Oct 14, 2009 7:17 am    Post subject: Reply with quote

As kde trunk is now dependent on qt-4.6, i'll expect qt-4.6 release candidates in kde-testing overlay soon. or maybe masked in portage ...
_________________
knowledge is power
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed Oct 14, 2009 10:51 am    Post subject: Reply with quote

gaelic_cargal wrote:
As kde trunk is now dependent on qt-4.6, i'll expect qt-4.6 release candidates in kde-testing overlay soon. or maybe masked in portage ...


But you can add the qting-edge overlay. Why mix the two overlays?
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Wed Oct 14, 2009 1:55 pm    Post subject: Reply with quote

rahulthewall wrote:
gaelic_cargal wrote:
As kde trunk is now dependent on qt-4.6, i'll expect qt-4.6 release candidates in kde-testing overlay soon. or maybe masked in portage ...


But you can add the qting-edge overlay. Why mix the two overlays?


Sure, that's possible. But I assume that many users don't want to start mixing overlays ...
_________________
knowledge is power
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed Oct 14, 2009 2:24 pm    Post subject: Reply with quote

gaelic_cargal wrote:
rahulthewall wrote:
gaelic_cargal wrote:
As kde trunk is now dependent on qt-4.6, i'll expect qt-4.6 release candidates in kde-testing overlay soon. or maybe masked in portage ...


But you can add the qting-edge overlay. Why mix the two overlays?


Sure that's possible. But I assume that many users don't want to start mixing overlays ...


"Users" who use kde-live or snapshots would not be afraid of issuing a simple layman -a qting-edge. :P
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Wed Oct 14, 2009 11:44 pm    Post subject: Reply with quote

I can report that with qt-4.6.9999 I can compile @kdedeps-live, @kdelibs-live, @kdebase-live, @kdeartwork-live, @kdeadmin-live, and kde-base/gwenview ark kdf okular ksystemlog marble dragonplayer kde-misc/konq-plugins kde-misc/webkit-kpart. :D So, we can get a somewhat functioning kde-live system even now against qt-4.6. Any other reports with the pre version?

On @kdepim-live, messagelist and kmail failed (errors apparently related to messagelist).
Also had problems with a revdep-rebuild (hoping to fix the kdepim-live failures), when it wanted to rebuild kget-9999, krdc-9999, and krfb-9999- these also fail. I'm still :? :? :? on these.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Thu Oct 15, 2009 9:08 am    Post subject: Reply with quote

rahulthewall wrote:
gaelic_cargal wrote:
rahulthewall wrote:
gaelic_cargal wrote:
As kde trunk is now dependent on qt-4.6, i'll expect qt-4.6 release candidates in kde-testing overlay soon. or maybe masked in portage ...


But you can add the qting-edge overlay. Why mix the two overlays?


Sure that's possible. But I assume that many users don't want to start mixing overlays ...


"Users" who use kde-live or snapshots would not be afraid of issuing a simple layman -a qting-edge. :P


Well, not afraid. But I'm not sure if a dependency of all ebuild of kde-testing on qting-edge is the right way. If there's really a hard dependency like that kde-testing should consider importing qting-edge git or at least parts of it.
_________________
knowledge is power
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Thu Oct 15, 2009 11:48 am    Post subject: Reply with quote

gaelic wrote:
rahulthewall wrote:
gaelic_cargal wrote:
rahulthewall wrote:
gaelic_cargal wrote:
As kde trunk is now dependent on qt-4.6, i'll expect qt-4.6 release candidates in kde-testing overlay soon. or maybe masked in portage ...


But you can add the qting-edge overlay. Why mix the two overlays?


Sure that's possible. But I assume that many users don't want to start mixing overlays ...


"Users" who use kde-live or snapshots would not be afraid of issuing a simple layman -a qting-edge. :P


Well, not afraid. But I'm not sure if a dependency of all ebuild of kde-testing on qting-edge is the right way. If there's really a hard dependency like that kde-testing should consider importing qting-edge git or at least parts of it.


But the qting-edge overlay team is the best team to provide working ebuilds for QT as they are developing them since long time.
So KDE overlay team-member can focuse on KDE completly and know that the QT ebuilds are the best ebuilds that are available...

There should now ressources be wasted by developing the same things two times...

(I hope you understand, what I mean)

Finswimmer
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Thu Oct 15, 2009 12:09 pm    Post subject: Reply with quote

Hi.

I know what you mean. Development can happen seperately. I just don't like the idea of dependencies of overlays.

Masked qt-4.6 tp1 ebuilds are maybe the best solution
_________________
knowledge is power
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Thu Oct 15, 2009 1:03 pm    Post subject: Reply with quote

gaelic wrote:
I know what you mean. Development can happen seperately. I just don't like the idea of dependencies of overlays.

And i don't like having the same ebuild in several Overlays! Having qt-ebuilds in kde-testing and qting-edge is quite confusing and you never know if you take the right one.
BTW, there are many other ebuilds lying aroung in qting-edge then only qt-4.x ones. I have installed qt via portage but use several packages from qting-edge.

I just want to say it is the right way the devs have chosen to go.
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Thu Oct 15, 2009 2:53 pm    Post subject: Reply with quote

franzf wrote:
Having qt-ebuilds in kde-testing and qting-edge is quite confusing and you never know if you take the right one.


Why is it confusing? If you are able to make a difference between a portage and an overlay ebuild, you can also determine the difference between ebuild of two overlays.
But as I said before. The qt TP is out in the wild and will hopefully enter portage before kde-4.6.7x is released.
_________________
knowledge is power
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Fri Oct 16, 2009 10:56 am    Post subject: Reply with quote

4.3.72 is out now. Curious whats happening now :)
_________________
knowledge is power
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 10, 11, 12 ... 36, 37, 38  Next
Page 11 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum