Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Wed Nov 18, 2009 1:29 pm    Post subject: Reply with quote

So everything should be ok...
Could you post
*) paludis --contents soprano
*) paludis -i1 soprano until src_configure finished (incl. soprano USE-Flags)
A build-log from soprano would be fine, too.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Wed Nov 18, 2009 4:41 pm    Post subject: Reply with quote

I can confirm kdelibs-4.3.75 not building anymore since latest qt-copy 4.6.9999 rebuild.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
heirecka
n00b
n00b


Joined: 23 Oct 2007
Posts: 13

PostPosted: Wed Nov 18, 2009 5:10 pm    Post subject: Reply with quote

paludis --contents soprano:
http://pastebin.com/m1393378

paludis -i1 soprano until src_configure finished (incl. soprano USE-Flags):
http://pastebin.com/mb0f66e1

Build-log:
http://pastebin.com/m7321f549
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Wed Nov 18, 2009 9:38 pm    Post subject: Reply with quote

heirecka wrote:
paludis --contents soprano:
http://pastebin.com/m1393378

paludis -i1 soprano until src_configure finished (incl. soprano USE-Flags):
http://pastebin.com/mb0f66e1

Build-log:
http://pastebin.com/m7321f549


try
Code:
USE="-java redland" emerge soprano
, after it kdelibs-4.3.75 compiled. after the merge of kdelibs you can switch back to your original useflags for soprano
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Wed Nov 18, 2009 11:40 pm    Post subject: Reply with quote

Ok right now kde is ultimately broken with latest Qt, _nothing_ works. :lol:

I'll try with javaless soprano, but I'm not too optimistic...

EDIT: Nope, still not working.

EDIT: 'solved' by compiling soprano with these USE flags (I temporarily added redland), and after that recompiling all of kde-4.3.75:
Code:
[ebuild   R   ] dev-libs/soprano-9999  USE="clucene dbus java raptor redland -debug -doc -virtuoso" 0 kB [1]


As a consequence though, nepomuk doesn't work...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Thu Nov 19, 2009 11:58 pm    Post subject: Reply with quote

genstorm wrote:
Quote:
Ok right now kde is ultimately broken with latest Qt, _nothing_ works. :lol:

Thanks for the heads-up! :D I just rebuilt one kde-live install 3 days ago with a new qt-4.6.9999, and it worked well. (I assume you mean 4.6.9999, correct, or not?)

I was just getting set to rebuild another one I hadn't updated in 3 weeks, including qt-4.6.9999. Really glad I saw your post- saved me a lot of grief.

EDIT: So compiling soprano with those USE flags worked for kde, and qt-4.6.9999 is really OK?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Fri Nov 20, 2009 10:35 am    Post subject: Reply with quote

Yes, speaking of 4.6.9999. Right now something between soprano <-> kdelibs (sesame2?) is broken, and because of a Qt ABI change between beta and rc1 ( :roll: ), KDE needs a rebuild. I'd combine the Qt rebuild with the upcoming KDE version bump. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Nov 20, 2009 5:56 pm    Post subject: Reply with quote

The last package, qt-assistant-4.6.9999 fails. Tried three times, afte removing git-src/4.9999 source files.
Here's the initial list of my qt packages, and below that what happened as to the errors:
Code:
kdesvn wrc # emerge -1pv @qt-all-4.6-live-kde

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-core-4.6.9999-r1  USE="exceptions glib iconv qt-copy qt3support ssl -debug -doc -optimized-qmake -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-sql-4.6.9999  USE="iconv mysql qt-copy qt3support sqlite -debug -exceptions -firebird -odbc -pch -postgres -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-dbus-4.6.9999  USE="qt-copy -debug -exceptions -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-script-4.6.9999  USE="iconv qt-copy -debug -exceptions -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-test-4.6.9999  USE="iconv qt-copy -debug -exceptions -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-xmlpatterns-4.6.9999  USE="qt-copy -debug -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-gui-4.6.9999-r1  USE="accessibility cups dbus glib gtk qt-copy qt3support tiff -debug -exceptions -mng -nas -nis -pch -raster -stable-branch* -xinerama" 0 kB [1]
[ebuild   R   ] x11-libs/qt-webkit-4.6.9999  USE="kde qt-copy -debug -exceptions -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-qt3support-4.6.9999  USE="accessibility kde qt-copy -debug -exceptions -pch -phonon -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-opengl-4.6.9999  USE="qt-copy qt3support -debug -exceptions -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-svg-4.6.9999  USE="iconv qt-copy -debug -exceptions -pch -stable-branch*" 0 kB [1]
[ebuild   R   ] x11-libs/qt-assistant-4.6.9999  USE="qt-copy -debug -exceptions -pch -stable-branch*" 0 kB [1]

Total: 12 packages (12 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/qting-edge


The actually compile output on qt-assistant, after all the 11 others fininshed OK, heavily snipped to save space. Anyone else seeing this problem?
Code:
kdesvn wrc # emerge -v1 qt-assistant
Error during set creation: Redefinition of set 'qt-all-4.6-live-kde' (sections: 'usersets', 'qting-edge sets')

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-assistant-4.6.9999  USE="qt-copy -debug -exceptions -pch -stable-branch*" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/qting-edge

!!! One or more updates have been skipped due to a dependency conflict:

x11-libs/qt-core:4

  ('ebuild', '/', 'x11-libs/qt-core-4.9999-r1', 'merge') conflicts with
    ~x11-libs/qt-core-4.6.9999[exceptions,-debug] required by ('installed', '/', 'x11-libs/qt-xmlpatterns-4.6.9999', 'nomerge')

!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/qt-assistant:4
x11-libs/qt-webkit:4

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-libs/qt-assistant-4.6.9999 from qting-edge
 * checking ebuild checksums ;-) ...                                                                               [ ok ]
 * checking auxfile checksums ;-) ...                                                                              [ ok ]
 * checking miscfile checksums ;-) ...                                                                             [ ok ]
 *
 * Please file bugs on bugs.gentoo.org and prepend the summary with
 * [qting-edge]. Alternatively, contact   qt@gentoo.org.
 * Thank you for using qting-edge overlay.
 *
 * The 4.6.9999 version ebuilds with qt-copy USE flag install qt-copy from gitorious kde-qt repository.
>>> Unpacking source...
 * GIT update -->
 *    repository:       git://gitorious.org/+kde-developers/qt/kde-qt.git
 * git fetch -f -u origin master:master
 *    at the commit:       cd8595efe9aace2afdaa5db37af7cfe82b87e4aa
 *    branch:          master
 *    storage directory:    "/usr/portage/distfiles/git-src/qt-4.6.9999"
Initialized empty Git repository in /var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work/qt-x11-opensource-src-4.6.9999/.git/
Checking out files: 100% (33774/33774), done.
Switched to a new branch 'branch-master'
>>> Unpacked to /var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work/qt-x11-opensource-src-4.6.9999
>>> Source unpacked in /var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work
>>> Preparing source in /var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work/qt-x11-opensource-src-4.6.9999 ...
 * Applying qt-assistant-4.6.0_rc1-tools.patch ...                                                                  [ ok ]
mkdir ./include
mkdir ./include/QtCore
mkdir ./include/Qt
header created for ./src/corelib/animation/qabstractanimation.h (3)
mkdir ./include/QtCore/private
mkdir ./include/Qt/private
header created for ./src/corelib/animation/qabstractanimation_p.h (2)

THEN LOTS OF HEADERS:  SNIPPED

linking sse2
sse2 enabled.
DB2 auto-detection... ()
i686-pc-linux-gnu-g++ -c -pipe -O2 -march=k8 -pipe -fomit-frame-pointer -ftracer -fno-ident -frename-registers -ftree-vectorize -floop-interchange -floop-strip-mine -floop-block -Wall -W  -I../../../mkspecs/linux-g++ -I. -o db2.o db2.cpp
db2.cpp:42:20: error: sqlcli.h: No such file or directory
db2.cpp:43:21: error: sqlcli1.h: No such file or directory
gmake: *** [db2.o] Error 1
DB2 disabled.

AND MORE LIKE THIS: SNIPPED

>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work/qt-x11-opensource-src-4.6.9999 ...
./configure -no-pch -release -no-separate-debug-info -arch i386 -platform linux-g++ -stl -verbose -largefile -confirm-license -no-rpath -prefix /usr -bindir /usr/bin -libdir /usr/lib/qt4 -datadir /usr/share/qt4 -docdir /usr/share/doc/qt-4.6.9999 -headerdir /usr/include/qt4 -plugindir /usr/lib/qt4/plugins -sysconfdir /etc/qt4 -translationdir /usr/share/qt4/translations -examplesdir /usr/share/qt4/examples -demosdir /usr/share/qt4/demos -silent -fast -no-exceptions -reduce-relocations -nomake examples -nomake demos -opensource -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig -no-glib -no-multimedia -no-qt3support -no-svg
Determining system architecture... (Linux:2.6.31-zen4:i686)
    32-bit Intel 80x86 (i386)
    'i386' is supported
System architecture: 'i386'
Symbol visibility control enabled.
Symbolic function binding enabled.

This is the Qt/X11 Open Source Edition.

You are licensed to use this software under the terms of
the Lesser GNU General Public License (LGPL) versions 2.1.

SNIPPED:

686-pc-linux-gnu-g++ -c -pipe -O2 -march=k8 -pipe -fomit-frame-pointer -ftracer -fno-ident -frename-registers -ftree-vectorize -floop-interchange -floop-strip-mine -floop-block -Wall -W  -I../../../mkspecs/linux-g++ -I. -o oci.o oci.cpp
oci.cpp:42:17: error: oci.h: No such file or directory
gmake: *** [oci.o] Error 1
OCI disabled.
ODBC auto-detection... ()
i686-pc-linux-gnu-g++ -c -pipe -O2 -march=k8 -pipe -fomit-frame-pointer -ftracer -fno-ident -frename-registers -ftree-vectorize -floop-interchange -floop-strip-mine -floop-block -Wall -W  -I../../../mkspecs/linux-g++ -I. -o odbc.o odbc.cpp
odbc.cpp:42:17: error: sql.h: No such file or directory
odbc.cpp:43:20: error: sqlext.h: No such file or directory
gmake: *** [odbc.o] Error 1

THEN FINALLY:

compiling .rcc/release-shared/qrc_assistant.cpp
compiling .rcc/release-shared/qrc_assistant_images.cpp
linking ../../../../bin/assistant
/usr/lib/gcc/i686-pc-linux-gnu/4.4.2/../../../libphonon.so: undefined reference to `QHashData::detach_helper(void (*)(QHashData::Node*, void*), void (*)(QHashData::Node*), int)'
collect2: ld returned 1 exit status
make[2]: *** [../../../../bin/assistant] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work/qt-x11-opensource-src-4.6.9999/tools/assistant/tools/assistant'
make[1]: *** [sub-assistant-make_default-ordered] Error 2
make[1]: Leaving directory `/var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work/qt-x11-opensource-src-4.6.9999/tools/assistant/tools'
make: *** [sub-tools-make_default-ordered] Error 2
 * ERROR: x11-libs/qt-assistant-4.6.9999 failed:
 *   emake in tools/assistant failed
 *
 * Call stack:
 *     ebuild.sh, line   49:  Called src_compile
 *   environment, line 3623:  Called qt4-build-edge_src_compile
 *   environment, line 3327:  Called build_directories '
 * tools/assistant
 * tools/pixeltool
 * tools/qdoc3'
 *   environment, line  683:  Called die
 * The specific snippet of code:
 *           emake CC="@echo compiling \$< && $(tc-getCC)" CXX="@echo compiling \$< && $(tc-getCXX)" LINK="@echo linking \$@ && $(tc-getCXX)" || die "emake in ${x} failed";

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
xibo
Apprentice
Apprentice


Joined: 21 Aug 2007
Posts: 152
Location: moving between kubuntu and ubuntu kde edition

PostPosted: Sat Nov 21, 2009 4:17 am    Post subject: Reply with quote

workaround to get qt-assistant installed:
when the emerge process aborts there is a complaint about some library not being found ( libQClucene.so.4 iirc ) which is built by the qt-assistant build process earlier. copy the library to /usr/lib and create the corresponding symlinks by hand, then restart emerge - when emerge finishes it will copy the library to /usr/lib anyway. alternatively you can also put the path with the library during the build progress into you LD_LIBRARY_PATH.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Nov 21, 2009 8:23 am    Post subject: Reply with quote

wrc1944 wrote:
The last package, qt-assistant-4.6.9999 fails. Tried three times, afte removing git-src/4.9999 source files.

The first errors belong to the configure-phase, checking what is available.
Final Error: rebuild media-sound/phonon.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Sat Nov 21, 2009 12:24 pm    Post subject: Reply with quote

Thanks much franzf and xibo! :D That fixed it up.

I had already done an emerge -C on verthing qt and kde to get a fresh start. I did that because I had gone ahead and tried @kdedeps-live, but got a bunch of file collisions on kdelibs, which I could have fixed manually but figured there would be more so I just opted to remove everything kde-base/* because things had changed so much since I last updated this kde-live installation.

Anyway, after that, I rebuilt media-sound/phonon, which also needed automoc first, and then did qt-assistant-4.6-9999, which finally compiled normally.

What I'm wondering is why would media-sound/phonon (which is part of kdedeps-live) need to be recompiled before ANY part of qt? I was under the impression that qt always came before any part of kde, and thus was independent of any kde packages. Is this no longer the case?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Sat Nov 21, 2009 12:33 pm    Post subject: Reply with quote

Now kdelibs fails, but not file collisions- now its early in configure. 8O
Here's what seems relevant:
Code:
>>> Emerging (10 of 15) kde-base/kdelibs-9999 from kde
 * checking ebuild checksums ;-) ...                                                                               [ ok ]
 * checking auxfile checksums ;-) ...                                                                              [ ok ]
 * checking miscfile checksums ;-) ...                                                                             [ ok ]
>>> Unpacking source...
 * subversion update start -->
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdelibs
U    kate/plugins/autobrace/ktexteditor_autobrace.desktop
U    kate/plugins/exporter/ktexteditor_exporter.desktop
U    kfile/kfilemodule.desktop
U    kio/kfile/kiofilemodule.desktop
U    kdecore/all_languages.desktop
U    knewstuff/knewstuff3/CMakeLists.txt
U    plasma/data/servicetypes/plasma-containment.desktop
U    plasma/data/servicetypes/plasma-containmentactions.desktop
U    plasma/kcm_remotewidgets.actions
U    kdoctools/customization/ca/user.entities
U    sonnet/plugins/hunspell/kspell_hunspell.desktop
U    CMakeLists.txt
Updated to revision 1052378.
 *    working copy: /usr/portage/distfiles/svn-src/kdelibs/kdelibs

-- Found automoc4: /usr/bin/automoc4
-- CTest cannot determine repository type. Please set UPDATE_TYPE to 'cvs' or 'svn'. CTest update will not work.

-- Building Fake KAuth backend
WARNING: KAuth will be built with Fake backend. The library will not work properly unless compiled with
             a working backend

-- Found LibXml2: /usr/lib/libxml2.so
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:70 (MESSAGE):
  Could NOT find NEPOMUK (missing: NEPOMUK_LIBRARIES NEPOMUK_INCLUDE_DIR)
Call Stack (most recent call first):
  cmake/modules/FindNepomuk.cmake:62 (find_package_handle_standard_args)
  knewstuff/knewstuff3/CMakeLists.txt:4 (find_package)


-- Configuring incomplete, errors occurred!
 * ERROR: kde-base/kdelibs-9999 failed:
 *   cmake failed

Think maybe a complete qt-4.6.9999 rebuild would help? I did all but qt-assistant last night due to failure mentioned above, and finally got assistant emerged this morning.

EDIT: Could this be a cmake version problem? Emerge -uD @world updated cmake to cmake-2.8.0 yesteday. Maybe i need to revert back to previous version, and rebuilt all of qt first?

Found this in the cmake change-log in portage
Quote:
*cmake-2.8.0 (14 Nov 2009)

14 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
-cmake-2.8.0_rc4.ebuild, +cmake-2.8.0.ebuild:
Version bump for new 2.8.0 release. Remove old rc. Tests are fatal, 100%
pased on all my machines right now.


Or, do i need a svn cmake version even newer that 2.8.0?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Nov 21, 2009 1:53 pm    Post subject: Reply with quote

It is not a cmake issue. Seems like a really GREAT! idea by the kde-devs, making kdenewstuff3 (lying in kdelibs) depending on nepomuk, which depends on kdelibs itself... Wohoo!
But probably this is just a change not finished (look, that can ever happen when using live-ebuilds).
Just try it again in a few hours. Good luck ;)
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Sat Nov 21, 2009 1:57 pm    Post subject: Reply with quote

franzf,
Yeah- just found out it's not a cmake problem. Reverted to cmake-2.6.4, and tried kdelibs, and got same errors.
Guess there's nothing else to do but wait. :(

Thanks for the feedback. :)

EDIT: Hmmm. Just found out qt-4.6.0-rc1 is in portage. Guess I'll go back to cmake-2.8.0, unmask 4.6.0-rc1, and try kde-live against it. It's worth a shot

Nice post about it here: http://www.linuxized.com/2009/11/qt-4-6-0-rc1-in-portage-binary-incompatibility-warning/#utm_source=feed&utm_medium=feed&utm_campaign=feed
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Sun Nov 22, 2009 10:12 am    Post subject: Reply with quote

Well, you have been warned after all. ;)

A recent build of qt-copy 4.6.9999 -stable-branch, soprano and akonadi-server (both 9999) and kdepim works as it should.

Also, with some of the qt commits amarok finally has been fixed.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Sun Nov 22, 2009 6:39 pm    Post subject: Reply with quote

Had the same kdelibs-live failure with qt-4.6.0-rc1 from portage, and also something to do with policykit. The kdelibs problems don't seem to be qt version related, as the output errors are exactly the same, letter for letter.

However, just noticed on websvn trunk some kdelibs commits have just been done 2 hours ago that are apparently fixes for the exact the same items all my errors were on, so I'm rebooting to that Gentoo install, and give kde-live a fresh try.

EDIT: Fixed it up. :) qt-4.6.0-rc1 and @kdedeps-live, @kdelibs-live, @kdebase-live, @kdeartwork-live, @kdeadmin-live, @kdepim-live, and my usual selected packages kde-base/gwenview ark kdf okular marble dragonplayer kde-misc/konq-plugins kde-misc/webkit-kpart now compile & install. :D

Quote:
Dolphin
Version 1.3.80
Using KDE 4.3.77 (KDE 4.3.77 (KDE 4.4 >= 20091120))

Only problem I had was with media-libs/gluon in @kdedeps-live, but it didn't make a difference in my case, so I just skipped it for now. Gluon couldn't fine Eigen2 in configure, and errored out, and there are apparently no ebuilds for eigen. I looked at the following sites and decided I wouldn't need it unless I install Koffice-2 and krita, or maybe kstars. I guess if you have a need for eigen and gluon, they look pretty interesting.
http://eigen.tuxfamily.org/index.php?title=Main_Page
http://gluon.tuxfamily.org/
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Wed Nov 25, 2009 8:09 pm    Post subject: Reply with quote

kalarm COMPILES!!! (4.3.77)
.. but pykde4 won't compile :(
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Thu Nov 26, 2009 1:19 am    Post subject: Reply with quote

wrc1944 wrote:
Gluon couldn't fine Eigen2 in configure, and errored out, and there are apparently no ebuilds for eigen.

Code:
 * Searching for eigen* ...
[-P-] [ ~] dev-cpp/eigen-2.0.4 (2)
[-P-] [ ~] dev-cpp/eigen-2.0.4-r1 (2)
[-P-] [  ] dev-cpp/eigen-2.0.5 (2)
[-P-] [ ~] dev-cpp/eigen-2.0.6 (2)
[IP-] [ ~] dev-cpp/eigen-2.0.9 (2)
[--O] [M ] dev-cpp/eigen-9999 (2)

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Thu Nov 26, 2009 8:39 am    Post subject: Reply with quote

Hmmm. According to the eigen main page http://eigen.tuxfamily.org/index.php?title=Main_Page the repo was just renamed.
Maybe I got caught in between when kdedeps-live was trying to emerge gluon or re-syncing, or the gluon ebuild was looking for the wrong repo, or "eigen2," or something........ :?
I had just synced both Gentoo and kde-testing, but when I manually tried to emerge eigen, it said no ebuilds. eix couldn't find them either, which is really strange. 8O

It's a mystery. :roll: However, eigen does show up in portage on my non-kde-live Gentoo partition, so I'll probably have it on kde-live when I go back to that in a day or two, and re-sync.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6948
Location: Austria

PostPosted: Thu Nov 26, 2009 8:43 am    Post subject: Reply with quote

It definitely is in portage: http://packages.gentoo.org/package/dev-cpp/eigen

So you should have the ebuild regardless of kde-live.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Thu Nov 26, 2009 1:30 pm    Post subject: akonadi-server Reply with quote

Akonadi-server failed to start.

From log:
The Nepomuk search service uses the 'virtuosobackend' backend, which is not recommended for use with Akonadi.

But: dev-libs/soprano-2.3.69_p1053368 (Change USE: +virtuoso)
(dependency required by "kde-base/nepomuk-4.3.77" [installed])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Nov 26, 2009 2:06 pm    Post subject: Reply with quote

is anyone having the same problems with okular ?

when trying to open up pdf files with okular it shows: "Could not open ... .pdf"

"Can not find a plugin which is able to handle the document being passed"

this happens with newly emerged okular 4.3.9999 (kde 4.3.9999)

and also

with

okular from 9999 (4.3.77 something)

any ideas what's wrong ? :(


I urgently need this application working :!: :?

help please !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Thu Nov 26, 2009 2:12 pm    Post subject: Reply with quote

Either a problem with poppler.
Or: run kbuildsycoca4 in a konsole as user, and right away start okular. That is how i solved the problem (after the upgradefrom 4.3.2 to 4.3.3)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Nov 26, 2009 2:44 pm    Post subject: Reply with quote

franzf wrote:
Either a problem with poppler.
Or: run kbuildsycoca4 in a konsole as user, and right away start okular. That is how i solved the problem (after the upgradefrom 4.3.2 to 4.3.3)


thanks franzf !

unfortunately it still shows that error:

a small detail I missed:

in the help ->

submenu "About Backend" is greyed out

strangely in the submenu "Tools" I can open the "configure backends" dialogue and ghostscript is shown



another detail:

when browsing through folders okular doesn't show pdf files when selecting (all supported files)


it's acting like it's not knowing / supporting them

:(

edit:

there's no pdf file format when filtering for supported documents at the open documents dialogue :!: :o

there's also no /usr/lib64/kde4/okularGenerator_poppler.so :evil:

edit2:

upgrading to kde 4.3.75 "fixed" it and okular finally supports pdf files again :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D


Last edited by kernelOfTruth on Thu Nov 26, 2009 7:29 pm; edited 3 times in total
Back to top
View user's profile Send private message
Zoboulo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2007
Posts: 97

PostPosted: Thu Nov 26, 2009 2:54 pm    Post subject: Reply with quote

Zoboulo wrote:

Hi,
koffice-2.0.91 still depends on wv2 and libwpd even if wv2 and wpd USE flags are disabled. Is it normal ?


Hi,

kword-9999 has still a non conditinal dependency on wv2 and libwpd. It shouldn't. Can you please fix it ?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 36, 37, 38  Next
Page 15 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum