Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Nov 26, 2009 6:15 pm    Post subject: Reply with quote

smoke-4.3.75 fails:

https://bugs.gentoo.org/show_bug.cgi?id=294739

I hope that's the right place to post / report ...
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
gaelic
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2003
Posts: 119
Location: Vienna, Austria, Europe, World, Solar System, Milky Way, Universe

PostPosted: Fri Nov 27, 2009 11:15 am    Post subject: Reply with quote

4.3.77 is out
_________________
knowledge is power
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4407

PostPosted: Fri Nov 27, 2009 11:24 am    Post subject: Reply with quote

gaelic wrote:
4.3.77 is out

In the overlay since yesterday.
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Fri Nov 27, 2009 2:00 pm    Post subject: Reply with quote

pykde4-4.3.77 fails, anyone else ?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6928
Location: Austria

PostPosted: Fri Nov 27, 2009 4:35 pm    Post subject: Reply with quote

Yep, pykde4 does not build whether using sip-4.9/PyQt4-4.6 or sip-4.10/PyQt4-4.7.

There:
Code:
sip: Unable to find file "abstractaudiooutput.sip"                                                 
make[2]: *** [python/pykde4/sip/phonon/sipphononpart0.cpp] Error 1                                 
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_phonon.dir/all] Error 2

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Nov 27, 2009 8:40 pm    Post subject: Reply with quote

not quite the same error, isn't it ?

Quote:
In file included from /var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6_build/python/pykde4/sip/akonadi/sipakonadipart0.cpp:7:
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:83:46: error: akonadi/kmime/specialcollections.h: No such file or directory
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:84:56: error: akonadi/kmime/specialcollectionsrequestjob.h: No such file or directory

[ 7%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/sip/dnssd/sipdnssdpart5.o
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6_build/python/pykde4/sip/dnssd/sipdnssdpart5.cpp:1: warning: this target does not support ‘-fsection-anchors’
In file included from /usr/include/python2.6/Python.h:8,
from /usr/include/python2.6/sip.h:33,
from /var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6_build/python/pykde4/sip/dnssd/sipAPIdnssd.h:11,
from /var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6_build/python/pykde4/sip/dnssd/sipdnssdpart5.cpp:7:
/usr/include/python2.6/pyconfig.h:1073:1: warning: "_XOPEN_SOURCE" redefined
<command-line>: warning: this is the location of the previous definition
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip: In function ‘const sipTypeDef* sipSubClass_Akonadi_AgentFilterProxyModel(void**)’:
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:142: error: expected type-specifier
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:142: error: expected ‘>’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:142: error: expected ‘(’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:142: error: ‘SpecialCollections’ is not a member of ‘Akonadi’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:142: error: expected primary-expression before ‘>’ token
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:143: error: expected ‘)’ before ‘sipType’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:198: error: expected type-specifier
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:198: error: expected ‘>’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:198: error: expected ‘(’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:198: error: ‘SpecialCollectionsRequestJob’ is not a member of ‘Akonadi’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:198: error: expected primary-expression before ‘>’ token
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:199: error: expected ‘)’ before ‘sipType’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip:199: warning: suggest braces around empty body in an ‘if’ statement
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip: In function ‘const sipTypeDef* sipSubClass_Akonadi_PreprocessorBase(void**)’:
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:71: error: expected type-specifier
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:71: error: expected ‘>’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:71: error: expected ‘(’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:71: error: ‘SpecialCollections’ is not a member of ‘Akonadi’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:71: error: expected primary-expression before ‘>’ token
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:72: error: expected ‘)’ before ‘sipClass’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:127: error: expected type-specifier
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:127: error: expected ‘>’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:127: error: expected ‘(’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:127: error: ‘SpecialCollectionsRequestJob’ is not a member of ‘Akonadi’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:127: error: expected primary-expression before ‘>’ token
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:128: error: expected ‘)’ before ‘sipClass’
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/preprocessorbase.sip:128: warning: suggest braces around empty body in an ‘if’ statement
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/kdecore/typedefs.sip: In function ‘PyObject* convertFrom_QSet_0100QByteArray(void*, PyObject*)’:
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/kdecore/typedefs.sip:578: warning: suggest explicit braces to avoid ambiguous ‘else’
[ 8%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/sip/dnssd/sipdnssdpart6.o
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6_build/python/pykde4/sip/dnssd/sipdnssdpart6.cpp:1: warning: this target does not support ‘-fsection-anchors’
[ 8%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/sip/dnssd/sipdnssdpart7.o
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6_build/python/pykde4/sip/dnssd/sipdnssdpart7.cpp:1: warning: this target does not support ‘-fsection-anchors’
Linking CXX shared library ../../lib/pykde/dnssd.so
make[2]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/sip/akonadi/sipakonadipart0.o] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 8%] Built target python_module_PyKDE4_dnssd
make: *** [all] Error 2
* ERROR: kde-base/pykde4-4.3.77 failed:
* Make failed!

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2253
Location: $TERM

PostPosted: Sat Nov 28, 2009 3:42 am    Post subject: Reply with quote

Well...there's a reason why these packages are 'testing' and in the overlays only.


Speaking of which phonon-9999 emerge flawlessly.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6928
Location: Austria

PostPosted: Sat Nov 28, 2009 11:20 am    Post subject: Reply with quote

kernelOfTruth wrote:
not quite the same error, isn't it ?

I think it's broken in several places. With USE="akonadi" I also get related errors, especially
Code:
/var/tmp/portage/kde-base/pykde4-4.3.77/work/pykde4-4.3.77-2.6/python/pykde4/sip/akonadi/agentfilterproxymodel.sip
is full of it.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Sat Nov 28, 2009 11:54 am    Post subject: Reply with quote

I get the same errror(s) like KernelOfTruth.
I looked up the missing files and they are all on my HDD installed (mostly by kde-base/kdepimlibs).
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6928
Location: Austria

PostPosted: Sat Nov 28, 2009 11:59 am    Post subject: Reply with quote

Which akonadi-server version do you have installed? Using kdepimlibs-4.3.77 it has to be -9999, so the issues could vary because of that.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Sat Nov 28, 2009 3:33 pm    Post subject: Reply with quote

first I had installed an "old" (maybe 2 weeks) version of akonadi-server-9999 and pykde4 failed. yesterday i updated akonadi-server-9999 and it still failed ;)

but .. however... is anybody here who can say that pykde4 compiled?? :D :D
Back to top
View user's profile Send private message
Gibbo_07
n00b
n00b


Joined: 15 Nov 2009
Posts: 38
Location: Brisbane, AU

PostPosted: Mon Nov 30, 2009 1:55 pm    Post subject: Reply with quote

Quote:
but .. however... is anybody here who can say that pykde4 compiled??


Code:

gentoobox gibbo # equery list pykde4
 * Searching for pykde4 ...
[I-O] [  ] kde-base/pykde4-4.3.9999 (4.3)


I am in sync with the testing overlay so I believe yes :)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6928
Location: Austria

PostPosted: Mon Nov 30, 2009 2:15 pm    Post subject: Reply with quote

That's because you < us, or to be precise, kde-4.3 < kde-4.4

;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Mon Nov 30, 2009 7:08 pm    Post subject: Reply with quote

pykde4-4.3.77 fails for me too, as always, jjust turned python off until 4.4 is released.

also i got failures in kde-base/akonadi-4.3.77
Code:
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:99: error: 'Nepomuk' has not been declared
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:99: error: ISO C++ forbids declaration of 'TagWidg
et' with no type
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:99: error: expected ';' before '*' token
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:101: error: ISO C++ forbids declaration of 'KRatin
gWidget' with no type
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:101: error: expected ';' before '*' token
[ 88%] Built target kabc_akonadi
[ 88%] /var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h: In member function 'void Ui_ContentViewWid
get::setupUi(QWidget*)':
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:353: error: 'tagWidget' was not declared in this s
cope
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:353: error: expected type-specifier before 'Nepomu
k'
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:353: error: expected ';' before 'Nepomuk'
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:363: error: 'ratingWidget' was not declared in thi
s scope
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:363: error: expected type-specifier before 'KRatin
gWidget'
/var/tmp/portage/kde-base/akonadi-4.3.77/work/kdepim-runtime-4.3.77_build/akonadiconsole/ui_browserwidget_contentview.h:363: error: expected ';' before 'KRatingWidget'


all other compiled fine after updating akonadi-server
may be failure is related to -semantic-desktop use flag?
anybody got this compiled?


Last edited by Dancingfire on Mon Nov 30, 2009 9:39 pm; edited 3 times in total
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Mon Nov 30, 2009 7:22 pm    Post subject: Reply with quote

Portage wants to install kdebase-runtime-meta and a dozen of dependencies but i don't want them on my system. Is there a way to not install kdebase-runtime-meta?

Thank you!!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6928
Location: Austria

PostPosted: Mon Nov 30, 2009 8:35 pm    Post subject: Reply with quote

It is pulled in by kdelibs-4.3.77 since a recent ebuild change.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
darc
n00b
n00b


Joined: 03 Sep 2006
Posts: 14

PostPosted: Tue Dec 01, 2009 12:56 am    Post subject: Reply with quote

and... ? this is bug?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4407

PostPosted: Tue Dec 01, 2009 7:37 am    Post subject: Reply with quote

Tom_ wrote:
Portage wants to install kdebase-runtime-meta and a dozen of dependencies but i don't want them on my system. Is there a way to not install kdebase-runtime-meta?

from the kdelibs-4.3.77.ebuild:
Code:
PDEPEND="
        $(add_kdebase_dep kde-env)
        $(add_kdebase_dep kdebase-runtime-meta 'semantic-desktop?')
"

So disable semantic-desktop, and you wont get kdebase-runtime-meta.
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Tue Dec 01, 2009 8:04 am    Post subject: Reply with quote

The semantic-desktop support has already been disabled, so i don't understand what's wrong for me :
Code:
gentoo thomas # emerge kdelibs -av                                                             

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] kde-base/kdelibs-4.3.77  USE="3dnow acl alsa bzip2 fam mmx nls spell sse sse2 ssl (-altivec) (-aqua) -bindist -debug -doc -handbook -jpeg2k (-kdeenablefinal) (-kdeprefix) -kerberos -lzma -openexr -opengl -policykit -semantic-desktop -social-desktop -test -zeroconf" 0 kB [1]
[ebuild  N    ] kde-base/kuiserver-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/khelpcenter-4.3.77  USE="(-aqua) -debug -handbook (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kfile-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kdebase-menu-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kstart-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kdebugdialog-4.3.77  USE="(-aqua) -debug -handbook (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/drkonqi-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/renamedlg-plugins-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kiconfinder-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/solid-hardware-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/knetattach-4.3.77  USE="(-aqua) -debug -handbook (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/solidautoeject-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kquitapp-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/knewstuff-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/ktraderclient-4.3.77  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)" 0 kB [1]
[ebuild  N    ] kde-base/kdebase-runtime-meta-4.3.77  USE="(-kdeprefix) -semantic-desktop" 0 kB [1]


-semantic-desktop is a global flag on my machine. ;)

Any idea about this ?

Thx!
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4407

PostPosted: Tue Dec 01, 2009 8:26 am    Post subject: Reply with quote

Ah, sry, i misinterpreted the add_kdebase_dep-function... Should look into the eclass first.
Code:
# This takes 1 or 2 arguments.  The first being the package
# name, the optional second, is additional USE flags to append.

So the dependency is fix, but if you build kdelibs with semantic-desktop, also kdebase-runtime-meta must be built with semantic-desktop-flag.
Back to top
View user's profile Send private message
ravloony
n00b
n00b


Joined: 04 Feb 2005
Posts: 54
Location: France

PostPosted: Tue Dec 01, 2009 6:55 pm    Post subject: Reply with quote

plasma-workspace fails:

Code:

[ 34%] Building CXX object plasma/generic/containmentactions/contextmenu/CMakeFiles/plasma_containmentactions_contextmenu.dir/plasma_containmentactions_contextmenu_automoc.o                             
[ 35%] Building CXX object plasma/generic/containmentactions/contextmenu/CMakeFiles/plasma_containmentactions_contextmenu.dir/krunner_interface.o                                                         
[ 36%] Building CXX object plasma/generic/applets/systemtray/CMakeFiles/plasma_applet_systemtray.dir/statusnotifierwatcher_interface.o                                                                     
[ 36%] Built target kded_statusnotifierwatcher                                                                                                                                                             
[ 36%] Building CXX object plasma/generic/containmentactions/contextmenu/CMakeFiles/plasma_containmentactions_contextmenu.dir/screensaver_interface.o                                                     
In file included from /var/tmp/portage/kde-base/plasma-workspace-4.3.77/work/plasma-workspace-4.3.77_build/plasma/generic/applets/systemtray/plasma_applet_systemtray_final_cpp.cpp:20:                   
/var/tmp/portage/kde-base/plasma-workspace-4.3.77/work/plasma-workspace-4.3.77/plasma/generic/applets/systemtray/protocols/jobs/dbusjobprotocol.cpp:33: error: redefinition of ‘const char* SystemTray::engineName’                                                                                                                                                                                                   
/var/tmp/portage/kde-base/plasma-workspace-4.3.77/work/plasma-workspace-4.3.77/plasma/generic/applets/systemtray/protocols/notifications/dbusnotificationprotocol.cpp:35: error: ‘const char* SystemTray::engineName’ previously defined here                                                                                                                                                                         
Linking CXX shared module ../../../../lib/plasma_containmentactions_contextmenu.so                                                                                                                         


Anybody else getting this?
These are all that are left to go :
Code:

Calculating dependencies... done!
[ebuild  N    ] kde-base/plasma-workspace-4.3.77  USE="google-gadgets handbook kdeenablefinal semantic-desktop xinerama (-aqua) -debug (-kdeprefix) -python -rss" 0 kB [1]
[ebuild  N    ] kde-base/kdebase-startkde-4.3.77  USE="kdeenablefinal (-aqua) (-kdeprefix)" 0 kB [1]

Total: 2 packages (2 new), Size of downloads: 0 kB


which is rather frustrating...
_________________
No sig yet, sig ebuild up soon :-)
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Tue Dec 01, 2009 7:54 pm    Post subject: Reply with quote

4.3.80 is out ?! but some issues with solid-runtimes ...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6928
Location: Austria

PostPosted: Tue Dec 01, 2009 7:57 pm    Post subject: Reply with quote

kde-base/solid-runtime-4.3.80.ebuild is missing, which doesn't matter because the packages aren't ready anyway.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Tue Dec 01, 2009 8:09 pm    Post subject: Reply with quote

hm.. but now i can't run emerge -vauDN world ... i cannot see what's new in portage :(
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Wed Dec 02, 2009 12:47 pm    Post subject: Reply with quote

Thank you for your answers franzf. ;)

I don't understand why kdelibs requires kdebase-runtime-meta! :roll: My KDE setup works nicely without it!! I'm going to bug report it!! :evil:
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 36, 37, 38  Next
Page 16 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum