Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Sun Dec 20, 2009 10:58 pm    Post subject: Reply with quote

But maybe there is a way to compile those weekly snapshots like 4.3.84? Or live ebuilds are the same thing?
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 249

PostPosted: Mon Dec 21, 2009 11:37 am    Post subject: Reply with quote

live ebuils are a copy of the repository in the instact you compile. So if you install a live ebuild right now you wuld have the 4.3.85 copy (well a alitel more, perhaps)
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Mon Dec 21, 2009 9:58 pm    Post subject: Reply with quote

ksirk-4.3.85 fails with the following:

* Failed Patch: ksirk-4.2.1-freebsd-darwin.patch !


EDIT:
This patch has been removed from the live ebuild: git diff
I guess the patch is now applied upstream on 4.3.85 so should be removed from the ebuild :)
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Mon Dec 21, 2009 11:04 pm    Post subject: Reply with quote

Nice, pykde4 compiles at last :)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Tue Dec 22, 2009 12:34 am    Post subject: Reply with quote

..that's not pykde-4.3.85 you're speaking of? Because it now fails right after the beginning at 2%. :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Tue Dec 22, 2009 2:56 am    Post subject: Reply with quote

genstorm wrote:
..that's not pykde-4.3.85 you're speaking of? Because it now fails right after the beginning at 2%. :lol:


pykde4-4.3.85 compiled here ;)
Back to top
View user's profile Send private message
pholthau
Guru
Guru


Joined: 27 Nov 2005
Posts: 361
Location: Bielefeld, Germany

PostPosted: Tue Dec 22, 2009 10:41 am    Post subject: Reply with quote

Can anyone give me a hint, why pykde complains about python3 not compiled with threads use-flag?
I have python3 installed with this flag enabled.

Eselect shows python2 as my system's python interpreter. Do I have to change that? I'd like to avoid
fiddling around with an experimental python as a system interpreter.

Thanks,
Patrick
_________________
The message is Feierei, alder! The message is Gude Laune, alder! [Sven]
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Tue Dec 22, 2009 10:36 pm    Post subject: Reply with quote

jeanfrancis wrote:
genstorm wrote:
..that's not pykde-4.3.85 you're speaking of? Because it now fails right after the beginning at 2%. :lol:


pykde4-4.3.85 compiled here ;)

+1, it was 4.3.85, and it's compiled nicely here. I was a little afraid before compiling, so compiled without any USE flags, maybe that helps?

to pholthau
Everything seems to be like on my machine: python2 as default, python3 compiled with gdbm ipv6 ncurses readline ssl threads xml USE flags, but everything is OK for me. I think that you have to check that threads USE flag one more time
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Tue Dec 22, 2009 11:33 pm    Post subject: Reply with quote

damnit, I'm starting to get angry now. :lol:

It doesn't work for me. Last words:
Code:
[ebuild     U ] kde-base/pykde4-4.3.85 [4.3.75] USE="akonadi* policykit semantic-desktop (-aqua) -debug -examples (-kdeenablefinal) (-kdeprefix)"
Scanning dependencies of target compile_python_files
[  1%] Generating sip/akonadi/sipakonadipart0.cpp, sip/akonadi/sipakonadipart1.cpp, sip/akonadi/sipakonadipart2.cpp, sip/akonadi/sipakonadipart3.cpp, sip/akonadi/sipakonadipart4.cpp, sip/akonadi/sipakonadipart5.cpp, sip/akonadi/sipakonadipart6.cpp, sip/akonadi/sipakonadipart7.cpp



[  1%] Built target compile_python_files
[  2%] Generating sip/dnssd/sipdnssdpart0.cpp, sip/dnssd/sipdnssdpart1.cpp, sip/dnssd/sipdnssdpart2.cpp, sip/dnssd/sipdnssdpart3.cpp, sip/dnssd/sipdnssdpart4.cpp, sip/dnssd/sipdnssdpart5.cpp, sip/dnssd/sipdnssdpart6.cpp, sip/dnssd/sipdnssdpart7.cpp

sip: /var/tmp/portage/kde-base/pykde4-4.3.85/work/pykde4-4.3.85-2.6/python/pykde4/sip/kdecore/typedefs.sip:472: %MappedType template for this type has already been defined
make[2]: *** [python/pykde4/sip/akonadi/sipakonadipart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
sip: /var/tmp/portage/kde-base/pykde4-4.3.85/work/pykde4-4.3.85-2.6/python/pykde4/sip/kdecore/typedefs.sip:472: %MappedType template for this type has already been defined
make[2]: *** [python/pykde4/sip/dnssd/sipdnssdpart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_dnssd.dir/all] Error 2
make: *** [all] Error 2

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Wed Dec 23, 2009 12:10 am    Post subject: Reply with quote

Have you tried to rebuild PyQt4 ans sip?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Wed Dec 23, 2009 12:42 am    Post subject: Reply with quote

yes, doesn't change a thing.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Wed Dec 23, 2009 9:19 pm    Post subject: Reply with quote

Maybe it's because of sip or pyqt4 version? I have PyQt 4.6.2 and sip 4.9.3 (ones that aren't masked)
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Fri Dec 25, 2009 9:32 am    Post subject: Reply with quote

Hi,

I've just installed 4.3.85: everything compiled smoothly, the file indexer worked a lot converting the old index and indexing again but now the nepomyk search doesn't work at all. Any ideas?
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Dec 25, 2009 5:11 pm    Post subject: Reply with quote

After getting pykde4-9999 to build a week ago once it started failing again. There was a commit to pykde the other day enabling animations, this needs the snapshot of PyQt4. I updated sip and PyQt4 from qting-edge and it's building again.

The specific error was 'sip: QAbstractAnimation has not been defiined'.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Fri Dec 25, 2009 5:32 pm    Post subject: Reply with quote

NForce wrote:
Maybe it's because of sip or pyqt4 version? I have PyQt 4.6.2 and sip 4.9.3 (ones that aren't masked)

Thank you very much, that finally did the trick. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pholthau
Guru
Guru


Joined: 27 Nov 2005
Posts: 361
Location: Bielefeld, Germany

PostPosted: Sat Dec 26, 2009 2:16 pm    Post subject: Reply with quote

Actually portage complains about the missing threads use flag after this error message while trying to compile pykde4:

Code:

  File "/usr/lib/portage/bin/portageq", line 52                                                                                                                                     
    print "ERROR: insufficient parameters!"                                                                                                                                         
                                          ^                                                                                                                                         
SyntaxError: invalid syntax

_________________
The message is Feierei, alder! The message is Gude Laune, alder! [Sven]
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Dec 26, 2009 6:58 pm    Post subject: Reply with quote

smoke is missing a patch and thus failing:
Quote:
* Applying smoke-phonon-fix.patch ...

* Failed Patch: smoke-phonon-fix.patch !
* ( /usr/gentoo/overlays/kde-testing/kde-base/smoke/files/smoke-phonon-fix.patch )
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/kde-base/smoke-4.3.85/temp/smoke-phonon-fix.patch-24569.out

* ERROR: kde-base/smoke-4.3.85 failed:
* Failed Patch: smoke-phonon-fix.patch!
*
* Call stack:
* ebuild.sh, line 55: Called src_prepare
* environment, line 9104: Called kde4-meta_src_prepare
* environment, line 8286: Called kde4-base_src_prepare
* environment, line 7919: Called base_src_prepare
* environment, line 5607: Called base_src_util 'autopatch'
* environment, line 5657: Called epatch '/usr/gentoo/overlays/kde-testing/kde-base/smoke/files/smoke-phonon-fix.patch'
* environment, line 6955: Called die
* The specific snippet of code:
* die "Failed Patch: ${patchname}!";








for reference for those having problems with pykde4, sip, PyQt4:

* python-2.6.4 (python-2.6 is selected)
* dev-python/sip-4.9.3-r1
* dev-python/PyQt4-4.6.2

qt-version is 4.6.9999 (non-stable branch)

I first emerged sip, PyQt4 and after that kdelibs, etc. as a dependency followed pykde4

then it should compile ...

Good luck !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 946
Location: Greece

PostPosted: Mon Jan 04, 2010 1:11 pm    Post subject: Reply with quote

What do you guys think about KDE-4.4? (I am afraid of trying upgrade it =X)

About the Amarok-2.20, it isn't editing id3 tags yet, is it? Neither Moving/Copying to collection, right?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Mon Jan 04, 2010 1:36 pm    Post subject: Reply with quote

4.4 works like a charm (speaking of 4.3.85). If you want to try it out, wait for the next beta/RC release coming soon. 4.3.85 has been around for some time now.

Can't tell about amarok-2.20, but 9999 does edit tags and moving/copying to collection.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Mon Jan 04, 2010 1:36 pm    Post subject: Reply with quote

Holysword wrote:
What do you guys think about KDE-4.4? (I am afraid of trying upgrade it =X)

About the Amarok-2.20, it isn't editing id3 tags yet, is it? Neither Moving/Copying to collection, right?

KDE 4.4 is usable already. Yes, plasma crashes when i try to start knetworkmanager and yes, kmail is working a bit strangely (does not automatically start on KDE startup), but i think it's more bug-free than 4.3.0 was. I dont think about going to 4.3.x since 4.3.82.

I am using Amarok 2.2.2 beta 1 and moving/copying to collection works as far. And tag editing works too, but I tried it only few times and sometimes it worked even on 2.0.0
genstorm wrote:
4.4 works like a charm (speaking of 4.3.85). If you want to try it out, wait for the next beta/RC release coming soon. 4.3.85 has been around for some time now.

Right, i think it's coming january 5th or 6th
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 946
Location: Greece

PostPosted: Mon Jan 04, 2010 10:40 pm    Post subject: Reply with quote

genstorm wrote:
4.4 works like a charm (speaking of 4.3.85). If you want to try it out, wait for the next beta/RC release coming soon. 4.3.85 has been around for some time now.


Great, waitin'

NForce wrote:
I am using Amarok 2.2.2 beta 1 and moving/copying to collection works as far. And tag editing works too, but I tried it only few times and sometimes it worked even on 2.0.0

Weird... I don't even have that option to move/copy to collection. I have the edit option, but it just does nothing.
I'm upgrading to 2.2.1.90, see if something changes.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 946
Location: Greece

PostPosted: Tue Jan 05, 2010 1:48 pm    Post subject: Reply with quote

After upgrading amarok it started to change *some* things in ID3 tags, but only when it wants to. Moreover it messed up some of my old tags, like deleting track number or renaming to other song's name. Other thing that I noticed is that some of the songs now have weird length, like 00:00 or 63:00 (okay, they are not Mike Oldfield's songs, so they are like 5min long, not 63 xD).

Ah, the option to move to collection appears now, but again, only sometimes. I cannot rate albums anymore or set a song to be displayed under "Various Artists".

It is acting pretty unstable here :? :? :?
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Tue Jan 05, 2010 7:57 pm    Post subject: Reply with quote

Strange thing, because it's pretty stable over here. The only thing that bothers me - if I connect one of 3 my mp3 players, amarok grabs it and doesnt let to open it with dolphin but doesnt show it's files in collection like it does with creative zen v. And there is no option in amarok to release the player, so I cant upload pictures, movies or music to that player when amarok is running.
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Wed Jan 06, 2010 8:04 pm    Post subject: Reply with quote

4.3.90 has been tagged for release today :) The 4.4.0 is getting closer and closer
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Fri Jan 08, 2010 9:15 am    Post subject: Reply with quote

pykde4 is broken again (PyQt4.6.2, sip 4.9.3). Maybe someone got it compiled with newer PyQt4 or sip?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 36, 37, 38  Next
Page 18 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum