Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Biert
n00b
n00b


Joined: 14 Sep 2006
Posts: 45
Location: The Netherlands

PostPosted: Fri Jan 08, 2010 10:32 am    Post subject: Reply with quote

NForce wrote:
pykde4 is broken again (PyQt4.6.2, sip 4.9.3). Maybe someone got it compiled with newer PyQt4 or sip?

Yes, it compiled fine with PyQt4 (4.7 pre) and sip (4.10 pre) from the qting-edge overlay.
_________________
http://www.last.fm/user/Biert/
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Fri Jan 08, 2010 10:53 am    Post subject: Reply with quote

Damnit, and I had just removed it from my overlays. :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Biert
n00b
n00b


Joined: 14 Sep 2006
Posts: 45
Location: The Netherlands

PostPosted: Fri Jan 08, 2010 11:13 am    Post subject: Reply with quote

kopete-4.3.90 fails for me:

Code:
[ 66%] Building CXX object kopete/protocols/wlm/CMakeFiles/kopete_wlm.dir/ui/wlmeditaccountwidget.o
In file included from /var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/wlmserver.h:21,
                 from /var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/wlmaccount.h:25,
                 from /var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/ui/wlmeditaccountwidget.cpp:34:
/var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/wlmlibmsn.h:283: error: 'MSN::hotmailInfo' has not been declared
/var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/wlmlibmsn.h:461: error: 'MSN::hotmailInfo' has not been declared
In file included from /var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/ui/wlmeditaccountwidget.cpp:34:
/var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/wlmaccount.h:260: error: 'MSN::hotmailInfo' has not been declared
/var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/ui/wlmeditaccountwidget.cpp: In constructor 'WlmEditAccountWidget::WlmEditAccountWidget(QWidget*, Kopete::Account*)':
/var/tmp/portage/kde-base/kopete-4.3.90/work/kopete-4.3.90/kopete/protocols/wlm/ui/wlmeditaccountwidget.cpp:45: warning: unused variable 'config'
make[2]: *** [kopete/protocols/wlm/CMakeFiles/kopete_wlm.dir/ui/wlmeditaccountwidget.o] Error 1
make[1]: *** [kopete/protocols/wlm/CMakeFiles/kopete_wlm.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....


EDIT: Upgrading to net-libs/libmsn-4.0_beta8 fixed that.


Oh and Choqok stopped working somehow, it doesn't seem to be updating the timeline anymore (Twitter account).
_________________
http://www.last.fm/user/Biert/
Back to top
View user's profile Send private message
Gibbo_07
n00b
n00b


Joined: 15 Nov 2009
Posts: 38
Location: Brisbane, AU

PostPosted: Fri Jan 08, 2010 12:02 pm    Post subject: Reply with quote

NForce wrote:
pykde4 is broken again (PyQt4.6.2, sip 4.9.3). Maybe someone got it compiled with newer PyQt4 or sip?


Would not build for me either, until I added the qting-edge overlay and unmasked sip and PyQt4.

Code:

* Searching for pykde4 ...
[I-O] [  ] kde-base/pykde4-4.3.90:4.4

 * Searching for sip ...
[I-O] [  ] dev-python/sip-4.10_pre20100102:0

 * Searching for PyQt4 ...
[I-O] [  ] dev-python/PyQt4-4.7_pre20091231:0


edit: oops bit late missed the next page.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 08, 2010 5:00 pm    Post subject: Reply with quote

I've been using kde-live with this overlay on several boxes, but I'd like to try the new just released kde-4.4-rc1 (4.3.90) on one of my installations.

Am I correct in thinking we first remove all the kde-live packages, and use the kde-4.4.keywords, kde-4.4 sets, and the current portage ~arch qt version will suffice?

I was hoping to avoid using the qting-edge overlay again, but noticed that PyQt4 (4.7 pre) and sip (4.10 pre) from the qting-edge overlay were needed. So, I'm wondering if we also need the entire qt-4.7_pre from the overlay if we only want kde-4.4-rc1.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Fri Jan 08, 2010 5:34 pm    Post subject: Reply with quote

err, kde 4.4 uses qt 4.6 doesn't it?
_________________
~amd64 | gcc 4.4.2 | linux 2.6.33-git w/ alsa 1.0.22.1 and drm-radeon-testing | gnome(-light) 2.28.2 | xorg-x11 and xf86-video-ati from git
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jan 08, 2010 6:01 pm    Post subject: Reply with quote

justinkb wrote:
err, kde 4.4 uses qt 4.6 doesn't it?


++

I don't know if the versioning of PyQt4 and dev-python/sip is related in any way to x11-libs/qt but those versions you mentioned seem to be unstable snapshots

you really only should install those if you can't compile kde-4.4 without them


currently I'm updating qt4.6 and kde4.4 and will post if I run into problems when NOT running the "stable" versions (PyQt4 4.6.2, sip 4.9.3)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 08, 2010 6:57 pm    Post subject: Reply with quote

So, in order to get 4.3.90 (which as I understand it is kde4.4-rc1) we do use use the kde-4.4.keywords and kde-4.4 sets, and maybe also have to unmask kde-4.4?

I'm not clear because there are 4.3.90 ebuilds, but not sets or keywords, and nothing on this in the layman/kde/Documentation.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Jan 08, 2010 7:19 pm    Post subject: Reply with quote

wrc1944 wrote:
So, in order to get 4.3.90 (which as I understand it is kde4.4-rc1) we do use use the kde-4.4.keywords and kde-4.4 sets, and maybe also have to unmask kde-4.4?

I'm not clear because there are 4.3.90 ebuilds, but not sets or keywords, and nothing on this in the layman/kde/Documentation.


Yes, you have the right idea. link the kde-4.4.keywords file into your keywords and the kde-4.4 file into your unmask.

Same thing for 4.4.9999 (4.4 branch) now too since 4.4 in general is masked but use the 4.4.9999 keyword file obviously and the same 4.4 unmask file.

/me who got the decoder ring on the right notch in irc finally this morning

Anyone on -live going to 4.4.9999 branch it will download a fresh checkout from svn by default. I copied my /usr/portage/disfiles/svn-src/ directories into their foo-4.4.9999 name and did a 'svn switch' inside each one to switch them to the branch. Branch is kde/branches/KDE/4.4/ and trunk is kde/trunk/KDE/. Use 'svn info' to see where it's pointed now and for the full url. Hope this helps anyone not wanting to download everything again if you're switching. You can also just rename the directories too if you don't need a trunk copy and and do the svn switch. There might be other ways too but this worked ok for me.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 08, 2010 8:23 pm    Post subject: Reply with quote

OK- I'm missing somethings, and I've been doing this for 2 years with kde-live. :roll:

I've done both of these,
Code:
kdesvn wrc # cd /etc/portage
kdesvn portage # ln -s /usr/local/portage/layman/kde/Documentation/package.keywords package.keywords
kdesvn portage # ln -s /usr/local/portage/layman/kde/Documentation/package.unmask package.unmask
kdesvn portage # 
kdesvn portage # ln -s /usr/local/portage/layman/kde/Documentation/package.keywords/kde-4.4.keywords kde-4.4.keywords
kdesvn portage # ln -s /usr/local/portage/layman/kde/Documentation/package.unmask/kde-4.4 kde-4.4

and neither seems to work, plus unmasking ~dev-libs/soprano-2.3.70, and ~app-office/akonadi-server-1.2.90, but I'm still getting this:
Code:
emerge -pv1 @kdedeps-4.4 @kdelibs-4.4 @kdebase-4.4

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "kde-base/kdepimlibs:4.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdepimlibs-4.4.9999 (masked by: package.mask, missing keyword)
/usr/local/portage/layman/kde/profiles/package.mask:
# Autogenerated by regenerate-files, DO NOT EDIT.
# You can use this file to mask/unmask KDE 4.4 release.
# Edit Documentation/package.unmask/kde-4.4.d/ files instead.
# kde-base/kdeartwork-kwin-styles:4.4 <--- not ready yet by upstream
# ~app-office/akonadi-server-1.2.90
# ~dev-libs/soprano-2.3.70

- kde-base/kdepimlibs-4.3.90 (masked by: package.mask)
- kde-base/kdepimlibs-4.3.85-r1 (masked by: package.mask)

What (precisely, step-by-step) needs to be done to try kde-4.4-rc1? I'm just not getting this. :roll:
I've done this with kde-live, for a long time, but it doesn't seem to work this time. Why does it keep wanting to pull in kde-base/kdepimlibs-4.4.9999, when I haven't keyworded or unmasked any live or 9999 versions?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Jan 08, 2010 8:35 pm    Post subject: Reply with quote

I don't think you're getting your symlink into your /etc/portage/package.keywords/ directory.

Code:

ln -s /usr/local/portage/layman/kde/Documentation/package.keywords/kde-4.4.keywords /etc/portage/package.keywords/
ln -s /usr/local/portage/layman/kde/Documentation/package.unmask/kde-4.4 /etc/portage/package.unmask/


I'm linked to 4.4.9999 here but it's the same idea.
Code:

# ls -l /etc/portage/package.keywords/
lrwxrwxrwx 1 root root  82 Jan  7 15:24 kde-4.4.9999.keywords -> /usr/local/portage/layman/kde/Documentation/package.keywords/kde-4.4.9999.keywords
lrwxrwxrwx 1 root root  83 Dec 22 20:03 qt-4.6-live-kde -> /usr/local/portage/layman/qting-edge/Documentation/package.keywords/qt-4.6-live-kde

# ls -l /etc/portage/package.unmask/
lrwxrwxrwx 1 root root  66 Jan  8 09:23 kde-4.4 -> /usr/local/portage/layman/kde/Documentation/package.unmask/kde-4.4


_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 08, 2010 11:01 pm    Post subject: Reply with quote

When I use the code I posted above, just like I've always done with kde-live, the symlinks were there. It just doesn't work when I try emerging. When I use your code above to make the links, I get this:
Code:
kdesvn wrc # ln -s /usr/local/portage/layman/kde/Documentation/package.keywords/kde-4.4.keywords /etc/portage/package.keywords/
ln: target `/etc/portage/package.keywords/' is not a directory: No such file or directory
kdesvn wrc # ln -s /usr/local/portage/layman/kde/Documentation/package.unmask/kde-4.4 /etc/portage/package.unmask/
ln: target `/etc/portage/package.unmask/' is not a directory: No such file or directory
kdesvn wrc #

I've never used a trailing "/" before making these types of symlinks, so i still don't get it. :?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Fri Jan 08, 2010 11:18 pm    Post subject: Reply with quote

wrc1944 wrote:
When I use the code I posted above, just like I've always done with kde-live, the symlinks were there. It just doesn't work when I try emerging. When I use your code above to make the links, I get this:
Code:
kdesvn wrc # ln -s /usr/local/portage/layman/kde/Documentation/package.keywords/kde-4.4.keywords /etc/portage/package.keywords/
ln: target `/etc/portage/package.keywords/' is not a directory: No such file or directory
kdesvn wrc # ln -s /usr/local/portage/layman/kde/Documentation/package.unmask/kde-4.4 /etc/portage/package.unmask/
ln: target `/etc/portage/package.unmask/' is not a directory: No such file or directory
kdesvn wrc #

I've never used a trailing "/" before making these types of symlinks, so i still don't get it. :?


I guess you don't have package.keywords and unmask as directories. My references above are to put a symlink inside package.keyword and package.mask directories.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jan 08, 2010 11:19 pm    Post subject: Reply with quote

ok which genius made this:
Quote:
In file included from /usr/include/qt4/QtTest/QtTest:4,
from /var/tmp/portage/app-office/akonadi-server-9999/work/akonadi-9999/libs/tests/notificationmessagetest.cpp:25:
/usr/include/qt4/QtTest/qbenchmark.h:46:47: error: QtTest/private/qbenchmarkmetric_p.h: No such file or directory
[ 3%] Generating preprocessormanageradaptor.cpp, preprocessormanageradaptor.h
[ 3%] Generating agentmanagerinterface.cpp, agentmanagerinterface.h
[ 3%] Generating resourceinterface.cpp, resourceinterface.h
[ 3%] Generating preprocessorinterface.cpp, preprocessorinterface.h
[ 3%] Generating agentcontrolinterface.cpp, agentcontrolinterface.h
[ 3%] Generating xesaminterface.cpp, xesaminterface.h
[ 3%] Generating queryserviceinterface.cpp, queryserviceinterface.h
[ 3%] Generating queryinterface.cpp, queryinterface.h
[ 4%] Generating qrc_akonadidb.cxx
[ 5%] Generating tracernotificationadaptor.moc
[ 6%] Generating traceradaptor.moc
[ 7%] Generating notificationmanageradaptor.moc
[ 8%] Generating serveradaptor.moc
In file included from /usr/include/qt4/QtTest/QtTest:4,
from /var/tmp/portage/app-office/akonadi-server-9999/work/akonadi-9999/libs/tests/notificationmessagetest.cpp:25:
/usr/include/qt4/QtTest/qbenchmark.h:91: error: ‘QBenchmarkMetric’ has not been declared
[ 9%] Generating debuginterfaceadaptor.moc
[ 10%] Generating resourcemanageradaptor.moc
make[2]: *** [libs/tests/CMakeFiles/notificationmessagetest.dir/notificationmessagetest.cpp.o] Error 1
make[1]: *** [libs/tests/CMakeFiles/notificationmessagetest.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 11%] [ 12%] Generating preprocessormanageradaptor.moc


since when is non-stable 4.6.9999 qt not sufficient anymore ? :evil:

qt 4.7 isn't even finished - a little too edgy, isn't it ?


any missing code in this file? (I know it fits better in qting-edge thread but this is right now a necessity to get kde 4.3.90* to compile)

/usr/include/qt4/QtTest/qbenchmark.h
Quote:
/****************************************************************************
**
** Copyright (C) 2009 Nokia Corporation and/or its subsidiary(-ies).
** All rights reserved.
** Contact: Nokia Corporation (qt-info@nokia.com)
**
** This file is part of the QtTest module of the Qt Toolkit.
**
** $QT_BEGIN_LICENSE:LGPL$
** No Commercial Usage
** This file contains pre-release code and may not be distributed.
** You may use this file in accordance with the terms and conditions
** contained in the Technology Preview License Agreement accompanying
** this package.
**
** GNU Lesser General Public License Usage
** Alternatively, this file may be used under the terms of the GNU Lesser
** General Public License version 2.1 as published by the Free Software
** Foundation and appearing in the file LICENSE.LGPL included in the
** packaging of this file. Please review the following information to
** ensure the GNU Lesser General Public License version 2.1 requirements
** will be met: http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
**
** In addition, as a special exception, Nokia gives you certain additional
** rights. These rights are described in the Nokia Qt LGPL Exception
** version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
**
** If you have questions regarding the use of this file, please contact
** Nokia at qt-info@nokia.com.
**
**
**
**
**
**
**
**
** $QT_END_LICENSE$
**
****************************************************************************/

#ifndef QBENCHMARK_H
#define QBENCHMARK_H

#include <QtTest/qtest_global.h>
#include <QtTest/private/qbenchmarkmetric_p.h>

QT_BEGIN_HEADER

QT_BEGIN_NAMESPACE

QT_MODULE(Test)

namespace QTest
{

//
// W A R N I N G
// -------------
//
// The QBenchmarkIterationController class is not a part of the
// QTestlib API. It exists purely as an implementation detail.
//
//
class Q_TESTLIB_EXPORT QBenchmarkIterationController
{
public:
enum RunMode { RepeatUntilValidMeasurement, RunOnce };
QBenchmarkIterationController();
QBenchmarkIterationController(RunMode runMode);
~QBenchmarkIterationController();
bool isDone();
void next();
int i;
};

}

// --- BEGIN public API ---

#define QBENCHMARK \
for (QTest::QBenchmarkIterationController __iteration_controller; \
__iteration_controller.isDone() == false; __iteration_controller.next())

#define QBENCHMARK_ONCE \
for (QTest::QBenchmarkIterationController __iteration_controller(QTest::QBenchmarkIterationController::RunOnce); \
__iteration_controller.isDone() == false; __iteration_controller.next())

namespace QTest
{
void Q_TESTLIB_EXPORT setBenchmarkResult(qreal result, QBenchmarkMetric metric);
}

// --- END public API ---

QT_END_NAMESPACE

QT_END_HEADER

#endif // QBENCHMARK_H



thanks !

edit:

could this problem be due to fvisibility-inlines-hidden ? :oops:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 08, 2010 11:42 pm    Post subject: Reply with quote

firephoto,
Thanks! I always did them as directory symlinks before for kde-live, and that worked fine. I've got them like you described, but i still get this. What version am i supposed to be getting for kde-4.4-rc1, or as i assume, kde-4.3.90?
Code:
kdesvn wrc # emerge -pv1 @kdedeps-4.4 @kdelibs-4.4 @kdebase-4.4

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "kde-base/kdepimlibs:4.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdepimlibs-4.4.9999 (masked by: package.mask, missing keyword)
/usr/local/portage/layman/kde/profiles/package.mask:
# Autogenerated by regenerate-files, DO NOT EDIT.
# You can use this file to mask/unmask KDE 4.4 release.
# Edit Documentation/package.unmask/kde-4.4.d/ files instead.
# kde-base/kdeartwork-kwin-styles:4.4 <--- not ready yet by upstream
# ~app-office/akonadi-server-1.2.90
# ~dev-libs/soprano-2.3.70
# ~media-sound/phonon-4.3.80

- kde-base/kdepimlibs-4.3.90 (masked by: package.mask)
- kde-base/kdepimlibs-4.3.85-r1 (masked by: package.mask)


Do i have to unmask and/or keyword every 4.3.90 package manually in another file?

EDIT: Never mind, finally got it! Thanks for bearing with me. :) Now working on package.use changes for 4.3.90.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Sat Jan 09, 2010 12:07 am    Post subject: Reply with quote

wrc1944 wrote:
Never mind, finally got it! Thanks for bearing with me. :) Now working on package.use changes for 4.3.90.


No problem, I've been on a many year break from Gentoo over in kubuntu land so I'm learning new things too.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
Dont Panic
Guru
Guru


Joined: 20 Jun 2007
Posts: 322
Location: SouthEast U.S.A.

PostPosted: Sat Jan 09, 2010 3:24 am    Post subject: Reply with quote

I'm having problem building kde-base/gwenview-4.3.90 with USE="-semantic-desktop".

The build process appears to be looking for semantic desktop libs despite the USE flag setting.
Code:
/var/tmp/portage/kde-base/gwenview-4.3.90/work/gwenview-4.3.90/gwenview/app/main
window.cpp: In member function ‘void Gwenview::MainWindow::Private::setupContext
Manager()’:
/var/tmp/portage/kde-base/gwenview-4.3.90/work/gwenview-4.3.90/gwenview/app/mainwindow.cpp:422: error: ‘SemanticInfoContextManagerItem’ was not declared in this scope
/var/tmp/portage/kde-base/gwenview-4.3.90/work/gwenview-4.3.90/gwenview/app/mainwindow.cpp:422: error: ‘semanticInfoItem’ was not declared in this scope
[ 96%] Building CXX object gwenview/app/CMakeFiles/gwenview.dir/startpage.o
[ 97%] Building CXX object gwenview/app/CMakeFiles/gwenview.dir/thumbnailviewhelper.o
make[2]: *** [gwenview/app/CMakeFiles/gwenview.dir/mainwindow.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/tmp/portage/kde-base/gwenview-4.3.90/work/gwenview-4.3.90/gwenview/app/startpage.cpp:187: warning: unused parameter ‘index’
make[1]: *** [gwenview/app/CMakeFiles/gwenview.dir/all] Error 2
make: *** [all] Error 2
 * ERROR: kde-base/gwenview-4.3.90 failed:
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat Jan 09, 2010 5:08 am    Post subject: Reply with quote

Same exact thing here on gwenview-4.3.90.

Also, pykde4, printer-applet, system-config-printer-kde, and superkaramba fail.

I have no printer hooked up to this box, and those two always failed before, so maybe that's the problem for them. Pykde4 is probably because I need PyQt4 (4.7 pre) and sip (4.10 pre) from the qting-edge overlay, and IIRC, superkaramba always failed before for many months, but I don't us it anyway so I never bothered trying to find the reason.

I do need gwenview from time to time. :(

EDIT: Equery d says only superkaramba depends on pykde4, so I'm not too worried at this point :wink:
Code:
equery d pykde4 
 * These packages depend on pykde4:
kde-base/superkaramba-9999

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat Jan 09, 2010 5:42 am    Post subject: Reply with quote

Weird. Kde wouldn't start, and I discovered startkde hadn't been installed. Apparenty, it, and plasma-workspace now depend on pykde4, so I guess I'll need the sip and PyQt4 pre versions from the other overlay to even start kde-4.4-rc1. :?
Code:
kdesvn wrc # emerge -v1 kdebase-startkde --keep-going

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] kde-base/pykde4-4.3.90  USE="-akonadi (-aqua) -debug -examples (-kdeenablefinal) (-kdeprefix) -semantic-desktop" 0 kB [1]
[ebuild  N    ] kde-base/plasma-workspace-4.3.90  USE="handbook python (-aqua) -debug -google-gadgets (-kdeenablefinal) (-kdeprefix) -rss -semantic-desktop -xinerama" 0 kB [1]
[ebuild  N    ] kde-base/kdebase-startkde-4.3.90  USE="(-aqua) (-kdeenablefinal) (-kdeprefix)" 0 kB [1]

Total: 3 packages (3 new), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/kde

then, after pykde4-4.3.90 failed:
Code:
* Messages for package kde-base/kdebase-startkde-4.3.90:

 * emerge --keep-going: kde-base/kdebase-startkde-4.3.90 dropped due to
 * unsatisfied dependency.

 * Messages for package kde-base/plasma-workspace-4.3.90:

 * emerge --keep-going: kde-base/plasma-workspace-4.3.90 dropped due to
 * unsatisfied dependency.
 *
 * The following 3 packages have failed to build or install:
 *
 *  ('ebuild', '/', 'kde-base/pykde4-4.3.90', 'merge'), Log file:
 *   '/var/tmp/portage/kde-base/pykde4-4.3.90/temp/build.log'
 *  ('ebuild', '/', 'kde-base/kdebase-startkde-4.3.90', 'merge')
 *  ('ebuild', '/', 'kde-base/plasma-workspace-4.3.90', 'merge')

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Sat Jan 09, 2010 6:35 am    Post subject: Reply with quote

Or you can use -python flag, dont install printer applet and systemconfig-printer, and everything will be fine. I use kde 4.3.90 without pykde4 now
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat Jan 09, 2010 6:57 am    Post subject: Reply with quote

NForce,
Wish I'd have seen your post sooner. :roll:

I just did the sip and PyQt4 pre thing, and then pykde4, plasma-workspace, and startkde installed fine.

I just realized I ran into this same thing before several months ago with kde-live, and used the -python flag.

EDIT: :( Just tried to boot into kde-4.4, and ksplash hangs hard on the last icon. Mouse moves shakily, but still have to cold reboot.

Everything except gwenview and the printer items went fine.

Only thing I can figure is something needs rebuilding after doing the PyQt4 and sip "pre" updates.

Will try rebuilding everything tomorrow, now that everything is set up right.

I did just notice that Mandriva cooker has gone to all the python-qt4-4.0.7.20091231 packages, but kde-4.3.90's aren't showing up in the cooker repo yet- probably in a day or two.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 09, 2010 11:35 am    Post subject: Reply with quote

ok, I got it that "PyQt4 (4.7 pre) and sip (4.10 pre) from the qting-edge overlay" is needed for compilation of pykde4 and several python-related packages

did someone get kdelibs 4.3.90 to compile with qt 4.6.9999 ?

and what exact use-flags did you use ?


I ASAP need a working/"productive" kde environment again

many thanks in advance :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat Jan 09, 2010 3:06 pm    Post subject: Reply with quote

OK- I just started a basically full 4.3.90 rebuild with these sets: emerge -pv1 @kdedeps-4.4 @kdelibs-4.4 @kdebase-4.4 @kdeartwork-4.4 @kdeadmin-4.4 @kdenetwork-4.4 @kdegraphics-4.4 @kdeutils-4.4 @kdemultimedia-4.4 @kdepim-4.4, and the sip PyQt4 qting-edge updates I made after the first build wouldn't start.

Total: 168 packages (3 new, 1 in new slot, 164 reinstalls) The 4 "new" packages are not anything that would prevent starting (gwenview, superkaramba, system-config-printer-kde, printer-applet)

If this doesn't work, I don't know what to think, other than trying the full qting-edge set of 4.7.0 qt packages, seeing as how Mandriva is apparently going with those for qt. As soon as the rc1's show up in the cooker repos I'll try that to confirm that's indeed their plan.

Seems like such a basic thing as starting up would have been resolved before releasing an "rc1." :? I can't recall ever having this happen in at least the last year with kde-live.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Sat Jan 09, 2010 3:14 pm    Post subject: Reply with quote

Hm. I also ran into the pykde4 build error, let the remaints of kde-4.4 finish compile with --nodeps and unmasked PyQt4 and sip pre-releases afterwards. Works now without issues, so I'm not sure that is your exact problem here...

@kernelOfTruth: Unfortunately I can't tell, but it *should* work. I simply couldn't update the 4.6.9999 packages from qting-edge anymore, so a grew tired of it some weeks ago and simply downgraded to official 4.6.0.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 09, 2010 4:56 pm    Post subject: Reply with quote

genstorm wrote:
Hm. I also ran into the pykde4 build error, let the remaints of kde-4.4 finish compile with --nodeps and unmasked PyQt4 and sip pre-releases afterwards. Works now without issues, so I'm not sure that is your exact problem here...

@kernelOfTruth: Unfortunately I can't tell, but it *should* work. I simply couldn't update the 4.6.9999 packages from qting-edge anymore, so a grew tired of it some weeks ago and simply downgraded to official 4.6.0.


@genstorm:

thanks, buddy ! :D

*currently compiling*

this should help slowing down this moving target named qt and safe me some unneeded re-compiles of kde :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 36, 37, 38  Next
Page 19 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum