Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Biert
n00b
n00b


Joined: 14 Sep 2006
Posts: 45
Location: The Netherlands

PostPosted: Sat Jan 09, 2010 6:02 pm    Post subject: Reply with quote

wrc1944 wrote:
EDIT: :( Just tried to boot into kde-4.4, and ksplash hangs hard on the last icon. Mouse moves shakily, but still have to cold reboot.

I found that Plasma was incredibly unusable until I recompiled all plasmoids. I'm using autologin though so I can't say if ksplash causes trouble, but recompiling your plasmoids (one that aren't from kde-base/kdeplasma-addons) might help?
_________________
http://www.last.fm/user/Biert/
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7108
Location: Austria

PostPosted: Sat Jan 09, 2010 6:12 pm    Post subject: Reply with quote

kernelOfTruth wrote:
this should help slowing down this moving target named qt and safe me some unneeded re-compiles of kde :)

++ those 9999 ebuilds always try to seduce one to rebuild, thus running into issues to no end ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Sat Jan 09, 2010 6:19 pm    Post subject: Reply with quote

I've been running the @qt-all-4.6-live-kde set from qting-edge and it's been ok. With the qt-4.6-live-kde keywords and kde-qt flag it tracks 4.6.x.next changes with kde patches.

Superkarmaba installed and is working fine here but the printer config doesn't load, just shows the system-settings icon and a long 'it doesn't work' message after going into that kcm. I haven't don't anything to setup printing otherwise on that box either besides starting cupsd after the first encounter with the error.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Sat Jan 09, 2010 10:20 pm    Post subject: Reply with quote

OK- After a complete rebuild (only gwenview still failed) my problem with the ksplash hanging on the last icon also happened with kdm (I had been using gdm).
Both gdm and kdm come up normally and both booted up other DE's, but when selecting kde-4.4 I got the final icon hang again.
Finally tried startkde from a Console login as user, and X wouldn't start.
Then I booted to gnome, and tried startkde from a user terminal. Kde started up, but was co-mingled with gnome, so I rebooted and entered the minimalist TWM terminals mode, and as user got kde up enough to get into System Settings.

In my case, even with the graphics I have (ATI HD3300 128mb on a AMD 790gx chipset) apparently kde couldn't start because ALL desktop effects and compositing were on by default. :o

After I disabled effects and compositing, I rebooted and kdm started kde normally.

If even my not great but reasonably decent graphics setup can't start up kde, it's obvious effects and compositing should not be on by default, and what's with that terrible 1" tiled blue squares default background? 8O

I've never had this problem on any kde installation version, including kde-live.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Sun Jan 10, 2010 2:36 pm    Post subject: Reply with quote

wrc1944 wrote:
and what's with that terrible 1" tiled blue squares default background? 8O

At first i thought it was a graphical glitch and then i found out it's the new kde style :lol:
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Sun Jan 10, 2010 3:47 pm    Post subject: Reply with quote

What are the thinking?
They need to fire their art dept., or at the very least whoever made that decision needs a serious mental examination. There's no accounting for taste, and I realize they've been working incredibly hard, but come on. :roll: I too at first thought "what's gone wrong with xorg now?" :o
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7108
Location: Austria

PostPosted: Sun Jan 10, 2010 11:20 pm    Post subject: Reply with quote

wrc1944 wrote:
OK- After a complete rebuild (only gwenview still failed)

New patch committed for gwenview without semantic-desktop, you might want to try it now ;)

EDIT: strigi-0.7.1 missing an epatch source ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Shamus397
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 217
Location: Ur-th

PostPosted: Tue Jan 12, 2010 2:45 am    Post subject: Reply with quote

Cool! Now can we get a kdenlive ebuild that respects -semantic-desktop too? ;)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jan 12, 2010 2:24 pm    Post subject: Reply with quote

genstorm wrote:
kernelOfTruth wrote:
this should help slowing down this moving target named qt and safe me some unneeded re-compiles of kde :)

++ those 9999 ebuilds always try to seduce one to rebuild, thus running into issues to no end ;)


yay ! :P

and everything worked out well :)

downgrading to qt 4.6.0* was the "trick" - after that kde 4.3.90* emerged fine ^^

thanks again
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
anglov
n00b
n00b


Joined: 12 Jan 2010
Posts: 1

PostPosted: Tue Jan 12, 2010 4:38 pm    Post subject: Reply with quote

Error, when I install kde-base/kdepim-icons-4.3.90:

Code:
Could NOT find KdepimLibs (missing: KdepimLibs_CONFIG)
Call Stack (most recent call first):
/usr/share/apps/cmake/modules/FindKdepimLibs.cmake:80 (find_package_handle_standard_args)
/usr/share/apps/cmake/modules/MacroOptionalFindPackage.cmake:19 (find_package)
CMakeLists.txt:41 (macro_optional_find_package)

-- Configuring incomplete, errors occurred!
*
* ERROR: kde-base/kdepim-icons-4.3.90 failed.
* Call stack:
* ebuild.sh, line 49: Called src_configure
* environment, line 4062: Called kde4-meta_src_configure
* environment, line 3170: Called kde4-base_src_configure
* environment, line 2874: Called cmake-utils_src_configure
* environment, line 1025: Called _execute_optionaly 'src_configure'
* environment, line 460: Called enable_cmake-utils_src_configure
* environment, line 1452: Called die
* The specific snippet of code:
* cmake "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
* The die message:
* cmake failed


After installation kdepimlibs, this package will install too. Probably missing dependence.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jan 12, 2010 5:03 pm    Post subject: Reply with quote

anglov wrote:
Error, when I install kde-base/kdepim-icons-4.3.90:

Quote:
Could NOT find KdepimLibs (missing: KdepimLibs_CONFIG)
Call Stack (most recent call first):
/usr/share/apps/cmake/modules/FindKdepimLibs.cmake:80 (find_package_handle_standard_args)
/usr/share/apps/cmake/modules/MacroOptionalFindPackage.cmake:19 (find_package)
CMakeLists.txt:41 (macro_optional_find_package)

-- Configuring incomplete, errors occurred!
*
* ERROR: kde-base/kdepim-icons-4.3.90 failed.
* Call stack:
* ebuild.sh, line 49: Called src_configure
* environment, line 4062: Called kde4-meta_src_configure
* environment, line 3170: Called kde4-base_src_configure
* environment, line 2874: Called cmake-utils_src_configure
* environment, line 1025: Called _execute_optionaly 'src_configure'
* environment, line 460: Called enable_cmake-utils_src_configure
* environment, line 1452: Called die
* The specific snippet of code:
* cmake "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
* The die message:
* cmake failed


After installation kdepimlibs, this package will install too. Probably missing dependence.


sure take a look at my quote
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
ndse2112
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2007
Posts: 100

PostPosted: Wed Jan 13, 2010 9:56 pm    Post subject: Reply with quote

Over the last several days I have noticed that kde-misc/todo-list-0.4 from @plasmoids of kde-testing will not build for me. Has anyone else experienced this failure?

Code:

Linking CXX shared module ../../lib/plasma_engine_todo.so                                                                           
[ 58%] Built target plasma_engine_todo                                                                                             
[ 64%] Building CXX object src/applet/CMakeFiles/todoapplet.dir/todomodel.o                                                         
[ 70%] Building CXX object src/applet/CMakeFiles/todoapplet.dir/todomodelcategorydelegate.o                                         
[ 76%] Building CXX object src/applet/CMakeFiles/todoapplet.dir/todoview.o                                                         
[ 82%] Building CXX object src/applet/CMakeFiles/todoapplet.dir/todoitemdelegate.o
[ 88%] Building CXX object src/applet/CMakeFiles/todoapplet.dir/korganizerutil.o
/var/tmp/portage/kde-misc/todo-list-0.4/work/todo_plasmoid/src/applet/todoview.cpp: In constructor 'TodoView::TodoView(QWidget*)'
:
/var/tmp/portage/kde-misc/todo-list-0.4/work/todo_plasmoid/src/applet/todoview.cpp:37: error: 'setAlternatingBlockColors' was not de
clared in this scope
make[2]: *** [src/applet/CMakeFiles/todoapplet.dir/todoview.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [src/applet/CMakeFiles/todoapplet.dir/all] Error 2
make: *** [all] Error 2
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 157

PostPosted: Wed Jan 20, 2010 1:26 pm    Post subject: Reply with quote

Since about a couple of weeks ago, smoke (live version) fails to compile. The error I get is:
Code:

/var/tmp/paludis/kde-base-smoke-9999/work/smoke-9999_build/smoke/qt/x_1.cpp: In static member function 'static void __smokeqt::x_QAbstractPrintDialog::x_8(Smoke::StackItem*)':                           
/var/tmp/paludis/kde-base-smoke-9999/work/smoke-9999_build/smoke/qt/x_1.cpp:4175: error: cannot allocate an object of abstract type '__smokeqt::x_QAbstractPrintDialog'                                   
/var/tmp/paludis/kde-base-smoke-9999/work/smoke-9999_build/smoke/qt/x_1.cpp:4131: note:   because the following virtual functions are pure within '__smokeqt::x_QAbstractPrintDialog':                   
/usr/include/qt4/QtGui/qabstractprintdialog.h:87: note:         virtual int QAbstractPrintDialog::exec()
/var/tmp/paludis/kde-base-smoke-9999/work/smoke-9999_build/smoke/qt/x_1.cpp: In constructor '__smokeqt::x_QAbstractPrintDialog::x_QAbstractPrintDialog()':
/var/tmp/paludis/kde-base-smoke-9999/work/smoke-9999_build/smoke/qt/x_1.cpp:4178: error: no matching function for call to 'QAbstractPrintDialog::QAbstractPrintDialog()'
/usr/include/qt4/QtGui/qabstractprintdialog.h:114: note: candidates are: QAbstractPrintDialog::QAbstractPrintDialog(const QAbstractPrintDialog&)
/usr/include/qt4/QtGui/qabstractprintdialog.h:111: note:                 QAbstractPrintDialog::QAbstractPrintDialog(QAbstractPrintDialogPrivate&, QPrinter*, QWidget*)
/usr/include/qt4/QtGui/qabstractprintdialog.h:84: note:                 QAbstractPrintDialog::QAbstractPrintDialog(QPrinter*, QWidget*)

When I first hit this issue, I thought I only had to wait for the developers to fix the issue, but later I found out that also older svn revisions, which previously compiled correctly, now fail. This most likely means that the problem lies somewhere else, but I haven't got any idea about where. As far as I can see from the log, nothing major has changed between the last time I successfully installed smoke and the first time it failed this way. In particular, the Qt version hasn't changed (except the upgrading of qt-core and qt-gui from 4.6.0 to 4.6.0-r1 which, judging from the Changelogs, shouldn't have changed anything relevant for this issue).

Has anyone been successful in building a recent revision of smoke? Or has anyone some idea on what could be causing this problem? I also tried asking on the kdebindings mailing list, but so far I got no answer.

Thanks in advance
_________________
Stefano
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jan 20, 2010 2:58 pm    Post subject: Reply with quote

building smoke - successfully ?

you gotta be kidding :wink:

smoke NEVER built for me so far :(



anyone knows ETA for kde 4.4 RC2 tarballs ? (they are supposed to be consumable today but I guess tomorrow would be more accurate)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 157

PostPosted: Wed Jan 20, 2010 6:09 pm    Post subject: Reply with quote

kernelOfTruth wrote:
building smoke - successfully ?

you gotta be kidding :wink:

smoke NEVER built for me so far :(



Strange. I never had any problem with it, at least until the 19th of December
_________________
Stefano
Back to top
View user's profile Send private message
The Unabeefer
n00b
n00b


Joined: 23 Dec 2008
Posts: 60
Location: Chicago, IL

PostPosted: Fri Jan 22, 2010 8:08 am    Post subject: Reply with quote

Any news on the tarballs for 4.3.95?? I'm highly anticipating them...
_________________
I am a flying cow... worship me or DIE!!!

...and there he was, reigning supreme at number two...
The One... The Only... The Unabeefer
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jan 22, 2010 1:23 pm    Post subject: Reply with quote

The Unabeefer wrote:
Any news on the tarballs for 4.3.95?? I'm highly anticipating them...


they needed to postpone it:

a compilation error or something of that sorts


it (probably) will be released on Friday or Saturday now
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
The Unabeefer
n00b
n00b


Joined: 23 Dec 2008
Posts: 60
Location: Chicago, IL

PostPosted: Fri Jan 22, 2010 4:33 pm    Post subject: Reply with quote

kernelOfTruth wrote:
The Unabeefer wrote:
Any news on the tarballs for 4.3.95?? I'm highly anticipating them...


they needed to postpone it:

a compilation error or something of that sorts

it (probably) will be released on Friday or Saturday now


Good to know! As long as it's in the works and not just forgotten, I'm good. :D
_________________
I am a flying cow... worship me or DIE!!!

...and there he was, reigning supreme at number two...
The One... The Only... The Unabeefer
Back to top
View user's profile Send private message
sparc
n00b
n00b


Joined: 18 Aug 2005
Posts: 72
Location: Stockholm, Sweden

PostPosted: Sun Jan 24, 2010 12:20 am    Post subject: KDE 4.3.5 requires x11-libs/qscintilla[qt4] !!! Reply with quote

While updating to the new KDE 4.3.5, available through the kde-testing overlay, the package kde-base/smoke-4.3.5 gives the following error:

Code:

emerge: there are no ebuilds built with USE flags to satisfy "x11-libs/qscintilla[qt4]".
!!! One of the following packages is required to complete your request:                 
- x11-libs/qscintilla-2.4 (Missing IUSE: qt4)                                           
(dependency required by "kde-base/smoke-4.3.5" [ebuild])


The problem here is that the qscintilla-2.4 package (from the main repo) has NO qt4 euse!
Here it is:

Code:

$ sudo cat /usr/portage/x11-libs/qscintilla/qscintilla-2.4.ebuild                     
# Copyright 1999-2010 Gentoo Foundation                                                             
# Distributed under the terms of the GNU General Public License v2                                 
# $Header: /var/cvsroot/gentoo-x86/x11-libs/qscintilla/qscintilla-2.4.ebuild,v 1.9 2010/01/06 21:10:25 ranger Exp $

EAPI="2"

inherit eutils multilib qt4

MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"

DESCRIPTION="A Qt port of Neil Hodgson's Scintilla C++ editor class"
HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"

LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"                   
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="doc python"

RDEPEND="x11-libs/qt-gui:4"
DEPEND="${RDEPEND}"       
PDEPEND="python? ( ~dev-python/qscintilla-python-${PV} )"

S="${WORKDIR}"/${MY_P}

PATCHES=( "${FILESDIR}/${PN}-2.4-designer.patch" )

src_configure() {
        myqtver=4
        myqtdir=/usr/share/qt4

        cd "${S}"/Qt${myqtver}
        eqmake${myqtver} qscintilla.pro

        cd "${S}"/designer-Qt${myqtver}
        eqmake${myqtver} designer.pro 
}                                     

src_compile() {
        cd "${S}"/Qt${myqtver}
        emake all staticlib || die "emake failed"

        cd "${S}"/designer-Qt${myqtver}
        emake || die "failed to build designer plugin"
}                                                     

src_install() {
        cd "${S}"/Qt${myqtver}
        # header files
        insinto /usr/include/Qsci
        doins Qsci/*.h || die
        # libraries
        dolib.so libqscintilla2.so* || die
        dolib.a libqscintilla2.a || die
        # translations
        insinto /usr/share/${PN}/translations
        doins qscintilla_*.qm || die
        for trans in $(ls -1 qscintilla_*.qm); do
                dosym /usr/share/${PN}/translations/${trans} \
                        ${myqtdir}/translations/${trans} || die
        done

        # designer plugin
        cd "${S}"/designer-Qt${myqtver}
        emake INSTALL_ROOT="${D}" install || die "designer plugin installation failed"

        # documentation
        cd "${S}"
        dodoc ChangeLog NEWS
        if use doc; then
                dohtml doc/html-Qt${myqtver}/* || die
                insinto /usr/share/doc/${PF}/Scintilla
                doins doc/Scintilla/* || die
        fi
}

pkg_postinst() {
        ewarn "Please remerge dev-python/PyQt4 if you have problems with eric or other"
        ewarn "qscintilla related packages before submitting bug reports."
}


Any clues???
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Jan 24, 2010 6:22 pm    Post subject: Reply with quote

The Unabeefer wrote:


Good to know! As long as it's in the works and not just forgotten, I'm good. :D


it seems like the tarballs finally have landed :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Sun Jan 24, 2010 7:25 pm    Post subject: Reply with quote

I keep getting this on all KDE SC 4.4 RC2 mirrors:
Code:
>>> Downloading 'ftp://ftp.kde.org/pub/kde/unstable/4.3.95/src/kdebindings-4.3.95.tar.bz2'
--2010-01-24 14:19:58--  ftp://ftp.kde.org/pub/kde/unstable/4.3.95/src/kdebindings-4.3.95.tar.bz2
           => `/usr/portage/distfiles/kdebindings-4.3.95.tar.bz2'
Resolving ftp.kde.org... 131.220.16.1
Connecting to ftp.kde.org|131.220.16.1|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /pub/kde/unstable/4.3.95/src ... done.
==> SIZE kdebindings-4.3.95.tar.bz2 ... 4934850
==> PASV ... done.    ==> RETR kdebindings-4.3.95.tar.bz2 ... done.
Length: 4934850 (4.7M) (unauthoritative)

100%[================================================================================>] 4,934,850    198K/s   in 49s     

2010-01-24 14:20:50 (98.3 KB/s) - `/usr/portage/distfiles/kdebindings-4.3.95.tar.bz2' saved [4934850]

('Filesize does not match recorded size', 4934850L, 4934522)
!!! Fetched file: kdebindings-4.3.95.tar.bz2 VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      4934850
!!! Expected: 4934522
Refetching... File renamed to '/usr/portage/distfiles/kdebindings-4.3.95.tar.bz2._checksum_failure_.nNKIDC'

>>> Downloading 'http://mirror.csclub.uwaterloo.ca/kde/unstable/4.3.95/src/kdebindings-4.3.95.tar.bz2'
--2010-01-24 14:20:50--  http://mirror.csclub.uwaterloo.ca/kde/unstable/4.3.95/src/kdebindings-4.3.95.tar.bz2
Resolving mirror.csclub.uwaterloo.ca... 129.97.134.71
Connecting to mirror.csclub.uwaterloo.ca|129.97.134.71|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2010-01-24 14:20:50 ERROR 404: Not Found.

!!! Couldn't download 'kdebindings-4.3.95.tar.bz2'. Aborting.
 * Fetch failed for 'kde-base/pykde4-4.3.95', Log file:
 *  '/var/tmp/portage/kde-base/pykde4-4.3.95/temp/build.log'

>>> Failed to emerge kde-base/pykde4-4.3.95, Log file:


As a result, I can't get all of kde-base completed:
Code:
kdesvn wrc # emerge -pv1 kdebase-startkde       
WARNING: One or more repositories have missing repo_name entries:

   /usr/local/portage/layman/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] kde-base/pykde4-4.3.95 [4.3.90] USE="-akonadi (-aqua) -debug -doc% -examples (-kdeenablefinal) (-kdeprefix) -semantic-desktop" 4,819 kB [1]
[ebuild     U ] kde-base/plasma-workspace-4.3.95 [4.3.90] USE="handbook python (-aqua) -debug (-google-gadgets) (-kdeenablefinal) (-kdeprefix) -rss -semantic-desktop -xinerama" 0 kB [1]
[ebuild     U ] kde-base/kdebase-startkde-4.3.95 [4.3.90] USE="(-aqua) (-kdeenablefinal) (-kdeprefix)" 0 kB [1]

Total: 3 packages (3 upgrades), Size of downloads: 4,819 kB

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Jan 24, 2010 8:21 pm    Post subject: Reply with quote

wrc1944 wrote:
I keep getting this on all KDE SC 4.4 RC2 mirrors:

As a result, I can't get all of kde-base completed:
Code:
kdesvn wrc # emerge -pv1 kdebase-startkde       
WARNING: One or more repositories have missing repo_name entries:

   /usr/local/portage/layman/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] kde-base/pykde4-4.3.95 [4.3.90] USE="-akonadi (-aqua) -debug -doc% -examples (-kdeenablefinal) (-kdeprefix) -semantic-desktop" 4,819 kB [1]
[ebuild     U ] kde-base/plasma-workspace-4.3.95 [4.3.90] USE="handbook python (-aqua) -debug (-google-gadgets) (-kdeenablefinal) (-kdeprefix) -rss -semantic-desktop -xinerama" 0 kB [1]
[ebuild     U ] kde-base/kdebase-startkde-4.3.95 [4.3.90] USE="(-aqua) (-kdeenablefinal) (-kdeprefix)" 0 kB [1]

Total: 3 packages (3 upgrades), Size of downloads: 4,819 kB


sure !

how about re-syncing the overlay ? :roll:

there were several commits / changes in the last hours :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Sun Jan 24, 2010 8:31 pm    Post subject: Reply with quote

Right! I should think more before I post! :roll: That worked fine, along with deleting the old kdebindings source.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Sun Jan 24, 2010 10:36 pm    Post subject: Reply with quote

Only problem I had with 4.3.95 was korganizer failed, even after I removed the block:
Code:
[uninstall    ] kde-base/kontact-specialdates-4.3.90  USE="(-aqua) -debug (-kdeenablefinal) (-kdeprefix)"  [1]
[blocks b     ] kde-base/kontact-specialdates:4.4 ("kde-base/kontact-specialdates:4.4" is blocking kde-base/korganizer-4.3.95)

Code:
Scanning dependencies of target kontact_plannerplugin
[ 77%] [ 83%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/kontact_plannerplugin_automoc.o
Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/plannerplugin.o
[ 88%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/planner.o
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:29:44: error: korganizer/korganizerinterface.h: No such file or directory
Linking CXX shared module ../../../lib/kontact_specialdatesplugin.so
[ 94%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/calendarinterface.o
[ 94%] Built target kontact_specialdatesplugin
[100%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/korganizerinterface.o
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::viewEvent(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:784: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:784: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:786: error: 'korganizer' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::removeEvent(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:792: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:792: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:794: error: 'korganizer' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::viewTodo(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:886: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:886: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:888: error: 'korganizer' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::removeTodo(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:894: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:894: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:896: error: 'korganizer' was not declared in this scope
make[2]: *** [kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/planner.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/all] Error 2
make: *** [all] Error 2
 * ERROR: kde-base/korganizer-4.3.95 failed:
 *   Make failed!
 *
 * Call stack:
 *     ebuild.sh, line   48:  Called src_compile
 *   environment, line 4152:  Called kde4-meta_src_compile
 *   environment, line 3238:  Called kde4-base_src_compile
 *   environment, line 2925:  Called cmake-utils_src_compile
 *   environment, line 1104:  Called _execute_optionaly 'src_compile'
 *   environment, line  537:  Called enable_cmake-utils_src_compile
 *   environment, line 1477:  Called cmake-utils_src_make
 *   environment, line 1123:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Jan 25, 2010 4:30 pm    Post subject: Reply with quote

wrc1944 wrote:
Only problem I had with 4.3.95 was korganizer failed, even after I removed the block:
Code:
Scanning dependencies of target kontact_plannerplugin
[ 77%] [ 83%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/kontact_plannerplugin_automoc.o
Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/plannerplugin.o
[ 88%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/planner.o
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:29:44: error: korganizer/korganizerinterface.h: No such file or directory
Linking CXX shared module ../../../lib/kontact_specialdatesplugin.so
[ 94%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/calendarinterface.o
[ 94%] Built target kontact_specialdatesplugin
[100%] Building CXX object kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/korganizerinterface.o
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::viewEvent(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:784: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:784: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:786: error: 'korganizer' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::removeEvent(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:792: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:792: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:794: error: 'korganizer' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::viewTodo(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:886: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:886: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:888: error: 'korganizer' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp: In member function 'void Planner::removeTodo(const QString&)':
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:894: error: 'OrgKdeKorganizerKorganizerInterface' was not declared in this scope
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:894: error: expected ';' before 'korganizer'
/var/tmp/portage/kde-base/korganizer-4.3.95/work/korganizer-4.3.95/kontact/plugins/planner/planner.cpp:896: error: 'korganizer' was not declared in this scope
make[2]: *** [kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/planner.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [kontact/plugins/planner/CMakeFiles/kontact_plannerplugin.dir/all] Error 2
make: *** [all] Error 2
 * ERROR: kde-base/korganizer-4.3.95 failed:
 *   Make failed!
 *
 * Call stack:
 *     ebuild.sh, line   48:  Called src_compile
 *   environment, line 4152:  Called kde4-meta_src_compile
 *   environment, line 3238:  Called kde4-base_src_compile
 *   environment, line 2925:  Called cmake-utils_src_compile
 *   environment, line 1104:  Called _execute_optionaly 'src_compile'
 *   environment, line  537:  Called enable_cmake-utils_src_compile
 *   environment, line 1477:  Called cmake-utils_src_make
 *   environment, line 1123:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";


confirmed !

besides that kde-base/kdebindings-csharp-4.3.95 fails due to missing and not cleanly applying / failing patch (when it is renamed):

Quote:
>>> Source unpacked in /var/tmp/portage/kde-base/kdebindings-csharp-4.3.95/work
>>> Preparing source in /var/tmp/portage/kde-base/kdebindings-csharp-4.3.95/work/kdebindings-csharp-4.3.95 ...
* QA: File or directory "/usr/gentoo/overlays/kde-testing/kde-base/kdebindings-csharp/files/kdebindings-csharp-4.3.95-build-fixes.patch" does not exist.
* QA: Check your PATCHES array or add missing file/directory.
* ERROR: kde-base/kdebindings-csharp-4.3.95 failed:
* Some patches failed. See above messages.

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 36, 37, 38  Next
Page 20 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum