Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 23, 24, 25 ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Fri May 28, 2010 6:40 am    Post subject: Reply with quote

I can't tell. I don't think it would get more stable though... EDIT: Well, since it is still lingering around, missing in my @kde-4.5 set, I tried - and it started. 8)

Oh, how could I forget: pykde4 of course does not compile. :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri May 28, 2010 12:53 pm    Post subject: Reply with quote

genstorm wrote:
Oh, how could I forget: pykde4 of course does not compile. :lol:


Does that package ever compile before rc hits town!

On another note, koffice-2.2 has been released. Someone bump this! :P
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Fri May 28, 2010 8:16 pm    Post subject: Reply with quote

Unfortunately on amd64 I have:

Quote:
[ 35%] Building CXX object kdeui/CMakeFiles/kdeui.dir/paged/kpagedialog.o
[ 35%] Building CXX object kdeui/CMakeFiles/kdeui.dir/paged/kpagemodel.o
/var/tmp/paludis/kde-base-kdelibs-4.4.80/work/kdelibs-4.4.80/kdeui/notifications/kstatusnotifieritem.cpp: In member function 'virtual QString KDBusMenuExporter::iconNameForAction(QAction*)':
/var/tmp/paludis/kde-base-kdelibs-4.4.80/work/kdelibs-4.4.80/kdeui/notifications/kstatusnotifieritem.cpp:72: error: 'class KIcon' has no member named 'name'
make[2]: *** [kdeui/CMakeFiles/kdeui.dir/notifications/kstatusnotifieritem.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [kdeui/CMakeFiles/kdeui.dir/all] Error 2
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2


I have qt-4.7_beta1 installed, can this be the case? (I cannot downgrade for test as "Downgrading Qt is completely unsupported and will break your system!").

Also anybody knows whether kdepim works on those beta builds? I don't care if those are KDE 4.4 style or 4.5 pre-style. Just - does it work?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sat May 29, 2010 9:31 am    Post subject: Reply with quote

As I said, kdepim:4.4 suite is still around on my system (until the next --depclean), and it does work inside the 4.5 environment.

PS: Comparing your error with cruzki123's some posts ago, it seems kdelibs:4.5 currently won't compile with Qt-4.7. I've learnt the hard way that rushing dependencies is not always a good idea, especially with Qt. gcc-4.5 only adds additional spice on cruzki123's system, but Qt-4.7 seems to be the common issue here. Unless someone else proves me wrong?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Sat May 29, 2010 12:09 pm    Post subject: Reply with quote

Well than only hope is that it'll get fixed upstream, as I trust this warning about downgrading ;)
Back to top
View user's profile Send private message
heirecka
n00b
n00b


Joined: 23 Oct 2007
Posts: 13

PostPosted: Sun May 30, 2010 11:52 am    Post subject: Reply with quote

I took a look at the source code:
Code:
#if QT_VERSION >= 0x0I 40700
        // QIcon::name() is in the 4.7 git branch, but it is not in 4.7 TP.
        // If you get a build error here, you need to update your pre-release
        // of Qt 4.7.
        return icon.isNull() ? QString() : icon.name();
#else
        return QString();
#endif


Unfortunately this still seems to be true for the beta. Dirty replacement with return QString() allows kdelibs to compile again.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sun May 30, 2010 12:22 pm    Post subject: Reply with quote

rahulthewall wrote:
On another note, koffice-2.2 has been released. Someone bump this! :P

Renaming 2.1.81 ebuilds seems to work (well, emerging 3/10 now) ;)

EDIT: Not quite, koffice-libs wouldn't compile currently.

Btw, kde-4.4.81 is already available, compiling now.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 248

PostPosted: Sun May 30, 2010 6:24 pm    Post subject: Reply with quote

4.4.81 fails in the same point as 4.4.80 with qt 4.7 and gcc-4.5.

Is anyone that succed with gcc-4.5 and qt 4.6?

I will try to downgrade qt (yes I_KNOW_WHAT_I_AM_DOING="true" :P ) when I have my backup system in the office.

Should I bug upstream?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sun May 30, 2010 6:26 pm    Post subject: Reply with quote

No, your answer was already two posts above. ;)

Next Qt-4.7 update should bring the fix. Chances are it is already in Qt-4.6.9999 or such.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 248

PostPosted: Sun May 30, 2010 11:06 pm    Post subject: Reply with quote

I disn't see that post :S

I suppose I will try to update to qt-4.7.9999 "stable" (I have to read the docs to remembre what use flags should I set :S)

I will tell you tomorrow!!!

EDIT:

Ussing qt-4.7.9999 stable branch didn't work. With the heirecka's hack compile fine. I'm now copiling kde 4.4.81 :)

EDIT2:

I have compiled succefully but I miss oxygen windows style :( I only have: plastiq, redmon, cde, motif and cleanlooks. I have reemerge liboxygenstyle without look. May I have missing something?
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Mon May 31, 2010 10:47 pm    Post subject: Reply with quote

genstorm wrote:
I can't tell. I don't think it would get more stable though... EDIT: Well, since it is still lingering around, missing in my @kde-4.5 set, I tried - and it started. 8)

Oh, how could I forget: pykde4 of course does not compile. :lol:

pykde-4.4.81 compiles fine here!
but amarok-2.3.0.90 dont want to do his job after upgrading KDE to 4.4.81 anymore:
Code:
amarok: symbol lookup error: /usr/lib/libamaroklib.so.1: undefined symbol: _ZN15KPluginSelector16staticMetaObjectE

tried to recompile amarok. but got this compiling error:
Code:
[ 87%] Building CXX object src/context/engines/upcomingevents/CMakeFiles/amarok_data_engine_upcomingEvents.dir/UpcomingEventsEngine.o
In file included from /var/tmp/portage/media-sound/amarok-2.3.0.90/work/amarok-2.3.0.90/src/context/engines/similarartists/SimilarArtistsEngine.cpp:644:
/var/tmp/portage/media-sound/amarok-2.3.0.90/work/amarok-2.3.0.90/src/context/engines/similarartists/SimilarArtistsEngine.cpp: In member function »void SimilarArtistsEngine::parseSimilarArtists(KJob*)«:
/var/tmp/portage/media-sound/amarok-2.3.0.90/work/amarok-2.3.0.90/src/context/engines/similarartists/SimilarArtistsEngine.cpp:359: Warnung: »match« könnte in dieser Funktion uninitialisiert verwendet werden
[ 87%] Building CXX object src/context/engines/similarartists/CMakeFiles/amarok_data_engine_similarArtists.dir/__/__/applets/similarartists/SimilarArtist.o
Linking CXX shared module ../../../../lib/amarok_data_engine_similarArtists.so
[ 87%] Built target amarok_data_engine_similarArtists
Scanning dependencies of target amarok_containment_vertical
[ 87%] Building CXX object src/context/containments/verticallayout/CMakeFiles/amarok_containment_vertical.dir/amarok_containment_vertical_automoc.o
[ 87%] Building CXX object src/context/containments/verticallayout/CMakeFiles/amarok_containment_vertical.dir/VerticalToolbarContainment.o
[ 87%] Building CXX object src/context/engines/upcomingevents/CMakeFiles/amarok_data_engine_upcomingEvents.dir/__/__/applets/upcomingevents/LastFmEvent.o
Linking CXX shared module ../../../../lib/amarok_data_engine_upcomingEvents.so
[ 87%] Built target amarok_data_engine_upcomingEvents
Scanning dependencies of target amarok_appletscript_simple_javascript
[ 87%] Building CXX object src/context/scriptengine/javascript/CMakeFiles/amarok_appletscript_simple_javascript.dir/amarok_appletscript_simple_javascript_automoc.o
[ 87%] Building CXX object src/context/scriptengine/javascript/CMakeFiles/amarok_appletscript_simple_javascript.dir/simplejavascriptapplet.o
[ 87%] Building CXX object src/context/containments/verticallayout/CMakeFiles/amarok_containment_vertical.dir/VerticalAppletLayout.o
In file included from /var/tmp/portage/media-sound/amarok-2.3.0.90/work/amarok-2.3.0.90/src/context/scriptengine/javascript/simplejavascriptapplet.cpp:42:
/var/tmp/portage/media-sound/amarok-2.3.0.90/work/amarok-2.3.0.90/src/context/scriptengine/javascript/bind_dataengine.h:29: Fehler: Redefinition von »struct
QMetaTypeId<Plasma::DataEngine*>«
/usr/include/KDE/Plasma/../../plasma/dataengine.h:500: Fehler: vorherige Definition von »struct QMetaTypeId<Plasma::DataEngine*>«
make[2]: *** [src/context/scriptengine/javascript/CMakeFiles/amarok_appletscript_simple_javascript.dir/simplejavascriptapplet.o] Fehler 1
make[1]: *** [src/context/scriptengine/javascript/CMakeFiles/amarok_appletscript_simple_javascript.dir/all] Fehler 2
make[1]: *** Warte auf noch nicht beendete Prozesse...
Linking CXX shared module ../../../../lib/amarok_containment_vertical.so
[ 87%] Built target amarok_containment_vertical
make: *** [all] Fehler 2

do anybody have a hint to solve this issue?

PS: sorry for the german error code language
Code:
Fehler: vorherige Definition von »struct QMetaTypeId<Plasma::DataEngine*>«
means something like
Code:
Error: previous definition of »struct QMetaTypeId<Plasma::DataEngine*>«
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Tue Jun 01, 2010 7:04 am    Post subject: Reply with quote

AmonAmarth wrote:
pykde-4.4.81 compiles fine here!

Interesting. ;)
Which versions of...
- Qt
- PyQt4, sip
...are installed on your system?

I had amarok-9999 build successfully, right now amarok-utils-9999 seems to be broken but I don't think because of KDE. So there's hope for a fix, maybe with the next minor release already.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Tue Jun 01, 2010 9:32 am    Post subject: Reply with quote

genstorm wrote:
AmonAmarth wrote:
pykde-4.4.81 compiles fine here!

Interesting. ;)
Which versions of...
- Qt
- PyQt4, sip
...are installed on your system?

PyQt-4.7.3 with USE="X dbus kde multimedia opengl phonon sql svg webkit -assistant -debug -doc -examples -xmlpatterns"
each qt module in version 4.6.2
sip-4.10.2
pykde with USE="akonadi semantic-desktop -aqua -debug -doc -examples -kdeenablefinal -kdeprefix"
hope could help you with this information!
genstorm wrote:
I had amarok-9999 build successfully, right now amarok-utils-9999 seems to be broken but I don't think because of KDE. So there's hope for a fix, maybe with the next minor release already.

i will try to compile amarok-9999 now
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Wed Jun 02, 2010 4:35 pm    Post subject: Reply with quote

AmonAmarth wrote:
hope could help you with this information!

Indeed, I had exactly the same settings here. So I retried now, and it built fine! One of the recent syncs must have fixed the ebuild.

I really like what I see. beta1 already feels as stable as any final before - of course there are some of the usual beta glitches but no show stoppers. And pykde4 really never built that early in the game. :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Wed Jun 02, 2010 5:15 pm    Post subject: Reply with quote

genstorm wrote:
AmonAmarth wrote:
hope could help you with this information!

Indeed, I had exactly the same settings here. So I retried now, and it built fine! One of the recent syncs must have fixed the ebuild.

I really like what I see. beta1 already feels as stable as any final before - of course there are some of the usual beta glitches but no show stoppers. And pykde4 really never built that early in the game. :lol:


you are right! first time i experience that pykde compiles that early ;-)
just for the protocol: amarok-2.3.1 compiles and works now
but one (oder two) problem(s) i recognize with kde-4.4.81, maybe somebody have a fix for it:
my kdm forgets everytime the last user who has logged in. i have to type in my username everytime i logout or restart.
the other point is that plasma seems to forget its configuration with logout. my wallpaper, the desktop activity settings and as well all plasmoids are forgotten or disapeared, respectively.
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Wed Jun 02, 2010 10:07 pm    Post subject: Reply with quote

AmonAmarth wrote:
genstorm wrote:
AmonAmarth wrote:
hope could help you with this information!

Indeed, I had exactly the same settings here. So I retried now, and it built fine! One of the recent syncs must have fixed the ebuild.

I really like what I see. beta1 already feels as stable as any final before - of course there are some of the usual beta glitches but no show stoppers. And pykde4 really never built that early in the game. :lol:


you are right! first time i experience that pykde compiles that early ;-)
just to the record: amarok-2.3.1 compiles and works now
but one (oder two) problem(s) i recognize with kde-4.4.81, maybe somebody have a fix for it:
my kdm forgets everytime the last user who has logged in. i have to type in my username everytime i logout or restart.
the other point is that plasma seems to forget its configuration with logout. my wallpaper, the desktop activity settings and as well all plasmoids are forgotten or disapeared, respectively.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Thu Jun 03, 2010 12:14 pm    Post subject: Reply with quote

AmonAmarth wrote:
my kdm forgets everytime the last user who has logged in. i have to type in my username everytime i logout or restart.

I currently don't even use kdm because it is nonfunctional. The buttons don't work which makes session changes rather difficult. So, startx for me - I'm the only user anyway. ;)
AmonAmarth wrote:
the other point is that plasma seems to forget its configuration with logout. my wallpaper, the desktop activity settings and as well all plasmoids are forgotten or disapeared, respectively.

I'll look into that, 4.4.80 did save the plasmoids, but the desktop was cleared with the update to 4.4.81.


Now, what about the new network management plasmoid? How do we get it?

PS: koffice-2.2.0 ebuilds now inside kde overlay - and the recent sync hopefully fixed the compile error I had already experienced with my own ebuilds.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Thu Jun 03, 2010 8:04 pm    Post subject: Reply with quote

genstorm wrote:
AmonAmarth wrote:
the other point is that plasma seems to forget its configuration with logout. my wallpaper, the desktop activity settings and as well all plasmoids are forgotten or disapeared, respectively.

I'll look into that, 4.4.80 did save the plasmoids, but the desktop was cleared with the update to 4.4.81.

The plasmoids still seem to be there from the verbose messages that startx is printing out, but are not visible. Hm.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 248

PostPosted: Thu Jun 03, 2010 9:06 pm    Post subject: Reply with quote

genstorm wrote:
AmonAmarth wrote:
my kdm forgets everytime the last user who has logged in. i have to type in my username everytime i logout or restart.

I currently don't even use kdm because it is nonfunctional. The buttons don't work which makes session changes rather difficult. So, startx for me - I'm the only user anyway. ;)


I'm having the same problem

AmonAmarth wrote:
the other point is that plasma seems to forget its configuration with logout. my wallpaper, the desktop activity settings and as well all plasmoids are forgotten or disapeared, respectively.

I'll look into that, 4.4.80 did save the plasmoids, but the desktop was cleared with the update to 4.4.81.
[/quote]

Well, I thought that you have problem with "activities". My plasma setup have disapears from time to time but what was hapenning was that it was changed the "activity".
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Fri Jun 04, 2010 9:20 am    Post subject: Reply with quote

KOffice-2.2 works great here. Compiles, works and all that stuff :)

For KDE I'll probably wait for 4.4.85 (Wednesday or something).

Will I have to keep my kdepim-4.4 to have KMail and Akregator working? Cause that'd make me stay with 4.4.4 probably for now...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Fri Jun 04, 2010 10:05 am    Post subject: Reply with quote

Well, KMail and Akregator still work with 4.4.81 so far. Not sure about ebuild compatibility because right now I just have them lurking around without record inside the world file or an installed set (removed them from :4.5 set), just one depclean from removal away. I'll report back on that later this evening.

I still got a compile error with koffice-libs-2.2.0 yesterday, but maybe that was fixed with a sync.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 248

PostPosted: Fri Jun 04, 2010 10:14 pm    Post subject: Reply with quote

I have still geting the compiler error with koffice.

Code:

[ 76%] Building CXX object libs/main/CMakeFiles/komain.dir/rdf/RdfSemanticTreeWidgetSelectAction.o                                                                                 
[ 76%] Building CXX object libs/main/CMakeFiles/komain.dir/rdf/InsertSemanticObjectActionBase.o                                                                                   
[ 76%] Building CXX object libs/main/CMakeFiles/komain.dir/rdf/InsertSemanticObjectCreateAction.o                                                                                 
[ 76%] Building CXX object libs/main/CMakeFiles/komain.dir/rdf/InsertSemanticObjectReferenceAction.o                                                                               
Linking CXX shared library ../../lib/libkomain.so                                                                                                                                 
CMakeFiles/komain.dir/KoTemplateCreateDia.o: In function `KoTemplateCreateDia::slotOk()':                                                                                         
KoTemplateCreateDia.cpp:(.text+0x27bf): undefined reference to `KIO::file_copy(KUrl const&, KUrl const&, QFlags<KIO::JobFlag>)'
collect2: ld devolvi� el estado de salida 1
make[2]: *** [lib/libkomain.so.7.0.0] Error 1
make[1]: *** [libs/main/CMakeFiles/komain.dir/all] Error 2
make: *** [all] Error 2
 * ERROR: app-office/koffice-libs-2.2.0 failed:
 *   Make failed!
 *
 * Call stack:
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Sun Jun 06, 2010 11:18 am    Post subject: Reply with quote

genstorm wrote:
Well, KMail and Akregator still work with 4.4.81 so far. Not sure about ebuild compatibility because right now I just have them lurking around without record inside the world file or an installed set (removed them from :4.5 set), just one depclean from removal away. I'll report back on that later this evening.

I still got a compile error with koffice-libs-2.2.0 yesterday, but maybe that was fixed with a sync.


Any more information on kdepim (um... at least KMail and Akregator)? :D I'd waste 2 days compiling forth and back (in case of `fail`) to check by myself, so I'd rather ask again :)
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1595
Location: Just over the horizon

PostPosted: Sun Jun 06, 2010 2:01 pm    Post subject: Reply with quote

Looks like the kdedeps-4.4 set file disappeared from the overlay. When I try to emerge, it errors out with this:

Quote:

emerge: the given set 'world' contains a non-existent set named 'kdedeps-4.4'.


Anybody else running into this?
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1599
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Sun Jun 06, 2010 4:24 pm    Post subject: Reply with quote

It was deleted from the overlay, it only contained the following according to the git history.

1 ~app-office/akonadi-server-1.3.1
2 ~dev-libs/soprano-2.4.3
3 media-sound/phonon

You probably don't need it in your world file if you have higher up kde pieces installed.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 23, 24, 25 ... 36, 37, 38  Next
Page 24 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum