Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
genkernel not working out-of-the-box on ppc and ppc64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Atha
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 168

PostPosted: Tue Jun 30, 2009 7:17 pm    Post subject: genkernel not working out-of-the-box on ppc and ppc64 Reply with quote

Hi!

Is it just me or are there others who have trouble with genkernel on PowerPC?
I used sys-kernel/genkernel on my x86 (an IBM ThinkPad R51, 2003) with no problems at all.

On my Apple Power Mac G4 MDD 1GHz Dual I had the problem that genkernel would abort with an error message, that it couldn't find the config file. I used --oldconfig, so there shouldn't be a problem (at least it works on x86).

The workaround: I have to set the variables [tt]CMD_KERNEL_CONFIG[/tt] and [tt]GK_SHARE[/tt] and it works.
Code:
CMD_KERNEL_CONFIG=/usr/src/linux/.config GK_SHARE=/usr/share/genkernel /usr/bin/genkernel --no-clean --no-mrproper --postclear --no-splash --no-ramdisk-modules --disklabel --tempdir=/var/tmp/portage --install all



I now have the same problem on my new Apple Power Mac G5 DC 1.0GHz (Late 2005, PCIe).

First I thought it was only the G4. Since I now set up a Gentoo Linux from scratch (stage3 with re-bootstraping --> stage1-like) I have to assume that this is a bug in genkernel.

Can anyone confirm this or did I miss something here?

Thanks. A.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum