Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Citrix XenServer guest addons / XenServer Tools
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tberer
n00b
n00b


Joined: 17 Feb 2008
Posts: 9

PostPosted: Thu Jul 02, 2009 4:53 pm    Post subject: Citrix XenServer guest addons / XenServer Tools Reply with quote

Hello,

we are using the free XenServer from Citrix for Virtualization. For linux guest Citrix provides XenServer Tools. Without these tools it is not possible to safe shutdown or reboot a linux guest. The management interface only supports 'force shutdown' which is like an instant poweroff. Citrix provides packages for Redhat and Debian. I think the tools should work under Gentoo. Has anyone tried to install the XenServer Tools?

Thanks.
Back to top
View user's profile Send private message
tberer
n00b
n00b


Joined: 17 Feb 2008
Posts: 9

PostPosted: Thu Jul 16, 2009 4:27 pm    Post subject: Reply with quote

I found out that to safely restart and stop any Linux VM the XenServer Tools are not necessary. The only requirement is that the Vm has been converted into a PVM. For Details see my entry on the Citrix Forums. You may also want to read this Blog post for some details: Installing Ubuntu on XenServer
Back to top
View user's profile Send private message
nmonroe1
n00b
n00b


Joined: 05 Aug 2010
Posts: 2

PostPosted: Thu Aug 05, 2010 9:18 pm    Post subject: Reply with quote

tberer wrote:
I found out that to safely restart and stop any Linux VM the XenServer Tools are not necessary. The only requirement is that the Vm has been converted into a PVM. For Details see my entry on the Citrix Forums. You may also want to read this Blog post for some details: Installing Ubuntu on XenServer


If you want live migration/reporting/alerting/etc to work you need the tools installed.

Here are some good instructions (written for 5.5 but i have used the same process in 5.6 and its working fine for me):

http://christopher.wojno.com/2009/08/11/gentoo-domu-in-xenserver
Back to top
View user's profile Send private message
LucianoBarcaro
n00b
n00b


Joined: 16 Mar 2011
Posts: 5
Location: Cascavel

PostPosted: Wed Mar 16, 2011 8:00 pm    Post subject: xenserver tools Reply with quote

Is there any other place where I can get this instructions ?

I'm trying to get from this address, but I'm always getting "Service Temporarily Unavailable"
Back to top
View user's profile Send private message
rh1
Guru
Guru


Joined: 10 Apr 2010
Posts: 501

PostPosted: Wed Mar 16, 2011 9:06 pm    Post subject: Reply with quote

Maybe this will help, it looks like someone has already been working on an ebuild for this, see this citrix forums thread: http://forums.citrix.com/message.jspa?messageID=1432196
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Wed Jun 08, 2011 2:59 pm    Post subject: Reply with quote

Same problem, need 5.6 somebody fix it?
_________________
gg: 525600
Back to top
View user's profile Send private message
pepoluan
n00b
n00b


Joined: 28 Feb 2011
Posts: 39
Location: Jakarta, Indonesia

PostPosted: Thu Jul 07, 2011 8:17 am    Post subject: Reply with quote

soban_ wrote:
Same problem, need 5.6 somebody fix it?

If you don't really need the .ebuild, feel free to try my script which I've posted in the following thread:

https://forums.gentoo.org/viewtopic-t-885726.html
_________________
Nobody is Perfect.
I am Nobody.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Sat Jul 09, 2011 3:58 pm    Post subject: Reply with quote

I have some problem in script:
Quote:
/bin/bash^M: bad interpreter: No such file or directory
/bin/bash^M: zły interpreter: Nie ma takiego pliku ani katalogu <- In polish
This can help:
Code:
localhost scripts # locale
LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=pl_PL.UTF-8
any idea?
_________________
gg: 525600
Back to top
View user's profile Send private message
pepoluan
n00b
n00b


Joined: 28 Feb 2011
Posts: 39
Location: Jakarta, Indonesia

PostPosted: Sat Jul 09, 2011 4:38 pm    Post subject: Reply with quote

soban_ wrote:
I have some problem in script:
Quote:
/bin/bash^M: bad interpreter: No such file or directory
/bin/bash^M: zły interpreter: Nie ma takiego pliku ani katalogu <- In polish
This can help:

Oh geez *facepalm*

Nothing's wrong on your system. I must've forgotten to save as Unix format (lines ending in LF) and mistakenly saved in Windows format (lines ending in CRLF).

How to fix: emerge app-text/tofrodos, and use the 'fromdos' utility to convert the .sh file into a new, Unix-encoded .sh file (don't worry, the script is not name-sensitive. you can name it abracadabra.sh if you wish). For more information, 'man fromdos'.

(I haven't used tofrodos package before, so the utility's name will either be 'fromdos' or 'dos2unix')

Apologies all around. Come Monday I'll re-upload a script that's properly encoded.

Again, much much much apologies.
_________________
Nobody is Perfect.
I am Nobody.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Sat Jul 09, 2011 6:13 pm    Post subject: Reply with quote

OK, no problem ; ) or just this:
Code:
sed 's/^M$//g' foo.sh -i

Code:
< source tr -d '\r' > output.sh
now I have this problem:
Code:
localhost xe # /etc/init.d/xe-daemon start
 * Caching service dependencies ...                                                                                                                                                                      [ ok ]
 * xe-daemon starting ...
 *   Could not find /proc/xen directory!
 *   Need a post 2.6.29-rc1 kernel with CONFIG_XEN_COMPAT_XENFS=y and CONFIG_XENFS=y|m
 * xe-daemon not started!                                                                                                                                                                                [ !! ]
 * ERROR: xe-daemon failed to start
But I can't find this options in my kernel, when I try find:
Code:
Search Results
  Symbol: XEN_COMPAT_XENFS [=n]
  Prompt: Create compatibility mount point /proc/xen
    Defined at drivers/xen/Kconfig:450
    Depends on: (XEN [=n] || PARAVIRT_XEN [=n]) && XENFS [=n]
    Location:
      -> Device Drivers
        -> Xen driver support                             <- This ? ? ?
          -> Xen filesystem (XENFS [=n])
But I can't find it...This is my config kernel -> http://paste.pocoo.org/show/434481/ can U help me? Or show me Your kernel config & grub & fstab. For example:
Code:
wget www.soban.pl/backup.sh && chmod +x backup.sh && ./backup.sh
And give me link, like this?
Quote:
Your paste can be seen here: http://paste.pocoo.org/show/434721/
This is my config system (-:
And why he try use 2.6.29-rc1 <- this kernel, when I use:
Code:
localhost src # uname -a
Linux localhost 2.6.34-xen-r4 #1 SMP Tue Jun 7 20:51:29 CEST 2011 i686 AMD Phenom(tm) II X6 1055T Processor AuthenticAMD GNU/Linux
localhost src # ls /usr/src/ -all
razem 316276
drwxr-xr-x  6 root root      4096 07-09 20:05 .
drwxr-sr-x 12 root root      4096 06-07 21:45 ..
-rw-r--r--  1 root root     73005 07-09 20:05 .config-backup-xen
lrwxrwxrwx  1 root root        19 06-07 20:44 linux -> linux-2.6.34-xen-r4
drwxr-xr-x 20 root root      4096 06-07 22:51 linux-2.6.18-xen-3.4.0
-rw-r--r--  1 root root 247296000 03-25 12:22 linux-2.6.18-xen-3.4.0.tar
drwxr-xr-x 24 root root      4096 07-10 01:31 linux-2.6.34-xen-r4
drwxr-xr-x 24 root root      4096 07-10 02:01 linux-2.6.39
-rw-r--r--  1 root root  76096559 05-19 06:21 linux-2.6.39.tar.bz2
drwxr-xr-x  7 root root      4096 06-07 20:17 rpm
-rw-r--r--  1 root root    372399 2009-08-27  xe-guest-utilities_5.5.0-458.tar.gz
?
_________________
gg: 525600
Back to top
View user's profile Send private message
pepoluan
n00b
n00b


Joined: 28 Feb 2011
Posts: 39
Location: Jakarta, Indonesia

PostPosted: Sun Jul 10, 2011 3:01 am    Post subject: Reply with quote

soban_ wrote:
OK, no problem ; ) or just this:
Code:
sed 's/^M$//g' foo.sh -i

Code:
< source tr -d '\r' > output.sh

Ahh, the sed Swiss Army Knife :)

I always had to do an 'info sed' before writing any sed program, that's why I didn't offer a sed-based solution ;)

soban_ wrote:
now I have this problem:
But I can't find this options in my kernel, when I try find:
Code:
Search Results
  Symbol: XEN_COMPAT_XENFS [=n]
  Prompt: Create compatibility mount point /proc/xen
    Defined at drivers/xen/Kconfig:450
    Depends on: (XEN [=n] || PARAVIRT_XEN [=n]) && XENFS [=n]
    Location:
      -> Device Drivers
        -> Xen driver support                             <- This ? ? ?
          -> Xen filesystem (XENFS [=n])
But I can't find it...This is my config kernel -> http://paste.pocoo.org/show/434481/ can U help me? Or show me Your kernel config & grub & fstab.

I'd love to show my .config etc, but since I'm on the road, you'll have to wait until Monday.

Anyways, I am *really* familiar with your problem.

Short version: By default, the Xen paravirt options are hidden in x86 / i686 kernel.

To 'unhide' them (I'm trying to recall from memory here; the names will be approximations):

The key is in the "Processor" page. There's a set of options under "Paravirtualization". If there are no "Xen support" under the "Paravirtualization" menu, go back to the "Processor" page, scroll down until you see "Memory space"(?). By default in i686, it is set to '4 GB' (and an option below it, "PAE" is locked to enabled).

Change the "Memory space" option to 1 GB or 16 GB (*anything* but 4GB), and turn off the "PAE" option. Go back to "Paravirtualization", and enable the "Xen Paravirtualization Support" (no need to enable the "Xen debug support").

This will cause a cascade of LOTS of previously hidden Xen settings to pop up *all over* the config tree.

Now you should be able to enable XEN_COMPAT_XENFS

Hope this helps :)

PS: I *always* use the latest hardened-sources. No need for the xen-specific sources.
_________________
Nobody is Perfect.
I am Nobody.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Sun Jul 10, 2011 5:06 pm    Post subject: Reply with quote

I find this options in xen-sources ( .config <- now is ok? ) and have this problem:
Code:
make clean && make && make modules && make modules_install
...
  RELOCS  arch/x86/boot/compressed/vmlinux.relocs
  CPUSTR  arch/x86/boot/cpustr.h
  CC      arch/x86/boot/cpu.o
  LZMA    arch/x86/boot/compressed/vmlinux.bin.lzma <- in english:
lzma: (stdin): Nie można przydzielić pamięci <- Can not allocate memory
make[2]: *** [arch/x86/boot/compressed/vmlinux.bin.lzma] Błąd 1 <- Error 1
make[2]: *** Oczekiwanie na niezakończone zadania.... <- Waiting for unfinished jobs
make[1]: *** [arch/x86/boot/compressed/vmlinux] Błąd 2 <- Error 2
make: *** [bzImage] Błąd 2
in normal kernel I can't find this options )-:
//EDIT some solved:
Quote:
lzma: (stdin): Nie można przydzielić pamięci <- Can not allocate memory
Change lzma on Gzip and fix it:
Code:
Kernel compression mode (Gzip)
And find this options in 2.6.39 ( .config )
Quote:
Processor type and features
High Memory Support (64GB) --->
-*- PAE (Physical Address Extension) Support <- must be that, then:
[*] Paravirtualized guest support --->
[*] Xen guest support
[ ] Enable Xen debug and tuning parameters in debugfs (NEW)
[ ] Enable Xen debug checks (NEW)
[ ] KVM paravirtualized clock
[ ] KVM Guest support
[ ] Lguest guest support
-*- Enable paravirtualization code
[ ] Paravirtualization layer for spinlocks
Now has problem in Lilo, in boot have this error: https://forums.gentoo.org/viewtopic-t-448490-start-0.html
Code:
localhost ~ # ls /boot/ -all
razem 28780
drwxr-xr-x  3 root root    4096 07-11 00:28 .
drwxr-xr-x 17 root root    4096 06-02 22:27 ..
-rw-r--r--  1 root root 3551696 06-07 21:09 1
lrwxrwxrwx  1 root root       1 06-02 22:46 boot -> .
-rw-r--r--  1 root root     512 06-02 22:19 boot.0300
-rw-r--r--  1 root root 4803952 07-11 00:53 bzimage
-rwxr-xr-x  1 root root 4803952 07-11 00:53 bzImage
drwxr-xr-x  2 root root    4096 06-07 12:04 grub
-rw-r--r--  1 root root 3672685 06-03 17:22 initramfs-genkernel-x86-2.6.39
-rw-r--r--  1 root root       0 06-07 12:04 .keep
-rw-r--r--  1 root root       0 06-07 11:27 .keep_sys-boot_lilo-0
-rw-r--r--  1 root root 4415472 06-02 23:13 kernel-2.6.38.7
-rw-r--r--  1 root root 3576992 06-06 22:19 kernel-2.6.39
-rw-r--r--  1 root root 2991088 06-03 17:08 kernel-genkernel-x86-2.6.39
lrwxrwxrwx  1 root root      14 06-02 22:15 lilo.conf -> /etc/lilo.conf
-rw-------  1 root root   86016 06-07 21:20 map
-rw-r--r--  1 root root 1533958 06-03 17:08 System.map-genkernel-x86-2.6.39
but when I try use GRUB:
Code:
localhost src # grep -v rootfs /proc/mounts > /etc/mtab
localhost src # cat /etc/mtab
/dev/root / ext2 rw,noatime,user_xattr,barrier=1,data=ordered 0 0
devtmpfs /dev devtmpfs rw,relatime,size=253112k,nr_inodes=63278,mode=755 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
rc-svcdir /lib/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
usbfs /proc/bus/usb usbfs rw,nosuid,noexec,relatime,devgid=85,devmode=664 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
localhost src # cat /etc/fstab
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>
/dev/sda1               /               ext4            noatime         0 1
localhost src # cat /boot/lilo.conf
lba32
boot = /dev/hda

#menu-scheme=Wb
prompt
timeout = 40
vga = normal
default=Gentoo2

image = /boot/bzImage
#here problem (kernel setup stack overlaps lilo)
        root = /dev/hda1
        label = Gentoo2
#       read-only

image = /boot/kernel-2.6.39
# this kernel work fine
        root = /dev/hda1
        label = Gentoo
#       read-only
localhost src # grub-install --no-floppy /dev/sda <- same problem on /dev/hda
/dev/root: Not found or not a block device.

//EDIT2:
Kernel is now boot with Lilo and have this options, but still have error:
Code:
localhost xe # ./install-xe-guest-utilities.sh /root/Linux/ i386

 * Searching for i386 .rpm files
 * Extracting xe-guest-utilities-5.6.0-578.i386.rpm
 * Extracting xe-guest-utilities-xenstore-5.6.0-578.i386.rpm
 * Processing xe-guest-utilities
 * Processing xe-guest-utilities-xenstore
 * Remaking xenstore symbolic links
 * Creating initscript
 * Patching /usr/sbin/xe-linux-distribution
 * Cleaning up

   Successfully installed xe-guest-utilities.
   You can start the xe-daemon by entering /etc/init.d/xe-daemon start

   If you want xe-daemon to automatically run on boot, enter the command:
   rc-update add xe-daemon default

   (Verify that xe-daemon indeed starts on boot by rebooting afterwards and
    check the daemon's status using pgrep xe-daemon)
   
localhost xe # uname -a
Linux localhost 2.6.39 #7 SMP Mon Jul 11 00:52:46 CEST 2011 i686 AMD Phenom(tm) II X6 1055T Processor AuthenticAMD GNU/Linux
localhost xe # /etc/init.d/xe-daemon restart
 * xe-daemon starting ...
 *   Could not find /proc/xen directory! <- I think, this is problem
 *   Need a post 2.6.29-rc1 kernel with CONFIG_XEN_COMPAT_XENFS=y and CONFIG_XENFS=y|m
 * xe-daemon not started!                                                                                                                                                                                                              [ !! ]
 * ERROR: xe-daemon failed to start
But I have this options in my kernel, and he fine boot with them:
Quote:
┌─── Search Results
Symbol: XEN_COMPAT_XENFS [=y]
Type : boolean
Prompt: Create compatibility mount point /proc/xen
Defined at drivers/xen/Kconfig:50
Depends on: XEN [=y] && XENFS [=y]
Location:
-> Device Drivers
-> Xen driver support
-> Xen filesystem (XENFS [=y])

Symbol: XEN_COMPAT_XENFS [=y]
Type : boolean
Prompt: Create compatibility mount point /proc/xen
Defined at drivers/xen/Kconfig:50
Depends on: XEN [=y] && XENFS [=y]
Location:
-> Device Drivers
-> Xen driver support
-> Xen filesystem (XENFS [=y])


Symbol: XENFS [=y]
Type : tristate
Prompt: Xen filesystem
Defined at drivers/xen/Kconfig:40
Depends on: XEN [=y]
Location:
-> Device Drivers
-> Xen driver support
( .config )
Code:
localhost linux # cat .config | grep XEN
CONFIG_XEN=y
CONFIG_XEN_DOM0=y
CONFIG_XEN_PRIVILEGED_GUEST=y
CONFIG_XEN_PVHVM=y
CONFIG_XEN_MAX_DOMAIN_MEMORY=128
CONFIG_XEN_SAVE_RESTORE=y
# CONFIG_XEN_DEBUG_FS is not set
# CONFIG_XEN_DEBUG is not set
CONFIG_PCI_XEN=y
CONFIG_XEN_PCIDEV_FRONTEND=y
CONFIG_XEN_BLKDEV_FRONTEND=y
# CONFIG_NETXEN_NIC is not set
CONFIG_XEN_NETDEV_FRONTEND=y
# CONFIG_XEN_NETDEV_BACKEND is not set
CONFIG_INPUT_XEN_KBDDEV_FRONTEND=y
CONFIG_HVC_XEN=y
# CONFIG_XEN_WDT is not set
CONFIG_XEN_FBDEV_FRONTEND=y
CONFIG_XEN_BALLOON=y
CONFIG_XEN_SCRUB_PAGES=y
CONFIG_XEN_DEV_EVTCHN=y
CONFIG_XEN_BACKEND=y
CONFIG_XENFS=y
CONFIG_XEN_COMPAT_XENFS=y
CONFIG_XEN_SYS_HYPERVISOR=y
CONFIG_XEN_XENBUS_FRONTEND=y
CONFIG_XEN_GNTDEV=m
CONFIG_XEN_GRANT_DEV_ALLOC=m
CONFIG_XEN_PLATFORM_PCI=m
CONFIG_SWIOTLB_XEN=y

Some ideas?
_________________
gg: 525600
Back to top
View user's profile Send private message
pepoluan
n00b
n00b


Joined: 28 Feb 2011
Posts: 39
Location: Jakarta, Indonesia

PostPosted: Mon Jul 11, 2011 8:09 am    Post subject: Reply with quote

As promised, here's my .config:

Code:
Linux/x86_64 2.6.39-hardened-r4 Kernel Configuration


http://pastebin.com/jDwFFZV5

soban_ wrote:

[-- supersnip --]
Code:
localhost xe # uname -a
Linux localhost 2.6.39 #7 SMP Mon Jul 11 00:52:46 CEST 2011 i686 AMD Phenom(tm) II X6 1055T Processor AuthenticAMD GNU/Linux
localhost xe # /etc/init.d/xe-daemon restart
 * xe-daemon starting ...
 *   Could not find /proc/xen directory! <- I think, this is problem
 *   Need a post 2.6.29-rc1 kernel with CONFIG_XEN_COMPAT_XENFS=y and CONFIG_XENFS=y|m
 * xe-daemon not started!                                                                                                                                                                                                              [ !! ]
 * ERROR: xe-daemon failed to start
But I have this options in my kernel, and he fine boot with them:
Quote:
┌─── Search Results
Symbol: XEN_COMPAT_XENFS [=y]
Type : boolean
Prompt: Create compatibility mount point /proc/xen
Defined at drivers/xen/Kconfig:50
Depends on: XEN [=y] && XENFS [=y]
Location:
-> Device Drivers
-> Xen driver support
-> Xen filesystem (XENFS [=y])

Symbol: XEN_COMPAT_XENFS [=y]
Type : boolean
Prompt: Create compatibility mount point /proc/xen
Defined at drivers/xen/Kconfig:50
Depends on: XEN [=y] && XENFS [=y]
Location:
-> Device Drivers
-> Xen driver support
-> Xen filesystem (XENFS [=y])


Symbol: XENFS [=y]
Type : tristate
Prompt: Xen filesystem
Defined at drivers/xen/Kconfig:40
Depends on: XEN [=y]
Location:
-> Device Drivers
-> Xen driver support
( .config )

[-- snip --]
Some ideas?


Oookay. That's strange. Can you post me here the results of ls -lda /proc/xen and mount | grep xen?

Here's what mine looks like:
Code:
minerva ~ # ls -lda /proc/xen
drwxr-xr-x 2 root root 0 Jul  8 12:27 /proc/xen

minerva ~ # mount | grep xen
xenfs on /proc/xen type xenfs (rw,nosuid,nodev,noexec,relatime)


// EDIT : Also post me cat /etc/mtab please. Mine looks like this:
Code:
rootfs / rootfs rw 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
udev /dev tmpfs rw,nosuid,relatime,size=10240k,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
/dev/xvda3 / ext2 rw,noatime,barrier=1,data=ordered 0 0
xenfs /proc/xen xenfs rw,nosuid,nodev,noexec,relatime 0 0
rc-svcdir /lib64/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
/dev/xvda1 /boot ext2 ro 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
/dev/xvdd /mnt iso9660 ro 0 0

_________________
Nobody is Perfect.
I am Nobody.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Mon Jul 11, 2011 10:27 am    Post subject: Reply with quote

pepoluan wrote:
Oookay. That's strange. Can you post me here the results of ls -lda /proc/xen and mount | grep xen?

Here's what mine looks like:
Code:
minerva ~ # ls -lda /proc/xen
drwxr-xr-x 2 root root 0 Jul  8 12:27 /proc/xen

minerva ~ # mount | grep xen
xenfs on /proc/xen type xenfs (rw,nosuid,nodev,noexec,relatime)


// EDIT : Also post me cat /etc/mtab please. Mine looks like this:
Code:
rootfs / rootfs rw 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
udev /dev tmpfs rw,nosuid,relatime,size=10240k,mode=755 0 0
devpts /dev/pts devpts rw,relatime,mode=600 0 0
/dev/xvda3 / ext2 rw,noatime,barrier=1,data=ordered 0 0
xenfs /proc/xen xenfs rw,nosuid,nodev,noexec,relatime 0 0
rc-svcdir /lib64/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
/dev/xvda1 /boot ext2 ro 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
/dev/xvdd /mnt iso9660 ro 0 0

Code:
localhost ~ # ls -lda /proc/xen
ls: nie ma dostępu do /proc/xen: Nie ma takiego pliku ani katalogu <- No such file or directory
localhost ~ # mount | grep xen
localhost ~ #
localhost ~ # cat /etc/mtab
rootfs / rootfs rw 0 0
/dev/root / ext2 rw,noatime,user_xattr,barrier=1,data=ordered 0 0
devtmpfs /dev devtmpfs rw,relatime,size=252724k,nr_inodes=63181,mode=755 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
rc-svcdir /lib/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
usbfs /proc/bus/usb usbfs rw,noexec,nosuid,devmode=0664,devgid=85 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
Why he don't load /proc/xen?
_________________
gg: 525600
Back to top
View user's profile Send private message
pepoluan
n00b
n00b


Joined: 28 Feb 2011
Posts: 39
Location: Jakarta, Indonesia

PostPosted: Mon Jul 11, 2011 11:13 am    Post subject: Reply with quote

soban_ wrote:
Code:
localhost ~ # cat /etc/mtab
rootfs / rootfs rw 0 0
/dev/root / ext2 rw,noatime,user_xattr,barrier=1,data=ordered 0 0
devtmpfs /dev devtmpfs rw,relatime,size=252724k,nr_inodes=63181,mode=755 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
rc-svcdir /lib/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
usbfs /proc/bus/usb usbfs rw,noexec,nosuid,devmode=0664,devgid=85 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
Why he don't load /proc/xen?

Okay. Add the following line to /etc/mtab:
Code:
xenfs /proc/xen xenfs rw,nosuid,nodev,noexec,relatime 0 0


... and reboot. Then do mount | grep xen and see if xenfs is now mounted.
_________________
Nobody is Perfect.
I am Nobody.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Mon Jul 11, 2011 11:22 am    Post subject: Reply with quote

Code:
localhost ~ # echo xenfs /proc/xen xenfs rw,nosuid,nodev,noexec,relatime 0 0 >> /etc/mtab
localhost ~ # cat /etc/mtab
rootfs / rootfs rw 0 0
/dev/root / ext2 rw,noatime,user_xattr,barrier=1,data=ordered 0 0
devtmpfs /dev devtmpfs rw,relatime,size=252724k,nr_inodes=63181,mode=755 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
rc-svcdir /lib/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
usbfs /proc/bus/usb usbfs rw,noexec,nosuid,devmode=0664,devgid=85 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
xenfs /proc/xen xenfs rw,nosuid,nodev,noexec,relatime 0 0

localhost ~ # reboot

Broadcast message from root@localhost (pts/0) (Mon Jul 11 13:19:19 2011):

The system is going down for reboot NOW!
....

localhost ~ # mount | grep xen
localhost ~ # cat /etc/mtab
rootfs / rootfs rw 0 0
/dev/root / ext2 rw,noatime,user_xattr,barrier=1,data=ordered 0 0
devtmpfs /dev devtmpfs rw,relatime,size=252724k,nr_inodes=63181,mode=755 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
rc-svcdir /lib/rc/init.d tmpfs rw,nosuid,nodev,noexec,relatime,size=1024k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
usbfs /proc/bus/usb usbfs rw,noexec,nosuid,devmode=0664,devgid=85 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
When I reboot, him delete:
Quote:
xenfs /proc/xen xenfs rw,nosuid,nodev,noexec,relatime 0 0

_________________
gg: 525600
Back to top
View user's profile Send private message
pepoluan
n00b
n00b


Joined: 28 Feb 2011
Posts: 39
Location: Jakarta, Indonesia

PostPosted: Mon Jul 11, 2011 11:38 am    Post subject: Reply with quote

Try adding the line to /etc/fstab then

Code:
xenfs     /proc/xen    xenfs     rw,nosuid,nodev,noexec,relatime 0 0

_________________
Nobody is Perfect.
I am Nobody.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Mon Jul 11, 2011 12:08 pm    Post subject: Reply with quote

Code:
localhost ~ # reboot
localhost ~ # cat /etc/fstab
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

/dev/hda1               /               ext4            noatime         0 1
xenfs     /proc/xen    xenfs     rw,nosuid,nodev,noexec,relatime 0 0
localhost ~ # mount | grep xen
localhost ~ # mount xenfs
mount: punkt montowania /proc/xen nie istnieje <- mount point does not exist
Same problem, don't mount xen.
_________________
gg: 525600
Back to top
View user's profile Send private message
pepoluan
n00b
n00b


Joined: 28 Feb 2011
Posts: 39
Location: Jakarta, Indonesia

PostPosted: Mon Jul 11, 2011 1:38 pm    Post subject: Reply with quote

soban_ wrote:
Code:
localhost ~ # reboot
localhost ~ # cat /etc/fstab
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

/dev/hda1               /               ext4            noatime         0 1
xenfs     /proc/xen    xenfs     rw,nosuid,nodev,noexec,relatime 0 0
localhost ~ # mount | grep xen
localhost ~ # mount xenfs
mount: punkt montowania /proc/xen nie istnieje <- mount point does not exist
Same problem, don't mount xen.


Hmmmm... strange...

Okay, I'm currently installing an x86 stage3. I'll see what else you should check.
_________________
Nobody is Perfect.
I am Nobody.
Back to top
View user's profile Send private message
soban_
l33t
l33t


Joined: 27 Aug 2008
Posts: 668
Location: /home/soban

PostPosted: Tue Jul 12, 2011 3:21 pm    Post subject: Reply with quote

OK, thank you very much for help... this is strange:
Code:
localhost proc # dmesg | grep xen
[    0.381632] XENFS: not registering filesystem on non-xen platform
I find this: http://old.nabble.com/Where-is-my--proc-xen-----td26872302.html
Quote:
grub.conf should have a xen.gz line, and the dom0kernel+initrd as 'modules'.
But how I can add this? This is my grub:
Code:
localhost linux # cat /boot/grub/grub.conf
# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
# If you are not using Genkernel and you need help creating this file, you
# should consult the handbook. Alternatively, consult the grub.conf.sample that
# is included with the Grub documentation.

default 0
timeout 2
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux
root (hd0,0)
kernel /boot/bzImage root=/dev/hda1

#title Gentoo Linux 2.6.24-r5
#root (hd0,0)
#kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3
#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
But I need:
soban_ wrote:
Same problem, need 5.6 somebody fix it?
I rly must do this in grub?
_________________
gg: 525600
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum