Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[wifi] se connecter à un hotspot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 366
Location: LENS

PostPosted: Tue Jul 14, 2009 12:55 pm    Post subject: [wifi] se connecter à un hotspot Reply with quote

Savez-vous comment on se connecte à un hotspot.

Se qu'il se passe avec windows c'est que une fois connecté à un hotspot (par exemple chez NeufWifi), on ouvre le navigateur internet et automatiquement apparait la page web permettant de se faire accepter par le hotspot.

Le problème avec gento est que le navigateur n'ouvre pas cette page web impossible donc de surfer.

Qu'est-ce qu'il doit manquer?
_________________
Gentoo rocks
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Jul 14, 2009 1:32 pm    Post subject: Reply with quote

Salut,

je suppose que c'est une histoire de nameserver dans /etc/resolv.conf. Je pense que tant que t'es pas authentifié, les résolutions DNS pointent toutes vers la page d'identification. Mais si t'as un serveur DNS autre que le hotspot dans ton fichier resolv, tu ne sera pas automatiquement redirigé vers cette page.

Vérifie que ton serveur DNS est bien le hotspot.

PS : Ceci n'est qu'une supposition, j'ai pas de hotspot sous la main pour tester...

EDIT : Bon je viens de tester avec un HotSpot de l'université, je suis redirigé vers la page d'identification mais à priori c'est pas une histoire de DNS.
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 366
Location: LENS

PostPosted: Tue Jul 14, 2009 1:57 pm    Post subject: Reply with quote

Alors j'ai fait un essai : sous windows, j'ai copié l'adresse web sur une clé USB.
Je reboot sur Gentoo et j'ouvre le navigateur avec la même adresse. La page s'affiche, je clique sur se connecter.
J'ai une page blanche avec le sablier qui ne se termine jamais.

Je me demande si ça ne vient pas du cryptage?
Je vais donner le .config de mon kernel.
_________________
Gentoo rocks
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Jul 14, 2009 2:01 pm    Post subject: Reply with quote

mh, je ne pense pas que ça soit une histoire de crypto. L'ideal serait de capturer le trafic réseau entre ton PC et le Hotspot pour voir ce qui se passe.

T'as essayé avec différents navigateurs ? Pas de Javascript de bloqué ?
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum