Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kompozer fails wysiwyg editor needed. [SOLVED EXTERNALLY]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ilovebeer
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2008
Posts: 87

PostPosted: Tue Jul 14, 2009 11:55 pm    Post subject: kompozer fails wysiwyg editor needed. [SOLVED EXTERNALLY] Reply with quote

hello, i've recently been looking for a wysiwyg editor. i added kompozer to portage overlay.
when i emerge i get this error.

Code:
configure: error: --enable-application=APP is required
*** Fix above errors and then restart with "make -f client.mk build"


there is one similiar occurrence here on gentoo but the resolution doesn't apply here. does anyone know at all what it means?
regards, ilb


Last edited by ilovebeer on Thu Jul 16, 2009 2:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
FranZ
Apprentice
Apprentice


Joined: 15 Feb 2004
Posts: 212
Location: Enschede, Holland

PostPosted: Wed Jul 15, 2009 6:12 am    Post subject: Reply with quote

The build is failing during the configure step because a necessary parameter isn't there.

Add --enable-application=APP to the configure arguments in the ebuild.
_________________
Horse sense is the thing that keeps horses from betting on people. --W.C. Fields

Ask Smart Questions
Back to top
View user's profile Send private message
ilovebeer
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2008
Posts: 87

PostPosted: Wed Jul 15, 2009 6:39 am    Post subject: Reply with quote

hello, to my amazement i actually did that but it didn't work. i am guessing i put the needed parameters in the wrong place. just need to find the right place. thanks for the tip. :-)
Back to top
View user's profile Send private message
ilovebeer
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2008
Posts: 87

PostPosted: Wed Jul 15, 2009 7:50 am    Post subject: Reply with quote

hello, after studying the gentoo ebuild wiki my limitations are painfully evident. i just don't understand! could some kind soul tell me where i'd put the --enable-application=APP please.
here is the ebuild;
Code:
inherit eutils mozconfig flag-o-matic multilib

DESCRIPTION="A web authoring system combining web file management and WYSIWYG editing"
HOMEPAGE="http://kompozer.net/"

MY_P=${P/_alpha/a}

SRC_URI="http://downloads.sourceforge.net/kompozer/${MY_P}-src.tar.bz2"

LICENSE="GPL-2"
SLOT="0"

KEYWORDS="x86 amd64"
IUSE=""
DEPEND="x11-proto/printproto
        sys-apps/gawk
        dev-lang/perl
        >=media-libs/freetype-2.1.9-r1"

S=${WORKDIR}/mozilla

pkg_setup() {
   if ! built_with_use --missing true x11-libs/pango X; then
      eerror "Pango is not built with X useflag."
      eerror "Please add 'X' to your USE flags and re-emerge pango."
      die "Pango needs X"
   fi
}

src_unpack() {
        unpack ${A}
   cd ${S}
   cp ${FILESDIR}/mozconfig-${PVR} ./.mozconfig
}

src_compile() {
   make -f client.mk build_all || die "Make failed"
}

src_install() {
   #Dirty Bugfix by unregistr3d (ignore nsModules.o):
   cd xpfe/components/
   cp Makefile.in Makefile.in_backup
   cat Makefile.in_backup | grep -v build2 > Makefile.in
   cd ../..

   make -f client.mk DESTDIR=${D} install || die

   #menu entry for gnome/kde
   insinto /usr/share/applications
   sed -e "s:/usr/lib/kompozer:/usr/$(get_libdir)/kompozer:" \
               ${FILESDIR}/kompozer.desktop > ${T}/kompozer.desktop
   doins ${T}/kompozer.desktop

   # Remove useless file to avoid package-collision:
   rm ${D}/usr/share/aclocal/nspr.m4
}

pkg_postinst() {
   elog "This package has a very dirty bugfix!!! If you want to fill"
   elog "a Bugreport to the mainstream developers, at least be sure"
   elog "to refer to http://bugs.gentoo.org/show_bug.cgi?id=146761#c39 "
   elog "Thanks"
}
Back to top
View user's profile Send private message
jw5801
Apprentice
Apprentice


Joined: 12 Jun 2008
Posts: 251
Location: Melbourne, Australia

PostPosted: Wed Jul 15, 2009 8:28 am    Post subject: Reply with quote

Whereabouts did you get the ebuild from? The Gentoo bugzilla is usually a good place to look for ebuilds that haven't hit portage, and there's a bug there for kompozer already which is might be worth looking at.

https://bugs.gentoo.org/show_bug.cgi?id=146761
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Wed Jul 15, 2009 2:12 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
ilovebeer
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2008
Posts: 87

PostPosted: Thu Jul 16, 2009 12:39 am    Post subject: Reply with quote

hello, i got it here https://bugs.gentoo.org/146761 i got kompozer 7.10 to build okay but the wretched thing keeps crashing. sure is a shortage of non-kde non-gnome wysiwyg editors in linux land. must be a huge job maintaining them.
thanks


Last edited by ilovebeer on Thu Jul 16, 2009 2:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
ilovebeer
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2008
Posts: 87

PostPosted: Thu Jul 16, 2009 2:19 pm    Post subject: Reply with quote

hello, i installed sidux. then... "apt-get install kompozer" perfect install. no crashes and works with no apparent bugs. binaries are real easy sometimes.
ilb
Back to top
View user's profile Send private message
yaciboss
n00b
n00b


Joined: 05 Sep 2009
Posts: 4

PostPosted: Sat Sep 12, 2009 2:57 am    Post subject: Reply with quote

Did you put 'mozconfig-0.8_alpha4' in ...app-editors/kompozer/files/??
I had the same problem and that fixed it...
Hope It help
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum