Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Abaqus 6.8-2 "Segmentation fault"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Alkin
n00b
n00b


Joined: 01 Oct 2006
Posts: 21
Location: Bulgaria

PostPosted: Sun Aug 02, 2009 9:08 pm    Post subject: Abaqus 6.8-2 "Segmentation fault" Reply with quote

Hello Gentoo community,

I am trying to run Abaqus CAE on Gentoo machine
Code:
uname -a
Linux * 2.6.29-gentoo-r5 #4 * 2009 i686 Intel(R) Pentium(R) 4 CPU 1500MHz GenuineIntel GNU/Linux

without any success so far. The sysinfo file provided by Abaqus gave me the following output:

Code:
***ERROR:  One or more system tests have failed the minimum installation
           requirements. The installation procedure will not continue.
           Hit <Enter> to view the output from this system check.

Checking for GNU Lib C version 2.3.2 or newer.
Pass - Found GNU Lib C Version 2.9.
Segmentation fault


The "Segmentation Fault" comes from the ./Python.exe while trying to load the shared library "libABQUTI_CoreUtils.so"

Code:
GNU gdb 6.8
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(gdb) run
Starting program: /opt/Abaqus/6.8-2/Python/Obj/Python.exe
[Thread debugging using libthread_db enabled]
[New Thread 0xb76c66c0 (LWP 22572)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb76c66c0 (LWP 22572)]
0xb7bca11d in omn_enableFPE () from /opt/Abaqus/6.8-2/exec/lbr/libABQUTI_CoreUtils.so
(gdb) where
#0  0xb7bca11d in omn_enableFPE () from /opt/Abaqus/6.8-2/exec/lbr/libABQUTI_CoreUtils.so
#1  0xb7bca404 in omni_initialize () from /opt/Abaqus/6.8-2/exec/lbr/libABQUTI_CoreUtils.so
#2  0xb7bca3d1 in UTI_CoreUtils_initialize () from /opt/Abaqus/6.8-2/exec/lbr/libABQUTI_CoreUtils.so
#3  0x080489e9 in PythonMain_initialize ()
#4  0x08048928 in main ()
(gdb)

I am able to get Abaqus installed with -nosyscheck option, but the "Segmentation Fault" error remains after the installation. For example "abaqus cae" which also depends on "libABQUTI_CoreUtils.so" returns "Segmentation Fault".
I think I have sorted out all library dependencies.

Code:
ldd ./libABQUTI_CoreUtils.so

        linux-gate.so.1 =>  (0xb801c000)
        librt.so.1 => /lib/librt.so.1 (0xb7f72000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7f6e000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7f56000)
        libsvml.so => /opt/Abaqus/6.8-2/External/libsvml.so (0xb7ef7000)
        libimf.so => /opt/Abaqus/6.8-2/External/libimf.so (0xb7cb8000)
        libm.so.6 => /lib/libm.so.6 (0xb7c92000)
        libgcc_s.so.1 => /usr/lib/gcc/i686-pc-linux-gnu/4.3.2/libgcc_s.so.1 (0xb7c84000)
        libcxaguard.so.5 => /opt/intel/cc/10.0.026/lib/libcxaguard.so.5 (0xb7c82000)
        libirc.so => /opt/Abaqus/6.8-2/External/libirc.so (0xb7c41000)
        libc.so.6 => /lib/libc.so.6 (0xb7afd000)
        /lib/ld-linux.so.2 (0xb801d000)


Code:
ldd ./abq682.exe
        not a dynamic executable


Does anybody has any experience running Abaqus on Gentoo?
I know that GNU/Linux version of Abaqus is not officially supported by SIMULA and Gentoo, but I am desperate of running Abaqus on Gentoo since it is my favorite distro.
Any thought regarding the solution of the problem will be appreciated.

King regards
_________________
It is not the strongest that survives, nor the most intelligent. It is the one that is the most adaptable to environmental changes.
Back to top
View user's profile Send private message
Alkin
n00b
n00b


Joined: 01 Oct 2006
Posts: 21
Location: Bulgaria

PostPosted: Wed Aug 05, 2009 12:22 am    Post subject: Update Reply with quote

New development.

I think it might be a hardware issue since Scientific Linux which is a source compilation of RHEL 5 (officially supported by SIMULA) gives me the same error. I think it is a threading issue since /proc/cpuinfo indicates that the processor is capable of hyper-threading, but I can't enable it. Actually I am wondering does it really capable of ht?

Quote:
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 0
model name : Intel(R) Pentium(R) 4 CPU 1500MHz
stepping : 7
cpu MHz : 1495.461
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pebs bts
bogomips : 2990.92
clflush size : 64
power management:

_________________
It is not the strongest that survives, nor the most intelligent. It is the one that is the most adaptable to environmental changes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum