Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[how-to] 3d hardware acc with ati open source driver.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 27, 28, 29  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Mon Jul 18, 2011 9:29 am    Post subject: Reply with quote

Are you guys running mplayer with external ffmpeg enabled? Because mkv files fail to play on mine with some ffmpeg related error, even after I did recompile ffmpeg with "vdpau" USE-flag
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Mon Jul 18, 2011 9:40 am    Post subject: Reply with quote

NForce wrote:
Are you guys running mplayer with external ffmpeg enabled? Because mkv files fail to play on mine with some ffmpeg related error, even after I did recompile ffmpeg with "vdpau" USE-flag

nope, try to run sintel and see if it fails
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Mon Jul 18, 2011 2:17 pm    Post subject: Reply with quote

It fails too. Here is the log:
Code:
/usr/bin/mplayer -noquiet -v -nofs -nomouseinput -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, -sub-fuzziness 1 -identify -slave -vo vdpau -ao alsa -nokeepaspect -framedrop -autosync 100 -mc 0 -dr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 29360587 -monitorpixelaspect 1 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/nforce/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp enca:ru:UTF-8 -subpos 100 -volume 100 -cache 10000 -osdlevel 0 -vf-add ass -vf-add screenshot -slices -channels 2 -af volnorm=1,scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 500 /mnt/Downloads/Movies/Sintel.2010.1080p.mkv

MPlayer SVN-r33094-4.5.2 (C) 2000-2011 MPlayer Team
CPU vendor name: GenuineIntel  max cpuid level: 11
CPU: Intel(R) Core(TM) i3 CPU       M 350  @ 2.27GHz (Family: 6, Model: 37, Stepping: 2)
extended cpuid-level: 8
extended cache-info: 16801856
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
Tests of OS support for SSE passed.
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2 SSSE3 CMOV
get_path('codecs.conf') -> '/home/nforce/.mplayer/codecs.conf'
Reading /home/nforce/.mplayer/codecs.conf: Can't open '/home/nforce/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
get_path('fonts') -> '/home/nforce/.mplayer/fonts'
Configuration: --cc=i686-pc-linux-gnu-gcc --host-cc=i686-pc-linux-gnu-gcc --prefix=/usr --bindir=/usr/bin --libdir=/usr/lib --confdir=/etc/mplayer --datadir=/usr/share/mplayer --mandir=/usr/share/man --disable-svga --disable-svgalib_helper --disable-ass-internal --disable-arts --disable-kai --enable-networking --enable-joystick --disable-nemesi --disable-libnut --disable-smb --disable-lirc --disable-lircc --disable-apple-ir --disable-cdparanoia --disable-dvdread-internal --disable-libdvdcss-internal --charset=UTF-8 --disable-tv-bsdbt848 --disable-ivtv --disable-pvr --disable-tv-v4l1 --enable-radio --enable-radio-capture --disable-musepack --disable-libmpeg2-internal --disable-librtmp --disable-libmpeg2 --disable-mpg123 --disable-xanim --disable-libopenjpeg --codecsdir=/opt/RealPlayer/codecs --enable-win32dll --disable-directfb --disable-caca --disable-mga --disable-xmga --disable-3dfx --disable-tdfxvid --disable-tdfxfb --disable-xvr100 --disable-esd --disable-nas --disable-pulse --disable-gui --disable-dxr3 --disable-ggi --enable-menu --disable-vesa --enable-xvmc --with-xvmclib=XvMCW
CommandLine: '-noquiet' '-v' '-nofs' '-nomouseinput' '-vc' 'ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,' '-sub-fuzziness' '1' '-identify' '-slave' '-vo' 'vdpau' '-ao' 'alsa' '-nokeepaspect' '-framedrop' '-autosync' '100' '-mc' '0' '-dr' '-double' '-input' 'nodefault-bindings:conf=/dev/null' '-stop-xscreensaver' '-wid' '29360587' '-monitorpixelaspect' '1' '-ass' '-embeddedfonts' '-ass-line-spacing' '0' '-ass-font-scale' '1' '-ass-styles' '/home/nforce/.config/smplayer/styles.ass' '-fontconfig' '-font' 'Arial' '-subfont-autoscale' '0' '-subfont-osd-scale' '20' '-subfont-text-scale' '20' '-subcp' 'enca:ru:UTF-8' '-subpos' '100' '-volume' '100' '-cache' '10000' '-osdlevel' '0' '-vf-add' 'ass' '-vf-add' 'screenshot' '-slices' '-channels' '2' '-af' 'volnorm=1,scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0' '-softvol' '-softvol-max' '500' '/mnt/Downloads/Movies/Sintel.2010.1080p.mkv'
Using nanosleep() timing
Parsing input config file /dev/null
Input config file /dev/null parsed: 0 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
get_path('Sintel.2010.1080p.mkv.conf') -> '/home/nforce/.mplayer/Sintel.2010.1080p.mkv.conf'

Playing /mnt/Downloads/Movies/Sintel.2010.1080p.mkv.
get_path('sub/') -> '/home/nforce/.mplayer/sub/'
[file] File size is 1172428172 bytes
STREAM: [file] /mnt/Downloads/Movies/Sintel.2010.1080p.mkv
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0  pre:2048000  eof:0 

Cache fill:  0.00% (0 bytes)   

LAVF_check: Matroska/WebM file format
libavformat file format detected.
[matroska,webm @ 0xae1bf40] Estimating duration from bitrate, this may be inaccurate
ID_CHAPTER_ID=0
ID_CHAPTER_0_START=0
ID_CHAPTER_0_END=103125
ID_CHAPTER_0_NAME=Chapter 01
ID_CHAPTER_ID=1
ID_CHAPTER_1_START=103125
ID_CHAPTER_1_END=148667
ID_CHAPTER_1_NAME=Chapter 02
ID_CHAPTER_ID=2
ID_CHAPTER_2_START=148667
ID_CHAPTER_2_END=349792
ID_CHAPTER_2_NAME=Chapter 03
ID_CHAPTER_ID=3
ID_CHAPTER_3_START=349792
ID_CHAPTER_3_END=437208
ID_CHAPTER_3_NAME=Chapter 04
ID_CHAPTER_ID=4
ID_CHAPTER_4_START=437208
ID_CHAPTER_4_END=472075
ID_CHAPTER_4_NAME=Chapter 05
ID_CHAPTER_ID=5
ID_CHAPTER_5_START=472075
ID_CHAPTER_5_END=678833
ID_CHAPTER_5_NAME=Chapter 06
ID_CHAPTER_ID=6
ID_CHAPTER_6_START=678833
ID_CHAPTER_6_END=744083
ID_CHAPTER_6_NAME=Chapter 07
ID_CHAPTER_ID=7
ID_CHAPTER_7_START=744083
ID_CHAPTER_7_END=888032
ID_CHAPTER_7_NAME=Chapter 08
==> Found video stream: 0
ID_VIDEO_ID=0
======= VIDEO Format ======
  biSize 87
  biWidth 1920
  biHeight 818
  biPlanes 0
  biBitCount 0
  biCompression 875967048='H264'
  biSizeImage 0
Unknown extra header dump: [1] [64] [0] [29] [ff] [e1] [0] [1e] [67] [64] [0] [29] [ac] [c8] [60] [1e] [1] [a7] [e2] [26] [a0] [40] [40] [28] [0] [0] [3] [0] [8] [0] [0] [3] [1] [84] [78] [c1] [8c] [d0] [1] [0] [6] [68] [e9] [7b] [13] [21] [30]
===========================
[lavf] stream 0: video (h264), -vid 0
==> Found audio stream: 1
ID_AUDIO_ID=0
ID_AID_0_LANG=eng
ID_AID_0_NAME=AC3 5.1 @ 640 Kbps
======= WAVE Format =======
Format Tag: 8192 (0x2000)
Channels: 6
Samplerate: 48000
avg byte/sec: 80000
Block align: 1
bits/sample: 0
cbSize: 0
==========================================================================
[lavf] stream 1: audio (ac3), -aid 0, -alang eng, AC3 5.1 @ 640 Kbps
ID_SUBTITLE_ID=0
ID_SID_0_LANG=ger
[lavf] stream 2: subtitle (unknown), -sid 0, -slang ger
ID_SUBTITLE_ID=1
ID_SID_1_LANG=eng
[lavf] stream 3: subtitle (unknown), -sid 1, -slang eng
ID_SUBTITLE_ID=2
ID_SID_2_LANG=spa
[lavf] stream 4: subtitle (text), -sid 2, -slang spa
ID_SUBTITLE_ID=3
ID_SID_3_LANG=fre
[lavf] stream 5: subtitle (text), -sid 3, -slang fre
ID_SUBTITLE_ID=4
ID_SID_4_LANG=ita
[lavf] stream 6: subtitle (text), -sid 4, -slang ita
ID_SUBTITLE_ID=5
ID_SID_5_LANG=dut
[lavf] stream 7: subtitle (text), -sid 5, -slang dut
ID_SUBTITLE_ID=6
ID_SID_6_LANG=pol
[lavf] stream 8: subtitle (text), -sid 6, -slang pol
ID_SUBTITLE_ID=7
ID_SID_7_LANG=por
[lavf] stream 9: subtitle (text), -sid 7, -slang por
ID_SUBTITLE_ID=8
ID_SID_8_LANG=rus
[lavf] stream 10: subtitle (text), -sid 8, -slang rus
ID_SUBTITLE_ID=9
ID_SID_9_LANG=vie
[lavf] stream 11: subtitle (text), -sid 9, -slang vie
LAVF: 1 audio and 1 video streams found
LAVF: build 3434240
VIDEO:  [H264]  1920x818  0bpp  24.000 fps    0.0 kbps ( 0.0 kbyte/s)
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xaf915e0] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xae35a40] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xae7c428] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xae7bd28] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xb350bd8] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xae26880] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xaea2550] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xae285b0] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xae70f50] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[ass] File size: 300
[ass] ENCA supported languages
[ass] lang be
[ass] lang bg
[ass] lang cs
[ass] lang et
[ass] lang hr
[ass] lang hu
[ass] lang lt
[ass] lang lv
[ass] lang pl
[ass] lang ru
[ass] lang sk
[ass] lang sl
[ass] lang uk
[ass] lang zh
[ass] lang __
[ass] ENCA detected charset: ASCII
[ass] Opened iconv descriptor
[ass] Closed iconv descriptor
[ass] [0xae2dd40] Style: Default,Arial,20,&H00ffffff,&H00000000,&H00000000,0,0,2,1,1,2,20,20,8
[V] filefmt:44  fourcc:0x34363248  size:1920x818  fps:24.000  ftime:=0.0417
Load subtitles in /mnt/Downloads/Movies/
get_path('sub/') -> '/home/nforce/.mplayer/sub/'
ID_FILENAME=/mnt/Downloads/Movies/Sintel.2010.1080p.mkv
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1920
ID_VIDEO_HEIGHT=818
ID_VIDEO_FPS=24.000
ID_VIDEO_ASPECT=2.3472
ID_AUDIO_FORMAT=8192
ID_AUDIO_BITRATE=640000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_START_TIME=0.00
ID_LENGTH=888.03
ID_SEEKABLE=1
ID_CHAPTERS=8
X11 opening display: :0
vo: X11 color mask:  FFFFFF  (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1366x768 with depth 24 and 32 bpp (":0" => local display)
[x11] Current fstype setting doesn't honour any X atoms
Opening video filter: [screenshot]
Opening video filter: [ass]
[screenshot] query(Planar YV12) -> 3
[ass] FreeType library version: 2.4.5
[ass] FreeType headers version: 2.4.4
[ass] Init
get_path('fonts') -> '/home/nforce/.mplayer/fonts'
get_path('subfont.ttf') -> '/home/nforce/.mplayer/subfont.ttf'
[ass] Updating font cache
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
ID_VIDEO_CODEC=ffh264vdpau
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 192000 + 65536 = 257536 bytes for output buffer.
FFmpeg's libavcodec audio codec
INFO: libavcodec "ac3" init OK!
AUDIO: 48000 Hz, 2 ch, s16le, 640.0 kbit/41.67% (ratio: 80000->192000)
ID_AUDIO_BITRATE=640000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter volnorm
[libaf] Adding filter scaletempo
[libaf] Adding filter equalizer
[scaletempo] 1.000 speed * 1.000 scale_nominal = 1.000
[libaf] Adding filter format
[format] Changing sample format from little-endian 16-bit signed int to little-endian 32-bit float
[format] Accelerated little-endian 16-bit signed int to little-endian 32-bit float conversion
[scaletempo] 1.000 speed * 1.000 scale_nominal = 1.000
[format] Changing sample format from little-endian 16-bit signed int to little-endian 32-bit float
[format] Accelerated little-endian 16-bit signed int to little-endian 32-bit float conversion
Trying preferred audio driver 'alsa', options '[none]'
alsa-init: requested format: 48000 Hz, 2 channels, 1d
alsa-init: using ALSA 1.0.24.1
alsa-init: setup for 1/2 channel(s)
alsa-init: using device default
alsa-init: pcm opened in blocking mode
alsa-init: got buffersize=65536
alsa-init: got period size 1024
alsa: 48000 Hz/2 channels/8 bpf/65536 bytes buffer/Float 32 bit Little Endian
AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@streamminister.de>
AO: Comment: under development
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/floatle...
[scaletempo] 1.000 speed * 1.000 scale_nominal = 1.000
[format] Changing sample format from little-endian 16-bit signed int to little-endian 32-bit float
[format] Accelerated little-endian 16-bit signed int to little-endian 32-bit float conversion
[scaletempo] 1.000 speed * 1.000 scale_nominal = 1.000
[format] Changing sample format from little-endian 16-bit signed int to little-endian 32-bit float
[format] Accelerated little-endian 16-bit signed int to little-endian 32-bit float conversion
ID_AUDIO_CODEC=ffac3
[Mixer] No hardware mixing, inserting volume filter.
[libaf] Adding filter volume
[scaletempo] 1.000 speed * 1.000 scale_nominal = 1.000
[format] Changing sample format from little-endian 16-bit signed int to little-endian 32-bit float
[format] Accelerated little-endian 16-bit signed int to little-endian 32-bit float conversion
[scaletempo] 1.000 speed * 1.000 scale_nominal = 1.000
[format] Changing sample format from little-endian 16-bit signed int to little-endian 32-bit float
[format] Accelerated little-endian 16-bit signed int to little-endian 32-bit float conversion
Starting playback...
[libaf] Reallocating memory in module format, old len = 0, new len = 69637
Increasing filtered audio buffer size from 0 to 69632
[VD_FFMPEG] Trying pixfmt=0.
[ffmpeg] aspect_ratio: 0.000000
VDec: vo config request - 1920 x 818 (preferred colorspace: H.264 VDPAU acceleration)
Trying filter chain: ass screenshot vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale params: -1 x -1 (-1=no scaling)
Trying filter chain: scale ass screenshot vo
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
[h264_vdpau @ 0x87b1e00]decoding to PIX_FMT_NONE is not supported.
[h264_vdpau @ 0x87b1e00]decode_slice_header error
[h264_vdpau @ 0x87b1e00]no frame!
Error while decoding frame!

The error is at the end and it just repeats itself after that many times
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Mon Jul 18, 2011 2:25 pm    Post subject: Reply with quote

try my line, without all the rest, maybe any of the other params is the issue.

also what gpu are you using?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Mon Jul 18, 2011 3:22 pm    Post subject: Reply with quote

True, it works with your line. However it sometimes isn't really smooth, while xv isn't lagging at all. I use HD5470
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Mon Jul 18, 2011 3:25 pm    Post subject: Reply with quote

NForce wrote:
True, it works with your line. However it sometimes isn't really smooth, while xv isn't lagging at all. I use HD5470


I've heard that in HD6xxx and HD5xxx there are artifacts issues, I'm using a HD3xxx so I cannot comment on the issue.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Mon Jul 18, 2011 7:41 pm    Post subject: Reply with quote

No artifacts at all, but it seems like it's struggling to give a constant fps sometimes
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Mon Jul 18, 2011 8:09 pm    Post subject: Reply with quote

NForce wrote:
No artifacts at all, but it seems like it's struggling to give a constant fps sometimes


I've lost you then, is it working or not?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
NForce
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2009
Posts: 79
Location: Kaunas, Lithuania

PostPosted: Tue Jul 19, 2011 3:37 pm    Post subject: Reply with quote

It's working when I try without all the options I've used before. However with XV output the video is smoother
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Tue Jul 19, 2011 4:40 pm    Post subject: Reply with quote

NForce wrote:
It's working when I try without all the options I've used before. However with XV output the video is smoother

strange, ok then
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Wed Jul 20, 2011 1:07 pm    Post subject: Reply with quote

Guys, you are not using GPU decoding.

VDPAU has two stages -- decoding and presentation. The presentation stage is essentially the same as XVideo, it does the scaling, colour conversion, etc. That's what you get with "-vo vdpau" instead of "-vo xv". The decoding is done by ffmpeg on the CPU, as always, just the video output is through vdpau.

XVideo is much more mature than the Gallium vdpau implementation, so no wonder that it's a bit smoother.

To turn on the decoding part of vdpau, you have to use "-vc ffmpeg12vdpau" as well. It only works with MPEG2 atm, won't work with DivX or h264

From Christian himself (http://phoronix.com/forums/showthread.php?52837-Gallium3D-VDPAU-On-Radeon-Starts-Working/page7):
Quote:
Most people are currently only testing the yuv->rgb and scaling part of vdpau, since this works with all supported codecs.

This stages of the rendering pipeline are just a bit slower than Xv because of the debugging overhead. If you compile the state tracker without debugging support, it should be slightly faster because we don't need to call the x server to display every frame.

But the real improvement comes only when you enable more decoding stages, with mplayer provide the "-vc ffmpeg12vdpau" option for example.
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Wed Jul 20, 2011 6:06 pm    Post subject: Reply with quote

pingufunkybeat wrote:
Guys, you are not using GPU decoding.

VDPAU has two stages -- decoding and presentation. The presentation stage is essentially the same as XVideo, it does the scaling, colour conversion, etc. That's what you get with "-vo vdpau" instead of "-vo xv". The decoding is done by ffmpeg on the CPU, as always, just the video output is through vdpau.

XVideo is much more mature than the Gallium vdpau implementation, so no wonder that it's a bit smoother.

To turn on the decoding part of vdpau, you have to use "-vc ffmpeg12vdpau" as well. It only works with MPEG2 atm, won't work with DivX or h264

From Christian himself (http://phoronix.com/forums/showthread.php?52837-Gallium3D-VDPAU-On-Radeon-Starts-Working/page7):
Quote:
Most people are currently only testing the yuv->rgb and scaling part of vdpau, since this works with all supported codecs.

This stages of the rendering pipeline are just a bit slower than Xv because of the debugging overhead. If you compile the state tracker without debugging support, it should be slightly faster because we don't need to call the x server to display every frame.

But the real improvement comes only when you enable more decoding stages, with mplayer provide the "-vc ffmpeg12vdpau" option for example.


great :( sintel doesn't work...
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Wed Jul 20, 2011 6:40 pm    Post subject: Reply with quote

Only MPEG2 works at the moment. Motion Compensation, iDCT and some other goodies.

MPEG4 (including h264) require more complex stuff that's not done yet.
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Sat Jul 23, 2011 6:58 pm    Post subject: Reply with quote

I'd like to link to this thread because I found it really useful:

32bit driver ebuilds for amd64.

Just remember that you need to use the "pic" flag for mesa and turn off collision protection.
Back to top
View user's profile Send private message
moben
n00b
n00b


Joined: 09 Jan 2009
Posts: 52

PostPosted: Sun Jul 24, 2011 7:32 am    Post subject: Reply with quote

moben wrote:
but, does it reduce the cpu load on your machines? i think it uses quite the same as without vdpau... maybe it just *seem* to work?


i felt right :D has anyone a 1080p mpeg2 movie to test & maybe compare?
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Sun Jul 24, 2011 7:39 am    Post subject: Reply with quote

pingufunkybeat wrote:
I'd like to link to this thread because I found it really useful:

32bit driver ebuilds for amd64.

Just remember that you need to use the "pic" flag for mesa and turn off collision protection.


can you elaborate on how this is helpful please?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Mon Jul 25, 2011 10:38 am    Post subject: Reply with quote

DaggyStyle wrote:
can you elaborate on how this is helpful please?


Because it helps you install 32-bit drivers from git on a 64-bit system? How is that not useful?

Or do you have a better way of doing it?
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Mon Jul 25, 2011 12:04 pm    Post subject: Reply with quote

pingufunkybeat wrote:
DaggyStyle wrote:
can you elaborate on how this is helpful please?


Because it helps you install 32-bit drivers from git on a 64-bit system? How is that not useful?

Or do you have a better way of doing it?


why would I want these 32 bit drivers on my 64 bit system? what is the gain in having them?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Mon Jul 25, 2011 1:04 pm    Post subject: Reply with quote

DaggyStyle wrote:
why would I want these 32 bit drivers on my 64 bit system? what is the gain in having them?

You can run 32-bit OpenGL apps.

This means games like Quake4, Doom3, Trine, Shadowgrounds, Prey, Amnesia, Penumbra, and anything running through WINE.

These are all 32-bit and don't run with 64-bit drivers. The pre-compiled emulation compatibility libs provided by gentoo are too ancient and don't have the cool stuff compiled in.
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 439
Location: Maryland, US

PostPosted: Wed Nov 02, 2011 5:04 pm    Post subject: Reply with quote

I was having some problems trying to emerge mesa-9999 and libdrm-9999 using the ebuilds from Funtoo's Experimental branch, (which I'll now report over there). However, using the x11 overlay, I was able to emerge mesa-9999, libdrm-9999, and xf86-video-ati-9999, successfully.

Thanks..


Last edited by jasn on Wed Nov 02, 2011 8:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Wed Nov 02, 2011 6:35 pm    Post subject: Reply with quote

Just emerged mesa-9999 without problem
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Wed Nov 02, 2011 8:16 pm    Post subject: Reply with quote

can any of you emerge libdrm-9999 or xf86-video-ati-9999?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 439
Location: Maryland, US

PostPosted: Wed Nov 02, 2011 8:37 pm    Post subject: Reply with quote

Once I switched to the x11 overlay, I was able to emerge all three correctly using the overlay's ebuilds.

Thanks..


Last edited by jasn on Wed Nov 02, 2011 8:57 pm; edited 3 times in total
Back to top
View user's profile Send private message
yellowhat
Guru
Guru


Joined: 10 Sep 2008
Posts: 500

PostPosted: Wed Nov 02, 2011 8:42 pm    Post subject: Reply with quote

Emerged mesa-9999 libdrm-9999 and xf86-video-ati-9999 without problem, I am using standard ebuild from x11 overlay.
_________________
Gentoo Linux ~amd64, Kernel 4.5.3, Enermax 400W, Intel i7-3770, DDR3 8GB, Sapphire HD6870
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5325

PostPosted: Wed Nov 02, 2011 9:02 pm    Post subject: Reply with quote

I don't get it, I use the packages directly from the overlay (I don't like layman) but I get this freaking error:
Code:
 * Running elibtoolize in: libdrm-9999/build-aux/
 * Portage patch failed to apply (ltmain.sh version 2.4)!
 * Please file a bug report to add a proper patch.
 * ERROR: x11-libs/libdrm-9999 failed (prepare phase):
 *   Portage patch failed to apply!
 *

_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 27, 28, 29  Next
Page 28 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum