Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz-manager not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
psycophobia
Guru
Guru


Joined: 08 May 2005
Posts: 460
Location: uk

PostPosted: Wed Aug 05, 2009 9:49 pm    Post subject: compiz-manager not working Reply with quote

Just updated and i am not sure why this is happening

Code:
compiz-manager
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA: 01:00.0 0300: 10de:05e1 (rev a1) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1152x864) to maximum 3D texture size (2048): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting emerald
/usr/bin/compiz (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz (core) - Error: Failed to manage screen: 0
/usr/bin/compiz (core) - Fatal: No manageable screens found on display :0
Window manager warning: 0 stored in GConf key /desktop/gnome/peripherals/mouse/cursor_size is out of range 1 to 128
Window manager warning: Failed to load theme "Clearlooks": Failed to find a valid file for theme Clearlooks


Ty
Back to top
View user's profile Send private message
lcj
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2004
Posts: 82
Location: Opole, Poland

PostPosted: Fri Aug 07, 2009 7:19 am    Post subject: Reply with quote

Check if you have libcompizconfig 0.8.2-r2, if so downgrade to libcompizconfig 0.8.2
_________________
--
Lukasz C. Jokiel via web
Back to top
View user's profile Send private message
psycophobia
Guru
Guru


Joined: 08 May 2005
Posts: 460
Location: uk

PostPosted: Fri Aug 07, 2009 9:41 am    Post subject: Reply with quote

Yes i have rolled that back but still same error,i have allso rolled back nvidia-drivers xorg-server and so on as its since the system update things have got bad on all fronts.
I have allways started compiz with compiz-manager :?
Back to top
View user's profile Send private message
lcj
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2004
Posts: 82
Location: Opole, Poland

PostPosted: Thu Sep 24, 2009 8:19 pm    Post subject: Reply with quote

psycophobia wrote:
Yes i have rolled that back but still same error,i have allso rolled back nvidia-drivers xorg-server and so on as its since the system update things have got bad on all fronts.
I have allways started compiz with compiz-manager :?


I did quick test today:

1. added new user dummy - same effect when I run compiz manager I get stuck on emerald, when Ctrl+C is pressed I got ** double free ** error.
2. running as root - SUCCESS - emerald starts works fine. What's going on ?
_________________
--
Lukasz C. Jokiel via web
Back to top
View user's profile Send private message
lcj
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2004
Posts: 82
Location: Opole, Poland

PostPosted: Thu Oct 22, 2009 10:35 am    Post subject: Reply with quote

Silly me - ccsm had options configured, after deletion of .compiz folder I reconfigured them again - but forgot to use Window Decoration plugin!
So at least for me case is solved.
_________________
--
Lukasz C. Jokiel via web
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum