Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge gives "masked by: corruption" (pd-overlay)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
01
n00b
n00b


Joined: 03 Aug 2009
Posts: 7

PostPosted: Wed Aug 12, 2009 8:14 pm    Post subject: emerge gives "masked by: corruption" (pd-overlay) Reply with quote

Hi,

I can't solve the issue I'm having with a package.

I try to emerge puredata :

Code:
emerge media-sound/pd
Calculating dependencies \ *
 * ERROR: media-sound/pd-0.42_p0-r1 failed.
 * Call stack:
 *               ebuild.sh, line 1879:  Called _source_ebuild
 *               ebuild.sh, line 1818:  Called source '/usr/portage/local/layman/pd-overlay/media-sound/pd/pd-0.42_p0-r1.ebuild'
 *    pd-0.42_p0-r1.ebuild, line    5:  Called inherit 'eutils' 'toolchain-funcs'
 *               ebuild.sh, line 1218:  Called die
 * The specific snippet of code:
 *         [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *  The die message:
 *   eutils.eclass could not be found by inherit()
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *
 *
 * ERROR: media-sound/pd-0.41_p4 failed.
 * Call stack:
 *               ebuild.sh, line 1879:  Called _source_ebuild
 *               ebuild.sh, line 1818:  Called source '/usr/portage/local/layman/pd-overlay/media-sound/pd/pd-0.41_p4.ebuild'
 *       pd-0.41_p4.ebuild, line    5:  Called inherit 'eutils' 'toolchain-funcs'
 *               ebuild.sh, line 1218:  Called die
 * The specific snippet of code:
 *         [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *  The die message:
 *   eutils.eclass could not be found by inherit()
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *
 *
 * ERROR: media-sound/pd-0.40_p3-r1 failed.
 * Call stack:
 *               ebuild.sh, line 1879:  Called _source_ebuild
 *               ebuild.sh, line 1818:  Called source '/usr/portage/local/layman/pd-overlay/media-sound/pd/pd-0.40_p3-r1.ebuild'
 *    pd-0.40_p3-r1.ebuild, line    5:  Called inherit 'eutils' 'toolchain-funcs'
 *               ebuild.sh, line 1218:  Called die
 * The specific snippet of code:
 *         [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *  The die message:
 *   eutils.eclass could not be found by inherit()
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *
 *
 * ERROR: media-sound/pd-0.39_p2 failed.
 * Call stack:
 *               ebuild.sh, line 1879:  Called _source_ebuild
 *               ebuild.sh, line 1818:  Called source '/usr/portage/local/layman/pd-overlay/media-sound/pd/pd-0.39_p2.ebuild'
 *       pd-0.39_p2.ebuild, line    5:  Called inherit 'eutils'
 *               ebuild.sh, line 1218:  Called die
 * The specific snippet of code:
 *         [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *  The die message:
 *   eutils.eclass could not be found by inherit()
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *
... done!

!!! All ebuilds that could satisfy "media-sound/pd" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-sound/pd-0.42_p0-r1 (masked by: corruption)
- media-sound/pd-0.41_p4 (masked by: corruption)
- media-sound/pd-0.40_p3-r1 (masked by: corruption)
- media-sound/pd-0.39_p2 (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I had it previously installed, then one day emerge bugged me about these messages each time I ran emerge.
I uninstalled pd, and now I can't reinstall it.

I deleted the overlay using layman, and added it again, synced it, it doesn't solve the problem.

What should I do ? :)

Thanks for your help.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Wed Aug 12, 2009 9:53 pm    Post subject: Reply with quote

Quote:
eutils.eclass could not be found by inherit()

Strange, your sync must have been gone wrong. So try again:
Code:

emerge --sync
layman -s pd-overlay

or the same thing with one command:
Code:

eix-sync

You can try different mirror for GENTOO_MIRRORS on your make.conf.
Also check your disks for errors with fsck just to be sure.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
01
n00b
n00b


Joined: 03 Aug 2009
Posts: 7

PostPosted: Thu Aug 13, 2009 11:20 am    Post subject: Reply with quote

No luck, I synced it several times in the past, I tried again, it doesn't help and I still get that error. :(

About the mirrors, I'm not sure it helps if I change it, as it only concerns the main tree and not overlays, right ?

Hmm, as for fsck, it's been a while I have the problem, it's been fscked a few times with usual reboots ;)
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5618
Location: Removed by Neddy

PostPosted: Thu Aug 13, 2009 11:46 am    Post subject: Reply with quote

masked by corruption can sometimes be due to the checksum of the ebuild doesn't match that stored in the manifest.
A crude way would be to just do :

emerge /path/to/overlay/media-sound/pd/pd-0.42_p0-r1.ebuild digest

and do the same for hte others
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
01
n00b
n00b


Joined: 03 Aug 2009
Posts: 7

PostPosted: Thu Aug 13, 2009 2:04 pm    Post subject: Reply with quote

You meant "ebuild", not "emerge"
Code:
ebuild /path/to/overlay/media-sound/pd/pd-0.42_p0-r1.ebuild digest

I did it for each package, unfortunately, that doesn't solve the problem either ...
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Thu Aug 13, 2009 2:50 pm    Post subject: Reply with quote

01 wrote:
You meant "ebuild", not "emerge"
Code:
ebuild /path/to/overlay/media-sound/pd/pd-0.42_p0-r1.ebuild digest

I did it for each package, unfortunately, that doesn't solve the problem either ...

Since I am using the pd-overlay, too, there is no problem in the overlay. So you must not need to "ebuild blabla manifest".
It is probably your portage tree or something. That happened to me once. And emerge --sync fixed it some later.
The following line makes me think your portage tree is broken:
Quote:

eutils.eclass could not be found by inherit()

Do you have that eclass?
Code:

ls -l /usr/portage/eclass/eutils.eclass

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
01
n00b
n00b


Joined: 03 Aug 2009
Posts: 7

PostPosted: Thu Aug 13, 2009 4:45 pm    Post subject: Reply with quote

Code:
# ebuild pd-0.39_p2.ebuild manifest
 *
 * ERROR: media-sound/pd-0.39_p2 failed.
 * Call stack:
 *               ebuild.sh, line 1879:  Called _source_ebuild
 *               ebuild.sh, line 1818:  Called source '/usr/portage/local/layman/pd-overlay/media-sound/pd/pd-0.39_p2.ebuild'
 *       pd-0.39_p2.ebuild, line    5:  Called inherit 'eutils'
 *               ebuild.sh, line 1218:  Called die
 * The specific snippet of code:
 *         [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 *  The die message:
 *   eutils.eclass could not be found by inherit()
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *


Code:
$ ls -l /usr/portage/eclass/eutils.eclass
-rw-r--r-- 1 root root 52424 mars  1 09:09 /usr/portage/eclass/eutils.eclass


I synced it so many times since ... (with layman -S, and with emerge --sync)

Edit: oops, I read too quickly and typed that "manifest" command :D, okay, the problem doesn't come from the overlay ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum