Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDE] probleme arts et package.mask
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Fri Aug 14, 2009 11:45 am    Post subject: [KDE] probleme arts et package.mask Reply with quote

Bonjour,
J'utilise la version stable de kde. J'ai des mises a jour que je n'arrive pas a faire en raison de dependances d'une version à une autre.
Je ne sais pas trop quoi faire.

Code:
[ebuild     UD] kde-base/arts-3.5.9 [3.5.10] USE="-kdeenablefinal% -xinerama%"
[ebuild     U ] kde-base/kdelibs-3.5.10-r6 [3.5.9-r4]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

kde-base/arts:3.5

  ('installed', '/', 'kde-base/arts-3.5.10', 'nomerge') pulled in by
    ~kde-base/arts-3.5.10 required by ('ebuild', '/', 'kde-base/kdelibs-3.5.10-r6', 'merge')
    (and 21 more)

  ('ebuild', '/', 'kde-base/arts-3.5.9', 'merge') pulled in by
    ~kde-base/arts-3.5.9 required by ('installed', '/', 'kde-base/kdeaddons-3.5.9', 'nomerge')
    (and 21 more)

kde-base/kdelibs:3.5

  ('ebuild', '/', 'kde-base/kdelibs-3.5.10-r6', 'merge') pulled in by
    ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/umbrello-3.5.10', 'nomerge')
    ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/kde-i18n-3.5.10', 'nomerge')

  ('installed', '/', 'kde-base/kdelibs-3.5.9-r4', 'nomerge') pulled in by
    ~kde-base/kdelibs-3.5.9 required by ('installed', '/', 'kde-base/kdetoys-3.5.9', 'nomerge')
    ~kde-base/kdelibs-3.5.9 required by ('installed', '/', 'kde-base/kdegames-3.5.9', 'nomerge')
    ~kde-base/kdelibs-3.5.9 required by ('installed', '/', 'kde-base/kdeaddons-3.5.9', 'nomerge')
    (and 12 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.


De plus maintenant j'ai a chaque fois le message suivant quand je fais un "emerge -unDaN world"

Code:
!!! The following installed packages are masked:
- x11-libs/qt-4.5.1 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ben de Groot <yngwin@gentoo.org> (25 Jun 2009)
# Mask the Qt4 meta ebuild, to prevent devs from being silly and depend on
# the meta ebuild instead of on the specific split Qt ebuilds needed. See
# bug 217161 comment 11. Users may unmask this if they want to pull in all
# Qt modules, but packages in portage (or overlays) will pull in the split
# modules they need as dependency. Unmasking this will most likely pull in
# more than you need. This meta ebuild will be removed when we can add sets
# to the portage tree.


Je suis a la version 3.3.8b-r1 stable de qt
Merci d'avance pour vos solutions
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Aug 14, 2009 11:51 am    Post subject: Reply with quote

Hum, tu peux nous donner la commande que tu utilises pour mettre kde à jour?

Pour le message à la fin, c'est rien, c'est juste un dev qui met un message de prévention pour tout le monde, je l'ai aussi, c'est juste informatif.
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Fri Aug 14, 2009 5:34 pm    Post subject: Reply with quote

Cela fait suite à une mise à jour
Code:
emerge -unDaN world
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Fri Aug 14, 2009 7:08 pm    Post subject: Reply with quote

Perso le "n" minuscule dans ta commande, je le trouve louche...

Et si tu fais ça : "emerge -1av kde-base/kdelibs" , ça passe ?
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Fri Aug 14, 2009 9:14 pm    Post subject: Reply with quote

Réponse :

Code:
WARNING: A requested package will not be merged because it is listed in
package.provided:

  kde-base/kdelibs pulled in by 'args'


dans le fichier package.provided j'ai :

Code:
kde-base/kdelibs-3.5.2-r6
kde-env/kde-env-3
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Sat Aug 15, 2009 9:56 am    Post subject: Reply with quote

o_O'
Mais pourquoi t'as un package.provided ??? o_O'

Commente ces deux lignes (avec un # devant) et retente.
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Thu Aug 20, 2009 8:16 am    Post subject: Reply with quote

Bonjour,
J'ai commenté ces deux lignes.
J'ai plus de paquets bloquants :

Code:
[ebuild     UD] kde-base/arts-3.5.9 [3.5.10] USE="-kdeenablefinal% -xinerama%"
[ebuild     U ] media-plugins/audacious-plugins-2.1-r1 [2.1]
[ebuild     U ] kde-base/kdelibs-3.5.10-r6 [3.5.9-r4]
[blocks B     ] kde-base/kdenetwork ("kde-base/kdenetwork" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kde ("kde-base/kde" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdetoys ("kde-base/kdetoys" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdeaccessibility ("kde-base/kdeaccessibility" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdeartwork ("kde-base/kdeartwork" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdepim ("kde-base/kdepim" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdemultimedia ("kde-base/kdemultimedia" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdeadmin ("kde-base/kdeadmin" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdebase ("kde-base/kdebase" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdeedu ("kde-base/kdeedu" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdegraphics ("kde-base/kdegraphics" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdewebdev ("kde-base/kdewebdev" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdegames ("kde-base/kdegames" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdeaddons ("kde-base/kdeaddons" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kdeutils ("kde-base/kdeutils" is blocking kde-base/kdelibs-3.5.10-r6)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'kde-base/kdeaddons-3.5.9', 'nomerge') pulled in by
    ~kde-base/kdeaddons-3.5.9 required by ('installed', '/', 'kde-base/kde-3.5.9', 'nomerge')
    kde-base/kdeaddons required by world

  ('installed', '/', 'kde-base/kdegraphics-3.5.9', 'nomerge') pulled in by
    ~kde-base/kdegraphics-3.5.9 required by ('installed', '/', 'kde-base/kde-3.5.9', 'nomerge')
    kde-base/kdegraphics:3.5 required by ('installed', '/', 'app-editors/kile-2.0.3-r1', 'nomerge')

  ('installed', '/', 'kde-base/kdewebdev-3.5.9', 'nomerge') pulled in by
    kde-base/kdewebdev required by world
    ~kde-base/kdewebdev-3.5.9 required by ('installed', '/', 'kde-base/kde-3.5.9', 'nomerge')

  ('installed', '/', 'kde-base/kde-3.5.9', 'nomerge') pulled in by
    kde-base/kde required by world

  ('ebuild', '/', 'kde-base/kdelibs-3.5.10-r6', 'merge') pulled in by
    =kde-base/kdelibs-3.5* required by ('installed', '/', 'app-editors/kile-2.0.3-r1', 'nomerge')
    =kde-base/kdelibs-3.5* required by ('installed', '/', 'kde-misc/kdnssd-avahi-0.1.2-r1', 'nomerge')
    ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/kde-i18n-3.5.10', 'nomerge')
    (and 2 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Thu Aug 20, 2009 9:54 am    Post subject: Reply with quote

Y a vraiment un truc pas sain du tout dans ton installation.
Ton world a l'air complètement foutu ...

En gros, t'as kdelibs qui veut passer en 3.5.10 et tout le reste qui veut rester en 3.5.9 ... je comprends pas.


....... finalement je crois comprendre !!!!

T'es en train de vouloir mélanger KDE meta et KDE modulaire et ça te pète au nez !

T'as installé le paquet générique "kde-base/kde" pour installer tout KDE, or dans portage c'est la version 3.5.9 qui s'y trouve.

Apparemment, "kde-base/kdelibs" est aussi dans ton world mais ne devrait pas l'être, car dépendance de "kde-base/kde". "kde-base/kdelibs" étant dans ton world et dispo en version 3.5.10, il essaye de s'upgrader mais ça bloque car "kde-base/kde" est toujours en 3.5.9. Encore que, je crois que portage essaye d'upgrader les dépendances quoi qu'il arrive et dans ce cas ce serait une merde dans l'arbre portage.

Bah, bloque "kde-base/kdelibs-3.5.10-r6" dans ton "package.mask" ou sinon, ton installation me parait en mal barrée...
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
mcsky2
Guru
Guru


Joined: 25 Aug 2005
Posts: 307

PostPosted: Thu Aug 20, 2009 10:23 am    Post subject: Reply with quote

Merci pour l'info
Je peux pas virer le kde et refaire une install avec kde-meta ?
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Thu Aug 20, 2009 10:53 am    Post subject: Reply with quote

Je sais pas trop ... perso je passe par "kdebase-startkde" pour installer ce que je veux ... je peux pas trop t'aider.
Pis je suis pas sûr du problème, mais je pense à un mic mac dans le genre...
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Thu Aug 20, 2009 2:38 pm    Post subject: Reply with quote

Temet+1 concernant le mic-mac entre la version monolithique et les ebuild séparés !

Tu devrais pouvoir rattrapper le coup en effaçant d'abord toute trace de tes précédentes tentatives d'install de kde.
J'utiliserais une commande du genre :
eix -I --only-names 'kde-(misc|base)/*'|xargs emerge -Ca

Ensuite, comme suggéré par Temet, je lancerais un emerge kde-base/kdebase-startkde -av pour installer le minimum vital et je complèterais ensuite par les divers paquets qui me plaisent.

Perso, je n'utiliserais pas kde-meta : tu ne ferais qu'encombrer ton système d'un tas de choses totalement inutiles, que tu n'utiliseras jamais et dont tu iras même jusqu'à ignorer l'existence (ça te dit vraiment d'installer le package amor sans que tu t'en rendes compte ? ;) )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum