Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[KDE] problème d'installation (paquets bloqués)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Fri Aug 21, 2009 10:08 pm    Post subject: [KDE] problème d'installation (paquets bloqués) Reply with quote

Bonsoir,

Je viens d'installer Gentoo en suivant la documentation. Tout s'est bien passé jusqu'à l'installation de KDE. Ca a commencé avec emerge kdemultimedia qui renvoie une erreur de dépendence circulaire entre media-sound/jack-audio-connection-kit et media-libs/libsndfile-1.0.20. J'ai vu dans la documentation qu'il est conseillé de syncroniser Portage, ce que j'ai fait, mais ça ne change rien au problème.
Ensuite, j'ai voulu configurer la langue mais la commande emerge kde-i18n me renvoie une erreur pour paquets bloqués avec kde-base/kdelibs, kde-base/kdeadmin, kde-base/kdeartwork, kde-base/kdegraphics et kde-base/kdebase.
J'ai pourtant suivi la documentation et il n'y a aucun avertissement à ce propos, je ne comprends donc pas d'où vient ce problème... Avez-vous une idée?

De plus, est-il normal que la version de KDE qui s'est installée soit KDE3.5 alors que j'utilise KDE4 depuis longtemps sous Fedora? J'ai essayé de mettre le système à jour pour essayer de régler le problème mais j'ai, là aussi, des paquets bloqués qui empêchent la mise à jour :
Code:
('ebuild', '/', 'sys-apps/man-pages-posix-2003a', 'merge') pulled in by
    sys-apps/man-pages-posix required by ('ebuild', '/', 'sys-apps/man-pages-3.21', 'merge')


Je ne comprends pas trop d'où ça vient, est-il possible que ça vienne d'un mauvais réglage quelque part?

Merci beaucoup par avance

Kevin57
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Fri Aug 21, 2009 11:45 pm    Post subject: Re: [KDE] problème d'installation (paquets bloqués) Reply with quote

Kevin57 wrote:
Ca a commencé avec emerge kdemultimedia

Cherche pas plus loin : si tu as fait "emerge kdemultimedia", il t'a bloqué à la version 3.5.9 monolithique et ça provoque des conflits avec d'autres versions.
Voir ce document
En fait, sous gentoo, il y a essentiellement 3 versions de kde :
- la version monolithique constituée de 3 ou 4 gros paquets fournissant TOUT KDE et le reste ;)
- la version "splitée" : les gros paquets sont divivisés en de nombreux paquets élémentaires. La dernière version stable est la 3.5.10.
- la branche 4.*, toujours considérée comme "unstable" à des degrés divers.

Oublie la version monolithique : elle frise l'obsolescence ...
Tu as alors 3 approches :
- Utiliser les paquets stables suffixés "-meta" (ex : kde-meta), qui miment le comportement de l'ancienne version monolithique (en gros : TOUT kde)
- Opter pour une installation de base stable avec le paquet kdebase-startkde et l'étoffer avec des paquets de ton choix.
- Te tourner vers la branche 4.* en étant conscient qu'elle n'est pas encore stabilisée sous gentoo.
Cette branche étant "unstable", elle demande un peu plus d'expérience pour être installée car il faut la "forcer" via diverses configurations avancées de gentoo.
Actuellement, tu as 2 versions pour kde4:
- la 4.2.4, en cours de stabilisation
- la 4.3.0 "hardmasquée".

Ca va, tu tiens le coup ? ;)
Bon, alors, j'enfonce le clou : vu que kde est "slotté", tu peux parfaitement installer une version 3.5 et une version 4.* en même temps, côte à côte.
Elles pourront tourner simultanément dans des sessions séparées (très pratique pour les comparer !)
Un peu de doc supplémentaire ici

Bon week-end quand même ! ;) :lol:
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat Aug 22, 2009 12:05 am    Post subject: Reply with quote

Bon tout d'abord merci beaucoup pour la réponse!
C'est dommage que KDE4 soit encore instable sous Gentoo parce que je ne suis pas fan du tout de KDE3... Enfin en attendant on fera avec!

Donc en fait ce que j'ai installé pour KDE est obsolète (kdebase, kdeadmin, etc), c'est ça? Il faudrait donc que je vire tout et que je réinstalle juste kdebase-startkde et que je l'agrémente ensuite de ce que je veux y ajouter... Vu que j'ai fait un backup avant d'installer KDE, je vais donc surement l'utiliser pour revenir à une installation propre, à moins qu'il y ait mieux?
Par contre, existe-t-il quelque part une liste des programmes de KDE, histoire de savoir lesquels installer?

Je ne vais pas me lancer dans l'installation de KDE4 instable puisque je découvre Gentoo donc en cas de soucis je vais pas savoir comment faire! Mais est-ce que KDE4 a des chances de devenir bientôt stable? Je suis surpris que ça soit déjà utilisé sur certaines distributions et pas d'autres...

Et aussi, du coup, si j'ai bien compris la documentation est donc assez obsolète...donc comment je peux passer KDE en français après avoir installé kdebase-startkde?

Merci beaucoup, bon week-end et bonne nuit!

Kevin57
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sat Aug 22, 2009 1:08 am    Post subject: Reply with quote

Kevin57 wrote:
Bon tout d'abord merci beaucoup pour la réponse!
C'est dommage que KDE4 soit encore instable sous Gentoo parce que je ne suis pas fan du tout de KDE3... Enfin en attendant on fera avec!

Stable/instable ... disons que les termes ne correspondent pas nécessairement à la définition du dictionnaire ;)
Dans les faits, l'instable est généralement très stable, sans exclure pour autant un plongeon occasionel dans le cambouis ;)
Perso, j'ai toujours été en "full unstable" depuis mon premier contact avec gentoo et je n'ai jamais eu de véritable catastrophe en relation avec la "stabilité". Bien sûr, j'avais déjà quelques années d'expérience avec d'autres distros et l'usage exclusivement privé que j'ai de mon ordi me permet d'accepter certains risques ...

Quote:
à moins qu'il y ait mieux?

Peut-être ... ;)
Si tu ne l'as pas encore fait, je te conseille d'abord d'installer le package eix qui permet d'interroger la base de données de gentoo dans tous les sens.
Ensuite, la commande eix -I --only-names 'kde-(misc|base)/*'|xargs emerge -Ca devrait te permettre de virer tous les packages kde installés jusqu'ici.
Tu pourras alors repartir sur une base propre ...
Quote:
Par contre, existe-t-il quelque part une liste des programmes de KDE, histoire de savoir lesquels installer?

Outre eix et les fonctions de recherche d'emerge, tu peux voir les paquets disponibles dans /usr/portage, répertoires kde-base et kde-misc ...
Il existe aussi des applications graphiques comme porthole, portato et himerge.
Il y a aussi différents sites, par exemple : http://packages.gentoo.org/categories/

Quote:
Mais est-ce que KDE4 a des chances de devenir bientôt stable?

Les mainteneurs travaillent sur la stabilisation de la 4.2.4. A mon avis, ça ne devrait plus trop tarder ...

Quote:
Et aussi, du coup, si j'ai bien compris la documentation est donc assez obsolète...donc comment je peux passer KDE en français après avoir installé kdebase-startkde?

Les références que je t'ai données sont toujours valables. Eventuellement changer les n° de version ...
Sinon, pour passer en français, c'est comme sur toutes les distribs : Centre de configuration/Régionalisation et accessibilité ...
Ou plutôt : Control Center/Regional & Accessibility ... ;)
Mais si je me rappelle bien (à vérifier), il tient compte de tes locales dès le départ ...
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat Aug 22, 2009 8:43 am    Post subject: Reply with quote

Merci pour les explications. Je vais donc faire comme tu me le proposes pour enlever KDE. Quant à KDE4, je vais attendre encore un peu si tu dis qu'il devrait bientôt être stabilisé, ça sera plus simple.

Pour les langues, le problème est que là où tu me dis de régler, je n'ai que English (US)... Enfin on va voir en réinstakllant, peut-être que ça va changer.

Donc merci beaucoup pour tout, je vais faire ça et je reviens après!
Back to top
View user's profile Send private message
ppg
Apprentice
Apprentice


Joined: 05 Oct 2008
Posts: 178
Location: Toulouse

PostPosted: Sat Aug 22, 2009 8:53 am    Post subject: Reply with quote

Kevin57 wrote:
Merci pour les explications. Je vais donc faire comme tu me le proposes pour enlever KDE. Quant à KDE4, je vais attendre encore un peu si tu dis qu'il devrait bientôt être stabilisé, ça sera plus simple.

Pour les langues, le problème est que là où tu me dis de régler, je n'ai que English (US)... Enfin on va voir en réinstakllant, peut-être que ça va changer.

Donc merci beaucoup pour tout, je vais faire ça et je reviens après!


Pour les langues, normalement il n'y pas besoin d'installer explicitement un kde-i18n *si* la virable LINGUAS est bien renseignée dans /etc/make.conf. (En tout cas pour gnome ça suffit, je suppose que pour kde aussi).
Si ce n'est pas déjà fait ajoute LINGUAS="fr en" dans ton make.conf ; pense aussi à vérifier que tu les locales sont bien générées voir ici.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat Aug 22, 2009 10:06 am    Post subject: Reply with quote

Merci, je l'avais bien fait pour le make.conf mais pas pour les locales... Du coup comment je fais maintenant vu que je viens d'installer kdebase-startkde et que, si possible, j'aimerais éviter de tout recommencer! :)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sat Aug 22, 2009 11:03 am    Post subject: Reply with quote

emerge kde-i18n ... ;)
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat Aug 22, 2009 11:26 am    Post subject: Reply with quote

OK merci beaucoup! Tout à l'air de bien vouloir marcher, je suis en train d'installer mes logiciels mais par contre j'ai un souci avec amarok qui me sort un problème de dépendences circulaires, exactement comme kdemultimedia au début... Avez-vous une idée de la raison du problème?
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sat Aug 22, 2009 11:45 am    Post subject: Reply with quote

Quelle commande as-tu tapée et peux-tu donner le message exact ?
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sat Aug 22, 2009 12:11 pm    Post subject: Reply with quote

J'ai tapé emerge amarok. Le message d'erreur est le suivant :

Code:
Calculating dependencies... done!


[nomerge      ] media-sound/amarok-1.4.10_p20090130-r3  USE="amazon kde opengl python -daap -debug -ifp -ipod -mp4 -mtp -musicbrainz -mysql -njb -postgres (-real) -visualization -xinerama" LINGUAS="fr -af -ar -az -be -bg -bn -br -ca -cs -cy -da -de -el -en_GB -eo -es -et -eu -fa -fi -ga -gl -he -hi -hu -id -is -it -ja -km -ko -ku -lo -lt -mk -ms -nb -nds -ne -nl -nn -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -sr@Latn -ss -sv -ta -tg -th -tr -uk -uz -zh_CN -zh_TW"
[nomerge      ]  media-libs/xine-lib-1.1.16.3-r1  USE="X a52 aac alsa dts dvd ipv6 jack mad modplug musepack nls opengl speex theora v4l vcd vorbis win32codecs xcb xv -aalib (-altivec) -arts -directfb -dxr3 -esd -fbcon -flac -gnome -gtk -imagemagick -libcaca -mmap -mng -oss -pulseaudio (-real) -samba -sdl -truetype -vidix (-vis) -wavpack -xinerama -xvmc"
[nomerge      ]   media-sound/jack-audio-connection-kit-0.109.2-r1  USE="alsa (-altivec) -caps (-coreaudio) -cpudetection -debug -doc -mmx -netjack -oss -sse"
[ebuild  N    ]    media-libs/libsndfile-1.0.20  USE="alsa jack -minimal -sqlite"
[ebuild  N    ]     media-sound/jack-audio-connection-kit-0.109.2-r1  USE="alsa (-altivec) -caps (-coreaudio) -cpudetection -debug -doc -mmx -netjack -oss -sse"

 * Error: circular dependencies:

('ebuild', '/', 'media-libs/libsndfile-1.0.20', 'merge') depends on
  ('ebuild', '/', 'media-sound/jack-audio-connection-kit-0.109.2-r1', 'merge') (buildtime)
('ebuild', '/', 'media-sound/jack-audio-connection-kit-0.109.2-r1', 'merge') depends on
  ('ebuild', '/', 'media-libs/libsndfile-1.0.20', 'merge') (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
Koboneil
n00b
n00b


Joined: 18 Jun 2007
Posts: 18
Location: Mulhouse (68), France

PostPosted: Sat Aug 22, 2009 1:31 pm    Post subject: Reply with quote

ghoti wrote:

Quote:
Mais est-ce que KDE4 a des chances de devenir bientôt stable?

Les mainteneurs travaillent sur la stabilisation de la 4.2.4. A mon avis, ça ne devrait plus trop tarder ...


En fait, ils ont voté récemment la version 4.3.1 comme étant la version à stabiliser. cf ce bug.
_________________
Koboneil.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sat Aug 22, 2009 2:06 pm    Post subject: Reply with quote

Ah ouais, c'est tout chaud !
Bonne nouvelle ! :-)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sat Aug 22, 2009 2:13 pm    Post subject: Reply with quote

Kevin57 wrote:
* Note that circular dependencies can often be avoided by temporarily
* disabling USE flags that trigger optional dependencies.

Ce qui provoque la dépendance circulaire, c'est le useflag "jack" au niveau de libsndfile.
Il faut procéder en 3 étapes :
1. installer libsndfile sans le support de jack :
USE="-jack" emerge libsndfile -1av

2. installer jack
emerge jack-audio-connection-kit -1av

3. réinstaller libsndfile avec le support de jack :
emerge libsndfile -1av
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Sat Aug 22, 2009 6:01 pm    Post subject: Reply with quote

T'ain c'est tordu ce coup la avec le flag.

Et pour la stabilisation de KDE 4, m'est d'avis qu'ils ont attendu beaucoup, mais beaucoup trop longtemps!
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sun Aug 23, 2009 12:49 pm    Post subject: Reply with quote

Merci ghoti, ça a marché!

Par contre j'ai un autre problème de paquets bloqués quand je veux faire une mise à jour. Quand je tape emerge -uDNpv world j'ai l'erreur suivante qui apparait :

Code:
* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'sys-apps/man-pages-posix-2003a', 'merge') pulled in by
    sys-apps/man-pages-posix required by ('ebuild', '/', 'sys-apps/man-pages-3.21', 'merge')

  ('ebuild', '/', 'kde-base/kdelibs-3.5.10-r6', 'merge') pulled in by
    ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/kate-3.5.10', 'nomerge')
    ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/kdebase-kioslaves-3.5.10-r1', 'nomerge')
    ~kde-base/kdelibs-3.5.10 required by ('installed', '/', 'kde-base/ksmserver-3.5.10', 'nomerge')
    (and 47 more)

  ('installed', '/', 'kde-base/mpeglib-3.5.9', 'nomerge') pulled in by
    kde-base/mpeglib required by world


Est-ce que je dois désinstaller les packages qui bloquent?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum