Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ebuild for multi-threaded ("multi-core") mplayer (ffmpeg-mt)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 133

PostPosted: Tue May 04, 2010 5:32 pm    Post subject: Reply with quote

Uhm... there is no more mplayer ebuild in the wirelay overlay... it seems it is in the multimedia overlay now.
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Tue May 04, 2010 5:40 pm    Post subject: Reply with quote

Yes, it was moved to the multimedia overlay:

https://bugs.gentoo.org/show_bug.cgi?id=282154#c52
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sat May 08, 2010 12:52 am    Post subject: Reply with quote

(Sorry for bumping too soon, but ffmpeg-mt merged mainline yesterday.)

Update to 1.0_rc4_p20100508. ffmpeg-mt revision 6abde3d, mplayer revision 31142.

ebuild synced with current portage live (9999) ebuild.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Fri May 21, 2010 1:33 pm    Post subject: Reply with quote

Update to 1.0_rc4_p20100521. ffmpeg-mt revision c91d7a2, mplayer revision
31188.

ebuild synced with current portage live (9999) ebuild.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sun May 30, 2010 6:20 pm    Post subject: Reply with quote

There was quite a bit of ffmpeg-mt Git activity since the last update.

Update to 1.0_rc4_p20100530. ffmpeg-mt revision 11b1a8e, mplayer revision
31288.
Back to top
View user's profile Send private message
truekaiser
l33t
l33t


Joined: 05 Mar 2004
Posts: 753

PostPosted: Sun Jun 06, 2010 6:28 am    Post subject: Reply with quote

i am having a bit of problem with this version of mplayer. when playing ac3 audio it plays it so fast it makes people sound like chipmonks.
_________________
"My father rode a camel. I drive a car. My son flies a jet-plane. His son will ride a camel."
—Saudi saying
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sun Jun 06, 2010 6:38 am    Post subject: Reply with quote

truekaiser wrote:
i am having a bit of problem with this version of mplayer. when playing ac3 audio it plays it so fast it makes people sound like chipmonks.

To check whether this is related to ffmpeg-mt, rebuild with the "ffmpeg-mt" USE flag disabled:

USE="-ffmpeg-mt" emerge mplayer
Back to top
View user's profile Send private message
truekaiser
l33t
l33t


Joined: 05 Mar 2004
Posts: 753

PostPosted: Sun Jun 06, 2010 8:44 am    Post subject: Reply with quote

RealNC wrote:
truekaiser wrote:
i am having a bit of problem with this version of mplayer. when playing ac3 audio it plays it so fast it makes people sound like chipmonks.

To check whether this is related to ffmpeg-mt, rebuild with the "ffmpeg-mt" USE flag disabled:

USE="-ffmpeg-mt" emerge mplayer


edit: jumped the gun, got it to duplicate in normal non frontend mplayer by telling it to decode into 6 channels on both ffmpeg-mt enabled and non-ffmeg-mt enabled.
_________________
"My father rode a camel. I drive a car. My son flies a jet-plane. His son will ride a camel."
—Saudi saying
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Mon Jun 14, 2010 6:31 pm    Post subject: Reply with quote

mplayer-1.0_rc4_p20100614

Updated ffmpeg-mt (revision 5380fee) and mplayer (revision 31420.) Synced ebuild with current portage version.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sat Jun 26, 2010 6:20 pm    Post subject: Reply with quote

mplayer-1.0_rc4_p20100626

Updated ffmpeg-mt (revision 7e928f6) and mplayer (revision 31559.)

Temporarily removed "faad" USE flag and forced "--disable-faad" configure
switch since it only compiles with bundled faad2 library.
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5338

PostPosted: Sat Jun 26, 2010 7:21 pm    Post subject: Reply with quote

RealNC wrote:
mplayer-1.0_rc4_p20100626

Updated ffmpeg-mt (revision 7e928f6) and mplayer (revision 31559.)

Temporarily removed "faad" USE flag and forced "--disable-faad" configure
switch since it only compiles with bundled faad2 library.


that because ffmpeg has dropped the faad flag.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sun Jun 27, 2010 6:52 am    Post subject: Reply with quote

DaggyStyle wrote:
that because ffmpeg has dropped the faad flag.

As far as I can tell, that's because mplayer r31543 broke building with external faad2 library ("--disable-faad-internal"). Using "--disable-faad" means that ffmpeg takes over the decoding again (as was the default in the past anyway.)

It would be possible to use the bundled faad2 instead. But there's no really good reason to do that since ffmpeg does the job just fine (and probably better; mplayer switched to faad2 a while back just to get some feedback on how well it works.)
Back to top
View user's profile Send private message
zigzag2
n00b
n00b


Joined: 16 Nov 2004
Posts: 16
Location: No(r)way

PostPosted: Sun Jun 27, 2010 3:56 pm    Post subject: Reply with quote

hey guys, cant compile the 9999 build today, anyone tried?
get the following compile error:
Code:

/var/tmp/portage/media-video/ffmpeg-9999-r1/work/ffmpeg-9999/libavcodec/libavcodec.so: undefined reference to `ff_vp8dsp_init_x86'
/var/tmp/portage/media-video/ffmpeg-9999-r1/work/ffmpeg-9999/libavcodec/libavcodec.so: undefined reference to `ff_h264_pred_init_x86


Regards,
Chris
_________________
Best regards,
ZiGzAg
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sun Jun 27, 2010 3:59 pm    Post subject: Reply with quote

Wrong thread :P
Back to top
View user's profile Send private message
zigzag2
n00b
n00b


Joined: 16 Nov 2004
Posts: 16
Location: No(r)way

PostPosted: Sun Jun 27, 2010 4:20 pm    Post subject: Reply with quote

pleease? :)
Cant find any active thread for ffmpeg-mt, and this one kinda depends on it? :)

Chris :)
_________________
Best regards,
ZiGzAg
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5338

PostPosted: Sun Jun 27, 2010 5:48 pm    Post subject: Reply with quote

zigzag2 wrote:
hey guys, cant compile the 9999 build today, anyone tried?
get the following compile error:
Code:

/var/tmp/portage/media-video/ffmpeg-9999-r1/work/ffmpeg-9999/libavcodec/libavcodec.so: undefined reference to `ff_vp8dsp_init_x86'
/var/tmp/portage/media-video/ffmpeg-9999-r1/work/ffmpeg-9999/libavcodec/libavcodec.so: undefined reference to `ff_h264_pred_init_x86


Regards,
Chris

12 hours ago it compiled well, wait a few hours to days.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Wed Jul 21, 2010 3:05 am    Post subject: Reply with quote

mplayer-1.0_rc4_p20100718

Updated ffmpeg-mt (revision 8232490) and mplayer (revision 31749.)

Ebuild synced with portage.
Back to top
View user's profile Send private message
xibo
Apprentice
Apprentice


Joined: 21 Aug 2007
Posts: 152
Location: moving between kubuntu and ubuntu kde edition

PostPosted: Wed Jul 21, 2010 9:25 am    Post subject: Reply with quote

is there any major difference between these mplayer ebuilds and the ones from mplayer-uau ?
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Wed Jul 21, 2010 9:27 am    Post subject: Reply with quote

"uau" is the mplayer fork previously known as mplayer-git. This here is just official mplayer with ffmpeg-mt.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Mon Aug 02, 2010 4:24 am    Post subject: Reply with quote

mplayer-1.0_rc4_p20100802

Updated ffmpeg-mt (revision ff69da3) and mplayer (revision 31895.)
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Tue Aug 03, 2010 6:27 am    Post subject: Reply with quote

mplayer-1.0_rc4_p20100803

Small update. Fixes a bug in ffmpeg-mt affecting multithreading:

http://gitorious.org/~astrange/ffmpeg/ffmpeg-mt/commit/9ec9f0868de2df3d3448dec887e7440ebb006b27
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Thu Aug 12, 2010 6:23 pm    Post subject: Reply with quote

mplayer-1.0_rc4_p20100811

Updated ffmpeg-mt (revision 9e981c8) and mplayer (revision 31951.)
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Sat Sep 11, 2010 6:14 pm    Post subject: Reply with quote

mplayer-1.0_rc4_p20100910

Updated ffmpeg-mt (revision 0097d3b) and mplayer (revision 32128.)
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 133

PostPosted: Mon Sep 20, 2010 11:04 pm    Post subject: Reply with quote

Uhm... did you change overlay again?
I can't find it in multimedia overlay...
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Tue Sep 21, 2010 9:42 am    Post subject: Reply with quote

I don't have commit access to the overlay, Alex Alexander does the pushing. Either he's not around or didn't see the bugzilla email yet.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum