Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EMERGE] probleme avec libxcb-xlib.so.0 (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Thu Aug 27, 2009 7:28 pm    Post subject: [EMERGE] probleme avec libxcb-xlib.so.0 (résolu) Reply with quote

Salut les gars,

je suis passé hier en profil 10/Desktop au lieu de 2008/Desktop

a priori c juste un clone pour l'instant, mais en fait il doit y avoir des USEFLAGS en plus, j'ai lancé un emerge -uDNa world

j'ai eu une 30aine de paquets a mettre a jour, j'ai lancé ça à distance du boulot, je suis rentré et surprise!

freeze systme, je reboot, xorg ne démarre pas, je lance un revdep-rebuilg et j'obtient ça :

http://pastebin.com/m2880eefa

j'ai essayé de reinstaller a la main libxcb, je n'ai pas eu d'erreur, derrière j'ai fais un xcb-rebuilder.sh mais ça ne m'a pas aidé !

qd je lance un emerge -uDNa world maintenant il me propose ça :

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-server-1.5.3-r6  USE="sdl*"
[ebuild   R   ] net-nds/openldap-2.3.43  USE="minimal*"
[ebuild   R   ] dev-libs/pwlib-1.10.10-r1  USE="sdl*"
[ebuild   R   ] dev-lang/php-5.2.10  USE="spell* truetype*"
[ebuild   R   ] net-print/cups-1.3.10-r2  USE="ppds*"
[ebuild   R   ] net-fs/samba-3.0.33  USE="fam*"
[ebuild  N    ] net-wireless/bluez-utils-3.36  USE="alsa cups gstreamer usb -debug -examples -old-daemons -test-programs"
[ebuild   R   ] media-sound/easytag-2.1.6-r2  USE="mp4*"
[ebuild   R   ] media-libs/swfdec-0.8.4  USE="gstreamer*"
[ebuild   R   ] gnome-base/gvfs-1.0.3-r2  USE="bluetooth*"
[ebuild   R   ] media-libs/libcanberra-0.11  USE="gstreamer*"
[ebuild   R   ] media-sound/pulseaudio-0.9.9-r54  USE="bluetooth*"
[ebuild   R   ] media-video/mjpegtools-1.9.0  USE="sdl*"
[ebuild   R   ] x11-libs/wxGTK-2.8.10.1-r1  USE="gstreamer* sdl*"
[ebuild   R   ] app-editors/gedit-2.24.3  USE="spell*"
[ebuild   R   ] x11-libs/wxGTK-2.6.4.0-r5  USE="sdl*"
[ebuild   R   ] media-video/gpac-0.4.4-r1  USE="sdl* truetype*"
[ebuild   R   ] gnome-base/gnome-vfs-2.24.1  USE="fam*"
[ebuild   R   ] media-libs/xine-lib-1.1.16.3-r1  USE="sdl* truetype*"
[ebuild   R   ] net-libs/xulrunner-1.9.0.13  USE="startup-notification*"
[ebuild   R   ] www-client/mozilla-firefox-3.0.13  USE="startup-notification*"
[ebuild   R   ] gnome-extra/bug-buddy-2.24.2  USE="eds*"
[ebuild   R   ] net-voip/ekiga-2.0.12  USE="sdl*"
[ebuild   R   ] media-video/totem-2.24.3  USE="bluetooth*"
[ebuild   R   ] net-im/kadu-0.6.5.2-r3  USE="spell*"
[ebuild   R   ] gnome-base/gnome-settings-daemon-2.24.1-r1  USE="gstreamer*"
[ebuild   R   ] x11-misc/notification-daemon-0.4.0  USE="gstreamer*"
[ebuild   R   ] net-irc/xchat-2.8.6-r1  USE="spell*"
[ebuild   R   ] www-client/epiphany-2.24.3-r10  USE="spell*"
[ebuild   R   ] gnome-base/gnome-panel-2.24.3-r1  USE="eds*"
[ebuild   R   ] media-gfx/imagemagick-6.5.2.9  USE="truetype*"
[ebuild   R   ] media-video/vlc-1.0.1  USE="sdl* truetype*"
[ebuild   R   ] media-libs/gegl-0.0.22  USE="sdl*"
[ebuild   R   ] gnome-base/gnome-control-center-2.24.0.1  USE="eds*"
[ebuild   R   ] gnome-base/gnome-applets-2.24.3.1  USE="acpi* gstreamer*"
[ebuild   R   ] gnome-extra/deskbar-applet-2.24.3  USE="eds* spell*"
[ebuild   R   ] gnome-base/gdm-2.20.9-r1  USE="branding*"

Would you like to merge these packages? [Yes/No]


et ça crash direct a nouveau a cause de libxcb...

je ne m'en sors pas, quelqu'un peut il me tirer de se mauvais pas?

Merci les gars !


Last edited by gregool on Fri Aug 28, 2009 6:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Aug 27, 2009 8:03 pm    Post subject: Reply with quote

Oui, il suffit de suivre un peu la ML quand on utilise un nouveau profil :p

Toute la procédure est là :
http://thread.gmane.org/gmane.linux.gentoo.devel/62766

Quote:
1) make sure that /usr/lib/libxcb-xlib.* are gone. Portage 2.2_rc* users
_should_ remove it as well.

2) run /usr/portage/x11-libs/libxcb/files/xcb-rebuilder.sh to fix .la
files. If the tool reports broken packages, please read on. If not,
lucky you, your system is ready to go :)

3) run the following one liner to rebuild a simple, yet effective,
subset of potentially broken packages. Do not worry, packages you don't
have installed will not be installed.

emerge --oneshot --nodeps \
$(for i in x11-proto/ x11-libs/libxcb x11-libs/libX11 x11-libs/libXext \
x11-libs/libX x11-libs/xcb-util x11-libs/cairo \
x11-libs/pango x11-libs/gtk+ gnome-base/libgnomeui \
x11-libs/qt-gui; do \
qlist -IC $i; \
done) -pv

4) use revdep-rebuild (from app-portage/gentoolkit) to finish fixing the
rest of your system.

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Thu Aug 27, 2009 9:29 pm    Post subject: Reply with quote

merci pour ta réponse, j'y vois un peu plus clair, j'avais cru lire que la bascule était transparente puisque les profils etaient pour l'instant identiques.

donc j'ai suivi la procédure, plus de /usr/lib/libxcb-xlib.*

je lance xcb-rebuilder.sh qui me signale ça: http://pastebin.com/m3b90a519

je lance la commande suivante et ça crash au niveau de libX11-1.1.5 qui se plaint de s'absence de libxcb-1.4 qui vient pourtant d'être installé

cf log http://pastebin.com/m6583e82b

c'est peut etre moi qui suis completement idiot pour le coup, si c'est le cas désolé.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Aug 27, 2009 9:47 pm    Post subject: Reply with quote

Essaye de sauter le 3 et de passer direct au 4
A priori, ça doit marcher pareil, et ne pas poser de problème !
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Fri Aug 28, 2009 6:46 am    Post subject: Reply with quote

j'avais essayé de reprendre au revdep-rebuild, mais ça commence par x11-libs/libX11-1.1.5 et donc ça coince de la même façon.

mon pb c'est que ce paquet ne trouve pas xcb-xlib, donc apres la reinstallation de x11-libs/libxcb-1.4 je lance un ls /usr/lib | grep xcb

j'obtient ça :
Code:
libX11-xcb.a
libX11-xcb.la
libX11-xcb.so
libX11-xcb.so.1
libX11-xcb.so.1.0.0
libxcb-atom.a
libxcb-atom.la
libxcb-atom.so
libxcb-atom.so.1
libxcb-atom.so.1.0.0
libxcb-aux.a
libxcb-aux.la
libxcb-aux.so
libxcb-aux.so.0
libxcb-aux.so.0.0.0
libxcb-composite.a
libxcb-composite.la
libxcb-composite.so
libxcb-composite.so.0
libxcb-composite.so.0.0.0
libxcb-damage.a
libxcb-damage.la
libxcb-damage.so
libxcb-damage.so.0
libxcb-damage.so.0.0.0
libxcb-dpms.a
libxcb-dpms.la
libxcb-dpms.so
libxcb-dpms.so.0
libxcb-dpms.so.0.0.0
libxcb-event.a
libxcb-event.la
libxcb-event.so
libxcb-event.so.1
libxcb-event.so.1.0.0
libxcb-glx.a
libxcb-glx.la
libxcb-glx.so
libxcb-glx.so.0
libxcb-glx.so.0.0.0
libxcb-icccm.a
libxcb-icccm.la
libxcb-icccm.so
libxcb-icccm.so.1
libxcb-icccm.so.1.0.0
libxcb-image.a
libxcb-image.la
libxcb-image.so
libxcb-image.so.0
libxcb-image.so.0.0.0
libxcb-keysyms.a
libxcb-keysyms.la
libxcb-keysyms.so
libxcb-keysyms.so.0
libxcb-keysyms.so.0.0.0
libxcb-property.a
libxcb-property.la
libxcb-property.so
libxcb-property.so.1
libxcb-property.so.1.0.0
libxcb-randr.a
libxcb-randr.la
libxcb-randr.so
libxcb-randr.so.0
libxcb-randr.so.0.1.0
libxcb-record.a
libxcb-record.la
libxcb-record.so
libxcb-record.so.0
libxcb-record.so.0.0.0
libxcb-render-util.a
libxcb-render-util.la
libxcb-render-util.so
libxcb-render-util.so.0
libxcb-render-util.so.0.0.0
libxcb-render.a
libxcb-render.la
libxcb-render.so
libxcb-render.so.0
libxcb-render.so.0.0.0
libxcb-reply.a
libxcb-reply.la
libxcb-reply.so
libxcb-reply.so.1
libxcb-reply.so.1.0.0
libxcb-res.a
libxcb-res.la
libxcb-res.so
libxcb-res.so.0
libxcb-res.so.0.0.0
libxcb-screensaver.a
libxcb-screensaver.la
libxcb-screensaver.so
libxcb-screensaver.so.0
libxcb-screensaver.so.0.0.0
libxcb-shape.a
libxcb-shape.la
libxcb-shape.so
libxcb-shape.so.0
libxcb-shape.so.0.0.0
libxcb-shm.a
libxcb-shm.la
libxcb-shm.so
libxcb-shm.so.0
libxcb-shm.so.0.0.0
libxcb-sync.a
libxcb-sync.la
libxcb-sync.so
libxcb-sync.so.0
libxcb-sync.so.0.0.0
libxcb-wm.a
libxcb-wm.la
libxcb-wm.so
libxcb-wm.so.0
libxcb-wm.so.0.0.0
libxcb-xevie.a
libxcb-xevie.la
libxcb-xevie.so
libxcb-xevie.so.0
libxcb-xevie.so.0.0.0
libxcb-xf86dri.a
libxcb-xf86dri.la
libxcb-xf86dri.so
libxcb-xf86dri.so.0
libxcb-xf86dri.so.0.0.0
libxcb-xfixes.a
libxcb-xfixes.la
libxcb-xfixes.so
libxcb-xfixes.so.0
libxcb-xfixes.so.0.0.0
libxcb-xinerama.a
libxcb-xinerama.la
libxcb-xinerama.so
libxcb-xinerama.so.0
libxcb-xinerama.so.0.0.0
libxcb-xinput.a
libxcb-xinput.la
libxcb-xinput.so
libxcb-xinput.so.0
libxcb-xinput.so.0.0.0
libxcb-xprint.a
libxcb-xprint.la
libxcb-xprint.so
libxcb-xprint.so.0
libxcb-xprint.so.0.0.0
libxcb-xtest.a
libxcb-xtest.la
libxcb-xtest.so
libxcb-xtest.so.0
libxcb-xtest.so.0.0.0
libxcb-xv.a
libxcb-xv.la
libxcb-xv.so
libxcb-xv.so.0
libxcb-xv.so.0.0.0
libxcb-xvmc.a
libxcb-xvmc.la
libxcb-xvmc.so
libxcb-xvmc.so.0
libxcb-xvmc.so.0.0.0
libxcb.a
libxcb.la
libxcb.so
libxcb.so.1
libxcb.so.1.1.0


à priori il n'y a pas de libxcb-xlib ...

yaurait-il un autre paquet nécessaire pour voir la lib arriver dans /usr/lib ?

merci en tout cas
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7937
Location: ~Brussels - Belgique

PostPosted: Fri Aug 28, 2009 6:48 am    Post subject: Reply with quote

Salut,

Si tu as installé elogv, regarde le message lié à l'emerge de xcb.
Il a installé un xcb-update.sh (de mémoire, à vérifier), qui va corriger son "install au bazooka" ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Fri Aug 28, 2009 7:28 am    Post subject: Reply with quote

gregool wrote:
à priori il n'y a pas de libxcb-xlib ...

yaurait-il un autre paquet nécessaire pour voir la lib arriver dans /usr/lib ?

Bah oui, c'est normal qu'il n'y ait plus de libxcb-xlib !
Relis bien le point 1 du mail que j'ai copié plus haut : s'assurer que libxcb-xlib a bien été supprimé ;)


Bizarre que ton libX11 en ait besoin. Je n'ai eu aucun problème pour faire ce nettoyage...

[EDIT]
AHHHH MAIS !!!!!!
Voila, j'ai compris ! tu est en stable !!
C'est pas bon en stable : libX11-1.1.5 est trop vieux. Il faut impérativement libX11-1.2.x avec libxcb-1.4 !

C'est bizarre que tu ais le libxcb en ~arch et pas libX11 de ~arch... Tu as traffiqué quelquechose dans les keywords ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Fri Aug 28, 2009 10:44 am    Post subject: Reply with quote

merci guilc !

je suis le seul responsable de ce merdier, j'ai effectivement tildarché libxcb sans faire de meme avec libX11.

je me ne souviens plus de quand ni pourquoi j'ai eu a faire ça, mais ça ne date pas d'hier

me voila donc rattrapé doucement mais surement par le retour du baton du démasquage à la fronde.

le revdep-rebuild suit son cours, je flag résolu à la fin si tout marche!

merci encore !
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Fri Aug 28, 2009 6:46 pm    Post subject: Reply with quote

résolu...

sauf compiz qui ne se lance plus toussa toussa, mais plus de pb avec libxcb !

merci guilc
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum