Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu] [X] startx ne démarre pas - écran noir et plantage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Fri Aug 28, 2009 6:58 am    Post subject: [Résolu] [X] startx ne démarre pas - écran noir et plantage Reply with quote

Bonjour à toute la communauté Gentooienne (les francophones en particuliers ;) ), perso je suis nouveau dedans, et en lisant quelques topics sur ce forum, j'en ai une très bonne impression (je déteste quand je fais une recherche et que je tombe sur quelqu'un qui a exactement le même problème que moi mais à qui personne ne s'est même pas donné la peine de répondre, de poser une question, de proposer une idée, etc.).

Mon problème : je viens d'installer Gentoo, j'ai commencé il y a deux mois (je prends mon temps ^^ ), et X ne veut pas démarrer.
J'ai une carte ATI Radeon X600 Pro (RV380).

Il y a ensuite trois cas :

- Ou bien je prend le driver vga, et dans ce cas c'est l'écran noir total, tout plante, je n'ai plus aucun moyen de retourner au shell (hormis en appuyant sur le Reset)
- Ou bien je prend le driver libre radeon, et dans ce cas X essaye de se lancer mais n'y arrive pas et me renvoi une erreur.
- J'imagine que le mieux serait de prendre le driver proprio fglrx mais visiblement je ne peux pas l'installer, il est maqué. Et quand je regarde les raisons, ce sont "~amd64" (pas stable pour l'architecture amd64, si j'ai bien pigé le code), et j'aimerais bien savoir pourquoi :o Avant j'étais sous Debian, j'utilisais fglrx et je n'ai jamais eu de bug o_O

Voilà, merci d'avance pour votre aide :)

PS : je poste juste après les logs et ma config.
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---


Last edited by Saimoun on Tue Sep 01, 2009 9:44 am; edited 1 time in total
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Fri Aug 28, 2009 7:54 am    Post subject: Reply with quote

Voilà mon xorg.conf (dans le cas où j'ai mis le driver radeon) :
(j'ai supprimé les comentaires pour alléger)

Code:

# File generated by xorgconfig.                       

# [...]                                     

                                                               
Section "Module"                                                       

# This loads the DBE extension module.

    Load        "dbe"   # Double buffer extension

# [...]
    SubSection  "extmod"                                         
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection                                                       

# This loads the font modules
#    Load        "type1"     
#    Load        "freetype" 
#    Load        "xtt"       

# This loads the GLX module
#    Load       "glx"     
# This loads the DRI module
#    Load       "dri"     

EndSection

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set     
# **********************************************************************

Section "Files"

# [...]                                                               

    FontPath   "/usr/share/fonts/misc/"
#    FontPath   "/usr/share/fonts/TTF/"
#    FontPath   "/usr/share/fonts/OTF"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/75dpi/"
# [...]

# The module search path.  The default path is shown here.

#    ModulePath "/usr/lib/modules"

EndSection

# **********************************************************************
# Server flags section.                                                 
# **********************************************************************

Section "ServerFlags"
# [...]

#    Option "NoTrapSignals"

# [...]                                                       

#    Option "DontVTSwitch"

# Uncomment this to disable the <Ctrl><Alt><BS> server abort sequence
# This allows clients to receive this key event.                     

#    Option "DontZap"

# [...]

#    Option "Dont Zoom"

# [...]                                 

#    Option "DisableVidModeExtension"

# Uncomment this to enable the use of a non-local xvidtune client.

#    Option "AllowNonLocalXvidtune"

# Uncomment this to disable dynamically modifying the input device
# (mouse and keyboard) settings.                                 

#    Option "DisableModInDev"

# Uncomment this to enable the use of a non-local client to
# change the keyboard or mouse settings (currently only xset).

#    Option "AllowNonLocalModInDev"

EndSection

# **********************************************************************
# Input devices                                                         
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section                                   
# **********************************************************************

Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"     

    Option "AutoRepeat" "500 30"

# [...]

    Option "XkbRules"   "xorg"
    Option "XkbModel"   "logicd"
    Option "XkbLayout"  "fr"   

EndSection


# **********************************************************************
# Core Pointer's InputDevice section                                   
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "Auto" # Auto detect
    Option "Device"      "/dev/input/mice"   

# Mouse-speed setting for PS/2 mouse.

#    Option "Resolution"        "256"
# [...]     

#    Option "BaudRate"  "9600"
#    Option "SampleRate"        "150"

# [...]                                                       

    Option "ZAxisMapping"   "4 5 6 7"
# [...]

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

EndSection


# [...]                                                     

# **********************************************************************
# Monitor section                                                       
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "Ecran"

# [...]                   

#    HorizSync   31.5 - 64.3

#    HorizSync  30-64         # multisync
#    HorizSync  31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync  15-25, 30-50  # multiple ranges of sync frequencies

# [...]                       

#    VertRefresh 50-70

EndSection


# **********************************************************************
# Graphics device section                                               
# **********************************************************************

# Any number of graphics device sections may be present

# Standard VGA Device:

Section "Device"
    Identifier  "Standard VGA"
    VendorName  "Unknown"     
    BoardName   "Unknown"     

# [...]

#    Chipset    "generic"

# [...]

    Driver     "vga"
# [...]                                                         

#    BusID      "PCI:0:10:0"

#    VideoRam   256

#    Clocks     25.2 28.3

EndSection

# Device configured by xorgconfig:

Section "Device"
    Identifier  "ATI Radeon X600 Pro"
    Driver      "radeon"               
        # unsupported card           
    #VideoRam    131072             
    # Insert Clocks lines here if appropriate
EndSection                                   


# **********************************************************************
# Screen sections                                                       
# **********************************************************************

# [...]                                                       
Section "Screen"                                                         
    Identifier  "Screen 1"                                               
    Device      "ATI Radeon X600 Pro"                                   
    Monitor     "Ecran"                                                 
    DefaultDepth 24                                                     

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
EndSection

# **********************************************************************
# ServerLayout sections.
# **********************************************************************

# [...]

Section "ServerLayout"

# The Identifier line must be present
    Identifier  "Simple Layout"

# [...]

    Screen "Screen 1"

# [...]

    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

# Section "DRI"
#    Mode 0666
# EndSection


Et voilà le log dans le cas où j'utilise le driver vga (je remplace la ligne
Device "ATI Radeon X600 Pro"
par
Device "Standard VGA"
) :

Code:

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.29-gentoo-r5 x86_64
Current Operating System: Linux gentux 2.6.30-gentoo-r4 #3 Fri Aug 7 23:04:36 CEST 2009 x86_64                                                                 
Build Date: 02 August 2009  11:16:47PM                                         
                                                                               
        Before reporting problems, check http://wiki.x.org                     
        to make sure that you have the latest version.                         
Markers: (--) probed, (**) from config file, (==) default setting,             
        (++) from command line, (!!) notice, (II) informational,               
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.           
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 28 08:16:28 2009           
(==) Using config file: "/etc/X11/xorg.conf"                                   
(==) ServerLayout "Simple Layout"                                               
(**) |-->Screen "Screen 1" (0)                                                 
(**) |   |-->Monitor "Ecran"                                                   
(**) |   |-->Device "Standard VGA"                                             
(**) |-->Input Device "Mouse1"                                                 
(**) |-->Input Device "Keyboard1"                                               
(==) Not automatically adding devices                                           
(==) Not automatically enabling devices                                         
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".         
        Entry deleted from font path.                                           
        (Run 'mkfontdir' on "/usr/share/fonts/misc/").                         
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".         
        Entry deleted from font path.                                           
        (Run 'mkfontdir' on "/usr/share/fonts/misc/").                         
(WW) The directory "/usr/share/fonts/TTF/" does not exist.                     
        Entry deleted from font path.                                           
(WW) The directory "/usr/share/fonts/OTF" does not exist.                       
        Entry deleted from font path.                                           
(**) FontPath set to:                                                           
        /usr/share/fonts/Type1/,                                               
        /usr/share/fonts/100dpi/,                                               
        /usr/share/fonts/75dpi/,                                               
        /usr/share/fonts/Type1/,                                               
        /usr/share/fonts/100dpi/,                                               
        /usr/share/fonts/75dpi/,                                               
        built-ins                                                               
(==) ModulePath set to "/usr/lib64/xorg/modules"                               
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)       
(II) No APM support in BIOS or kernel                                           
(II) Loader magic: 0x3e00                                                       
(II) Module ABI versions:                                                       
        X.Org ANSI C Emulation: 0.4                                             
        X.Org Video Driver: 4.1                                                 
        X.Org XInput driver : 2.1                                               
        X.Org Server Extension : 1.1                                           
(II) Loader running on linux                                                   
(--) using VT number 7                                                         

(--) PCI:*(0@5:0:0) ATI Technologies Inc RV380 [Radeon X600 (PCIE)] rev 0, Mem @ 0xd8000000/134217728, 0xfd7f0000/65536, I/O @ 0x00006c00/256, BIOS @ 0x????????/131072                                                                         
(--) PCI: (0@5:0:1) ATI Technologies Inc RV380 [Radeon X600] rev 0, Mem @ 0xfd7e0000/65536                                                                     
(II) System resource ranges:                                                   
        [0] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]                     
        [1] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]                 
        [2] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]                 
        [3] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]                 
        [4] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]                     
        [5] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]                 
        [6] -1  0       0x000c0000 - 0x000effff (0x30000) MX[B]                 
        [7] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[B]                 
        [8] -1  0       0xffffffff - 0xffffffff (0x1) MX[B]                     
        [9] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[B]                 
        [10] -1 0       0x000c0000 - 0x000effff (0x30000) MX[B]                 
        [11] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[B]                 
        [12] -1 0       0xffffffff - 0xffffffff (0x1) MX[B]                     
        [13] -1 0       0x000f0000 - 0x000fffff (0x10000) MX[B]                 
        [14] -1 0       0x000c0000 - 0x000effff (0x30000) MX[B]                 
        [15] -1 0       0x00000000 - 0x0009ffff (0xa0000) MX[B]                 
        [16] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]                     
        [17] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]                     
        [18] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]                     
        [19] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]                     
        [20] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]                     
        [21] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]                     
        [22] -1 0       0x0000ffff - 0x0000ffff (0x1) IX[B]                     
        [23] -1 0       0x00000000 - 0x00000000 (0x1) IX[B]                     
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.                                                               
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.                                                                   
(II) "glx" will be loaded by default.                                           
(II) "record" will be loaded by default.                                       
(II) "dri" will be loaded by default.                                           
(II) LoadModule: "dbe"                                                         

(II) Loading /usr/lib64/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"               
        compiled for 1.5.3, module version = 1.0.0       
        Module class: X.Org Server Extension             
        ABI class: X.Org Server Extension, version 1.1   
(II) Loading extension DOUBLE-BUFFER                     
(II) LoadModule: "extmod"                                 

(II) Loading /usr/lib64/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"               
        compiled for 1.5.3, module version = 1.0.0           
        Module class: X.Org Server Extension                 
        ABI class: X.Org Server Extension, version 1.1       
(II) Loading extension SHAPE                                 
(II) Loading extension MIT-SUNDRY-NONSTANDARD               
(II) Loading extension BIG-REQUESTS                         
(II) Loading extension SYNC                                 
(II) Loading extension MIT-SCREEN-SAVER                     
(II) Loading extension XC-MISC                               
(II) Loading extension XFree86-VidModeExtension             
(II) Loading extension XFree86-Misc                         
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"

(II) Loading /usr/lib64/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        ABI class: X.Org Server Extension, version 1.1
(==) AIGLX enabled
(==) Exporting typical set of GLX visuals
(II) Loading extension GLX
(II) LoadModule: "record"

(II) Loading /usr/lib64/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension RECORD
(II) LoadModule: "dri"

(II) Loading /usr/lib64/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.0.0
        ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "vga"

(II) Loading /usr/lib64/xorg/modules/drivers//vga_drv.so
(II) Module vga: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 4.1.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 4.1
(II) LoadModule: "mouse"

(II) Loading /usr/lib64/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.4.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(II) LoadModule: "kbd"

(II) Loading /usr/lib64/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.3.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(II) VGA: Generic VGA driver (version 4.1) for chipsets: generic
(II) Primary Device is: PCI 05@00:00:0
(WW) Falling back to old probe method for vga


Enfin à part ça y'a du nouveau, je me suis penché un peu plus sur le paquet ati-drivers (les drivers proprio), et j'avoue que j'avais peu ou pas lu, y'a un message qui explique pourquoi le paquet est masqué :

Quote:
AMD is dropping support for graphic chips R500 and older. See [1] for a
complete list of chips and cards supported by the new ati-drivers.

Because of this, and the binary nature of the driver, all old drivers are going
to be masked and only the latest versions released from AMD are going to be
stabilised and supported by Gentoo.

This means that all older chipsets are going to be unsupported by the
ati-drivers package. For those of you who are not right now chewing your
card in anger, the migration guide [2] will be useful, which describes
migration from x11-drivers/ati-drivers to x11-drivers/xf86-video-ati driver,
which should support all versions of the Radeon cards [3].


[1] http://www2.ati.com/drivers/linux/catalyst_96_linux.pdf
[2] http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
[3] http://www.x.org/wiki/radeon


Du coup, j'ai installé le paquet xf86-video-ati, et en lançant X avec startx après avoir installé ce paquet, ça marche !

Par contre, j'ai beau avoir installé kdebase, il ne lance pas KDE...
J'imagine que ça vient du fait que je n'ai pas installé KDM, mais visiblement je ne peux pas l'installer : il est bloqué par le paquet kdebase (j'en avais déduis que kdm était inclus dans kdebase... mais apparemment ce n'est pas le cas) :
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Fri Aug 28, 2009 9:51 am    Post subject: Reply with quote

Saimoun wrote:
Par contre, j'ai beau avoir installé kdebase, il ne lance pas KDE...
J'imagine que ça vient du fait que je n'ai pas installé KDM, mais visiblement je ne peux pas l'installer : il est bloqué par le paquet kdebase (j'en avais déduis que kdm était inclus dans kdebase... mais apparemment ce n'est pas le cas) :

Pour mémoire, kdm n'est qu'un "login manager" et n'est absolument pas indispensable pour démarrer kde.
Tu peux parfaitement en utiliser un autre ou même t'en passer complètement.
Dans ce dernier cas, il suffit d'utiliser startx après avoir configuré ton ~/.xinitrc ou positionné la variable XSESSION à un des noms de fichiers trouvé dans /etc/X/Sessions

Pour ce qui est de l'installation de kde, pourrais-tu dire quels paquets tu as installé exactement ?
En effet, si tu as réellement installé kde-base/kdebase-3.5.9*, il s'agit d'un paquet de la version monolithique aujourd'hui obsolète.
Comme tu viens de Debian, tu ne verras sûrement pas d'inconvénient à ce que je te renvoie vers un peu de doc ?
:arrow: ici, ici et ici
;)
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Fri Aug 28, 2009 10:19 am    Post subject: Reply with quote

Quote:
Comme tu viens de Debian, tu ne verras sûrement pas d'inconvénient à ce que je te renvoie vers un peu de doc ?


Du tout, au contraire ^^
J'avoue que j'avais suivi la Doc jusqu'au lancement de X, et comme je voulais juste tester si X marchait ou non, j'ai fait "emerge kdebase" sans regarder ce qu'il fallait installer.
Faut que je le désinstalle ?

Enfin bref, je vais lire tout ce que tu m'as donné, et je vous donne des nouvelles ;)

Merci pour ta réponse.

Quelqu'un pourrait m'en dire plus sur les drivers ATI (c'est quand même le sujet de départ), m'expliquer pourquoi avec le driver radeon ça marche (avec le paquet xf86-video-ati) et pourquoi je n'ai pas le droit d'utiliser fglrx ?
Dans la Doc, il ya une "vraie" page pour les NVidia, tandis que pour les ATI, il n'y a qu'une FAQ...
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8123
Location: ~Brussels - Belgique

PostPosted: Fri Aug 28, 2009 10:26 am    Post subject: Reply with quote

Salut,

Pour les drivers ATI, il y a un sujet dans le forum... navigue ses dernières pages pour les dernières nouvelles ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Sun Aug 30, 2009 8:38 pm    Post subject: Reply with quote

Je commence mes lectures demain (Doc + Sujet ATI) et je vous tiens au courant.

En ce qui concerne le sujet ATI, il s'agit bien de celui-là : https://forums.gentoo.org/viewtopic-t-580403.html ?
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Mon Aug 31, 2009 7:41 pm    Post subject: Reply with quote

Ca y est, j'ai tout suivi, j'ai enfin pu démarrer KDE :)

Par contre, comme je ne voulais pas tout recompiler, je n'ai pas désintallé le paquet kdebase pour réinstaller kdebase-startkde (comme indiqué dans la Doc), mais du coup (enfin peut-être que ça ne vient pas de ça, j'en sais rien) je ne peux installer aucun paquet kde !!

Ils sont tous bloqués par le paquet kdebase !

Quelqu'un a une idée d'où ça vient et de comment faire pour arranger ça ?
PS : Si vous voulez le log, dîtes-le moi, je le recopierai à la main (je n'ai pas réussi à le recopier via l'ordi je n'ai pas Konsole et quand je fais "emerge truc > fichier.txt", ça ne met que la première ligne du renvoi dans "fichier.txt")

EDIT : non en fait, j'ai bien Konsole, je ne l'avais tout simplement pas vu ^^
Voici le log :
Code:

gentux saimoun # emerge kdm
Calculating dependencies... done!
[ebuild  N    ] x11-misc/shared-mime-info-0.60
[ebuild  N    ] dev-util/desktop-file-utils-0.15  USE="-emacs"
[ebuild  N    ] x11-misc/xdg-utils-1.0.2-r3  USE="-doc"
[ebuild     U ] kde-base/kdelibs-3.5.10-r6 [3.5.9-r4]
[ebuild  N    ] kde-base/libkonq-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kdialog-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kdebase-data-3.5.10  USE="-debug"
[ebuild  N    ] kde-base/kcheckpass-3.5.10  USE="pam -debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kcminit-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kdesu-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/khotkeys-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kmenuedit-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kdebase-kioslaves-3.5.10-r1  USE="-debug -hal -kdehiddenvisibility -ldap -openexr -samba"
[ebuild  N    ] kde-base/kdepasswd-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kfind-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kicker-3.5.10-r1  USE="-debug -kdehiddenvisibility -xcomposite"
[ebuild  N    ] kde-base/khelpcenter-3.5.10  USE="-debug -kdehiddenvisibility"
[ebuild  N    ] kde-base/kcontrol-3.5.10  USE="arts -debug -ieee1394 -joystick -kdehiddenvisibility -logitech-mouse -opengl"
[ebuild  N    ] kde-base/konqueror-3.5.10  USE="-branding -debug -java -kdehiddenvisibility"
[ebuild  N    ] kde-base/kdesktop-3.5.10  USE="-debug -kdehiddenvisibility -xscreensaver"
[ebuild  N    ] kde-base/kdm-3.5.10  USE="pam -debug -kdehiddenvisibility"
[blocks B     ] kde-base/kdepasswd:3.5 ("kde-base/kdepasswd:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdebase-kioslaves:3.5 ("kde-base/kdebase-kioslaves:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/libkonq:3.5 ("kde-base/libkonq:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdebase-data:3.5 ("kde-base/kdebase-data:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kcheckpass:3.5 ("kde-base/kcheckpass:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] =kde-base/kdebase-3.5* ("=kde-base/kdebase-3.5*" is blocking kde-base/kmenuedit-3.5.10, kde-base/kdialog-3.5.10, kde-base/kdebase-kioslaves-3.5.10-r1, kde-base/kicker-3.5.10-r1, kde-base/kcheckpass-3.5.10, kde-base/kdesktop-3.5.10, kde-base/kcminit-3.5.10, kde-base/kfind-3.5.10, kde-base/kdebase-data-3.5.10, kde-base/kdm-3.5.10, kde-base/kdesu-3.5.10, kde-base/konqueror-3.5.10, kde-base/khotkeys-3.5.10, kde-base/khelpcenter-3.5.10, kde-base/libkonq-3.5.10, kde-base/kcontrol-3.5.10, kde-base/kdepasswd-3.5.10)
[blocks B     ] kde-base/kdm:3.5 ("kde-base/kdm:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdialog:3.5 ("kde-base/kdialog:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kfind:3.5 ("kde-base/kfind:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kcontrol:3.5 ("kde-base/kcontrol:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kicker:3.5 ("kde-base/kicker:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdesu:3.5 ("kde-base/kdesu:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdebase ("kde-base/kdebase" is blocking kde-base/kdelibs-3.5.10-r6)
[blocks B     ] kde-base/kmenuedit:3.5 ("kde-base/kmenuedit:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/khelpcenter:3.5 ("kde-base/khelpcenter:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kdesktop:3.5 ("kde-base/kdesktop:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/konqueror:3.5 ("kde-base/konqueror:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/khotkeys:3.5 ("kde-base/khotkeys:3.5" is blocking kde-base/kdebase-3.5.9-r4)
[blocks B     ] kde-base/kcminit:3.5 ("kde-base/kcminit:3.5" is blocking kde-base/kdebase-3.5.9-r4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'kde-base/kdm-3.5.10', 'merge') pulled in by
    kdm

  ('installed', '/', 'kde-base/kdebase-3.5.9-r4', 'nomerge') pulled in by
    kde-base/kdebase required by world

_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Mon Aug 31, 2009 8:01 pm    Post subject: Reply with quote

Hello,
ben je dirais que ce qu'il t'arrive est correcte :)
Tu ne veux pas désinstaller le paquet obsolete monolithique de kdebase pour kdebase-starkde ou kdebase-meta, donc les problèmes rencontrés ici sont normal ;)
D'ailleurs, tu remarqueras que la version monolithique n'est plus à jour (v3.5.9 et l'autre v3.5.10..)
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
Saimoun
n00b
n00b


Joined: 28 Aug 2009
Posts: 70
Location: Evry

PostPosted: Tue Sep 01, 2009 9:43 am    Post subject: Reply with quote

Autant pour moi je n'avais pas lu la page de la Doc sur les e-builds séparés de KDE.

Tout marche nickel, là :D (j'ai tout réinstallé KDE)

Je suis à 2000 FPS sur glxgears, autant que je m'en rappelle je montais à 3500 avec le driver proprio (fglrx) mais bon, ça ira je pense (je ne joue pas à des jeux 3D ultra récents, quoi :p ).

Merci à tous !
_________________
Saimoun, nouveau dans le monde de Gentoo :)

--- Espace perso : http://www.saimoun.fr/ ---
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Tue Sep 01, 2009 10:57 am    Post subject: Reply with quote

Saimoun wrote:
Autant pour moi je n'avais pas lu la page de la Doc sur les e-builds séparés de KDE.

C'est peut-être de ma faute : je ne t'ai pas mis les liens dans le bon ordre ! ;) :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum