Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kdm] plus aucune réaction (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sun Aug 30, 2009 10:02 am    Post subject: [kdm] plus aucune réaction (résolu) Reply with quote

Bonjour,

Je démarre mon ordinateur ce matin et, surprise, plus rien ne réagit. J'arrive sous kdm pour m'identifier mais la souris et le clavier ne réagissent pas et je ne crois pas avoir vu de message d'erreur pendant le démarrage. Je redémarre donc mon ordinateur (puisque même alt+ctrl+Fx ne marche pas) sous Fedora, où tout fonctionne. Je monte la partition de Gentoo pour essayer de trafiquer un peu mais même en remettant un ancien kernel, qui marchait, toujours aucune réaction. Serait-il possible que le problème vienne du fait que de nouvelles sources du noyau ont été téléchargées hier mais que je n'ai pas pris le temps de compiler? J'ai vérifier, /usr/src/linux pointe toujours vers les anciennes sources (2.6.30-gentoo-r4 de mémoire) mais dans /usr/src j'ai -r4 et aussi -r5. Si le problème vient de là, comment je peux faire?

Je vous remercie par avance de votre aide,

Kevin57


Last edited by Kevin57 on Sun Aug 30, 2009 1:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Sun Aug 30, 2009 10:06 am    Post subject: Reply with quote

Toi, tu as l'air d'avoir mis à jour Xorg sans t'en rendre compte...
Fais une recherche sur le fofo à ce sujet.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sun Aug 30, 2009 10:10 am    Post subject: Reply with quote

C'est possible, j'ai fait un emerge --update --deep --newuse world sans penser à lui ajouter --pretend avant... Je vais voir sur le forum si je trouve quelque chose!

Edit : je pense avoir trouvé quelque chose qui peut m'aider sur ce topic . En effet j'ai ajouté le useflag hal avant ma mise à jour, donc il se pourrait que xorg se soit recompilé en fonction. Si j'ai bien compris, il faudrait que j'utilise evdev pour que ça marche, mais comment savoir si je l'utilise vu que je n'arrive plus à rien faire sous Gentoo? En gros, il faudrait empêcher kdm de se lancer automatiquement, mais je ne sais pas comment faire... Et après si j'installe evdev, il faudrait corriger mon make.conf avec cette ligne, c'est ça?
Code:
INPUT_DEVICES="keyboard mouse evdev"

Puis
Code:
emerge -uDvN world
si j'ai bien tout compris... Qu'en pensez-vous?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Sun Aug 30, 2009 12:10 pm    Post subject: Reply with quote

pour désactiver kdm ou n'importe quel truc-dm, c'est:
Code:
rc-update del xdm

evdev est à activer dans le noyau si ce n'est déjà fait.

Ensuite prends ton temps :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Kevin57
Guru
Guru


Joined: 21 Aug 2009
Posts: 373

PostPosted: Sun Aug 30, 2009 12:12 pm    Post subject: Reply with quote

Merci mais avant de faire ça il faudrait que j'ai accès à un mode console, comment je peux faire ça vu que kdm se lance automatiquement et bug?

Edit : c est bon j ai trouve, en passant par le mode boot interactif. J ai donc installe evdev, dans make.conf j ai mis juste evdev dans INUPUT_DEVICES mais maintenant mon clavier est repasse en QWERTYm pourtant /etc/conf.d/keymaps est juste. Comment je peux changer ca?

Edit 2 : c'est bon j'ai trouvé, en cherchant un petit peu on trouve tout! Il fallait changer /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi Tout remarche c'est parfait!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum