Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
veetle 0.9.15 on x86_64 needs gnomebreakpad and canberra-gtk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Tue Sep 08, 2009 4:44 pm    Post subject: veetle 0.9.15 on x86_64 needs gnomebreakpad and canberra-gtk Reply with quote

Hi,
I'm trying to running latest veetle (0.9.15) on a x86_64 multilib system, this is a 32bit plug-in and I installed it with nspluginwrapper.
It doesn't work and I get the following errors launching firefox from a terminal :
Code:
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "gnomebreakpad": libgnomebreakpad.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory


It seems veetle is looking for 32bit versions of libgnomebreakpad.so and libcanberra-gtk-module.so and naturally on my system I have only 64bit versions of those libs and none of the emul-linux packages seems to contain those libs. Is there a way I can obtain 32bit version of those libs ? Should I report those missing libs from emul-linux-* on bugzilla?
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Wed Sep 09, 2009 12:30 am    Post subject: Reply with quote

As that's not in portage, you're not likely going to get much from bugzilla. You'll need to find the libraries (I often use the ones from fedora packages ) and put them in the lib32 directory yourself.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Wed Sep 09, 2009 8:55 am    Post subject: Reply with quote

loftwyr wrote:
As that's not in portage, you're not likely going to get much from bugzilla. You'll need to find the libraries (I often use the ones from fedora packages ) and put them in the lib32 directory yourself.


I tried to do like you said , for each package that was missing I used rpmfind to find a suitable rpm from fedora 10 i386:
I took note of each rpm and file copied from it :



Anyway I get the same result, I mean veetle doesn't claim anymore for missing files but it says :
Code:
VLC media player 0.9.15 Janus
Veetle remote control interface initialized. Type `help' for help.
Connecting back to port 58968.
Done!
Reparent: 75497474
parentwin: returned 0 (no error)
** (npviewer.bin:21666): DEBUG: This Gtk+ version doesn't have the GtkSettings::gtk-enable-input-feedback-sounds property.


so it seems the last problem is the missing GtkSettings::gtk-enable-input-feedback-sounds property ... What should I try now ?
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Wed Sep 09, 2009 2:30 pm    Post subject: Reply with quote

Well, you'll have to find the right gtk+ version to match, I suggest googling the error and see what happens.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Wed Sep 09, 2009 3:15 pm    Post subject: Reply with quote

loftwyr wrote:
Well, you'll have to find the right gtk+ version to match, I suggest googling the error and see what happens.

searching the exact phrase "This Gtk+ version doesn't have the GtkSettings::gtk-enable-input-feedback-sounds property." leads me to 1 only result : this topic.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Wed Sep 09, 2009 9:01 pm    Post subject: Reply with quote

According to the GTK docs, that call exists so you likely have an old version.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Tue Sep 15, 2009 9:01 am    Post subject: Reply with quote

loftwyr wrote:
According to the GTK docs, that call exists so you likely have an old version.


I'm using the one provided by emul-linux-x86-gtklibs package , I also tried to install the testing version but I have the same output .
Back to top
View user's profile Send private message
gr0x0rd
Guru
Guru


Joined: 12 Aug 2006
Posts: 311

PostPosted: Wed Oct 27, 2010 1:55 am    Post subject: Reply with quote

I just tried installing version 0.9.17 on a 32bit system (via instructions in their linux self-installer) and all I get is a dead firefox.

Veetle is getting more and more popular. Wonder if it will make it into portage some day.
_________________
~g
emerge -FML...
Back to top
View user's profile Send private message
Pulcio Codasco
n00b
n00b


Joined: 29 Dec 2010
Posts: 3
Location: Helsinki - Finland

PostPosted: Wed Dec 29, 2010 9:18 pm    Post subject: Post subject: veetle 0.9.17 on x86_64 needs gnomebreakpad an Reply with quote

I succeded to get veetle to work with firefox-bin in the following way

  • I installed ~/.veetle_vlc .
  • emerge app-arch/rpm2targz
  • package veetle-0.9.17.tgz
    files copied :
    /usr/lib32/nsbrowser/plugins/libveetle-core-plugin.so
    /usr/lib32/nsbrowser/plugins/libveetle-broadcast-plugin.so
    /usr/lib32/nsbrowser/plugins/libveetle-player-plugin.so
  • package libcanberra-gtk2-0.10-3.fc10.i386
    files copied :
    /usr/lib32/libcanberra-gtk.so.0
    /usr/lib32/libcanberra-gtk.so.0.0.4
    /usr/lib32/gtk-2.0/modules/libcanberra-gtk-module.so
  • package glib2-2.18.4-2.fc10.i386.rpm
    files copied :
    /usr/lib32/libgio-2.0.so.0
    /usr/lib32/libgio-2.0.so.0.1800.4
  • package : libcanberra-0.10-3.fc10.i386.rpm
    files copied :
    /usr/lib32/libcanberra.so.0
    /usr/lib32/libcanberra.so.0.1.3
  • package libselinux-2.0.78-1.fc10.i386.rpm
    files copied: /usr/lib32/libselinux.so.1
  • package libtdb-1.1.1-30.fc10.i386.rpm
    files copied :
    /usr/lib32/libtdb.so.1
  • package bug-buddy-2.24.2-1.fc10.i386.rpm
    files copied :
    /usr/lib32/gtk-2.0/modules/libgnomebreakpad.so
    /usr/lib32/libbreakpad.so
    /usr/lib32/libbreakpad.so.0
    /usr/lib32/libbreakpad.so.0.0.0
  • package elfutils-libelf-0.142-1.fc10.i386.rpm
    files copied
    /usr/lib32/libelf-0.142.so
    /usr/lib32/libelf.so.1
  • package: SDL-1.2.13-6.fc10.i386.tar.gz
    cp ./usr/lib/libSDL-1.2.so.0 /usr/lib32/
    cp ./usr/lib/libSDL-1.2.so.0.11.2 /usr/lib32/
  • emerge nspluginwrapper adobe-flash firefox-bin

The difference with the post above is that I needed to add the plugins from the package: SDL-1.2.13-6.fc10.i386.tar.gz and to use firefox-bin, otherwise veetle does not work for me with the present workaround.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum