Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blender crashes when rendering any ffmpeg avi.[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Ric95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2007
Posts: 94
Location: Alberta Can.

PostPosted: Sun Sep 13, 2009 2:13 am    Post subject: Blender crashes when rendering any ffmpeg avi.[SOLVED] Reply with quote

Whenever I try to render an animation in any ffmpeg format, Blender crashes.

My cflags = -o2 -march=native (I'm using amd64)
I emerged with:
Code:

USE="ffmpeg nls openal openexr openmp player png" emerge blender-2.48

It compiled fine. I can open it, all the other tools and functions work so far.
But when I try an ffmpeg animation:
Quote:

Starting ouput to /tmp/0001_0007.d d(ffmpeg)...
Using type=1, codec=2, audio_codec=86016,
video_bitrate=6000, audio_bitrate=128,
gop_size=15, multiplex=0, autosplit=0
render width=720, render height=576
[dvd @ 0*14c29eo]Aspect ratio mismatch between encoder and muxer layer
Output #0, dvd, to '/tmp/0001_0007.dvd':
Stream #0.0: Video: mpeg2video, yuv420p, 720*576 [PAR 1:1 DAR 5:4], q=2-31, 6000 kb/s, 90k tbn, 25 tbc
Writing frame 1, render width=720, render height=576
[mpeg2video @ 0x14c3a10]rc buffer underflow
Video Frame PTS: 0
Floating point exception

The first frame renders, then both blender and the render window close. The avi file is created, but is empty.
What am I doing wrong? (Would the package maintainer know? How can I contact the maintainer?)
_________________
Corporations are not like people. They don't need rights as people do, they only need an even playing field on which to compete.


Last edited by Ric95 on Sun Sep 20, 2009 12:20 am; edited 1 time in total
Back to top
View user's profile Send private message
Ric95
Tux's lil' helper
Tux's lil' helper


Joined: 10 Apr 2007
Posts: 94
Location: Alberta Can.

PostPosted: Sat Sep 19, 2009 11:59 pm    Post subject: Reply with quote

Solved.
The cflag was set to -march=native. I'm not sure what gcc did diferent, but it needed the cflag to be set to -march=k8,
Blender users will be interested to know that test.blend rendered 3 seconds faster with the 'k8' flag than it did with the 'native' flag.
_________________
Corporations are not like people. They don't need rights as people do, they only need an even playing field on which to compete.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum