Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[résolu] [rtorrent] Bus error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Legoboy
n00b
n00b


Joined: 13 Sep 2009
Posts: 15

PostPosted: Thu Sep 17, 2009 9:33 am    Post subject: [résolu] [rtorrent] Bus error Reply with quote

Bonjour,

J'ai quelques soucis avec rtorrent.
Et le comble c'est que je m'en suis appercu quand, dans un moment de désespoir, j'avais lancé le téléchargement du LiveDVD de Fedora.

Au bout de quelques minutes, il m'affiche un message « Bus error » et c'est le Kernel Panic.

D'où est-ce que cela peut venir ??

Merci d'avance !


Last edited by Legoboy on Sun Oct 04, 2009 9:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Thu Sep 17, 2009 9:49 am    Post subject: Re: [rtorrent] Bus error Reply with quote

Legoboy wrote:
D'où est-ce que cela peut venir ??

Hum... Je dirais d'autre chose... Pas de rtorrent en tout cas.

T'as vérifier les logs usuels pour des informations croustillantes?
_________________
The End of the Internet!
Back to top
View user's profile Send private message
Legoboy
n00b
n00b


Joined: 13 Sep 2009
Posts: 15

PostPosted: Tue Sep 22, 2009 8:51 pm    Post subject: Reply with quote

Bah justement je ne trouve aucun log avec la moindre information.

Je pourrais peut être avoir une petite information ?

La seule chose que je sais c'est que cela ne se produit que lorsque l'ordinateur est connecté au réseau.

Edit: Maintenant j'ai des problèmes avec des « cp » de grande taille.
Back to top
View user's profile Send private message
Legoboy
n00b
n00b


Joined: 13 Sep 2009
Posts: 15

PostPosted: Wed Sep 23, 2009 2:06 pm    Post subject: Reply with quote

En fait le problème est systèmatique lorsqu'il y a des écritures importantes sur le disque.
Il doit me manquer une option lors de la compilation du noyau.

Après j'ai des messages « input / output error » plus ou moins systématique.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Wed Sep 23, 2009 3:24 pm    Post subject: Reply with quote

Ou alors tu as un problème matériel...
Serre les fesses et backup, fils :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Wed Sep 23, 2009 3:27 pm    Post subject: Reply with quote

Comme je viens d'en parler là : https://forums.gentoo.org/viewtopic-t-793909.html
smartmontools est ton ami pour diagnostiquer des problèmes de santé de ton disque ;)

Pourquoi pas envisager aussi un souci de RAM ? (memtest dans ce cas)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Legoboy
n00b
n00b


Joined: 13 Sep 2009
Posts: 15

PostPosted: Thu Sep 24, 2009 7:30 am    Post subject: Reply with quote

Mon PC revient tout juste du SAV (problème sur la carte mère), j'ai pas spécialement envie d'avoir encore des problèmes hardware.

Je ne pense pas que la RAM pose problème : les problème n'arrivent qu'en cas d'écriture intensive sur le disque dur (compiler, jouer et utiliser de la RAM comme un porc ne pose aucun problème, je vais quand même faire tourner un bon memtest cette nuit).

konsole wrote:
localhost ~ # smartctl -a /dev/sda | grep Current_Pending_Sector | awk '{print $NF}'
0
localhost ~ # smartctl -a /dev/sda | grep Reallocated_Sector_Ct | awk '{print $NF}'
655


Je pense que le problème est logiciel et non matériel.
D'abord parce que j'ai ce problème depuis plus d'une semaine, ensuite parce que c'est ma première fois sur Gentoo, la première fois que je fais l'expérience de la compilation du noyau et que donc il risque d'y avoir des problèmes de ce côté là.

J'ai maintenant un message récurant dans les log :
Quote:
Sep 24 09:26:29 localhost dbus-daemon: Rejected send message, 1 matched rules; type="method_call", sender=":1.16" (uid=1000 pid=3304 comm="/usr/bin/python2.6) interface="org.freedesktop.Hal.Manager" member="FindDeviceByCapability" error name="(unset)" requested_reply=0 destination=":1.0" (uid=0 pid=2954 comm="/usr/sbin/hald))



Edit...
J'ai fais un tour un peu plus détaillé sur smartctl

Quote:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x000f 200 200 051 Pre-fail Always - 147
3 Spin_Up_Time 0x0003 188 186 021 Pre-fail Always - 1591
4 Start_Stop_Count 0x0032 097 097 000 Old_age Always - 3146
5 Reallocated_Sector_Ct 0x0033 118 118 140 Pre-fail Always FAILING_NOW 655
7 Seek_Error_Rate 0x000f 100 253 051 Pre-fail Always - 0
9 Power_On_Hours 0x0032 095 095 000 Old_age Always - 4127
10 Spin_Retry_Count 0x0013 100 100 051 Pre-fail Always - 0
11 Calibration_Retry_Count 0x0012 100 100 051 Old_age Always - 0
12 Power_Cycle_Count 0x0032 097 097 000 Old_age Always - 3102
192 Power-Off_Retract_Count 0x0032 196 196 000 Old_age Always - 3092
193 Load_Cycle_Count 0x0032 177 177 000 Old_age Always - 71349
194 Temperature_Celsius 0x0022 111 095 000 Old_age Always - 36
196 Reallocated_Event_Count 0x0032 162 162 000 Old_age Always - 38
197 Current_Pending_Sector 0x0012 200 198 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0010 100 253 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x003e 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0009 100 253 051 Pre-fail Offline - 0
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Thu Sep 24, 2009 8:06 am    Post subject: Reply with quote

Legoboy wrote:
Mon PC revient tout juste du SAV (problème sur la carte mère), j'ai pas spécialement envie d'avoir encore des problèmes hardware.

Justement ça me rappelle un problème que j'avais eu il y a quelques années avec un chipset VIA (en fait j'ai ai eu plein, c'était les moins chers et ce n'était pas un hasard), lorsque je copiais des gros fichiers ils étaient corrompus. Ce problème n'apparaissait que sur les noyaux -ck donc j'avais envoyé un rapport de bug mais il s'est avéré que c'était parce que cette variante stressait beaucoup plus le matériel que le vanilla. Réponse du mainteneur: "j'ai le même problème sur une machine, j'ai underclocké le bus." Donc n'exclus pas la thèse du [strike]suicide[/strike] problème matériel.

Legoboy wrote:
D'abord parce que j'ai ce problème depuis plus d'une semaine, ensuite parce que c'est ma première fois sur Gentoo, la première fois que je fais l'expérience de la compilation du noyau et que donc il risque d'y avoir des problèmes de ce côté là.

Est-ce que tu as la possibilité de remettre ce noyau fait avec genkernel et de voir si ça fonctionne à nouveau? Sinon est-ce que tu peux en refaire un neuf et tester?

Legoboy wrote:
J'ai maintenant un message récurant dans les log :
Quote:
Sep 24 09:26:29 localhost dbus-daemon: Rejected send message, 1 matched rules; type="method_call", sender=":1.16" (uid=1000 pid=3304 comm="/usr/bin/python2.6) interface="org.freedesktop.Hal.Manager" member="FindDeviceByCapability" error name="(unset)" requested_reply=0 destination=":1.0" (uid=0 pid=2954 comm="/usr/sbin/hald))

Tu as un programme écrit en python que tu lances en tant qu'utilisateur (uid=1000) qui a l'air d'appeler une méthode incorrecte de HAL. Est-ce que tu as une idée de ce que ça peut être?
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Sep 24, 2009 8:13 am    Post subject: Reply with quote

non c'est pas logiciel, c'est matériel ! Le disque est en train de mourir.

655 secteurs réalloués, c'est énorme.
D'ailleurs le rapport smart te préviens : FAILING_NOW !!
Si le SAV n'a pas vérifié ça, _ça veut dire qu'ils n'ont même pas fait un petit diagnostic complet pour vérifier que tout va bien (ça me semble une vérification élémentaire

Le disque a aussi beaucoup de spin up : 71349 ça commence à faire. 17 spin-up par heure en moyenne, c'est relativement élevé. Ca contribue à réduire la durée de vie des disques ça.


[Edit]
Et j'insiste hein : le rapport smart est totalement indépendant de l'OS utilisé. C'est des diagnostics faits par le firmware du disque lui même. C'est beaucoup plus bas niveau que ne le serait un test du disque avec "badblocks"

[Edit2]
Un détail supplémentaire là :
Code:
5 Reallocated_Sector_Ct 0x0033 118 118 140 Pre-fail Always FAILING_NOW 655

sur les 3 valeurs "118 118 140".
Là, le disque te dit que le seuil de deffectuosité c'est 140. La valeur initiale est 200 (valeur standardisée). Elle est descendue à 118, et 118 est la pire valeur que le disque à rencontré (pour le cas particulier de Reallocated_Sector_Ct cela ne remonte JAMAIS).
Comme la valeur est passée sous le seuil, le disque te prévient qu'il est en train de mourir.

La, la situation du disque est passé au seuil critique. La seule chose à faire, c'est backup et envoi du disque au SAV pour remplacement...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Legoboy
n00b
n00b


Joined: 13 Sep 2009
Posts: 15

PostPosted: Thu Sep 24, 2009 9:07 am    Post subject: Reply with quote

Le SAV ne peut rien pour moi.
Ils m'ont remplacé la carte mère à cause d'un problème de chipset Nvidia considéré comme un vice caché.

Merci dans tous les cas.
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Sep 24, 2009 9:27 am    Post subject: Reply with quote

Legoboy wrote:
Le SAV ne peut rien pour moi.
Ils m'ont remplacé la carte mère à cause d'un problème de chipset Nvidia considéré comme un vice caché.

Merci dans tous les cas.

Bien sûr que si le SAV peut !
un disque défectueux au bout de 4127h (171 jours donc) de fonctionnement, c'est un défaut. Il doivent le remplacer !
Et le SAV de ton ordinateur ne veut rien faire, tu peux toujours passer directement par le constructeur du disque (ça pourra d'ailleurs aller plus vite) !
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Legoboy
n00b
n00b


Joined: 13 Sep 2009
Posts: 15

PostPosted: Thu Sep 24, 2009 9:44 am    Post subject: Reply with quote

Ok.
Je vais contacter WD.

Merci infiniment dans tous les cas !
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Thu Sep 24, 2009 1:31 pm    Post subject: Reply with quote

Chez western faut aller voir là :
http://support.wdc.com/warranty/index_end.asp?lang=fr

Tu colles le numéro de série du disque, ils te disent à quoi tu as droit. En général, les disques en OEM ne sont pas repris directement, il faut passer par le monteur... Dans tous les cas, c'est indiqué, leur truc de suivi est super bien foutu. Si tu es dans les clous pour la garantie, il suffit d'ouvrir une RMA et de suivre la procédure qui est bien détaillée...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Legoboy
n00b
n00b


Joined: 13 Sep 2009
Posts: 15

PostPosted: Sun Oct 04, 2009 10:04 pm    Post subject: Reply with quote

J'ai réinstallé mon système sur un nouveau disque dur...
C'est fou comme ça marche mieux.

Merci beaucoup à tous !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum