Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
weird file command output
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Sep 17, 2009 6:01 pm    Post subject: weird file command output Reply with quote

hi all,

this has been happening for some time now in my g4 powerbook but it never caused any problems afaict, so that i really didnt care much about it.

if i do f.ex. file /bin/bash :

Code:
/bin/bash: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, with unknown capability 0x41000000 = 0x11676e75, with unknown capability 0x10000 = 0x90401, stripped


when it should say altivec enabled instead of unknown capability blablabla.

does anyone know what is causing this ?

thanks !
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
Ato
n00b
n00b


Joined: 22 Dec 2007
Posts: 66
Location: Duisburg, Germany

PostPosted: Sun Sep 20, 2009 6:04 am    Post subject: Reply with quote

Same here on a Mac Mini G4:
Code:
mac ~ # file /bin/bash
/bin/bash: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, with unknown capability 0x41000000 = 0xf676e75, stripped


But I am not concerned at all since I know that everything is built properly. Bottom line: the file tool or a linked library does not evaluate the capabilities on ppc too well. I would not pay too much attention to this. Perhaps it is worth a report on https://bugs.gentoo.org.

Cheers,
Thomas[/code]
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Mon Sep 21, 2009 10:18 am    Post subject: Reply with quote

nice, i´m not alone ;-)
Would be good to know if this a general "problem" or just happens to a few of us.

At some point it correctly said "altivec enabled" but i have no idea when this changed, maybe i fill a bug later but everything works as expected so that i really don´t care much, was just wondering about this.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum