Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ext4]No filesystem could mount root - 2.6.31(en cours)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
CroK
n00b
n00b


Joined: 18 Sep 2009
Posts: 4

PostPosted: Fri Sep 18, 2009 9:15 pm    Post subject: [ext4]No filesystem could mount root - 2.6.31(en cours) Reply with quote

Salut.
Voilà, j'ai un petit problème, lors du boot de ma gentoo toute fraîche.
J'ai fait 3 partitions (/dev/sda1, /dev/sda2 et /dev/sda3), les 3 sont dans l'ordre /boot, le swap et / (comme dans le handbook quoi :))
J'ai fait /dev/sda3 en ext4, à l'aide de mkfs.ext4, mais j'ai toujours le message d'erreur :
No filesystem could mount root, etc ...

Je suis tombé sur ce topic : https://forums.gentoo.org/viewtopic-t-779426.html mais je n'ai pas cette option dans le 2.6.31 (ou alors je suis aveugle, mais il est tard (pour moi), et je vois déjà plus très clair).

Enfin voilà, si quelqu'un a un système en ext4 sur du 2.6.31 et qu'il a la solution miracle.. Merci :)

Edit : Je viens juste de voir dans le topic que je cite, dans l'aide ils disent que mke2fs supporte par défaut les grosses tailles de partitions.. Ça peut être ça ?
_________________
Lenovo Y530 : C2D T6400, 4GB DDR3, NVIDIA 9600M
*need* de passer sous Gentoo !


Last edited by CroK on Sat Sep 19, 2009 9:12 pm; edited 4 times in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sat Sep 19, 2009 12:30 am    Post subject: Reply with quote

Salut et bienvenue ! Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)

Et t'as bien pensé à activer le support ext4 dans ton kernel ?

(le topic que tu pointes n'a pas l'air d'exister)
Back to top
View user's profile Send private message
CroK
n00b
n00b


Joined: 18 Sep 2009
Posts: 4

PostPosted: Sat Sep 19, 2009 5:22 am    Post subject: Reply with quote

Voilà pour le titre ! (J'aurais du y penser, sur le forum d'Arch c'est le même qui est utilisé en plus :)

Oui, j'avais bien activé le support de l'ext4 dans mon kernel.

Edit : J'ai enfin trouvé pour le topic, en fait il prenait aussi la virgule dans l'url, maintenant c'est bon.
_________________
Lenovo Y530 : C2D T6400, 4GB DDR3, NVIDIA 9600M
*need* de passer sous Gentoo !
Back to top
View user's profile Send private message
CroK
n00b
n00b


Joined: 18 Sep 2009
Posts: 4

PostPosted: Sun Sep 20, 2009 4:02 pm    Post subject: Reply with quote

Je remonte un petit coup, j'ai toujours pas trouvé... Avec Genkernel ça fonctionne, mais bon j'ai +160 modules de chargés.. Quoique avec ma config je suis pas sur que ce soit vraiment grave... Si ?
_________________
Lenovo Y530 : C2D T6400, 4GB DDR3, NVIDIA 9600M
*need* de passer sous Gentoo !
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Sun Sep 20, 2009 4:55 pm    Post subject: Reply with quote

Salut,

Evite de faire des bumps tous les jours s'il-te-plaît, c'est le week-end et il faut croire que les gens sont sortis de chez eux (en ce qui me concerne, je n'avais plus de connexion...).

Est-ce que tu as bien précisé dans le /etc/fstab que ta partition / est de type ext4?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8128
Location: ~Brussels - Belgique

PostPosted: Sun Sep 20, 2009 4:58 pm    Post subject: Reply with quote

Salut,

Rien ne t'empêche de configurer ton kernel avec genkernel --menuconfig.

De mon côté, je me délecte de deux liens
- Pappys's kernel seeds : http://62.3.120.141/~pappy/
- "lspci -n" -> http://kmuto.jp/debian/hcl/

après ça, j'ai un kernel minimal qui supporte ma machine à 100% :)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum