Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 2.26 breaks everything?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Tristanm
Apprentice
Apprentice


Joined: 15 Aug 2008
Posts: 209

PostPosted: Sat Sep 19, 2009 2:19 pm    Post subject: Gnome 2.26 breaks everything? Reply with quote

After upgrading to gnome 2.26, I've noticed multiple things have stopped working. My laptop is no longer able to suspend or hibernate. The SD Reader has stopped working. The video drivers have a tendency to randomly crash. While I have recently updated my kernel, the problems started and were present prior to the kernel upgrade, first being noticed after the gnome upgrade.

HP Pavillion dv9000
64-bit Gentoo

GCC Version - 4.4.1
Kernel Version - 2.6.31
Kernel .config <-- Uses Pappy's seeds
NVIDIA Drivers version - 185.18.31

emerge --info wrote:
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.4.1, glibc-2.9_p20081201-r2, 2.6.31-gentoo x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-x86_64-AMD_Turion-tm-_64_X2_Mobile_Technology_TL-56-with-gentoo-2.0.1
Timestamp of tree: Fri, 18 Sep 2009 15:45:02 +0000
app-shells/bash: 4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python: 2.6.2-r1
dev-util/cmake: 2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc: 0.4.1-r1
sys-apps/sandbox: 1.6-r2
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -mmmx -msse -msse2 -m3dnow"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -mmmx -msse -msse2 -m3dnow"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo http://www.gtlib.gatech.edu/pub/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage/"
USE="3dnow X a52 aac aalib acl acpi alsa amd64 applet automount bash-completion berkdb bidi bootstrap branding bzip2 cairo canna cdda cddb cdio cdr cjk cli consolekit cpudetection cracklib crypt cups cupsddk dbus dc1394 device-mapper disk-partition dri dts dvb dvd dvdr eds emboss emerald encode esd fam fat fbcon ffmpeg firefox flac fontconfig fortran fuse gd gdbm ggi gif gmp gnome gnome-keyring gnutls gpm gstreamer gtk gtk2 hal hardened httpd iconv ide imap imlib ipv6 isdnlog jack java javascript jpeg jpeg2k laptop lcms ldap libcaca libffi libnotify lirc live mad matroska mdnsresponder-compat mikmod mmx modplug mono mp3 mp4 mpeg mudflap multicall multilib multislot musepack nautilus ncurses networkmanager nls nptl nptlonly nsplugin ntfs ntfs-3g ogg opengl openmp oss pam pcre pdf perl php png ppds pppd pulseaudio python qt3support quicktime readline reflection replytolist rtsp ruby samba scanner sdl sdl-image session shout speex spell spl sqlite sse sse2 ssh ssl startup-notification stream svg symlink sysfs tcl tcpd thunar tiff tools truetype unicode upnp usb v4l vlm vorbis wmf x264 xcomposite xinerama xml xorg xosd xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="vesa vga nvidia"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Last edited by Tristanm on Sat Sep 19, 2009 5:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Sep 19, 2009 4:15 pm    Post subject: Reply with quote

Have you downgraded your kernel to see if it fixes the problem?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Tristanm
Apprentice
Apprentice


Joined: 15 Aug 2008
Posts: 209

PostPosted: Sat Sep 19, 2009 5:20 pm    Post subject: Reply with quote

All these features worked flawlessly with the previous (2.6.30-r4) kernel. I even got help from someone who knows what they are doing far more than myself with that one. It worked. No problems surfaced until i upgraded to gnome 2.26. The upgrade of gnome was a week or two ago, the upgrade of the kernel was only a day or two ago, and it seems to be working fine other than the problems that had surfaced prior to the kernel upgrade. Would you like me to try an older kernel, like 2.6.29? Since I'm on ext4, I am somewhat hesitant to use a kernel version that still has the data-loss bug that was patched in 2.6.30
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum