Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[installation]impossible d'émerger gentoo-sources (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ProgVal
n00b
n00b


Joined: 28 Sep 2009
Posts: 20
Location: France

PostPosted: Mon Sep 28, 2009 6:01 pm    Post subject: [installation]impossible d'émerger gentoo-sources (résolu) Reply with quote

Bonjour,

Tout est ici:
Code:
(chroot) Ordi-de-Val-Kubuntu / # emerge  gentoo-sources
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-kernel/gentoo-sources-2.6.30-r6
openpty failed: 'out of pty devices'
 * linux-2.6.30.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                  [ ok ]
 * genpatches-2.6.30-7.base.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...      [ ok ]
 * genpatches-2.6.30-7.extras.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...    [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-2.6.30.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.30-r6/work
>>> Unpacking genpatches-2.6.30-7.base.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.30-r6/work/patches
>>> Unpacking genpatches-2.6.30-7.extras.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.30-r6/work/patches
 * Applying 1000_linux-2.6.30.1.patch (-p0+) ...                                                                                                                                                     [ ok ]
 * Applying 1001_linux-2.6.30.2.patch (-p0+) ...                                                                                                                                                     [ ok ]
 * Applying 1002_linux-2.6.30.3.patch (-p0+) ...                                                                                                                                                     [ ok ]
 * Applying 1003_linux-2.6.30.4.patch (-p0+) ...                                                                                                                                                     [ ok ]
 * Applying 1004_linux-2.6.30.5.patch (-p0+) ...                                                                                                                                                     [ ok ]
 * Applying 1510_hid-move-deref-below-null-test.patch (-p0+) ...                                                                                                                                     [ ok ]
 * Applying 2500_ide-cd-handle-fragmented-patckets.patch (-p0+) ...                                                                                                                                  [ ok ]
 * Applying 2900_makefile-no-delete-null-pointer-checks-fix.patch (-p0+) ...                                                                                                                         [ ok ]
 * Applying 4100_dm-bbr.patch (-p0+) ...                                                                                                                                                             [ ok ]
 * Applying 4202_fbcondecor-0.9.6.patch (-p0+) ...                                                                                                                                                   [ ok ]
 * Applying 4400_alpha-sysctl-uac.patch (-p0+) ...                                                                                                                                                   [ ok ]

J'ai eu beau faire des Ctrl + C et relancer, ça reste bloqué au même endroit (par bloqué, j'entends que ça n'avance pas)

Je fais l'installation à partir de Kubuntu en chroot. Mes deux distribs sont en x86.

Merci d'avance,
ProgVal


Last edited by ProgVal on Wed Sep 30, 2009 11:49 am; edited 2 times in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Tue Sep 29, 2009 7:31 am    Post subject: Reply with quote

Salut ! Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)

Et si tu lui laisses le temps de bosser à emerge ? Les gentoo-sources c'est gros ;)
Back to top
View user's profile Send private message
ProgVal
n00b
n00b


Joined: 28 Sep 2009
Posts: 20
Location: France

PostPosted: Tue Sep 29, 2009 3:17 pm    Post subject: Reply with quote

Titre édité.

Et je lui ai laissé beaucoup de temps. J'ai déjà fait une installation de Gentoo (du moins, j'ai tenté), et je ne me souviens pas avoir réalisé cette étape, ça veut dire qu'elle ne m'a pas posé problème...
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Sep 29, 2009 3:19 pm    Post subject: Reply with quote

Est-ce que tu constates une activité au niveau du HD / CPU pendant que t'attends ? (regarde avec top/htop pour l'activité CPU)
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8125
Location: ~Brussels - Belgique

PostPosted: Tue Sep 29, 2009 3:19 pm    Post subject: Reply with quote

As-tu assez d'espace disque ?

que donne "df -h /var/tmp/portage" ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8125
Location: ~Brussels - Belgique

PostPosted: Tue Sep 29, 2009 3:21 pm    Post subject: Reply with quote

Sympa de poster aussi en anglais !
On pue ou quoi :evil:
https://forums.gentoo.org/viewtopic-t-794589-start-0-postdays-0-postorder-asc-highlight-.html
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ProgVal
n00b
n00b


Joined: 28 Sep 2009
Posts: 20
Location: France

PostPosted: Tue Sep 29, 2009 3:37 pm    Post subject: Reply with quote

1. Je n'ai entendu aucune activité du disque dur. Quant au CPU, dès qu'il y a de l'activité, ça ralenti beaucoup mon PC, ce qui n'est pas le cas pendant l'émergence

2. J'exécuterai la commande dès que je rentrerai chez moi.

3. J'ai d'abord posté en Anglais.
Ensuite, j'ai vu (ou plutôt, on ma donné le lien) du forum Français. Et comme je comprend mieux le Français...
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Sep 29, 2009 4:12 pm    Post subject: Reply with quote

XavierMiller wrote:
Sympa de poster aussi en anglais !
On pue ou quoi :evil:
https://forums.gentoo.org/viewtopic-t-794589-start-0-postdays-0-postorder-asc-highlight-.html


Super accueil pour le nouveau ça... ahem.

Au fait, bienvenue ProgVal ;)
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Tue Sep 29, 2009 4:32 pm    Post subject: Reply with quote

Bah pas faire gaffe, Xavier est un peu ronchon de temps à autres ça nous arrive à tous une fois ou deux de-ci de-là :wink:
Donc bienvenue++ (ici on est tous sympa quand même tu verras à l'usage :P )

Sinon pour ton pb, tu peux montrer le retour d'un #mount hors du chroot stp ?
Et un #emerge --info tant qu'a y être...
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
NEOxAKIRA
Guru
Guru


Joined: 20 May 2007
Posts: 302
Location: France

PostPosted: Tue Sep 29, 2009 11:10 pm    Post subject: Reply with quote

question conne: t'as fait un emerge --sync ?
(ou eix-sync)
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8125
Location: ~Brussels - Belgique

PostPosted: Wed Sep 30, 2009 8:41 am    Post subject: Reply with quote

boozo wrote:
Bah pas faire gaffe, Xavier est un peu ronchon de temps à autres ça nous arrive à tous une fois ou deux de-ci de-là :wink:


Touché ;)

Bienvenue, et désolé pour mon coup de griffe mal placé :?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ProgVal
n00b
n00b


Joined: 28 Sep 2009
Posts: 20
Location: France

PostPosted: Wed Sep 30, 2009 11:47 am    Post subject: Reply with quote

Pas de problème, il m'arrive parfois d'accueillir des kikoolol comme ça, sur des forums techniques, je comprend ce qu'on ressent ;)

Sinon, problème résolu en faisant:
Code:
# mount -t proc none /mnt/gentoo/proc
# mount -o bind /dev /mnt/gentoo/dev
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8125
Location: ~Brussels - Belgique

PostPosted: Wed Sep 30, 2009 12:12 pm    Post subject: Reply with quote

Allez, pour me faire pardonner, voici mon script qui fait ce qu'il faut (et un chroot amélioré, provenant de LinuxFromScratch):
/data/build/scripts/go.sh:
#!/bin/bash

cd `dirname $0`
cd ../../..

case `uname -m` in
    (i686) LINUX32= ;;
    (x86_64) LINUX32=linux32 ;;
esac

for f in `mount | grep $PWD/ | sed -e 's/.* on //' -e 's/ .*//'`
do
    umount $f;
done

mount -o bind / data/build/host &&
mount -o bind /dev/ dev/ &&
mount -t proc none proc/ &&
$LINUX32 chroot . /bin/env -i \
    HOME=/root TERM="$TERM" PS1='\u:\w\$ ' \
    PATH=/bin:/usr/bin:/sbin:/usr/sbin \
    /bin/bash --login +h

for f in `mount | grep $PWD/ | sed -e 's/.* on //' -e 's/ .*//'`
do
    umount $f;
done

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum