Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Patch: faster GUI with fglrx (ati-drivers) and compositing
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Aug 29, 2010 7:23 pm    Post subject: Reply with quote

_Flame_ wrote:
energyman76b wrote:
hm?

I don't see any error.

besides, with a recent ati-driver you should not need it anymore.

I don`t see this.
Code:
>>> Source prepared.
 * Applying xserver-xorg-backclear.patch ...       [ ok ]


I use fglrx driver 10.8 from amd site and delay very big.
Gentoo ati-driver already has this patch?


nope, and it also won't get into the tree in the future

10.8 already has the new 2D/3D acceleration framework (in contrast to the old XAA-based one where you needed the patch)

so you don't need the patch



if you still want to use the old way:

set up a local overlay to apply the patch to your xorg-server version or follow the instructions above


then disable the new acceleration and force the old one (which needs the patch):

Code:
aticonfig --set-pcs-str=DDX,ForceXAA,TRUE

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
_Flame_
n00b
n00b


Joined: 14 Feb 2010
Posts: 47

PostPosted: Sun Aug 29, 2010 8:03 pm    Post subject: Reply with quote

kernelOfTruth wrote:
_Flame_ wrote:
energyman76b wrote:
hm?

I don't see any error.

besides, with a recent ati-driver you should not need it anymore.

I don`t see this.
Code:
>>> Source prepared.
 * Applying xserver-xorg-backclear.patch ...       [ ok ]


I use fglrx driver 10.8 from amd site and delay very big.
Gentoo ati-driver already has this patch?


nope, and it also won't get into the tree in the future

10.8 already has the new 2D/3D acceleration framework (in contrast to the old XAA-based one where you needed the patch)

so you don't need the patch



if you still want to use the old way:

set up a local overlay to apply the patch to your xorg-server version or follow the instructions above


then disable the new acceleration and force the old one (which needs the patch):

Code:
aticonfig --set-pcs-str=DDX,ForceXAA,TRUE


How to examine that new acceleration enabled? I did aticonfig --initial but maximizing a window is very slow with compositing.
And i have only xorg opengl.
Code:

$ eselect opengl list
Available OpenGL implementations:
  [1]   xorg-x11 *
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Aug 29, 2010 8:20 pm    Post subject: Reply with quote

so it's not installed correctly:

you need to install the catalyst-driver via portage (e.g. emerge ati-drivers)

and then set the opengl-backend of the catalyst/ati-driver:

Code:
eselect opengl set ati


which then should say:
Quote:
eselect opengl list
Available OpenGL implementations:
[1] ati *
[2] xorg-x11


note that it later also should say something like:
glxinfo wrote:

name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.4
client glx extensions:
GLX_ARB_create_context, GLX_ARB_create_context_profile,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_NV_swap_group,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGIX_swap_barrier, GLX_SGIX_swap_group,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap,
GLX_EXT_framebuffer_sRGB, GLX_ARB_fbconfig_float, GLX_AMD_gpu_association
GLX version: 1.4
GLX extensions:
GLX_ARB_create_context, GLX_ARB_create_context_profile,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_swap_control,
GLX_NV_swap_group, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_swap_barrier,
GLX_SGIX_swap_group, GLX_SGIX_visual_select_group,
GLX_EXT_texture_from_pixmap
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.0.10151 Compatibility Profile Context
OpenGL shading language version string: 4.00

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
_Flame_
n00b
n00b


Joined: 14 Feb 2010
Posts: 47

PostPosted: Sun Aug 29, 2010 8:28 pm    Post subject: Reply with quote

This exist: direct rendering: Yes
Hardware 3D works good.

Quote:
so it's not installed correctly:

you need to install the catalyst-driver via portage (e.g. emerge ati-drivers)

and then set the opengl-backend of the catalyst/ati-driver:

Why if i install driver from ati site then ati opengl don`t appear?
Back to top
View user's profile Send private message
_Flame_
n00b
n00b


Joined: 14 Feb 2010
Posts: 47

PostPosted: Sun Aug 29, 2010 10:34 pm    Post subject: Reply with quote

Direct2DAccel not for me because i have black squares in controlls and icons. Very bad artefacts.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Mon Aug 30, 2010 2:38 am    Post subject: Reply with quote

_Flame_ wrote:
Why if i install driver from ati site then ati opengl don`t appear?

This will break your system.
Back to top
View user's profile Send private message
_Flame_
n00b
n00b


Joined: 14 Feb 2010
Posts: 47

PostPosted: Mon Aug 30, 2010 7:12 am    Post subject: Reply with quote

RealNC wrote:
_Flame_ wrote:
Why if i install driver from ati site then ati opengl don`t appear?

This will break your system.

Why? I don`t believe.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Mon Aug 30, 2010 7:23 am    Post subject: Reply with quote

Because the ebuild installs files in different places than the official installer. It then uses eselect opengl to move the files around. If you use the official installer, this mechanism can break. You then have to know how to fix it.
Back to top
View user's profile Send private message
_Flame_
n00b
n00b


Joined: 14 Feb 2010
Posts: 47

PostPosted: Mon Aug 30, 2010 10:32 am    Post subject: Reply with quote

I have many problems with ati-drivers. If i uninstall official driver then ati-driver doesn`t build(linker errors). If i install official driver then ati-driver builds success and "ati opengl" appears. But with it all works very slow and compositing doesn`t work. With "xorg opengl" X doesn`t start. Only official driver works normally.
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Mon Aug 30, 2010 3:58 pm    Post subject: Reply with quote

That's because using the official installer broke your system; the ebuild can't work correctly anymore. Like I said, you now need to fix your system :P
Back to top
View user's profile Send private message
_Flame_
n00b
n00b


Joined: 14 Feb 2010
Posts: 47

PostPosted: Mon Aug 30, 2010 6:29 pm    Post subject: Reply with quote

RealNC wrote:
That's because using the official installer broke your system; the ebuild can't work correctly anymore. Like I said, you now need to fix your system :P

How?
Back to top
View user's profile Send private message
RealNC
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2008
Posts: 148

PostPosted: Mon Aug 30, 2010 6:42 pm    Post subject: Reply with quote

Uninstalling fglrx and removing all traces of it from the system. Unfortunately, I don't know what fglrx installs because I'm not using fglrx at all anymore :? I switched to xf86-video-ati.
Back to top
View user's profile Send private message
s-hell
n00b
n00b


Joined: 17 Sep 2010
Posts: 1

PostPosted: Sun Sep 19, 2010 11:49 am    Post subject: Reply with quote

I had the same problem. I applied the patch without any success. No, i'm doing a fresh installation. Will see what will happen.May be i've more luck this time ;-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum