Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
curl-loader and apache2 (maxClient setting and open slots)!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
upengan78
l33t
l33t


Joined: 27 Jun 2007
Posts: 710
Location: IL

PostPosted: Tue Sep 29, 2009 9:19 pm    Post subject: curl-loader and apache2 (maxClient setting and open slots)!! Reply with quote

Hi I am using curl-loader program on gentoo

Program : http://curl-loader.sourceforge.net/

This gentoo system is running apache2. Most of the settings in apache2 are default.

my curl-loader config file is below :
Code:
########### GENERAL SECTION ################################
BATCH_NAME=frank4dd-test
CLIENTS_NUM_MAX=256
CLIENTS_NUM_START=256
CLIENTS_RAMPUP_INC=1
INTERFACE   =br0
NETMASK=255.255.255.0
IP_ADDR_MIN=
IP_ADDR_MAX=
CYCLES_NUM= -1
URLS_NUM= 1
########### URL SECTION ####################################
URL=http://myexternalIP/index.html
URL_SHORT_NAME="frank4dd-80-wpad"
REQUEST_TYPE=GET
TIMER_URL_COMPLETION = 3000
TIMER_AFTER_URL_SLEEP =100


I run it like this

Quote:
curl-loader -f configfile


I am running this to check if I am able to reach MaxClients settings, which I believe is 256 for apache2 on gentoo.

but after running curl loader even after long time I see the apache status shows,

Code:
./check_apachestatus.pl -H <externalip>

check_apachestatus.pl available here  (http://www.frank4dd.com/howto/nagios/check_apachestatus.pl)


Output :
Code:

OK  16.94773 seconds response time. Idle 0, busy 150, open slots 106 | 'Waiting for Connection'=0 'Starting Up'=0 'Reading Request'=1 'Sending Reply'=1 'Keepalive (read)'=148 'DNS Lookup'=0 'Closing Connection'=0 'Logging'=0 'Gracefully finishing'=0 'Idle cleanup'=0 'Open slot'=106 'Requests/sec'=61.6 'kB per sec'=34.2kB 'B per Request'=568.0B


As you can see in above o/p, "busy" never reaches 256, "open slots" never become 0, always remain at 106 while curl-loader is still running.

Does anyone know what's stopping curl-loader from using all 256 slots? Is it some kernel setting or apache2 config?

Please help!

To add more, I'd like to achieve following result in error_log for apache2,
Quote:
[error] server reached MaxClients setting, consider raising the MaxClients setting


so that later, I can configure Nagios to notify me when there are less than 30 "Open Slots"

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum