Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Official thread: "zen-sources" - Part 8
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Oct 06, 2009 11:01 pm    Post subject: Reply with quote

*friendly reminder*

please have a look again at the zen-sources bugtracker (@zen-sources.org) for reiser4 and add a fix for reiser4-for-2.6.31:

that fixes the new-introduced "problem" that reiser4-specific mount-options aren't recognized :idea:

thanks !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Oct 07, 2009 12:40 am    Post subject: Reply with quote

There is no patch attached to that bug report, reiser4-for-2.6.31 is in both kernels and the fix should be given to me if something is broken :O

*edit*
reiser4-for-2.6.31 has been in since yesterday on both trees - does it fix your problem or not?

*edit2*
I see now, fixed :oops:

Tons of drm stuffins changed too, don't worry - it's a gajillion ugly commits but the only reason was to make it easier for me (and update nouveau/drm i guess)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7106
Location: Austria

PostPosted: Thu Oct 08, 2009 7:44 am    Post subject: Reply with quote

latest zen-stable leads to graphics corruption on i915 hardware as soon as X is started (xorg-server-1.7, latest xf86-video-intel). Image compiled on Oct. 6th works!

Ok, there's a bug report about it already: http://zen-sources.org/content/visual-distortions-false-colors-zen-stable
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Thu Oct 08, 2009 2:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 848
Location: PL

PostPosted: Thu Oct 08, 2009 7:47 am    Post subject: Reply with quote

hmm, radeon kms broke on my system yesterday. goes straight into black screen with no display. or, if you just rebooted from another working kernel - screen contains garbage resembling your last X session.

i'm suspecting that zen-stable is equally experimental as development zen tree now.
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Thu Oct 08, 2009 8:03 am    Post subject: Reply with quote

don't know but it seems bfs-303 doesn't perform as well as bfs-300
on my system. there's a perception of increased latency.
wonder if anybody else notices same.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Thu Oct 08, 2009 8:55 am    Post subject: Reply with quote

I've read everything on the Kolivas bfs patches index page, but didn't see anything (could have missed it) regarding if you can for example apply bfs303 (or any 2.6.31 based bfs version) on kernels 2.6.32.x. Anyone know, or is it not possible/recommended?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Thu Oct 08, 2009 7:22 pm    Post subject: Reply with quote

@yoshi
A look at gitweb clearly indicates that it is not at all the same as zen

In fact, they are totally different

@drm problems
Uses nouveau and drm-next, i pull nouveau/drm-next any day that it is available (like today) - PULL NOW, and see if its fixed, tons of files updated (radeon and nouveau anyway)

There should be no problems with i915, however (if you are using zen-stable.git, the releases and zen.git could be another story)

@tranquilcool
Strongly doubtful, bfs 303 should be the fastest one yet (maybe some of the 2.6.32 scheduler changes ported to BFS made a difference -- these were reverted in zen-stable) -- you can compare it to 2.6.32 and zen.git and see if you notice it (although the only accurate way is for a benchmark)

@wrc1944
What's your motivation for that? is there a problem with zen?

And to answer the question, no. the patch on ck's page is for 2.6.31, not 2.6.32. It's not a simple apply, numerous functions need to be added/changed for 2.6.32 (if you see zen.git, or atleast took the zen-sched branch of it --- you could have 2.6.32 with bfs)

zen.git is based on linus/master, which currently is tagged 2.6.32-rc3 :P, zen-sched has been re-done for 2.6.32 in that one so it includes bfs with the necessary changes.

:D
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7106
Location: Austria

PostPosted: Thu Oct 08, 2009 8:39 pm    Post subject: Reply with quote

cheater1034 wrote:
@drm problems
Uses nouveau and drm-next, i pull nouveau/drm-next any day that it is available (like today) - PULL NOW, and see if its fixed, tons of files updated (radeon and nouveau anyway)

There should be no problems with i915, however (if you are using zen-stable.git, the releases and zen.git could be another story)

Unfortunately, no difference from the latest git pull!
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Thu Oct 08, 2009 9:48 pm    Post subject: Reply with quote

genstorm wrote:
cheater1034 wrote:
@drm problems
Uses nouveau and drm-next, i pull nouveau/drm-next any day that it is available (like today) - PULL NOW, and see if its fixed, tons of files updated (radeon and nouveau anyway)

There should be no problems with i915, however (if you are using zen-stable.git, the releases and zen.git could be another story)

Unfortunately, no difference from the latest git pull!


how about drm-next? or nouveau-drm branch (which includes drm-next)

(or could you tell me the last date it worked maybe?)

*edit*
found the problem, 99% sure, upstream still broken with this thing.
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.


Last edited by cheater1034 on Thu Oct 08, 2009 10:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7106
Location: Austria

PostPosted: Thu Oct 08, 2009 10:12 pm    Post subject: Reply with quote

It worked two days ago, I think with commit df748b025d1357c2b9659e16a6040596e60e4257

cheater1034 wrote:
how about drm-next? or nouveau-drm branch (which includes drm-next)

I'm new to git, so I'm not really sure what to do ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Fri Oct 09, 2009 12:50 am    Post subject: Reply with quote

genstorm wrote:
It worked two days ago, I think with commit df748b025d1357c2b9659e16a6040596e60e4257

cheater1034 wrote:
how about drm-next? or nouveau-drm branch (which includes drm-next)

I'm new to git, so I'm not really sure what to do ;)


should be fixed now anyway ;)

please confirm (im waiting on someone else's confirmation too)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3251
Location: Gainesville, Florida

PostPosted: Fri Oct 09, 2009 1:03 am    Post subject: Reply with quote

cheater1034 wrote
Quote:
@wrc1944
What's your motivation for that? is there a problem with zen?
Sorry- typo- I meant 2.6.31.x, not 2.6.32.x :oops:
No specific problem with zen- I just had gotten into the habit of keeping a vanilla bfs kernel around as the bfs versions kept coming.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Fri Oct 09, 2009 1:17 am    Post subject: Reply with quote

wrc1944 wrote:
cheater1034 wrote
Quote:
@wrc1944
What's your motivation for that? is there a problem with zen?
Sorry- typo- I meant 2.6.31.x, not 2.6.32.x :oops:
No specific problem with zen- I just had gotten into the habit of keeping a vanilla bfs kernel around as the bfs versions kept coming.

Ahh no problem, the bfs patches should work over 2.6.31.x fine

-------------

******
2.6.31-zen2 patch released, just got sick of seeing that ugly name everytime i menuconfig'd so i needed an excuse to change it (should be a good stable release)
If you're wondering where i get names from, i just say in #zen-sources "QUICK name" - and the first response intended to answer the question is the name i pick.

Even when someone says "No", i pick no :P, or when someone gets creative "Alien mind creator" or "Dead squirrel" i pick whatever they say, so don't blame me for terrible names, blame the guys in #zen-sources! (i stopped trying to think of creative names and took whatever anybody says first)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Fri Oct 09, 2009 4:26 am    Post subject: Reply with quote

alsa still doesn't work good on zen-stable..
maybe you guys upgrade it to master or downgrade to 1.0.20?
or say me how to do this.
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
manwithaplan1976
Tux's lil' helper
Tux's lil' helper


Joined: 28 Nov 2008
Posts: 101
Location: USA

PostPosted: Fri Oct 09, 2009 4:31 am    Post subject: Reply with quote

Rion wrote:
alsa still doesn't work good on zen-stable..
maybe you guys upgrade it to master or downgrade to 1.0.20?
or say me how to do this.


I can confirm this .... I am have some static and stuttering, since the recent pull.
Back to top
View user's profile Send private message
DigitalCorpus
Apprentice
Apprentice


Joined: 30 Jul 2007
Posts: 245

PostPosted: Fri Oct 09, 2009 5:58 pm    Post subject: Reply with quote

I know the big feature testing of Zen Sources right now is BFS, but is BtrFS pulled from git in zen not zen-sources?
_________________
Atlas (HDTV PVR, HTTP & Media server)
http://atlas.selfip.net/Info/
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Fri Oct 09, 2009 6:23 pm    Post subject: Reply with quote

2.6.32-rc3-zen1 + BFS pukes 'hardlocks' while loading kde-4.3.2
With CFS everything is fine and the improvements are showing.
The only diff in the last test is kernel and the test files are now
on a ext4 partition where as before it was on a reiserfs3.
http://global.phoronix-test-suite.com/index.php?k=profile&u=zero-7722-13245-5387
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Fri Oct 09, 2009 8:16 pm    Post subject: Reply with quote

dodo may have screwed the sound, i reverted sound-2.6, which shouldnt be there anyway.

2.6.32 bfs = sorry, i'll see what i can do. and maybe something is wrong in the porting of it
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
ponciarello
Apprentice
Apprentice


Joined: 22 Jul 2008
Posts: 223
Location: beach of slack

PostPosted: Fri Oct 09, 2009 9:21 pm    Post subject: Reply with quote

Jupiter1TX wrote:
2.6.32-rc3-zen1 + BFS pukes 'hardlocks' while loading kde-4.3.2

works fine for me (config), I'm on ext4 too. :)
wanna report this (in dmesg) booting same kernel version on same machine but a 32bit kernel (instead of usual 64) 8O
Code:
------------[ cut here ]------------
WARNING: at mm/page_alloc.c:1751 __alloc_pages_nodemask+0x14f/0x560()
Hardware name: Satellite X200
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.31-zen3 #3
Call Trace:
 [<c105c98f>] ? __alloc_pages_nodemask+0x14f/0x560
 [<c105c98f>] ? __alloc_pages_nodemask+0x14f/0x560
 [<c1026ca6>] ? warn_slowpath_common+0x76/0xd0
 [<c105c98f>] ? __alloc_pages_nodemask+0x14f/0x560
 [<c1026d13>] ? warn_slowpath_null+0x13/0x20
 [<c105c98f>] ? __alloc_pages_nodemask+0x14f/0x560
 [<c1471528>] ? xd_init+0x0/0x518
 [<c105cdf4>] ? __get_free_pages+0x14/0x30
 [<c14715be>] ? xd_init+0x96/0x518
 [<c1330492>] ? printk+0x17/0x25
 [<c14707a8>] ? loop_init+0x32c/0x334
 [<c1471528>] ? xd_init+0x0/0x518
 [<c100103e>] ? do_one_initcall+0x2e/0x190
 [<c14552d5>] ? kernel_init+0x149/0x1a1
 [<c145518c>] ? kernel_init+0x0/0x1a1
 [<c100391f>] ? kernel_thread_helper+0x7/0x18
---[ end trace b0f5d7402f86af53 ]---
xd: Out of memory.
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Fri Oct 09, 2009 11:28 pm    Post subject: Reply with quote

ponciarello wrote:

works fine for me (config), I'm on ext4 too. :)

Thanks bud. Made me take a second look at some of my settings.
All working now and some NICE PTS results with BFS...

@cheater1034
Let me know any PTS test you think may better reflect BFS improvements.
Am only running the same test Phoronix did on BFS...
http://global.phoronix-test-suite.com/index.php?k=profile&u=zero-1117-23558-20957
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 251

PostPosted: Sat Oct 10, 2009 12:46 am    Post subject: Reply with quote

One thing I have noticed since upgrading to 2.6.31-zen2

hedgehog / $ modprobe it87
FATAL: Error inserting it87 (/lib/modules/2.6.31-zen2/kernel/drivers/hwmon/it87.ko): Device or resource busy

Anyone else having this?
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Sat Oct 10, 2009 5:00 am    Post subject: Reply with quote

cheater1034 wrote:
dodo may have screwed the sound, i reverted sound-2.6, which shouldnt be there anyway.
many thanks! it works as it should again! :)
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
cyberdemon
n00b
n00b


Joined: 13 Mar 2005
Posts: 10

PostPosted: Sat Oct 10, 2009 8:43 am    Post subject: reiser4 problem with 2.6.31-zen3 Reply with quote

Hi there,

I'm not so familiar with kernel compile.. but wanna use Reiser4 fs.
So I decided to test on virtual machine (VMware) first before applying on my main computer.

I downloaded reiser4+truecrypt livecd which Neo2 made,
then booted up and compiled 2.6.31-zen3 kernel with reiser4 support.
Surely reiser4 root partition was created, installed stage3 tarball from Neo2's website.

After reboot the virtual machine, kernel panic happened. Messages are like below:

Code:
md: Waiting for all devices to be available before autodetect
md: If you don't use raid, use raid=noautodetect
md: Autodetecting RAID arrays.
md: Scanned 0 and added 0 devices.
md: autorun ...
md: ... autorun DONE.
VFS: Cannot open root device "sda3" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0b00          1048575 sr0 driver: sr
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(0,0)
Pid: 1, comm: swapper Not tainted 2.6.31-zen3 #5
Call Trace:
.....................
.....................
.....................



GRUB boot option is below:
Code:
root (hd0,0)
kernel /boot/kernel-2.6.31-zen3 root=/dev/sda3 vga=0x333



I did googling then found some info:
- Disable using 4k stack in Kernel hacking menu
- Enable deflate method in Cryptographic API
- Enable Prompt for development and/or incomplete code/drivers in Code Maturity Level menu

I applied them on kernel config then re-compiled the kernel,
But no success yet.

The question is:
Specific kernel option should be given?
Did I missing something?

Please help guys..
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Oct 10, 2009 9:03 am    Post subject: Reply with quote

Quote:
VFS: Cannot open root device "sda3" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
0b00          1048575 sr0 driver: sr
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(0,0)


you need to enable more drivers !

just to be sure - you have the following enabled, right ?

Device Drivers -> <*> Serial ATA (prod) and Parallel ATA (experimental) drivers -- ->

Quote:
--- Serial ATA (prod) and Parallel ATA (experimental) drivers │ │
│ │ [*] ATA ACPI Support │ │
│ │ [*] SATA Port Multiplier support │ │
│ │ <*> AHCI SATA support │ │
│ │ < > Silicon Image 3124/3132 SATA support │ │
│ │ [*] ATA SFF support


and more ...
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
mantoo
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2007
Posts: 98
Location: Germany

PostPosted: Sat Oct 10, 2009 9:29 am    Post subject: Reply with quote

Saundersx wrote:
One thing I have noticed since upgrading to 2.6.31-zen2

hedgehog / $ modprobe it87
FATAL: Error inserting it87 (/lib/modules/2.6.31-zen2/kernel/drivers/hwmon/it87.ko): Device or resource busy

Anyone else having this?


same here, but started with 2.6.31-zen0 or 1 if i remeber correctly.

read somewhere that this is related to ressourceconflict with acpi

for me:
Code:
[   18.527338] ACPI: I/O resource it87 [0x295-0x296] conflicts with ACPI region IP__ [0x295-0x296]

and
Code:
jebo_one# cat /proc/ioports
0000-001f : dma1
0020-0021 : pic1
0040-0043 : timer0
0050-0053 : timer1
0060-0060 : keyboard
0064-0064 : keyboard
0070-0077 : rtc
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : 0000:00:0f.1
  0170-0177 : via82cxxx
01f0-01f7 : 0000:00:0f.1
  01f0-01f7 : via82cxxx
[b]0290-029f : pnp 00:02[/b]
0376-0376 : 0000:00:0f.1
  0376-0376 : via82cxxx
03c0-03df : vga+
03f2-03f2 : floppy
03f4-03f5 : floppy
03f6-03f6 : 0000:00:0f.1
  03f6-03f6 : via82cxxx
03f7-03f7 : floppy
0400-047f : pnp 00:01
  0400-0403 : ACPI PM1a_EVT_BLK
  0404-0405 : ACPI PM1a_CNT_BLK
  0408-040b : ACPI PM_TMR
  0420-0423 : ACPI GPE0_BLK
  0450-0453 : ACPI GPE1_BLK
04d0-04d1 : pnp 00:02
0500-050f : pnp 00:01
  0500-0507 : vt596_smbus
0800-0805 : pnp 00:02
0880-088f : pnp 00:02
0cf8-0cff : PCI conf1
9000-9fff : PCI Bus 0000:04
  9c00-9c1f : 0000:04:04.0
    9c00-9c1f : snd_ca0106
a000-bfff : PCI Bus 0000:03
c000-cfff : PCI Bus 0000:02
  cc00-cc7f : 0000:02:00.0
d000-d0ff : 0000:00:12.0
  d000-d0ff : via-rhine
d400-d41f : 0000:00:10.3
  d400-d41f : uhci_hcd
d800-d81f : 0000:00:10.2
  d800-d81f : uhci_hcd
dc00-dc1f : 0000:00:10.1
  dc00-dc1f : uhci_hcd
e000-e01f : 0000:00:10.0
  e000-e01f : uhci_hcd
e400-e40f : 0000:00:0f.1
  e400-e40f : via82cxxx
e800-e8ff : 0000:00:0f.0
  e800-e8ff : sata_via
ec00-ec0f : 0000:00:0f.0
  ec00-ec0f : sata_via
f000-f003 : 0000:00:0f.0
  f000-f003 : sata_via
f400-f407 : 0000:00:0f.0
  f400-f407 : sata_via
f800-f803 : 0000:00:0f.0
  f800-f803 : sata_via
fc00-fc07 : 0000:00:0f.0
  fc00-fc07 : sata_via


didnt find any solution yet, not had any free time to dig deeper into it
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 4 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum