Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome overlay question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Wed Sep 30, 2009 5:15 pm    Post subject: gnome overlay question Reply with quote

Hello,

I wish to use the gnome overlay but I'm a little bit confused.

I have to do :
Code:

emerge layman
layman -l
layman -a gnome
emerge -qv <category>/<package>


Is catogory and package both Gnome if i want to install the whole gnome enviroment ?

Roelof
Back to top
View user's profile Send private message
jettjunker
Apprentice
Apprentice


Joined: 10 Sep 2005
Posts: 267

PostPosted: Wed Sep 30, 2009 6:14 pm    Post subject: Reply with quote

Pretty sure category is simply what appears before the package when you emerge... like www-client/mozilla-firefox. For gnome, it's
gnome-base/gnome. But, there's no need to specify the category except for when there are multiple packages with the same name but in different categories... otherwise it pulls it in just fine with "emerge <package>"

Either way, it pulls in dependencies.

In any event, use -a (ask: lists what will be emerged from that command, and prompts for a y/n) or -p (pretend: lists what would be emerged from that command, but kicks back to the terminal prompt) to see what's going to be emerged before actually doing so. I practically always do: emerge -av <package>
_________________
Core2Duo T7100 1.8 ghz mini-itx, Nvidia FX220: Gentoo/Gnome/CompizFusion:XGL
CoreDuo 1.83 ghz 13" Macbook, GMA 950: Ubuntu/Gnome/CompizFusion:AIGLX
Back to top
View user's profile Send private message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Thu Oct 01, 2009 2:19 pm    Post subject: Reply with quote

Oke,

I did all the steps but if I do emerge gentoo it wants to re-emerge version 2.24.1 instead of installing 2.28.0.

How can I solve this ?

Roelof
Back to top
View user's profile Send private message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Fri Oct 02, 2009 11:40 am    Post subject: Reply with quote

Nobody ????

Roelof
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Fri Oct 02, 2009 1:19 pm    Post subject: Reply with quote

Quote:
it wants to re-emerge version 2.24.1 instead of installing 2.28.0.


maybe because those packages are marked as ~arch ( or maybe even hardmasked)?

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Fri Oct 02, 2009 1:21 pm    Post subject: Reply with quote

Oke,

And how can i check this ?
The only message that i get when i do emerge gnome-2.28 that there are no ebuilds to satisfy gnome-2.28.

Roelof
Back to top
View user's profile Send private message
jomen
Guru
Guru


Joined: 04 Jan 2006
Posts: 536
Location: Leipzig, Germany

PostPosted: Fri Oct 02, 2009 1:56 pm    Post subject: Reply with quote

The gnome-packages you want to install are all masked (they have KEYWORDS="~x86" set)
To install those anyway you would need to unmask them (allow portage to use ~x86 - aka unstable packages)
You could do this one by one - which could be a lot of work for gnome.
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3&chap=3
You could use something like "autounmask"
http://www.iml.ece.mcgill.ca/~stephan/autounmask
You could even run the whole system as "~x86" (as I do for a long time)
For this all that is needed is:
add
ACCEPT_KEYWORDS="~x86"
to /etc/make.conf

There are problems to be expected when you mix packages from stable (x86) and unstable (~x86)!
I'll put "!" here again.
There will also be problems switching entirely to "~x86" - quite some reading is to be done before!

But IMO it is easier to just run ~x86 than to mess up the system mixing stable and unstable.
Both options are not recommended if you are fairly new to maintaining Gentoo - since there WILL be problems during the upgrage - or later on if you decide to mix stable/unstable
_________________
Cheers
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Fri Oct 02, 2009 2:18 pm    Post subject: Reply with quote

Quote:
The only message that i get when i do emerge gnome-2.28 that there are no ebuilds to satisfy gnome-2.28.


the meta-ebuild gnome-2.28 does not exist ( yet), not even in the gnome overlay.
I suppose such thing will be available once gnome-2.28 hits the tree.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
roelof
Guru
Guru


Joined: 05 Feb 2009
Posts: 488

PostPosted: Fri Oct 02, 2009 2:23 pm    Post subject: Reply with quote

Oke,

Then I stay with gnome 2.24 and will wait.

Roelof
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum